Inactive [INFO/ADMIN] LogBlock v1.54 - Enderdragon Logging! Tree Grow Logging! [1.4.5]

Discussion in 'Inactive/Unsupported Plugins' started by DiddiZ, Feb 15, 2011.

  1. Offline


    Version: 1.50​
    Find and Backroll those Damn Griefers
    LogBlock release are on DevBukkit:

    LogBlock dev builds:

    Please read the installation guide

    I won't port LogBlock myself to mcAPI. Source code is available, so it shouldn't be to difficult for someone else to do it, also I'm still here. so I can answer questions. If there is more than one willing, that's up to you to handle that.

    The reasons I take this step, are the usual: I quit playing Minecraft about 5 months ago and lastly I was struggling to keep up with updates. The developement of Guardian made slow progress, so I fear it won't be ready to fully replace LB in time.

    Download latest dev build: Jenkins
    View the source code: GitHub
    Table of contents:
    1. Description
    2. Features
    3. Why to use LogBlock
    4. Example command
    5. Older versions
    6. Change log
    7. Todo list / feature requests
    8. Permission nodes
    9. Plugins supporting this
    10. Support the dev
    11. How to post error messages
    12. Advertizing

    LogBlock logs block changes into a MySQL database. Block changes can be placed or destroyed block, explosions, burned blocks, sign text changes, chest access, leaves decay etc.
    It can be used as griefer identification tool, to find out who build a particular building, or even roll back changes by certain players. Other purposes can be e.g: Undoing of forest fires
    All additional features are optional, to keep the database as short as possible. All database actions run in their own threads to avoid server lags.
    The use of permissions plugin (or any clone) is possible, but not necessary.
    Uses Spout for chest logging (but it's fully optional, and there is no need for the client mod at all).

    • Logging for block placing, block braking, fire, explosions, leaves decay, signtexts, lava flow and chest content
    • Very mighty commands system, not only allowing to rollback and redo, but also to tp to blockchanges, delete log ingame etc. Full list of commands.
    • Many parameters for lookup/rollback/redo/tp/clearlog commands: Block changes of one ore more player, in a specific area, in a world edit selection, specific block types only, block changes older or newer that a specific date, destroyed/created block only, in a different world and combinations of all these parameters. Full list of parameters.
    • Rebuilding map after importing a backup (/lb redo)
    • Last parameter to use the parameters of the last command
    • Quick ingame lookup of block history a wood pickaxe or a bedrock block.
    • All commands accessible from console (exept tools :D)
    • Custom queries for tools.
    • Different tool modes (lookup, rollback, redo, writelogfile and clearlog)
    • Saves block data like wool color, log type, torch adjustment, etc
    • Multiworld and multiserver support (some servers sharing the same database)
    • BigBrother log import
    • Loggable super pickaxe plugin (not to confuse with WorldEdit's super pickaxe)
    • API
    • Webstats
    Why to use LogBlock:

    Example commands: (thanks to tha d0ctor, read more about commands here)

    /lb rollback player fire since 1d3h – rolls back fire 1 day 3 hours
    /lb rollback player fire since 1d3h area 15 – rolls back fire 1 day 3 hours within a radius of 15 blocks

    /lb rollback player thad0ctor since 1h - rolls back thad0ctor 1 hour
    /lb rollback player thad0ctor since 1d area 5 – rolls back thad0ctor actions for the last day within 5 blocks
    /lb rollback area 10 since 1h30m - rolls back all modifications within 10 blocks since the list 1 hours and 30 mins
    /lb rollback area 10 before 06.11.2011 - roll back all changes in an area of 1o before June 11th, 2011
    /lb rollback player thad0ctor since 05:36:00 - roll back all changes of thad0ctor since 05:36 (server time)

    Download, Command, Configuration and Details:

    -> Full changelog
    • LogBlock v1.50 # 81 (Dez. 13, 2011)
      Works with CraftBukkit 1.0.1-R1
      • Feature: /lb me shows the total block count
      • Feature: Chest logging without spout
      • Feature: Enderdragon logging
      • Feature: Logging for tree and mushroom grow (thanks to MD5 for the api)
      • Fix: Area param works again with default radius
      • Fix: Rollbacks got slowed down a bit to avoid rare server crashes
      • Fix: If mysql username, password or database only consist of unquoted numbers, LB will read them now
      • Config: World configs changed totally, some names changed and all logging options are now in an own section
    • LogBlock v1.41 #63 (Nov. 15, 2011)
      Works with CraftBukkit recommended build #1337
      • Fix: Players with spawnTools permission are no longer allowed to spawn all tools.
      • Fix: Added a check to avoid "The permission xy is already defined!" errors
    • LogBlock v1.40 #60 (Nov. 09, 2011)
      Works with CraftBukkit recommended build #1337
      • Feature: Custom auto ClearLog
      • Feature: Reduced error spam. Instead of like 40 line of error code, there is now just a warning stating the MySQL con
      • Feature: The queue will now be dumped after 10 tries even when the MySQL server is connected
      • Feature: Custom material names, allows naming custom blocks
      • Feature: LogBlock will now respond to messages when started without MySQL connection
      • Fix: Log import runs now async
      • Fix: Log import errors won't crash the server
      • Fix: Console commands work again
      • Fix: You can now use upper case letter in tool names (I don't know why you even should, but ...)
      • Config: Added, clearlog.enableAutoClearlog in main config. Added materials.yml. Removed clearlog.keepLogDays
      • Permissions: Added 'logblock.spawnTools'
    • LogBlock v1.32 (Oct. 04, 2011)
      Works with CraftBukkit recommended build #1240
      • Feature: Player info logging: firstLogin, lastLogin, onlinetime, ip. No ingame lookup yet.
      • Feature: /lb queuesize to see the current queue size
      • Fix: Door logging logs now also fence gates
      • Fix: Bukkit api break in CB #1191
      • Fix: time restriction works now as intended. Thanks to xrobau
      • Fix: Players with insufficient permissions can't smuggle bedrock from one world to another
      • Config: Added logPlayerInfo
    • LogBlock v1.30 (Sep. 22, 2011)
      Works with CraftBukkit recommended build #1185
      • Feature: Chat lookup /lb chat player diddiz search +admin +sucks +dicks (more info)
      • Feature: Door logging
      • Feature: Dynamic tools, define your own tools
      • Feature: Use since and before to define a timespan
      • Feature: Enderman logging
      • Feature: cake logging (who ate it)
      • Config: Added logEndermen, logCakes and logDoors to world config and moved the tool section in main config.
      • Permissions: logblock.tool changed to and
        logblock.toolblock to
    Todo List:

    Permission Nodes:

    Plugins supporting Logblock:
    List (open)

    When you want to appear your plugin here, tell me about

    Support the developer (that's me :D):
    If you want to support me writing plugins or want to thank me for the plugin/support, you can: Suggest features I missed, report bugs (best with fix :D), donate via PayPal, flattr my plugins, gift me The Witcher 2 (thanks to newyoukdaily), 2x 1GB DDR1 modules (thanks to HonestFlames), or send me the inner life of a laptop or netbook with a broken display (need it to build a model aircraft, so there is no need for parts like display and keyboard).


    How to post error messages:

    I won't aswer questions to general MySQL setup/installation/what is MySQL (there are lots of good tutorials out there, use google)
    Please read the installation guide before asking a question about installation problems.
    Please read the FAQ before posting a error report. It may be solved there.
    In case of rollback or lookup problems: Type /lb savequeue and try again (when it's fixed then, it was a consumer problem, see FAQ)
    When you post error messages, it's important to paste the whole stack trace!

    Newyorkdailys Plugin Support Buisness (open)
    Still can't get LogBlock working, or any other plugin? Are you getting errors in your console and cant figure out why? Newyorkdaily offers Basic/Advanced Plugin support.
    • General/Advanced troubleshooting: FREE!
    • Plugin Installations: 1-2 Plugins - FREE!
    • 3 or More Plugins - $2
    Click on the link below to connect to him now!

    There is a LogBlock irc channel: #logblock at
    You can ask me on skype. My name is 'hawky.diddiz'.
  2. Offline


    Yeah, the query and the schema are valid, so you gain nothing by renaming columns.
    As said, I guess it's a broken table/column. Did you already try to repair it? Repair the main table also, it might solve it.
  3. Offline


  4. Offline


    kk, so it's neither the query nor the tables.
    One more thing: MySQL server version and mode (strict/traditional/non strict)?
  5. Offline


    The sql version is
    mysql Ver 14.7 Distrib 4.1.22, for redhat-linux-gnu (x86_64) using readline 4.3

    And I'm not sure how to find out the MySQL mode.
  6. Offline


    This should be the reason: It's a bit outdated. Update to 5.1 or better 5.5.

    Tell me whether it works after updating, so I can add this to the FAQ.
  7. Offline


    I'm not so great with mysql, so do you happen to know which file i need to download here: ?
    The basic yum install command will only install mysql v4, so I need to do it all manually, and I don't know which file to download. I'm using a vps with CentOS release 4.8 (Final)
  8. Offline


    Don't know much about CentOS, but I'd use linux generic.
  9. Offline


    Well I got it working but this error spams console.

    2011-11-11 16:27:10 [SEVERE] [LogBlock Consumer] SQL exception on UPDATE `lb-players` SET lastlogin = FROM_UNIXTIME(1321050427), firstlogin = IF(firstlogin = 0, FROM_UNIXTIME(1321050427), firstlogin), ip = '/' WHERE playerid = 520;:
    com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Unknown column 'lastlogin' in 'field list'
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
    at java.lang.reflect.Constructor.newInstance(Unknown Source)
    at com.mysql.jdbc.Util.handleNewInstance(
    at com.mysql.jdbc.Util.getInstance(
    at com.mysql.jdbc.SQLError.createSQLException(
    at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    at com.mysql.jdbc.MysqlIO.sendCommand(
    at com.mysql.jdbc.MysqlIO.sqlQueryDirect(
    at com.mysql.jdbc.ConnectionImpl.execSQL(
    at com.mysql.jdbc.ConnectionImpl.execSQL(
    at com.mysql.jdbc.StatementImpl.execute(
    at com.mysql.jdbc.StatementImpl.execute(
    at Source)
    2011-11-11 16:27:17 [INFO] [Member] Edomien: I need an adventure companion! 
  10. Offline


    Alrighty, all fixed. It was simply because it was outdated lmao.
  11. Offline


    This error is usually an autoupdater fail. Set version in config to '1.30' and restart.
  12. Offline


    awesome, the answer to my problem just happens to be the last replied to post, by the dev :D
    fix time: ~4 seconds :p
    DiddiZ likes this.
  13. Offline

    Moo Master

    Off Topic:
    RedRoot, i found you again...

    Also am i the only one having issues with running this on CentOS?
  14. Offline


    I always get results similar to this.

  15. Offline

    That should help installing mysql. You're mc ign is moomaster1 right? I remember you, I just don't know from where, i'm thinking jadon mc, but I'm not sure.
  16. Offline


    PermissionsEX v1.15
    Logblock v1.40

    With the new logblock update people that shouldnt have permissions such as logblock.toolblock and tools now can use the command even WITHOUT the permissions node. I reverted back to LB v1.32 and the permissions were set fine again where people couldnt give themselves any tools or blocks.

    Oh btw let it generate a new config file with each change to see if that had any affect on anything, which it didn't. Please Fix.
  17. Offline


    Are there missed blocks floating in the air afterwards?
    If yes, does their history clearly state the actual change?
    It's important to differ between a logging or a rollback issue.
    It's still possible that there is no issue at all, since blocks that were modified later by other players won't be rolled back.
    OMG, looks like you're right ...

    EDIT: Latest dev should fix that.
  18. Offline


    I'm getting this error when updating to 1.40
    [LogBlock] Error while loading: while parsing a block mapping; expected <block end>, but found BlockMappingStart
  19. Offline


    Syntax error somewhere in the config. If you know a bit about YAML syntax, use to find it, otherwise delete config and let it regenerate.
  20. Offline


    It's not using the password I defined in the config.yaml is my best guess:

    [SEVERE] [LogBlock] Error while fetching connection:
    java.sql.SQLException: Access denied for user 'root'@'localhost' (using password: NO)
    at com.mysql.jdbc.SQLError.createSQLException(
    at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    at com.mysql.jdbc.MysqlIO.secureAuth411(
    at com.mysql.jdbc.MysqlIO.doHandshake(
    at com.mysql.jdbc.ConnectionImpl.coreConnect(
    at com.mysql.jdbc.ConnectionImpl.connectOneTryOnly(
    at com.mysql.jdbc.ConnectionImpl.createNewIO(
    at com.mysql.jdbc.ConnectionImpl.<init>(
    at com.mysql.jdbc.JDBC4Connection.<init>(
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(
    at java.lang.reflect.Constructor.newInstance(
    at com.mysql.jdbc.Util.handleNewInstance(
    at com.mysql.jdbc.ConnectionImpl.getInstance(
    at com.mysql.jdbc.NonRegisteringDriver.connect(
    at java.sql.DriverManager.getConnection(
    at java.sql.DriverManager.getConnection(
    at de.diddiz.util.MySQLConnectionPool.getConnection(
    at de.diddiz.LogBlock.LogBlock.getConnection(
    at de.diddiz.LogBlock.LogBlock.onLoad(
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at org.bukkit.craftbukkit.CraftServer.<init>(
    at net.minecraft.server.ServerConfigurationManager.<init>(
    at net.minecraft.server.MinecraftServer.init(

    I switched back to 1.32 and it worked with the same config.yaml file that threw the errors in 1.40...

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  21. Offline


    Put that pw in single quotes, like '123'.
    Strange ... maybe still the autoupdater. Set config in version to '1.32' if it's lower that '1.40'.
  22. Offline


    I installed this plugin yesterday and it was working fine. I added all of the permissions nodes to my Groups in permissions but it will still only let ops Use It. Help Please ASAP
  23. Offline


    This plugin is now superb. BUT I was wondering if possible if I could import logs from HawkEye.
  24. Offline


    The import should be very similar to BB import, but I haven't yet really looked at the HE schema.
    "/lb permissions" helps to track the error.
    What does LB say at server start about permissions plugin? If not found it uses bukkit permissions, most permission plugins offer a bridge in that case.
  25. Offline


    I tried /lb permissions at those ranks and it leaves them blank. So I need a permissions bridge for it? I Use Permissions 3.x and PermissionsPlus. If you could link me to it it would be SOOOOO helpful

    It says
    12.11 20:02:33 [Server] INFO [NoCheat] version [1.06] couldn't find CrafTIRC plugin. Disabling logging to IRC.
    12.11 20:02:33 [Server] INFO LogBlock v1.40 by DiddiZ enabled.
    12.11 20:02:33 [Server] INFO [LogBlock] Scheduled consumer with bukkit scheduler.
    12.11 20:02:33 [Server] INFO [LogBlock] Permissions plugin found.
    12.11 20:02:33 [Server] INFO [Administrate] - Permissions hooked using: Permissions v3.1.5
    12.11 20:02:33 [Server] INFO [ChestShop] iConomy 5 loaded.

    So I'm not sure......

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  26. Offline


    Personally I would suggest switching to a permissions plugin that doesnt require a bridge such as permissionsEX (PEX) or bpermissions as they both support bukkit permissions. You are using old, no longer updated, permissions.
  27. Offline


    PEX actually requires the bridge, as LB still relies on Nijikokuns permission api.
    Permissions has the bridge built in natively.
    So permissions is found ... but it acts like it's using bukkit permissions. Could be a conflict, i don't know. Try PEX, it's very similar to permissions 3.x, but newer.
  28. Offline


    Is it possible to log to files? I used this before, I think it was logging to file at that point of time. or?
    If not possible could you make a like:
    "usesql: true/false" ?

  29. Offline


    Flatfile support will never happen, it's way to slow.

    Or did you mean /lb writelogfile?
  30. Offline


    2011-11-13 21:11:16 [SEVERE] [LogBlock] Error while loading: null

    Doesn't seem like theres any errors around, I did get a "invalid time" before a restart happened by rToolkit, after it restarted I started getting this error.

    I was using Bukkit build 1396 after the restart, I downgraded already, waiting for restart and will get back to you.

    Instant edit: Yes, it's the build 1396, probably 1393 and above. 1392 works perfect.
  31. Offline


    Hm, the bukkit last change was "Fixed getResource not working post-reload", could be that it now doesn't work pre-reload.

Share This Page