Discussion in 'Inactive/Unsupported Plugins' started by Protected, Apr 13, 2011.

  1. Offline


  2. I kind of got the same Problem.
  3. Ok, that's fixed now.
    RaverGames likes this.
  4. Offline


    3 times I've tried installing this plugin and it won't create a config file. Do you have one that I can upload?
  5. Offline


    Create a new text document in the folder and name it "config.yml" It should change the format of the file
  6. Offline


    Did not work

    Uninstalled until this gets fixed.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  7. Offline



    The perch function does not seem to work properly for me. It creates a jack o lantern, but I fall through it straight away and it then dissapears.

    Any help appreciated?
  8. It disappears if you move away from it. Do you lag when playing in your server? Try using the stop function to stop first.
  9. Offline


    2011-05-27 02:50:10 [INFO] Enabling level saving..
    2011-05-27 02:51:28 [INFO] Wrong location! net.minecraft.server.EntitySkeleton@2bde0e
    2011-05-27 02:51:28 [INFO] 586.9692873339565,800.0828957051583(36,50) vs 35,50
    2011-05-27 02:51:28 [SEVERE] java.lang.Exception: Stack trace
    2011-05-27 02:51:28 [SEVERE]    at java.lang.Thread.dumpStack(Thread.java:1223)
    2011-05-27 02:51:28 [SEVERE]    at net.minecraft.server.Chunk.a(Chunk.java:367)
    2011-05-27 02:51:28 [SEVERE]    at net.minecraft.server.ChunkLoader.a(SourceFile:181)
    2011-05-27 02:51:28 [SEVERE]    at net.minecraft.server.ChunkRegionLoader.a(SourceFile:42)
    2011-05-27 02:51:28 [SEVERE]    at net.minecraft.server.ChunkProviderServer.loadChunk(ChunkProviderServer.java:132)
    2011-05-27 02:51:28 [SEVERE]    at net.minecraft.server.ChunkProviderServer.getChunkAt(ChunkProviderServer.java:62)
    2011-05-27 02:51:28 [SEVERE]    at net.minecraft.server.PlayerInstance.<init>(PlayerInstance.java:33)
    2011-05-27 02:51:28 [SEVERE]    at net.minecraft.server.PlayerManager.a(PlayerManager.java:37)
    2011-05-27 02:51:28 [SEVERE]    at net.minecraft.server.PlayerManager.movePlayer(PlayerManager.java:141)
    2011-05-27 02:51:28 [SEVERE]    at net.minecraft.server.ServerConfigurationManager.b(ServerConfigurationManager.java:107)
    2011-05-27 02:51:28 [SEVERE]    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:339)
    2011-05-27 02:51:28 [SEVERE]    at net.minecraft.server.Packet10Flying.a(SourceFile:126)
    2011-05-27 02:51:28 [SEVERE]    at net.minecraft.server.NetworkManager.a(NetworkManager.java:196)
    2011-05-27 02:51:28 [SEVERE]    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    2011-05-27 02:51:28 [SEVERE]    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    2011-05-27 02:51:28 [SEVERE]    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:377)
    2011-05-27 02:51:28 [SEVERE]    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    2011-05-27 02:51:28 [SEVERE]    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:377)
    2011-05-27 02:51:28 [SEVERE]    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:292)
    2011-05-27 02:51:28 [SEVERE]    at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    2011-05-27 02:51:55 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    2011-05-27 02:57:30 [INFO] randomplayer lost connection: disconnect.quitting
    2011-05-27 02:57:30 [INFO] Connection reset
    I am using bukkit 803, regios 3.2_01, movecraft 0.6.9 beta3, general 3.4, and flight 2.3
    Is this error from your plugin? I was thinking maybe because its the only one mentioned i can see
    where it says "at net.minecraft.server.Packet10Flying.a(SourceFile:126)"
    anyway, thanks for your help this is an awesome plugin!!
  10. As you can see that's a server error. Also, my plugin should not be touching skeletons. But you know an easier (and faster) way to find out? Disable the plugin and see if it still happens ;)

    I assume you have allow-flight set to true?
  11. Offline


    Installed Plugin, No Config File Generated, Works However. But I do need access to this config file to able to implement this add-on in my server. Please advise when it is fixed.
  12. It's in the top post somewhere ;) Copy and paste
  13. Offline


    Is it all right with you if I add your plugin to CBUTD?
  14. Offline


    awesome thanks for the fast reply. I've had no problems with 860 are you able to change the listed compatible version? :)
  15. Offline


    Spent ages trying to get permissions and setting to work, through that addon. All copy and paste, read every post etc and asked no questions. Worked awesome without permissions but with permissions everyone had access to everything even with no config and all the permissions removed from every user and group. All that aside, I may have found a bug in setting the permit item. I changed it from diamond to 32 (dead bush) and it stayed diamond. I was using none of the permissions addons and just flight, and the setting was in the .cfg. The price and other settings all worked fine, but I couldn't set permits to be a dead bush. I have no idea why that isn't working. In the meantime, I turned off permit buying altogether so I can control who uses this plugin by manually adding their name to the permit.dat . If permissions can't keep people out for me and giving special items can't keep people out... at least having no permit sales at all is doing the job. This is the best flight plugin I've tried so far. It's really important to be able to control the speed of flight, so horizontal speeding isn't as big a killer to the server. bflight was WAY too fast horizontally, and no way to slow it down. Also, it's great that the max flight height is the top block of a chunk, since with bflight the user could fly so high that the server went nuts. It's good to keep the users out of deep space. These are just my experiences and bravo on the configurable details that I could get working.
  16. Offline


    I can help you with permissions in the morning start a conversation with me and read my sig on getting help :)
  17. Thanks, keyosuke, but I don't see how you could be having those problems with permissions, provided your permissions are properly configured. I use this plugin in my own server and it's working fine.
  18. Offline


    Defiantly not a problem with the plugin works fine for me as well (running permissions 3.1.5)
  19. Offline


    For some reason, flying stops randomly and I get an error...

    2011-06-24 12:41:19 [SEVERE] java.lang.ArrayIndexOutOfBoundsException: 0
    2011-06-24 12:41:19 [SEVERE]    at org.bukkit.craftbukkit.CraftChunk.getEntities(CraftChunk.java:89)
    2011-06-24 12:41:19 [SEVERE]    at net.myshelter.minecraft.flight.Flight.playerOnPig(Flight.java:224)
    2011-06-24 12:41:19 [SEVERE]    at net.myshelter.minecraft.flight.Flight.updateFlight(Flight.java:288)
    2011-06-24 12:41:19 [SEVERE]    at net.myshelter.minecraft.flight.FlightEnforcer.run(FlightEnforcer.java:13)
    2011-06-24 12:41:19 [SEVERE]    at java.util.TimerThread.mainLoop(Timer.java:512)
    2011-06-24 12:41:19 [SEVERE]    at java.util.TimerThread.run(Timer.java:462)
    16:34:02 [INFO] Plugins: WeatherSync, iAuction, Backup, BlocksOnGlass, VanishNoPickup, ColoredSigns, Help, Flight, Mining TNT, Permissions, iConomy, CookieMonster, EasyBan, Dontkickme, mcbans, ServerInfo, LWC, GoldStandard, BorderGuard, Tombstone, BukkitContrib, BedRespawn, Tips, TrainYourLung, PermissionsPlus, p2Aliases, WorldEdit, TorchLight, Residence, AuthDB, Minequery, dynmap, MinecraftViewer, Essentials, EssentialsChat, CommandSigns, BedHealAdvanced, BigBrother, WorldGuard, MailBox, HeroicDeath, iConomyChestShop, ServerTime, EssentialsGeoIP, WormholeXTremeWorlds, WormholeXTreme, WormholeXTremeWorldsSpawn
    [CODE]16:34:31 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-823-gb9d0b04-b860jnks (MC: 1.6.6)
    16:34:31 [INFO] This server is also sporting some funky dev build of Bukkit!
  20. What exception?
  21. Offline


    Last edited by a moderator: May 13, 2016
  22. Hm, the error (stack trace) you posted here is different from the one in the other thread.

    Error in this thread: Apparently the chunk the player is on has no entities on it, which should be impossible because the player himself is an entity. Another plugin may be causing this weirdness; I don't know which, but you can always try disabling all of them and then enabling one by one until you find the one causing the issue (or disable one by one). Or are you flying REALLY fast? Did you increase the horizontal velocity a lot?

    Anyway, this problem is happening in a feature that wasn't yet finished - flying on pigs. Disable it by setting flight.can-fly-pigs to false in your config.yml or removing that permission if you're using Permissions and the problem should go away.

    Error in the other thread - Looks like a similar error but with the overall list of online players, where the list shrank while the plugin was going through it. Very weird, this shouldn't be possible either. What java version are you using?
  23. Offline


    Thanks for the speedy response... I installed...

    java version "1.6.0_26"
    Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
    Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)
  24. Offline


    well, this is useless for me...
    of course i am talking about permissions...
    isn't optional an option?

    don't start saying that there are enough flight plugins who do use permissions because this one is by far the best...
    i like everything about it a lot... :(
  25. Offline


    Would it be possible to make it so op's dont require items or a permit?
  26. I'm afraid you need a permit but you can always make it free. Use the operator attribute provider to allow operators to fly without fuel.

    You can also write an extended version of the operator provider to allow for different costs for operators (this is already possible with the permissions one).

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  27. Does this work with 1.7.2 (RB #953)?
  28. Offline


    No issues here with 953. Great plugin btw!

Share This Page