[INACTIVE][TP] SimpleWarp v2.3 - Simple Warping for the masses [1000] [UNSUPPORTED]

Discussion in 'Inactive/Unsupported Plugins' started by rymate1234, Jul 19, 2011.

  1. Offline


    SimpleWarp v2.3 - Simple Warping for the masses:

    Version: v2.3
    This is my first plugin, so be nice :)
    SimpleWarp is a simple plugin for handling warps. It has 3 commands:
    • /warp <warpname> - Warps to the specified warp (Permissions node warp.go)
    • /setwarp <warpname> - Creates a warp at your location (Permissions node warp.set)
    • /listwarps - List the first 8 warps in your warps.txt file. (Permissions node warp.list)
    The iConomy support is easily set up in the config file generated in the SimpleWarp folder, there you can set the price of warping :)

    • Warping to a warp
    • Creating new warps
    • Permissions
    • Warp listing
    • Economy Support
    Download it now!!! (Mediafire turns it into a .zip)
    Source Code!
    Experimental Release (Plus information)

    ToDo List (In order of importance):
    Red is not done, Orange is in progress, green is done (and coming in the next version!)

    • Configuration File
    • iConomy support
    • MySQL/SQLite warp storage
    • Warp Lists (/listwarps shows a list of warps) DONE! It can show up to 8 warps :p
    • Multiple warp list pages
    Version 2.3:
    • Added defaulting to OP functionality for people without permissions
    Read More.... (open)

    Version 2.2:
    • Fixed permissions node for /warp not working
    • Added feature for /warp that only warps you if there is enough headroom (Thanks to garbagemule for that :D)
    Version 2.1:
    • Fixed a major bug with /warp
    Version 2:
    • Adds a Config file!
    • Permissions 3.x support!
    • Economy support!
    • Warp listing!
    Version 1

    • Initial Release
    chapter_5 likes this.
  2. Offline


    I hate to say this because i may already know the answer, but please can you add permissions 3.1 support. I us it because one its easy for me, plus 75% of the plugins on bukkit use permissions 3.1 or support permissions 3.1. Limiting this plugin to another type of permissions that most people may or may not use or even know of will greatly limit how many people will want to use this. I personally need this plugin but can use it because its not permissions 3.1 supported. So please make it to were we can use 3.1.
  3. Offline


    Ok, now also in version 2 will be permissions 3.x support!
    chapter_5 likes this.
  4. Offline


    Ty soooo much!
  5. Offline


    Version 2 should be done soon :)

    Hopefully I can release today :D
    chapter_5 likes this.
  6. Offline


    okay, so permissions 3.0
    good thing I'm just beginning to use it again, none of my plugins really use permissioins, but I'm getting Multiverse, or whetever it's called, and I'm hoping i can block groups from entering certain worlds

    EDIT: I fixed the internal error because i wasnt an OP on my server
  7. Offline


    Also if you plan to add iconomy support and a /home id advise making this like optional. Iconomy is a good feature to add but not everyone may want to use it, so making it optional would be the safe route. Also the /home is kinda bad for rpg servers which is why it should be optional just incase non free build servers use this plugins.
  8. Offline


    This release adds a number of features to SimpleWarp including:
    • A Config file!
    • Permissions 3.x support!
    • Economy support!
    • Warp listing!
    Download Now!
    chapter_5 likes this.
  9. Offline


    Downloading it literally right now, thanks you very much for the speedy release, also do you plan to create other plugins? And if you what genre rpg, freebuild, or random?
  10. Offline


    I do plan to create other plugins.

    I'm not saying what though :p

    Also, it wasn't that speedy, been working on version 2 since I released version 1 :D
  11. Offline


    Well to me it was speedy seeing as you added permissions 3.1 support at the last minute :0
    Also im installing this on my server tonight so ill tell you if i find any errors. Which i doubt i will. Also why wont you say what plugins your gonna design, I may has ideas to help. :(
  12. Offline


    I suggest that you post the permission nodes..
  13. Offline


    Well if you have any ideas feel free to PM me them, but try not to hijack this post :p
    I'm trying to keep this on topic :D

    Also, permissions support wasn't that hard to code in, I just followed the tutorial on using permissions in a plugin xD

    The permissions nodes are in the post :p
    Look in the brackets next to where the commands are shown :D

    Anyone wanna test a beta experimental release?


    It features an enhancement to the permissions node, so doing warp.go.* allows you to go to any warp (hopefully :D) and if you want to restrict users to certain warps you can replace the star with your warp name. warp.go.test would ony ly allow users to go to the warp "test"

    You can add as many as you want!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  14. Offline


    This nasty error i get is so odd. I tried everything to fix it but its just not working. I can use /list and /setwarp but the /warp name doesnt work.
    Show Spoiler

    25.07 18:10:05 [Server] INFO ... 12 more
    25.07 18:10:05 [Server] INFO at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    25.07 18:10:05 [Server] INFO at net.rymate.SimpleWarp.WarpCommand.onCommand(WarpCommand.java:40)
    25.07 18:10:05 [Server] INFO Caused by: java.lang.NullPointerException
    25.07 18:10:05 [Server] INFO at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    25.07 18:10:05 [Server] INFO at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    25.07 18:10:05 [Server] INFO at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
    25.07 18:10:05 [Server] INFO at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    25.07 18:10:05 [Server] INFO at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
    25.07 18:10:05 [Server] INFO at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    25.07 18:10:05 [Server] INFO at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    25.07 18:10:05 [Server] INFO at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:670)
    25.07 18:10:05 [Server] INFO at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:677)
    25.07 18:10:05 [Server] INFO at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:713)
    25.07 18:10:05 [Server] INFO at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:320)
    25.07 18:10:05 [Server] INFO at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129)
    25.07 18:10:05 [Server] INFO at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
    25.07 18:10:05 [Server] INFO org.bukkit.command.CommandException: Unhandled exception executing command 'warp' in plugin SimpleWarp v1
    25.07 18:10:05 [Server] SEVERE null
  15. Offline


    You only posted half an error :p

    i rather think there may be more error above what you posted, but I cannot see it with this :(

    Also, are you using the main release or the experimental release?
  16. Offline


    i will try to get another error report, but no im using the one you released yesterday.
    Show Spoiler

    25.07 18:50:59 [Server] INFO ... 12 more
    25.07 18:50:59 [Server] INFO at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    25.07 18:50:59 [Server] INFO at net.rymate.SimpleWarp.WarpCommand.onCommand(WarpCommand.java:40)
    25.07 18:50:59 [Server] INFO Caused by: java.lang.NullPointerException
    25.07 18:50:59 [Server] INFO at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    25.07 18:50:59 [Server] INFO at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    25.07 18:50:59 [Server] INFO at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
    25.07 18:50:59 [Server] INFO at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    25.07 18:50:59 [Server] INFO at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
    25.07 18:50:59 [Server] INFO at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    25.07 18:50:59 [Server] INFO at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    25.07 18:50:59 [Server] INFO at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:670)
    25.07 18:50:59 [Server] INFO at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:677)
    25.07 18:50:59 [Server] INFO at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:713)
    25.07 18:50:59 [Server] INFO at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:320)
    25.07 18:50:59 [Server] INFO at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129)
    25.07 18:50:59 [Server] INFO at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
    25.07 18:50:59 [Server] INFO org.bukkit.command.CommandException: Unhandled exception executing command 'warp' in plugin SimpleWarp v1
    25.07 18:50:59 [Server] SEVERE null
    25.07 18:50:46 [Server] INFO ... 12 more
    25.07 18:50:46 [Server] INFO at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    25.07 18:50:46 [Server] INFO at net.rymate.SimpleWarp.WarpCommand.onCommand(WarpCommand.java:40)
    25.07 18:50:46 [Server] INFO Caused by: java.lang.NullPointerException
    25.07 18:50:46 [Server] INFO at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    25.07 18:50:46 [Server] INFO at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    25.07 18:50:46 [Server] INFO at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
    25.07 18:50:46 [Server] INFO at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    25.07 18:50:46 [Server] INFO at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
    25.07 18:50:46 [Server] INFO at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    25.07 18:50:46 [Server] INFO at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    25.07 18:50:46 [Server] INFO at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:670)
    25.07 18:50:46 [Server] INFO at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:677)
    25.07 18:50:46 [Server] INFO at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:713)
    25.07 18:50:46 [Server] INFO at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:320)
    25.07 18:50:46 [Server] INFO at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129)
    25.07 18:50:46 [Server] INFO at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
    25.07 18:50:46 [Server] INFO org.bukkit.command.CommandException: Unhandled exception executing command 'warp' in plugin SimpleWarp v1
    25.07 18:50:46 [Server] SEVERE null

    thats exactly as it was posted in the server log.
  17. Offline


    Thats odd, it worked in testing yeserday before i released it, I'll try to reproduce the error if possible
  18. Offline


    kk if you wish me to list all the plugins i have i can.
    Show Spoiler

  19. Offline


    I have been able to reproduce the error!

    It seems to be a problem with the Economy support

    I'll get to work on fixing this right away :D
  20. Offline


    ty ty its turning my server inside out (which im use to due to i find every error that nobody seems to be able to fix) >.> so im happy for once that someone could find my error
  21. Offline


    a temp fix is to disable economy usage in the config.properties file :D
  22. Offline


    I did that i set it to false and its still doing it
    edit: Wait is the value for enabling the economy like this?
    enable/disable or true/false
  23. Offline


    Oh :(

    At least i'm narrowing down he error then :D

    Mainly to @chapter_5 as he reported the bug:

    Version 2.1 released!

    This features a recode of all the Economy support and this plugin now only supportss iConomy :( But at least it works perfectly with iConomy now!

    Also a couple typo's fixed :D

    Download is at the usual location - http://rymatemc.co.cc/plugins/SimpleWarp.jar

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  24. Offline


  25. Offline


    I'm looking for a plugin like that, but based on WorldGuard or any other kind of region management.
    Basically, i want my users to be able to /warp only when they are inside a certain area (the spawn village)...
    Any chance you could work on that or would it be too much work?
  26. Offline


    Hi, Rymate! I love your idea, but can you tell me how to install it? I'm not much of a bukkit-plugins installer, so..yeah, can you help me out? Thanks!
  27. Offline


    kk if your running bukkit (which i assume you are) just download the .jar file and when its done put it into the plugin folder of your server files. Then restart your server and tada its done.
  28. Offline


    Hello! I tried your "beta experimental release" but recived this long error message when attempting to warp!

    11:26:06 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'warp' in plugin SimpleWarp v1
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129)
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:320)
    at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:713)
    at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:677)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:670)
    at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.NullPointerException
    at net.rymate.SimpleWarp.WarpCommand.onCommand(WarpCommand.java:40)
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    ... 12 more

    But i think the permissions work great as when a user attempts to warp the a warp that they do not have permission for it says "You do not have permission for that cammand" So thats good!

    Please Fix! as this is the main reason i wanted this "beta experimental release"
  29. Offline


    I see! Thanks
  30. Offline


    They still dont have permission to warp?
    Even though they got the node warp.go
  31. Offline


    its rly simple and great plugin, but i have a problem.

    when i put 'warp.go' in permissions node for player, it does not working... but when i put 'warp.*' it worked...
    I wont to give players access for 'warp.*'...

    Can u fix it? or its my local problems?

Share This Page