[INACTIVE][MISC] TentThis v2.2.0 - Portable Tent (and more!) System [670]

Discussion in 'Inactive/Unsupported Plugins' started by ssell, Mar 26, 2011.

  1. Offline


    TentThis - Portable Tent (and more!) System
    Version: v2.2.0

    Note: If you downloaded v2.2.0 before April 11, 2011, the TentThis.properties default schema is missing the </tentSchema> tag. A fixed .properties is now included in the downloads.

    Response to a request.

    Lost in the wilderness and it is getting dark? Going on a long expedition? Tired of hiding in holes? Well TentThis is here!

    Simply plop down a Sponge block, type in /ttTent, whack it once and watch the magic unfold. The tent will be created out of thin air (as long as their is enough space!). And when you need to move on just break one of the walls and watch the tent vanish and your Sponge return to you.

    Whats new in v2.2.0?

    See the release post.​

    Got an old style schema and need to convert it? Well see that post as well!​


    I am migrating (almost) all information from this post to the new wiki as the plugin grows.​

    • Fully customizable tents!
    • Reverse-Schemas!
    • Walls can be any color! (if wool)
    • May specify what block creates the tent!
    • Permission Support
    • Individual Schemas/Limits/Owned Tents
    • Support for the following blocks
      • All!
    Links / Install Instructions

    Tent How-To

    Creating your own custom tent is simple! I suggest to look at the default tent provided with the TentThis.properties. If there are any errors in loading/creating the tent make sure to check your console output for detailed information.​

    Once you have made the tent, try loading it with /ttSchema <TentName>.​

    If you receive the message "Tent schema 'TentName' loaded!" then all went well.​
    Otherwise check the console output.​

    Once your tent is ready for use and is loaded in, set down your Sponge block, type in /ttTent, and hit it!​

    If there is enough space the tent will be built. Otherwise you will receive the message "There is not enough space to build the tent 'TentName'!"​

    I Don't Want To Use a Sponge!

    Then edit the line in the TentThis.properties that by default says:​

    Replace the 19 with the data value of the block you want to use instead.​


    Known Issues
    • The tops of doors may at first be misaligned.
    • Save problems.
    • Have the tents-expire to prevent possible clutter.
    Special Thanks to

    • Mixcoatl - Doors/Beds working
    • Edward Hands - Providing the missing piece to the bed puzzle
    • Grimmkrieg - Schema trouble-shooting
    • GSecurity - Helped with Essentials issues
    Change Log

    Changelog (open)

    • Tents may be constructed of anything*
    • Reverse-Schemas!
    • /ttReverseSchema command. See this post.
    • New option in the TentThis.properties:
    #- Should NoCommand be the default mode?
    • Preemptively fixed issues with 'fragiles' (torches, ladders, paintings, etc.) from popping off walls ;)
    • Fixed crashes when running with Essentials Chat and other Chat plugins.
    • Works for (and only for) 600+ (tested on 606)
    • Permissions support!
      • TentThis.commands.setOwnSchema
      • TentThis.commands.setAllSchema
      • TentThis.commands.setLimit
      • TentThis.general.destroyAnyTent
    • Re-worked/New Commands
      • /ttSchema <Schema> <OptionalPlayer>
      • /ttWhat is now /ttInfo
      • /ttLimit <Name> <limit>
    • Owned Tents/Active Schema/Tent limit are now unique to each player, and not shared between the server.
    • More.
    • Fixed bug where /ttNoCommand worked only for the default Sponge.
    • Bed is no longer dropped on tent destruction.
    • Colored walls work. Use the color names as specified at http://www.minecraftwiki.net/wiki/Wool#Data_Values_for_Colored_Wool.
      • Names must have no space and be all lower-case.
    • Custom defined 'CreationBlock'. Default is Sponge.
      • Edit the 'CreationBlock=19' line in the TentThis.properties.
    • New command: /ttReload
      • This is in place so one does not have to restart the server to change the CreationBlock.
      • Edit the block in the properties file, then enter the /ttReload command and it should work!
    • Doors work (might be some irregularities with the orientation of the top at first)
    • Beds work (B = bed foot, H = bed head now)
    • Torches no longer drop when the tent is removed
    • Trying to remove anything but the walls does nothing
    • New command: /ttNoCommand.
      • Allows you to make tents without having to enter /ttTent first.
      • Must right click the block to make, as opposed to left click when this feature is disabled.
    • Initial Bukkit Release

    Help! My Tent Doesn't Work
    1. Check the console for any error output. I have made sure that 95% of all possible errors with the tent schema have detailed output as to the exact problem.
    2. Check the schema for any silly problems (dimensions not matching what you specified, missing floor, missing closing tags, non-capitalized letters).
    3. Repeat step 2.
    4. Repeat step 2.
    5. Repeat step 2.
    6. Post here.
    More Tents:

    Spelunker (open)

    By: Grimmkrieg

    The Spelunker:
    Designed for the inventory-conscious cave-explorer in us all! Carry a single sponge block with you, and never need to scrounge up those 4 wood for a workbench again!


    Woodsman (open)

    By: Grimmkrieg

    A one-man tent designed for 'everyday' use, with all the modern amenities.

    Expeditionist (open)

    By: Grimmkrieg

    A three-man safari tent, designed to be spacious while still accommodating the storage, smelting and crafting needs of all expedition members. Not designed for underground use. (This one sometimes loses torches off the wall, not sure why.)

    Aristocrat (open)

    By: Grimmkrieg

    The newest tent in the GRIMMDUSTRIES line, this one is getting a bit extravagant - but who doesn't like a bit of style? With a dedicated crafting area, 2nd floor loft sleeping quarters and two servant's beds, this tent is for the wealthy 'crafter with some space to spare!

    Fortress (open)

    By: killgoblen

    Ever get stuck in the middle of a mob of 100 creepers? No? Well, if you ever are, this is the tent for you! It has 3-block-thick walls with a layer of furnaces in the middle.


    Phaedrus, dr_brule and Long like this.
  2. Offline


    Loving this idea!

    If you an Op/Admin you should be able to use: /give yournamehere 19 1

    That will give you 1 Sponge.

    First let me start with, this is one great program so far. Everyone on my server now has a sponge. :) And thank you matejdro for suggesting it.

    I'm using RemoteToolkit, and after the server restarts... tents do not revert to sponges. This allows people to place tents at the 1min mark, and log back in and claim all the wool, torches, chests, furnaces, crafting tables, but they don't get their sponge back. Its more of an annoyance as everyone wants the sponge back.

    Can //ttNoCommand be set as the default maybe through toggle in the config so that it isn't needed to retype it after each server restart?

    I read this atleast once in this forum, but having a way to allow people to purchase schemas would be really nice. Allow them to look at the full list of schemas, but only select and use the ones they have purchased. Also if its possible, allowing the user to select the color when selecting the schema would be great too. (ie. /ttschema schemaname color)

    Also what exactly are the color values? I tried "lime", "lightgreen", and "light_green" but none of them seem to work, I either got white or the normal dark green color.

    Is it possible to have the ttReload also reload the schemas?

    I realize this started off as tent idea... but you really have the makings here for complete homes in an instant. Any chance once you have customization of each piece added, that you could have a secondary block that will make permanent structures which cannot be reverted. Complete home in a box... err block. Tied in with something like iConomy, this would be awesome!

    I'm using your 2.0.1 version but PluginsManager is still showing the version number as 2.0.0, just so you know.

    Currently this is the only tent available on my server... but I plan on making more.
    The current price you see is a point system we have for things that don't use currency.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  3. Offline


    That would be a great idea!

    Suggestion on how to implement that:

    Every time a user buys a tent, they get one use of that specific tent, and they get a free sponge included. It would be great if you implemented it with iConomy and BOSEeconomy.
  4. Offline


    I don't really understand how to make custom tents, I get the basics of it but I can't seem to do it. Can somebody please explain/give me a quick tutorial on this? I want to make my own but I'm having difficulties.

    P.S. Great mod, I love it!
  5. Offline

    Lex Mozli

    Suggestion: make something that will let us define what letters/blocks we use.

    For example we write in the propierties file W=79 and will build instead of wool, item #79 (i think it's ice)

    Sorry for poor english, i hope you get the ideea.

    Awesome plugin dude!
  6. Offline


    Great plugin!

    I have had the situation once where I made two tents and when packing up, I got one tent down nice and easy, as per intended, but the second tent didn't go back into a sponge :( it was able to be picked apart for all of its goodies :p
  7. Offline


    ssell, I did my best to get you started in the Wiki, and included a page on making/breaking down your default tent. Hope you don't mind, and hope it is helpful to others here. Please do as you wish with it.

    P.S. I also tried to include the graphic, but its just a link, for whatever reason the wiki just wouldn't let me upload it. :( Anyway, feel free to disregard it, or use it here on the forum, do with it as you wish.


    You can find the entry here: http://wiki.bukkit.org/Tentthis
  8. Offline

    Justin Peeler

    17:53:06 [SEVERE] Nag author: 'ssell' of 'TentThis' about the following: onPlaye
    rJoin has been replaced with a new signature, (PlayerJoinEvent)
    I'm getting this strange error all of a sudden. I can load the schema with the command and then type /tttent and it prompts me to hit the sponge but then nothing happens.

    This is everything I get upon loading my server, the error occurs right after I login.

    C:\Users\Justin\Desktop\Island Bukkit>java -Xms1021M -Xmx1024M -jar craftbukkit.
    17:52:57 [INFO] Starting minecraft server version Beta 1.4
    17:52:57 [INFO] Loading properties
    17:52:57 [INFO] Starting Minecraft server on
    17:52:57 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-612-
    g4c7a9e7-b617jnks (MC: 1.4)
    17:52:57 [INFO] Preparing level "world"
    17:52:57 [INFO] Preparing start region
    17:52:58 [INFO] 144 recipes
    17:52:58 [INFO] Preparing spawn area: 60%
    17:52:59 [INFO] Invalid config file found and converted to proper name/format.
    17:52:59 [INFO] [Permissions] (Phoenix) was Initialized.
    17:52:59 [INFO] [WormholeXTreme][v0.821][By Lologarithm & alron]Load Beginning.
    17:53:00 [INFO] [WormholeXTreme]3 Wormholes loaded from WormholeDB.
    17:53:00 [INFO] [WormholeXTreme][v0.821]Load Completed.
    17:53:00 [INFO] CivilizedSpawn (v0.5.2) is enabled!
    17:53:00 [INFO] creaturebox version 0.6.2 is enabled!
    17:53:00 [INFO] CrowdControl version 0.21 is enabled
    17:53:00 [INFO] Elevators version 1.4.1 is enabled and linked to Permissions!
    17:53:00 [INFO] Loaded Essentials build 2.1.15 maintained by Zenexer, ementalo,
    Aelux, Brettflan, KimKandor, snowleo and ceulemans.
    17:53:00 [INFO] [FenceStack] version [1.13] loaded.
    17:53:00 [INFO] [MagicCarpet] MagicCarpet version 1.5.2 is enabled!
    17:53:00 [INFO] [MagicCarpet] Take yourself wonder by wonder, using /magiccarpet
     or /mc.
    17:53:00 [INFO] [MagicCarpet] Using Permissions.
    17:53:00 [INFO] Minecart Mania Core version 1.07d is enabled!
    17:53:00 [INFO] Minecart Mania Pressure Plates version 1.06 is enabled!
    17:53:00 [INFO] Minecart Mania Sign Commands version 1.07 is enabled!
    17:53:00 [INFO] Minecart Mania Station version 1.07 is enabled!
    17:53:00 [INFO] [MYWARP]: 15 warps loaded
    17:53:00 [INFO] [MYWARP] Permissions enabled using: Permissions v2.5.5
    17:53:00 [WARNING] [MYWARP] 'Help' isn't detected. No /help support.
    17:53:00 [INFO] MyWarp 1.10.3 enabled
    17:53:00 [INFO] npcx : load settings (0.428) begun
    17:53:00 [INFO] jdbc:mysql://localhost:3306/npcx?autoReconnect=true
    17:53:00 [INFO] npcx : initialising database connection
    17:53:01 [INFO] npcx : loadsettings() ended
    17:53:01 [INFO] npcx : registering monitored events
    17:53:01 [INFO] npcx : Checking for DB Updates from DBVersion:1.08
    17:53:01 [INFO] npcx : loading player factions
    17:53:01 [INFO] npcx : Loaded 0 player factions.
    17:53:01 [INFO] npcx : loading npc factions
    17:53:01 [INFO] npcx : Loaded 0 npc factions.
    17:53:01 [INFO] npcx : Loaded 0 research.
    17:53:01 [INFO] npcx : loading zones
    17:53:01 [INFO] npcx : Loaded 0 zones with 0 zone_members.
    17:53:01 [INFO] npcx : loading Merchants
    17:53:01 [INFO] npcx : Loaded 0 Merchant with (0) entries.
    17:53:01 [INFO] npcx : loading factions
    17:53:01 [INFO] npcx : Loaded 0 factions.
    17:53:01 [INFO] npcx : loading pathgroups
    17:53:01 [INFO] npcx : Loaded 0 pathgroup.
    17:53:01 [INFO] npcx : loading loottables
    17:53:01 [INFO] npcx : Loaded 0 loottables.
    17:53:01 [INFO] npcx : loading spawngroups
    17:53:01 [INFO] 1 spawngroups loaded
    17:53:01 [INFO] npcx version 0.428 enabled.
    17:53:01 [INFO] [Permissions] version [2.5.5] (Phoenix)  loaded
    17:53:01 [INFO] PermissionsSupport: Found Permissions, using it for permissions.
    17:53:01 [INFO] PermissionsSupport version 0.1 is enabled
    17:53:01 [INFO] Persistence version 0.64 is enabled
    17:53:01 [INFO] PickBoat version 0.3.4 is enabled!
    17:53:01 [INFO] Portable Torch 1.04 Started! LightTime:10000
    17:53:01 [INFO] [Residence] Found Permissions Plugin!
    17:53:01 [INFO] [Residence] iConomy NOT found!
    17:53:01 [INFO] [Residence] - Save Loaded!
    17:53:01 [INFO] [Residence] Enabled! Version v1.2.8 BETA by bekvon
    17:53:01 [INFO] RetractableBridge plugin version 1.2.0 by Captain_Chaos enabled
    17:53:01 [INFO] Spells version 0.996 is enabled
    17:53:01 [INFO] TentThis v2.0.1 by ssell is enabled!
    17:53:01 [INFO] Wand version 0.69 is enabled
    17:53:01 [INFO] Loading wand-commands.txt
    17:53:01 [INFO] Wandmin version 0.32 is enabled
    17:53:01 [INFO] [WolfPound]- Version 0.4 Enabled
    17:53:01 [INFO] [WolfPound] using Essentials Economy!
    17:53:01 [INFO] [WolfPound] using Permissions
    17:53:01 [INFO] WorldEdit nightly enabled.
    17:53:01 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin
     for permissions.
    17:53:01 [INFO] [WormholeXTreme][v0.821]Enable Beginning.
    17:53:01 [INFO] [WormholeXTreme]Attached to Permissions version 2.5.5
    17:53:01 [INFO] [WormholeXTreme]Complex Permissions Enabled
    17:53:01 [INFO] [WormholeXTreme]iConomy Plugin not yet available - there will be
     no iConomy integration until loaded.
    17:53:01 [INFO] [WormholeXTreme]Help Plugin not yet available - there will be no
     Help integration until loaded.
    17:53:01 [INFO] [WormholeXTreme][v0.821]Enable Completed.
    17:53:01 [INFO] Minecart Mania Admin Controls version 1.07 is enabled!
    17:53:01 [INFO] Minecart Mania Autocart version 1.06 is enabled!
    17:53:01 [INFO] Minecart Mania Automations version 1.06 is enabled!
    17:53:01 [INFO] Minecart Mania Chest Control version 1.07a is enabled!
    17:53:01 [INFO] Done (0.376s)! For help, type "help" or "?"
    17:53:06 [INFO] [Minecart Mania] Loading Sensor Data.
    17:53:06 [INFO] Socopsycho [/] logged in with entity id 181
    17:53:06 [INFO] Persistence: Create a plugins/Persistence/permissions.yml to use
     internal permissions
    17:53:06 [INFO] Loaded world: world
    17:53:06 [SEVERE] Nag author: 'ssell' of 'TentThis' about the following: onPlaye
    rJoin has been replaced with a new signature, (PlayerJoinEvent)
    17:53:06 [INFO] Saving wand-commands.txt

    Any ideas what could be causing this?
  9. Offline


    its that the event of players logging in has changed. If you read a couple posts above, he says to disregard this, as he's already changed it and it wont go away. Also the plugin should work fine even with this error.

    CB617, 2.0.1 TentThis, updated essentials, and i still get

    Could not pass event BLOCK_DAMAGE to TentThis
    Could not pass event PLAYER_INTERACT to TentThis

    I know the first one is something you've tried to fix, but i haven't seen that second one.
    That happens when i use /ttnocommand and right click. Any possible fixes/suggestions?
    If not i can wait till its fixed. :p

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  10. Offline


  11. Offline


    Between working on making an assembler for a final project, meeting a deadline for my 3D-Modeling tool for work, and helping my brother move into his first house, I had absolutely no time this weekend. So will try to address all of the previous posts.

    I will definitely allow a toggle-able option in the .properties that will set /ttNoCommand by default. Also, thanks for starting a wiki.

    I am also aware, of the issue where when the server restarts, it forgets that the tents, are well, tents and thus behave as normal blocks. This will be addressed.

    @Lex Mozli / Kimberly2000
    Allowing the users to define their own letters to use in the schemas will definitely be added. Probably at the same time I do the 'reverse-schemas.'

    @Justin Peeler
    Ignore it. I am using the correct signature, and no one can explain to me why I am still getting that message, so I am just ignoring it myself.

    And those with the errors, I will look into them the first chance I get.

    Filed a support ticket to the Essentials devs. Hopefully will be able to get some information about the crashes when running with Essentials. I feel it is because they only officially support up to 602 (which is two RBs back) currently, but want to know for sure.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  12. Offline


    2011-04-04 15:47:37 [SEVERE] BLOCK_DAMAGE loading TentThis v2.0.0 (Is it up to date?)
    java.lang.NoSuchFieldError: BLOCK_DAMAGE
        at ssell.TentThis.TentThis.onEnable(TentThis.java:42)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:118)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:451)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:217)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:92)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:70)
        at org.bukkit.craftbukkit.CraftServer.reload(CraftServer.java:260)
        at org.bukkit.command.SimpleCommandMap$ReloadCommand.execute(SimpleCommandMap.java:196)
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:80)
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:221)
        at net.minecraft.server.MinecraftServer.b(MinecraftServer.java:380)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:366)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    I get this and the tent wont get built no matter what i try
  13. Hi you need to update to take into account http://forums.bukkit.org/threads/oops-i-broke-your-plugins.599/#post-162080
  14. Offline


    O.K. this is just strange. I have been using TentThis for a while already. I am using the 617 bukkit build. When I try to make a tent I type /ttTent as always and it says waiting to build tent, but then does absolutely nothing when I click on it, and I get this error message in the console:


    The only thing that has changed as far as I know, is that I have started a new map on my server, but that should not have any impact on the plugin. Also, I have started using Essentials plugin.

    Thank you for your time and I really hope you can help me out.

  15. Offline


  16. I have just tested this with v 2.1.18 of essentials and it is working ok. Can you pop onto our IRC. http://earth2me.com/x/minecraft/bukkit/irc/
  17. Offline


    Currently at work (shhhh), but I can check it when I get off tonight. The build I tested it against earlier was v2.1.17 of Essentials, so that may of been the cause.

    Thanks for helping me out with this.
  18. hehe no worries. just pop in anytime and a dev should be on.
  19. Offline


    I'll update essential and retry TentThis and Essential last version (found here : http://earth2me.net:8001/artifactory/webapp/browserepo.html V.2.1 from ~3h40 ) and edit my post with my results ^^

    [Edit] Using only TentThis and Essential and here's the result :
    2011-04-04 22:41:24 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-617-g78ac8a8-b621jnks (MC: 1.4)
    2011-04-04 22:41:24 [INFO] Preparing level "realm"
    2011-04-04 22:41:24 [INFO] Preparing start region
    2011-04-04 22:41:24 [INFO] 144 recipes
    2011-04-04 22:41:25 [INFO] Loaded Essentials build 2.1.18 maintained by Zenexer, ementalo, Aelux, Brettflan, KimKandor, snowleo and ceulemans.
    2011-04-04 22:41:25 [INFO] Loaded EssentialsSpawn build 2.1.18 maintained by Zenexer, ementalo, Aelux, Brettflan, KimKandor, snowleo and ceulemans.
    2011-04-04 22:41:25 [INFO] Loaded EssentialsProtect build 2.1.18 maintained by Zenexer, ementalo, Aelux, Brettflan, KimKandor, snowleo and ceulemans.
    2011-04-04 22:41:25 [INFO] Permission system not detected, defaulting to OP
    2011-04-04 22:41:25 [INFO] TentThis v2.0.1 by ssell is enabled!
    2011-04-04 22:41:25 [INFO] Done (0.106s)! For help, type "help" or "?"
    2011-04-04 22:41:47 [INFO] GSecurity [/] logged in with entity id 98
    2011-04-04 22:41:47 [SEVERE] Nag author: 'ssell' of 'TentThis' about the following: onPlayerJoin has been replaced with a new signature, (PlayerJoinEvent)
    2011-04-04 22:42:01 [SEVERE] Could not pass event BLOCK_DAMAGE to TentThis
        at ssell.TentThis.TTSchemaLoader.renderTent(TTSchemaLoader.java:336)
        at ssell.TentThis.TentThis.buildTent(TentThis.java:400)
        at ssell.TentThis.TTBlockListener.onBlockDamage(TTBlockListener.java:39)
        at org.bukkit.plugin.java.JavaPluginLoader$23.execute(JavaPluginLoader.java:303)
        at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
        at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:255)
        at org.bukkit.craftbukkit.event.CraftEventFactory.callBlockDamageEvent(CraftEventFactory.java:180)
        at net.minecraft.server.ItemInWorldManager.a(ItemInWorldManager.java:87)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:356)
        at net.minecraft.server.Packet14BlockDig.a(SourceFile:42)
        at net.minecraft.server.NetworkManager.a(NetworkManager.java:198)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:72)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:368)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
    @ssell : should I try again with your modified version ? (given 1-2 page(s) before this one)
  20. Offline



    The newest version I don't think will make a difference. It is odd that @ementalo just got it working but it is still failing for you.
  21. Offline


    @ssell yes, totally strange, dunno why it's happening... maybe the BC version is not the same ?
    Curious to know if you'll have it to work on your side too or not...
  22. Offline


    nice plugin works great.!! CB 617
  23. I see you have essentials protect maybe that is the issue, can you pastie your essentails config.yml
  24. Offline


  25. Offline


    I am having a similar problem. I am running build 617 and I get:

    when I try to make a tent
  26. Offline


    This is weird...Whenever I make a tent it goes off fine, but whenever someone else makes a tent the
    "[SEVERE] Could not pass event PLAYER_INTERACT to TentThis" pops up whenever someone left or right clicks on it. Then after no one else can make a tent, just get this error once more. Any ideas on the problems of this?
  27. Offline


    All the errors above are caused by running Essentials with TentThis. We are trying to fix this problem.
  28. Offline


    SEVERE] Nag author: 'ssell' of 'TentThis' about the following: onPlayerJoin has been replaced with a new signature, (PlayerJoinEvent)
    public void onPlayerJoin(PlayerJoinEvent event) {

  29. Offline



    That is what I am using. Don't know why it is still nagging me.
  30. Offline


    any chance you can add the ttNoCommand to the properties so its always on/off
  31. Offline


    Hey, I love the idea of this, but the errors are bugging me...

    In the game it tells me that when I /ttinfo or /ttschema it says there is an Internal error in red text.
    I am also seeing this as well as what Nijikokun is seeing:

    So that ^, and the Nag author error also, help please?

Share This Page