[INACTIVE][MECH] StarterKit v0.4a - Give all Players that join some defined items. [953]

Discussion in 'Inactive/Unsupported Plugins' started by Thomas Bucher, May 17, 2011.

  1. Offline

    Thomas Bucher

    StarterKit - Give all new Player (not seen before by the Plugin) some Starter Items

    Version: v0.4a

    You can Configure what kind of Items a never before seen player get if it Joins you server. There is also a get Items after Respawn mode.

    • Give a starterkit to a Player
    • No command needed,it just gets it on Join
    • Config for delay to give the Kit
    • Commands ingame for OPs
    • Respawn Mode Added
    • MultiInventory support on Multiworlds
    Download The Plugin 0.4a
    Download The Plugin 0.4
    Download The Plugin 0.3
    Download The Plugin 0.2a
    Download The Plugin 0.2
    Download The Plugin 0.1c
    Download The Plugin 0.1b
    Download The Plugin 0.1
    Source Code is in the Jar

    Config the Items:
    message: You got some Goodies, to start on this Server
    debug: false
     - <itemid>,<quanitity>
     - <itemid2>,<quanitity2>
    delay: 10000
    usemultiinv: false
    - normal
    - nether
    It has some Defaults built in.

    To start over, delete the playerlist.data file from the plugin/StarterKit directory.

    Ingame Commands: (OP only) -> Not for Respawn Mode
    • /starterkit import <importdir>
      Example: /starterkit import world/players
      Imports all players onto the List from the given Dir
    • /starterkit add <playername>
      Example /starterkit add ToasterKTN
      Adds that Playername to the List (Case Sensitive)
    • /starterkit del <playername>
      Example /starterkit del ToasterKTN
      Removes that player from the List
    • /starterkit search <searchstring>
      Example /starterkit search aster
      Lists all Player on the List with aster in the name
    • /starterkit list
      Lists all Player that are on the List
    • /starterkit clear
      Clear the whole list. No more players will be on the List.
    Todos / Ideas:
    • Check Inventory if it is empty before give items.
    • Add Colors to the Message
    • Add Datavalues to the Itemlists
    • Multiline Messages
    Version 0.4a
    • Import assumes player has been on all Worlds listen in worlds, if
      Multiinv has been enabled.
    Version 0.4
    • Added MultiInv/MultiVerse support.
      Enable usemultiinv
      set the Worlds you wanna get the Kits in worlds:
    • Note: With multiinv support, players in the List are world|playername
      see /starterkit list
      for examples.
    Version 0.3
    • Added a Respawn mode ( onrespawn: true ) in the config file.
    Version 0.2a
    • Added Dup Check on the List itself, to make sure no player gets on the List twice.
    Version 0.2
    • Added ingame Commands for OPs
    Version 0.1c
    • Added Configvariable delay <- delay before give the kit in miliseconds.
    Version 0.1b
    • Add the Items after a 10 Second Delay..
    Version 0.1
    • First Release
    Taranis01 likes this.
  2. Offline

    Thomas Bucher

    plugins/StarterKit/StarterKit.yml ?
  3. Offline


    another bug i found.. when i set an interval let say 2mins.. then a new user login.. then disconnect because of a end of stream.. and reconnect again.. they will have 2 starter kit..
    Thomas Bucher likes this.
  4. Offline


    link is not work
  5. Offline

    Thomas Bucher

    Its hosted on me.com
    Should work again..
  6. Offline


    i tried the space thing but its now working
    heres wat i use
    debug: false
    starterkit: - 277,1 - 278,1 - 279,1 - 264,500 - 310,1 - 311,1 - 312,1 - 313,1 - 50,500 - 263,500

    onrespawn: false

    delay: 10000

    usemultiinv: false

    wats delay

    changed to
    debug: false
    - 277,1
    - 278,1
    - 279,1
    - 264,500
    - 310,1
    - 311,1
    - 312,1
    - 313,1
    - 50,500
    - 263,500

    delay: 0
    usemultiinv: false
    - normal
    - nether
    not working
  7. Offline

    Thomas Bucher

    You also need the space things after the :
    example ->
    onrespawn: false

    etc.. check the yaml file for correctness.
  8. Offline


    Can someone help me out? The plugin is working but I want to change the default set. Below is my config file and it is not working. I still only get the wooden equipment upon respawning. Thanks!

    message: You're welcome
    - 276,1
    - 277,1
    - 278,1
    - 279,1
    - 310,1
    - 311,1
    - 312,1
    - 313,1
    - 50,64
    - 20,64
    - 1,64
    onrespawn: true
    delay: 10000
    debug: false
    usemultiinv: false
  9. Offline


    This error pops up in the console whenever a person respawns. The kit is still given to them though.
    15:59:06 [SEVERE] Exception in thread "Thread-9650"
    15:59:06 [SEVERE] java.lang.NullPointerException
    15:59:06 [SEVERE] at com.bukkit.toasterktn.StarterKit.PlayerDispenser.run(PlayerDispenser.java:26)
  10. Offline


    message: You got some Goodies, to start on this Server
    debug: false
    - 306,1
    - 307,1
    - 308,1
    - 309,1
    - 261,1
    - 267,1
    - 262,128
    delay: 10000
    usemultiinv: false
    - Arena
    onrespawn: true

    it doesnt work///

    yaml said it's good
  11. Offline


    Is working with Bukkit 1000, thx.
  12. Offline


    the link isnt working for me
  13. Bug(?) report:

    CB: 1000
    MultiInv: v2.3.0
    WorldManager: v1.2

    I did set onrespawn to true and everytime i spawnd in ANY world i did get the Kit altough i had specified only 2 worlds in the .yml. After setting it to false it seems to run fine.
    No errors or anything else i could give you sorry.

  14. Offline


    Hey, I got a suggestion:
    Could you add a permissions node system, so on respawn players will get the times they have a node for? so for example, the permissions node
    would then match to a config yml file with
        - (Items given on first join)
            - IRON_SWORD
            - IRON_HELMET
            - IRON_CHESTPLATE
            - IRON_LEGGINGS
            - IRON_BOOTS
    Meaning they'd get an iron sword and full armour when spawning :)
  15. Offline


    Update to RB1000! Error says that StartKit 0.4a is out of date!
  16. It's likely that you have done something wrong, as the plugin runs fine here using CB 1000, mind giving us the complete error-log?
  17. Offline


    How could I of done something wrong if it's the default config and a start up message :O
  18. That's why i said likely....

    However does the error say something like (is the plugin up to date?)? If so there should be some more lines saying what the error was and what caused it.
    As of now, it is working with CB 1000. So something on your end must be screwed up or it a bug in the code which occures due to your installation. Anyway without a detailed error log there is no chance we know whats wrong, so would you post one pls?

  19. Offline


    I've been hosting ever since minecraft came out I know how to place a plugin into a folder. I'm not a noob at this. Anyway's there was a problem with the default config. I fixed it. The developer needs to check his config via his post because it errors up :D
  20. I DID not say you do not know how to install, what i meant was, the plugins you have installed interfere which each other thus resulting in an error. Glad it was an easy fix with the config file.

    And i did not want to sound rude or anything like that, but i have coded mods for a different game in the past (Java ;)) and most of the time someone saying: "It's broke pls update" it was not an issue on my side but thiers. Which was easily found by giving me the EXACT error log produced. Thats why i asked for it.

    So take my apologies for not beeing clear and maybe sounding a bit...rude.
  21. Offline


    Yea I was offended/annoyed and nor did I know you had any idea what java was so I'm just like what's this guy going to do. But since this is made for 953 and the error said is it up to date I thought it was something wrong with the plugin, no it was my config but there was nothing pointing to it.. So I had to find that out myself :O I'm sorry to if I came on a little eh "strong".
  22. Did try the new uCreate v1.4 flatland generator. It created the world just fine using WorldManager v1.2.

    But as soon as i join the world i get this error:
    23:09:32 [SEVERE] Exception in thread "Thread-3580"
    23:09:32 [SEVERE] java.lang.NullPointerException
    23:09:32 [SEVERE]        at com.bukkit.toasterktn.StarterKit.PlayerDispenser.run(PlayerDispen
    Worldname is uCreateFlat if this helps.
  23. Offline


    hi, download link 4a just showing a blank page..
    well it works for chrome..
    Shame links dont work for IE.
  24. Offline


    hi, i am a new player for minecraft beta, and currently i am trying to set up a server for me and my friend to have some fun

    i tried to install your plug-in, and edited the "StarterKit" file as shown above
    here is the coding:

    message: You got some Goodies, to start on this Server
    debug: false
    - 26,10
    - 50,10
    - 64,10
    delay: 10000
    onrespawn: false
    usemultiinv: false
    - TEST
    - TEST_nether
    i did get the default item, the wood tool set, a compase, a storage box, and a piece of raw meat
    how ever, the items i entered under "startkit:" did not show up

    can u please tell me how to set it up properly please?
    thanks you very much
  25. Offline

    Thomas Bucher

    It would help, if you set debug to true, and post the Log on server load and on player join.

    Sincerely Thomas
  26. Offline


    thanks alot for willing to help ^^
    but like i said... i am new to this whole beta server thing
    so could you please tell me how to do what you said?? :)

    sorry for beenin a noob (lol)
    but thanks again for willing to help ^^

    ps: i am assuming you will need to join the server to fix this problem?
    i am in australia, that is a gmt+10 time zone
    and i wont be home till around 6pm here
  27. Offline


    Are the links broken? Just opens a blank page for me :(
  28. Offline


    Is this thread inactive?
  29. Offline

    Thomas Bucher

    Taking drugs ?
  30. Offline


    Actually I was asking because I posted that the download isn't working and 4 days later still had no reply. Then to get a response like that is just plain rude. Forget it I will use another one I found that does the same thing with the exception that I can actually download it.
    P.S I have other plugins built for 953 that still work! And good job on losing followers!
    Thomas Bucher likes this.
  31. Offline

    Thomas Bucher

    If you are not able to download a Jar, its not my fault.. even there are a lot of Posts, which explains problems like this. Once more, try a better / another browser, which doesn't expand or execute the jar without asking you.

Share This Page