[INACTIVE][MECH]CommandSigns v0.4 - Issue commands using signs [672]

Discussion in 'Inactive/Unsupported Plugins' started by Edward Hand, Feb 22, 2011.

  1. Offline


    Got more time and tested a bunch of "/tppos" commands and the signs, it seems tppos has some trouble teleporting to either a really high height or a really far place (can't tell which yet and don't exactly want to keep crashing my server to find out). The exact place it bugs out on is x:332 y:120 z:-1434 Either way, yeah it's not a commandsign problem. Thanks, and to the author of the plugin, thanks!
  2. Offline


    This plugin has really opened up a plethro of possiblities. I really appreciate your effort on this plugin. You have literally created sign shops/ sign teleport/ area based activities rather then anwhere on the server. I simply leave permissions off for a plugin, and use the/*command and then it's local based and people have to use the signs to use the plugin. Simply amazing
  3. Offline


    hey, love the plugin, wondering if you can get it to get the signs x,y,z instead of the players something like <sx> <sy> <sz> for signs postion

    this is as far as i got with ur source (i dont know java)
    _text = _text.replace("<SX>", ""+_sign.getLocation().getBlockX());
    _text = _text.replace("<SY>", ""+_sign.getLocation().getBlockY());
    _text = _text.replace("<SZ>", ""+_sign.getLocation().getBlockZ());
  4. Offline


    Woo i have been waiting for this mod for ever thank god for YOU SIR!!!

    <<---"Computer Support made easy" www.myitech.com.au--->>
  5. Offline


    cb 556, commandsigns .35, Group manager alpha 5. <-- may be the problem
    Similar issue

    Having some other issues with .35, many commands are simply not going through. When I use commands as 2 lines they always have issues.

    **[Need Snow?]
    /*give <NAME> 33

    "item id 33 unkown"
    **[Need Snow?]
    /*i snow_ball

    "nothing in display" console"/CommandSigns, true" <-- most combinations return this
    no snow given
    /*lookup <NAME>

    should return your status with mcbans. It puts in the console "/commandsigns""mcbans sent from /commandsigns .::. returns info to console.

    Tested these with myself as Admin, and a different regular member who had the permission to use signs. This is NOT a permission issue, at least as far as user error is concerned. Many other examples with heroic bounty, bettershop and local shop if you need them. It's not always with the /* command, but those are having most the issues. 2 lined commands are not working at all. Tried 20+ different ways, with spaces at the end of the command or no spaces. Anything spilling into the 2nd line will get read but not actually be a part of the command.

    **[Right Click]
    /shop list buy

    returns "invalid syntax, format is /shop list <buy/sell> <page>"

    **[Right Click]
    /shop list buy

    returns shop list buy menu properly

    trying to use, same response for me or for a regular member

    **[Right Click]


    hard to read but basically showing my permissions file, and console output, along with correct syntax for sign
  6. Offline


    when making a sign with the asterik (/*god) I get errors in my console on right click and the command on the sign does not work.

    2011-03-23 17:08:55 [INFO] /CommandSigns
    2011-03-23 17:08:55 [SEVERE] Could not pass event BLOCK_RIGHTCLICKED to SignColours
    java.lang.NoSuchMethodError: org.bukkit.Server.dispatchCommand(Lorg/bukkit/command/CommandSender;Ljava/lang/String;)Z
    at com.edwardhand.commandsigns.SignListener.onBlockRightClick(SignListener.java:120)
    at org.bukkit.plugin.java.JavaPluginLoader$20.execute(JavaPluginLoader.java:222)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:225)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:480)
    at net.minecraft.server.Packet15Place.a(SourceFile:57)
    at net.minecraft.server.NetworkManager.a(SourceFile:230)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:357)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
  7. Offline


    i cant get command signs to work with GroupManager

    i try a sign like
    /*manuaddv <NAME> prefix &cACE&f
    and it doesn;t work for me (admin) or players

    You are not allowed to use that command
    /manuaddv <user> <variable> <value>

    i used this to make a guild like system. all other commands work with the /*command system but GroupManager
    i can make the same with with-out the /* and it works fine for me the admin. but when i make it for other users
    the sign doesn't work. got a fix for me?

    Was also gong to use this for choosing classes on our RP server
  8. Offline

    Edward Hand

    Thank you for your incredibly detailed report.
    I am not having any trouble with multiline commands on my test server. I have tested with both in-built commands as well as plugin-based commands.

    Some of your issues are as a result of how the plugin interprets new lines. New lines are currently interpreted as a space, so:
    is interpreted as:
    (and indeed there is no item 33)
    Switching the whole of the number 332 to a new line, and not having a space at the end of the previous line should work.

    Your other errors I can't be sure about. I echo again the importance of not having spaces at the end of lines, since newlines are interpreted as spaces.

    I can change this behaviour if requested, though not without breaking multiline command signs that currently work...

    This error is usually caused by having an out-of-date version of bukkit/craftbukkit. Is this the case?

    Have you definitely got the user /CommandSigns set up with the necessary permissions?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 9, 2016
  9. Offline


    Yes multiline commands do indeed work. Thanks for the quick response.

    Still having issues with the /*deathtp, /*lookup

    However the op commands do work, such as /*heal, /*kick, /*give. These worked before I op'ed /commandsigns and before i put anything in the permissions file. I notice different capitalizations does this have any effect? /commandSigns or /CommandSigns.
  10. Offline

    Edward Hand

    The Permissions plugin is case sensitive. I'm not sure about GroupManager. Better safe than sorry though so make sure to use /CommandSigns

    **[click here]

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 9, 2016
  11. Offline

    City Builder

    Thanks, works like a charm.
  12. Offline


    Out of curiosity, is there a possibility for this plugin to work with 531?

  13. Offline

    Edward Hand

    Try it and see.
  14. Offline


    Confirmed that it works with 531 for anyone else wondering!
  15. Offline


    Yes i am using build 493. Im still waiting on a few plugins to upgrade.
  16. Offline


    I have this working with all other commands that a normal user can not use.
    its just Group manager thats not working.
    does anyone else have the /CommandSigns permissions override working with groupmanager commands?
  17. Offline


    use the roles plugin for that.
  18. Offline


    Can u add iconomy cost on sign usage please?
    Bes would be if admin could set the cost separated by every plugin. Would be a perfect plugin for shops, payed warps, class changes etc etc etc.
  19. Offline



    There is a command iconomy plugin. you could make the command cost money and when they use it on the sign it would achieve the same effect as what you are looking for.
  20. Offline


    For what I read you cant use it for making a shop or asign multiple classes because the price of the commands would be the same.

    the /give playername iten would have same cost for every iten, as for assigning classes to players, all classes would have same cost.
    It would be very cool if we could set the price directly on the sign. Then we could have diferent prices for the same command (cheaper markets by different places, cheapers teleports due to being far/near), have pries for commads with specifications (like a person buy a cheap miner class, or a expensive mage class) etc...
  21. Offline


    why does my sign turn red when i create it? i've made /commandsigns an op

    my sign is green when i make it as an admin

    but /*ta town Ravens_Refuge add <NAME>

    returns unknown console command
  22. Offline

    Edward Hand

    You need to have the permissions commandSigns.create to make them
    (explained fully in first post)
  23. Offline


    Great plugin and it works with most commands now for me, there is one problem with the /i and /give command.

    If i click a sign with:
    /*give <name> 1

    the chat will give the usual message: "Giving one of stone to Wilco"
    However the stone does not show in my inventory,
    A wierd fix for this that i found was holding a stone while clicking it.
    Then i would get a new stone + the stones that hadnt showed up before.

    Do you know what's causing this? and how i can solve it?
  24. Offline

    Edward Hand

    It sounds like a bug in minecraft. Not much either of us can do about that.
  25. Offline


    I dont test this plugin but can you add a Redstone Trigger? So we can make a hidden signs with a Redstone button to aktive the signs?
  26. Offline

    City Builder

    We have the same issue without using the command signs, when we give ourselves something nothing shows up in the inventory, but after logging out and back in, all the stuff we gave ourselves is in our inventory. I'm just assuming that it's a minecraft SMP bug for the moment.
  27. Offline

    Edward Hand

    All CommandSigns does is runs the command and little else besides. It's only as good/buggy as the commands you use it with.
  28. Offline


    is it having problems with 3 line commands? my 2 line commands work fine.
  29. Offline

    Edward Hand

    3 line commands should work just as well as 2 line commands (as long as you still keep in mind how it interprets new lines as spaces)
  30. Offline


    well when i make a sign with
    [command] /ta town Ravens_Refuge add <NAME>
    my players get "only an admin can use that command"
    then i make a sign with
    [command]<enter>/*ta town<enter>Ravens_Refuge<enter>add <NAME>
    [command]<enter>/*ta town<down arrow>Ravens_Refuge<down arrow>add <NAME>

    i get "unknown console command"
    and my console says

    i make a sign [command]
    /*give <NAME><enter>5 5
    my console shows
    18:18:11 [INFO] �9[PLAYER_COMMAND] /CommandSigns: /give fugue2005 5 5
    18:18:11 [INFO] true

    /commandSigns is opped
    and /commandSigns is a member of the admins group

Share This Page