[INACTIVE][MECH]CommandSigns v0.4 - Issue commands using signs [672]

Discussion in 'Inactive/Unsupported Plugins' started by Edward Hand, Feb 22, 2011.

  1. Offline


    yeah, i've got a few devices i want it to say also but if i put /say it spits it out in the console. Anyway to make the person who used the sign say the command?
  2. Offline


    I'm using the latest version (0.4) on CB 674, and i get weird errors. Some commands work, and some don't.

    For example, I use MCDocs, and the /rules command works thru a sign, but the /news doesn't work. It works if i type it into chat, but not on the sign. I used the /* but it tells me unknown console command. Looking into the console log i get
    [SEVERE] Could not pass event PLAYER_INTERACT to SignColours
    [INFO] link2110 could not execute command "/news  ". Does command exist?
    The thing is that they work in chat, so the command definitely exits, its just that doesn't seem to be able to use another plugins commands?

    EDIT: When the command is on lines 2, 3 or 4 with anything above, i get the could not execute command error. If there is no text above, i just get the severe error.
  3. Offline


    I love the idea of this but I cant help but feel its too limited by the size of the sign.
    have you though about making the signs work using commands...... just let me explain lol

    1) you make a sign with what ever text you want on it
    2) select the sign and type /CmdSign create [name]
    3) use /CmdSign add [/command] to add your commands to a selected sign
    also /CmdSign remove to remove all commands from your selected sign

    that way you can add alot more to one sign. its times like this i wish i could make plugins myself lol
    come to think of it you can use that same method to make command buttons and leavers (no redstone needed).

    do this and you will be a God...... there may be some [diamond][diamond][diamond][diamond] in it too
  4. Offline


    I turned double // off for worldedit, but this plugin still won't operate properly. I tried to move a block 1 north with "/move 1 north" and my console said "[INFO] punchin could not execute command "/move 1 north ". Does command exist?". I type it out in game exactly as it shows on the sign and console, and the block moves. What's the issue? I don't use any permissions plugins, and I'm an OP.
  5. Offline


    Expanded player targeting would be really great. If I could say /^DrWagstaff and have it run the command from user DrWagstaff, i'd be really happy.

    And also, if you could say at the top **[s:lalala] and it'd run script lala.txt we could do a lot more with one sign.
  6. Offline

    Steve Member

    Hey due could you correct the name of your plugin in plugin.yml so it doesnt say its SignColors ;-)
  7. Offline


    My must have Plugin!

    I builded a Admin Central for Remote Killing other Players :rolleyes:


    Keep up the Work!
  8. Offline


  9. Offline


    I have the same issue, commands work in game chat (for example /motd) but I get 'XXXX could not execute command "/motd ". Does command exist?'

    This plugin used to work perfectly in the past, and my spawn area is full of sign command signs that now no longer work :(

    On a side note, for some reason 'signcolours' appears twice in my /pl plugin list, but command signs is not listed (yet when I create a new sign with [command] on the first line it turns green and 'attempts' to execute the command (but with the error above). I have triple checked and I do NOT have multiple copies / versions of signcolours, and I most definitely have both the latest versions of both plugins.

    Plugin list
    Show Spoiler

    [INFO] Plugins: HeroBounty, AutoPlant, Permissions, SignColours, RemoteToolkitPlugin,
    LimitSpawns, WorldEdit, CommandHelper, RegexFilter, Commands Logging, HeroicDeath,
    HeroicRebuke, mcMMO, mcbans, MCDocs, Questioner, FakeMessage, PlugMan, uQuest,
    PetitionPlugin, CraftIRC, AutoMessage, CraftBukkitUpToDate, LocalShops, HeroChat,
    SpawnControl, BigBrother, DefaultCommands, Cleaner, CraftBookMechanisms, AfkBooter,
    WorldGuard, Stargate, iConomy, Stats, NoCheat, VoidMage, Towny, properTime, ecoCreature,
    MinecartManiaCore, DelayedStop, Minequery, RedeemCodes, CraftBookCircuits, dynmap,
    LWC, MinecartManiaAutocart, SimpleReserve, Vanish, DeathTpPlus, Achievements,
    MinecartManiaPressurePlates, BorderGuard, War, npcx, DynamicMarket, Growbie,
    GroupManager, ChunkRegenerate, KitPlugin, CraftBookCommon, RegionMarket,
    SignColours, MinecartManiaAdminControls, MinecartManiaAutomations,
    MinecartManiaSignCommands, MinecartManiaChestControl, MinecartManiaStation

  10. Offline


    I love this plugin beacuse u can put warps on it :p
  11. Offline


    Glad to see this has been done justice on Bukkit. Nice work Edward Hand.
  12. Offline


    I'd have to agree, there's some commands that don't work. I used a sign for
    \is reading the rules
    at my spawn and hasn't worked for a while. I even tried /kill
    /warp and /me works fine though
  13. Offline


    This is a great plugin, what would make it more great imo is allowing them to be activated by redstone. it would allow people to bind commands to all sort of redstone contraptions and increase the functionality of the plugin greatly. Also i wanna expand my control room XD
  14. Offline


    Figured I'd mention that Signcolors and commandsign both don't work on the CB 700+ series. :/
  15. Offline


    Oh god. 80% of my server RP depends of this plugin. Really hope that plugin gets fixed, or that next bukkit recomended build will unbreak it. Im scared :(
  16. Offline


    Can't wait for a fix, this is definitely borked in B:714/MC:1.5 :X
    I don't rely heavily on it these days, but I do really enjoy it all the same :)
  17. Offline


    Also stating that this is not working as intended on #714, the sign is being made, the [command] is green. However all commands put on the sign are non-functional.
  18. Offline


    Need a fix for this soon. Really helps setting up and getting users to join spleef/war-zone games if they have a sign to click on.
  19. Offline

    Amin Azman

    :D hope the developer aware of these problems :D
  20. Offline


    FUCK YEAH!!!!!!!!!!!!!!!!
    Edward is back! Im not scared anymore.
  21. Offline


    so any chance for 1.5 support?
  22. Offline


    looking forward to 1.5 support
  23. Offline


    i could kiss you. but im a guy and im 12. i cant wait to put this on my server and looking foreward to 1.5 support
  24. Offline


    Hey, when i create a sign like this:
    /item 5 64

    The [command] line gets green but when i rightklick on the sign nothing happens.
    Sry for bad english xD
  25. Offline


    The plugin hasn't worked since 1.5 came out. If I may suggest, next time you mention a bug about a plugin, read the thread's last page or two in case someone else mentioned the same thing.
  26. Pla, Kingjarrad, MintTheFox, Thokas, paully104, Atticusmas
    Repaired by me, working with 1.5 (tested with CB#714 and CB#731). I am not plugin developer, if you do not trust me, just do not download this, your choice. (nothing changed, just repaired - src included)

    Edit: Jesus, I edited this post so many times. I am sorry if something... :p
    Pla and CainFoool like this.
  27. Offline


    Thanks works great on CB#714
    Pla likes this.
  28. Offline


    Thought I'd jump in and add the ACTUAL error (unlike everyone else). This is with the latest recommended build (733).
    Show Spoiler
    2011-04-26 01:19:11 [SEVERE] Could not pass event PLAYER_INTERACT to SignColours
    java.lang.NoSuchFieldError: c
    at com.edwardhand.commandsigns.SignListener.onBlockRightClick(SignListener.java:74)
    at com.edwardhand.commandsigns.SignPlayerListener.onPlayerInteract(SignPlayerListener.java:20)
    at org.bukkit.plugin.java.JavaPluginLoader$9.execute(JavaPluginLoader.java:254)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:257)
    at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:162)
    at net.minecraft.server.ItemInWorldManager.interact(ItemInWorldManager.java:207)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:519)
    at net.minecraft.server.Packet15Place.a(SourceFile:57)
    at net.minecraft.server.NetworkManager.a(NetworkManager.java:195)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:74)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:370)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:285)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
  29. Offline


    BLOCK_INTERACT was changed to BLOCK_RIGHTCLICK. I believe that is what broke the plugin. Should be a simple fix.
  30. Offline


    Thank you it really works :D

Share This Page