[INACTIVE] iQuest v3.2.0 - Take NPC questing to the next level! [1060]

Discussion in 'Inactive/Unsupported Plugins' started by sddddgjd, Aug 2, 2011.

  1. Offline


    iQuest is no longer in active development!

    Yeah,that's right,i quit,you can all go home now...:D
    Jokes aside, i am forced to quit working on iQuest,for a number of reasons,including:​

    • The code was old...very old! Updating the entire thing just isn't possible!
    • I am really busy with 2 other,bigger,projects, so i can't spend that much time on this!
    • I am not as familiar with the code as i could be if i created it!
    • Big parts of the code just plain suck...i was a really bad coder when i starter this project! :D
    That being said,don't panic! I am going to recreate iQuest from SCRATCH, using just a small part of the main code! It will act the same,however some of the important changes will be:

    • Superperms support! It's the future,it's time for people to switch over...
    • More quest types!
    • Parties!
    • Speed improvements!
    • MySQL/SQLite database support!
    • Much easier commands,and interface
    • Spout support!
    • MASSIVE support for RPGWorld, one of the 2 big projects i'm working on...that thing will be INSANE!
    • New configuration support! Should be much harder to mess it up...

    You may be wondering,how am i going to pull this off? Well, first of all, i have @Samkio , @tips48, @r3Fuze , and the rest of our coding team to help me! However, we all have to work on separate parts of the plugin, so i will make yet another coding team, which will work exlusively at the questing part! (it will also work as a stand-alone,don't worry :D)

    So,that was it, i will start actually working on it now!
    If you want to take part in development,just PM me! If you have atleast one plugin,i'll probably know you already! :p


    You guys helped me the most during development...interested in joining this?

    For more details on the new plugin, click!

    chudy126p, Samkio, powback and 6 others like this.
  2. Offline


    @sddddgjd First off, very nice plugin! ;)
    But I have a problem. When I've completed a quest, I always get way too much money!
    For Example: I should get 160 Euro, but I get 300!
    I hope you can help me fix this! :)
  3. Offline


    Latest jar file and the iquest files is all you need!

    i HATE essentials...i seriously feel like removing this shit from my plugin! I'll look into it...

    if you're using my development version,delete iquest.bin or use the untested converter!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 18, 2016
  4. Offline


    Can you add "Find NPCs" quest types?
  5. Offline


    they're already in...get the developer version!
    You can change where the quest must be completed,you just select another npc, and don't put any objectives in!

    try deleting every file except for quest.yml!
    That includes iquest.bin!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 18, 2016
  6. Offline


    @sddddgjd No help for my problem?? ^^
  7. Offline


    What economy system are you using?
  8. Offline


  9. Offline


    Thanks for reporting the bug,it is now fixed!
    Also,the development version,since it doesn't seem THAT bugged,is not the normal one!
  10. Offline


    Not using the dev version, using the release version.
  11. Offline


    delete all the files except quests.yml...i'll look into this in the meantime!
    LE: Did you use a command to cause this?
  12. Offline


    2011-08-11 04:43:58 [SEVERE] Could not load 'plugins/iQuest.jar' in folder 'plugins':
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:173)
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:207)
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:130)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:128)
        at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:97)
        at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigurationManager.java:51)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:132)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.NoClassDefFoundError: com/earth2me/essentials/api/UserDoesNotExistException
        at sddddgjd.iquest.iQuest.<init>(iQuest.java:122)
        ... 13 more
    Caused by: java.lang.ClassNotFoundException: com.earth2me.essentials.api.UserDoesNotExistException
        at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
        ... 14 more
    I have the latest essentials and iQuest latest .jar.

    Please, help. Am ready to provide any information necessary.
  13. Offline


    Did as you said. This got rid of the internal server errors, but still my players aren't receiving quests.
    I didn't use any command to do this.

    Edit: Now any time I do a server reload it breaks all over again (even though it didn't work previously). I had this working one time and now it's completely broken. I have a feeling this is all due to essentials.
  14. Offline


    Sorry,essentials eco fans,but im removing support for it from my plugin!
    It's more pain then it's worth!

  15. Offline


    Well, I don't use EssentialsEco, god forbid..

    I use iConomy, the only essentials plugins I use are Essentials and EssentialsSpawn, and even those I don't wish to use.

    Although, the removal of support sounds good, too. Please reply whenever you do so. Thanks!
  16. Offline


    Download link updated, i removed it!
    The problem is,essentials eco sucks so much,there 's no way of disabling it if you use essentials,or checking it it's even loaded! And i had tons of problems because of this....
  17. Offline


    Thank you, will give this a try ASAP.
  18. Offline


    Success! Everything is fully functional.

    Thank you so much.
  19. Offline


  20. Offline


    I'm still not getting it to work. /q brings up the menu but nothing else works. /q give doesn't work, but it also don't give errors. /qn create <name> -1 says it creates a quester but it doesn't seem to work.
  21. Offline


    Have you removed Essentials? Please tell me you have becuse I can't make it work!
  22. Offline


    /q give ,done,and drop won't work! and you must not tell -1!
    just read the commands again...for the npcs to work,you need to do /qn create [npcname] [questnumber],if you dont give it a questnumber,it will make it random!

    i removed it! does it give you an error message?
  23. Offline


    Yes by me too. It says: Addning Npc NAME to the quester list. But there is nothing. when ic create a npc and do that its the same but he isnt give quests?

    And when i dont give a Quest numer its says: You need to specify the NPC's name and the quest number after *create*

    Can you make a Tutorial Video?
  24. Offline


    Still not working at all. NPCs don't work, trying off NPCs in config and using other commands like /q give doesn't work either.
  25. Offline


    alright,here's a step by step tutorial:
    1.type /npc create [name]
    2.type /qn create [name] [questnumber]
    right click the npc!

    are you sure it doesn't give any errors?
    if it doesnt,use the step by step tutorial!
  26. Offline


    Hi, I have this error

    2011-08-11 13:29:52 [SEVERE] Could not pass event ENTITY_DAMAGE to iQuest
        at sddddgjd.NPC.NPCListener3.onEntityDamage(NPCListener3.java:35)
        at org.bukkit.plugin.java.JavaPluginLoader$58.execute(JavaPluginLoader.java:649)
        at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
        at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:332)
        at net.minecraft.server.EntityHuman.damageEntity(EntityHuman.java:423)
        at net.minecraft.server.EntityPlayer.damageEntity(EntityPlayer.java:179)
        at net.minecraft.server.EntityHuman.d(EntityHuman.java:561)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:858)
        at net.minecraft.server.Packet7UseEntity.a(SourceFile:33)
        at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    How do I fix this?
  27. Offline


    Tried that, no luck...

    However, upgrading to your latest Essentials-free version fixed it :) Can't wait to try it out!
  28. Offline


    This is exactly what I'm doing and it's still now working. No errors at all in the game or in the console.
  29. Offline


    ooo.. Here's a quirky bug for you:

    I got the usual error on first-start about missing iQuest.bin. No biggie, it creates it right?

    I'm on a Linux host.. Instead of putting it in the plugins directory (or even better, the plugins/iQuest directory), it put it in my Minecraft directory named "plugins\iQuest.bin" (wrong slash).
  30. Offline


    Ahhh.. maybe this is what is happening to me.

    Edit: Didn't work.
  31. Offline


    Did you get it when you updated to the latest version?
    If yes,then use the untested convertor i put there,or just delete iquest.bin!

    aah,you guys have linux?
    I knew about this problem!!
    I'll fix it in 2 minutes! :D

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 18, 2016

Share This Page