[INACTIVE] iQuest v3.2.0 - Take NPC questing to the next level! [1060]

Discussion in 'Inactive/Unsupported Plugins' started by sddddgjd, Aug 2, 2011.

  1. Offline


    iQuest is no longer in active development!

    Yeah,that's right,i quit,you can all go home now...:D
    Jokes aside, i am forced to quit working on iQuest,for a number of reasons,including:​

    • The code was old...very old! Updating the entire thing just isn't possible!
    • I am really busy with 2 other,bigger,projects, so i can't spend that much time on this!
    • I am not as familiar with the code as i could be if i created it!
    • Big parts of the code just plain suck...i was a really bad coder when i starter this project! :D
    That being said,don't panic! I am going to recreate iQuest from SCRATCH, using just a small part of the main code! It will act the same,however some of the important changes will be:

    • Superperms support! It's the future,it's time for people to switch over...
    • More quest types!
    • Parties!
    • Speed improvements!
    • MySQL/SQLite database support!
    • Much easier commands,and interface
    • Spout support!
    • MASSIVE support for RPGWorld, one of the 2 big projects i'm working on...that thing will be INSANE!
    • New configuration support! Should be much harder to mess it up...

    You may be wondering,how am i going to pull this off? Well, first of all, i have @Samkio , @tips48, @r3Fuze , and the rest of our coding team to help me! However, we all have to work on separate parts of the plugin, so i will make yet another coding team, which will work exlusively at the questing part! (it will also work as a stand-alone,don't worry :D)

    So,that was it, i will start actually working on it now!
    If you want to take part in development,just PM me! If you have atleast one plugin,i'll probably know you already! :p


    You guys helped me the most during development...interested in joining this?

    For more details on the new plugin, click!

    chudy126p, Samkio, powback and 6 others like this.
  2. Offline


    doubt it,but you could try...sorry! The entire essentials is hard to work with,and eco is the shitties part of it....
  3. Offline


    So sould i remove all my Essentials plugins ? or just change the Eco plugin i use for iquest from Essentials eco to none or BOSE eco ?
    And which file editor can i use for traducing quests which make "é'èàâ not crash the plugin (there are a lot of char like é in french ><')?
  4. Offline


    minecraft doesn't support french characters....nothing i can do about it afaik!
    I'll post about this on the forums though! Maybe there is a fix...
    Just install BOSeconomy,i removed essentials support,which means it has no idea what essentials eco is anyway!

    Updated again! Added option to /qn change disable feature!
    Read more about it in the commands section!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 18, 2016
  5. Offline


    can i set blocks on quest rewards ? that could be good because i could reward players with a block which they can use or sell at the market and so earn as much money as the quest should give.
    concerning french characters: encoding the file as UTF-8 allow using french characters and single quotes too! (default encoding is ANSI)
  6. Offline


    Updated again! lol-fixed lots of errors when right clicking-left clicking a non-quester NPC!

    of course you can!
    Just look in the default quests.yml,there are a couple of quests that do that!
    and the problem isnt in the files,it's minecraft (and bukkit) itself!
    It doesn't support these kinds of characters!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 18, 2016
  7. Offline


    German Quests work now, thanks!
    But I still get the huge error message every single time when someone leftclicks a NPC.

    Edit: Oh, now I see there is an update. I'm going to test it soon.
  8. Offline


    yeaaah,fixed that error!
    Sorry about it,was really stupid of me to forget it there...

    P.S: JUST GOT MY FIRST DONER EVERYONE! He will get a special prize whenever he uses the iQuest plugin! ^^
    And,of course,an [iQuest Donor] tag near his name!
  9. Offline


    that isn't a question! Encoding files as UTF-8 works ! There are french characters in my quests and minecraft CAN display them ! If you want to Check it you can come on my serv tomorow
  10. Offline


    Wierd...i know it can't display chinese,and assumed it doesn't work for french either....ok people,just save as UTF-8!
  11. Offline


    Is there a way to let the NPC take the items?
  12. Offline


    Just 3 requests. :)

    1) Make the rewards configurable for each quest, not random rewards.

    2) I wanna make a storyline :D. Can you please implement a quest numbering system or so to prevent a user from starting a certain quest if he/she didn't complete another?

    3) If a quester asks for 100 cobble, at the end of the quest remove that cobble from the player, have the quester take the items he requested.

    Thanks for the awesome plugin :)
  13. Offline


    i found this trick because it was written in Essentials Config... Ironical isn't it ?
    A friend asked me for a quest "burn your neightbour's house" is it possible ?
  14. Offline


    Hey Randy, didn't mean to offend you. It's just EpicQuest is not in a workable state at all. Constant server errors and players could never get a quest done. If they did get a quest done it was completely random heh

    iQuest is still not working for me. I've delete all the files except quests.yml. I've updated to the newest version. Same issue, I create a quester but he doesn't not give quests. No errors, just nothing happens

    Bah, what boogles my mine is it WAS working! It was awesome when it was working and my players LOVED it! But it just randomly broke on a server restart and now nothing I do fixes it!
    /q works. The plugin is loaded. It's just the NPCs that aren't working.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 18, 2016
  15. Offline


    2011-08-11 18:08:55 [SEVERE] Error occurred while enabling iQuest v3.1.0 (Is it up to date?): null
    	at sddddgjd.iquest.questclasses.QuestLoader.getymlRewardsFromHashMap(QuestLoader.java:306)
    	at sddddgjd.iquest.questclasses.QuestLoader.getYamlQuestFromHashMap(QuestLoader.java:291)
    	at sddddgjd.iquest.questclasses.QuestLoader.loadAllQuests(QuestLoader.java:125)
    	at sddddgjd.iquest.iQuest.theQuestsLoadAllIntoArray(iQuest.java:411)
    	at sddddgjd.iquest.iQuest.onEnable(iQuest.java:197)
    	at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
    	at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:878)
    	at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:272)
    	at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:162)
    	at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:146)
    	at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:284)
    	at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:271)
    	at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:148)
    	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
    	at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    CB 1000
    Latest .jar file
  16. Offline


    Your iQuest isn't up to date.
  17. Offline


    Hello, I think this error occours when you hit a NPC without setting a quest to it.
    Does this plugin support superms?? (It should, right? superms simulate Permissions)
    The only prob @ my server is that I can't get a quest! When I right click the NPC after giving it a quest I get: "You don't have permission to get quests!"
    I set :

    iQuest.CanQuest.*: true
    iQuest.CanDropQuest: true
    iQuest.CanReloadQuests: true
    iQuest.CanReloadQuestConfig: true
    iQuest.CanQuest.set: true
    iQuest.*: true
  18. Offline


    CB 1000 and latest .jar file :)
  19. Offline

    Randy Schouten

    I know about the second part...
    Did you post all the normal errors in the thread? *maybe continue this on PM's* :p
  20. Offline


    I did post them. I just need to get quests working as my players really need them.
  21. Offline


    Hmm.. it's not working for me again. Was just working on quests (changed the text in quests file). Did nothing else. When i try to update the quests ingame, I get an error message in the chat and a huge one in the console:
    btw. its not 3.1.0, I'm using 3.1.8
  22. Offline

    Randy Schouten

    I'll read thru em carefully again and upload the proper quest file with it.
  23. Offline


    16:35:45 [SEVERE] Could not load 'plugins\iQuest.jar' in folder 'plugins':
            at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
            at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
            at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Sou
            at java.lang.reflect.Constructor.newInstance(Unknown Source)
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.j
            at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:128)
            at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:97)
            at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigur
            at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:132)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.NoClassDefFoundError: com/earth2me/essentials/api/UserDoesN
            at sddddgjd.iquest.iQuest.<init>(iQuest.java:122)
            ... 13 more
    Caused by: java.lang.ClassNotFoundException: com.earth2me.essentials.api.UserDoe
            at java.net.URLClassLoader$1.run(Unknown Source)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.net.URLClassLoader.findClass(Unknown Source)
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.
            at java.lang.ClassLoader.loadClass(Unknown Source)
            at java.lang.ClassLoader.loadClass(Unknown Source)
            ... 14 more
    3.1.0 just got it CB#1K
  24. Offline


    Somebody plz help me with my permission issue =s
    Does it suport superms? It says I don't have permission to get quests
  25. Offline


    Holy crap I got it to work! I deleted everything. Started server. Shut it down. Reinstalled. This time I didn't remove any quests I only changed the amount of gold and I have it so it's not using NPCs. I'd rather use NPCs, but I don't want to risk changing anything lol.
  26. Offline


    More than one quest per npc and chainquests would be awesome
  27. Offline


    how add quest objects like this: 35:2 or 351:4 ?
  28. Offline


    1.They are configurable! Look into quest.yml! It's just that,in the default quests,you rarely get items/blocks (the original creator did that,not me :D)!
    2.That is coming!
    3.It is taken at the end...unfortunately,there is a bug,where you still see the items as if they were in your inventory! But they're not! Just reconnect to the server,or try to place the items,and they will dissapear!

    they take the items...it 's just a bug that you still see them (nothing i can do,it's client side)! Try placing those blocks, or dropping them,they will dissapear!

    the quest reloading is broken,you need to do /reload!

    Your quests.yml file is broken! You have an error somewhere....
    Try with the default quests!

    Get it again,that error is fixed!

    More than one quest won't happen anytime soon,but chain quests are coming!

    You ARE using npcs,unless you changed "Use NPC based questing" to false in the settings!
    P.S: Whitelist me on your server,and i'll show you how to do it step by step! :D

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 18, 2016
  29. Offline


    well i hadnt got a chance to test since before you added the rclick/lclick function. just updated a few hours ago and gave it a run with two other guys. everything worked great. we all had fun (until someone got the quest to damage a wood block 5000 times lol, lclick to drop works by the way, 300+ wood punches later:))

    one thing i would like to see after thinking about how to implement this on my server would be the ability to make a quest.yml for a specific npc...like say i have a guy named 'questie'. if i could link him to questie_quests.yml and have him do only the quests in that file (preferably in order) and then return 'sorry i have no more work/use for you' (or a configurable string) when he is out of quests. this would be awesome for setting up things like a guild where a guy hands out appropriate quests that you configure yourself (like kill quests for the warrior guild, block place for engineers, that kind of thing), or a tutorial guy who teaches you how to do things, or whatever a person can imagine...
  30. Offline


        usePermissions: true
        pluginTimerCheck: 5
        MoneyPlugin: iConomy
        moneyName: Dough
    The required item's ID: 0
    'Use NPC based questing ': true
        SaveQuestersInfoIntervalInMinutes: 30
        broadcastSaving: false
        useSQLite: true
        hideQuestRewards: false
        questRewards: 87,Netherrack Blocks,10~88,Soul Sand Blocks,10~89,Glowstone Blocks,10~18,Leaf Blocks,10~344,Eggs,10~348,Glowstone Dust,10
        useDefaultiQuest: true
        questRewardInterval: 10
        questAnnounceInterval: 5
    Require item in hand for NPC questing: false
        scaleQuestLevels: true
        questLevelInterval: 50
        dropQuestCharge: 5000
        dropQuestInterval: 60
    Is there something wrong with this?
  31. Offline


    seems ok to me....what 's the problem?

Share This Page