[INACTIVE][FUN/TP] PressurePorts v1.3- Step on a Pressure Plate, Warp [818]]

Discussion in 'Inactive/Unsupported Plugins' started by Wurstfabrik, May 20, 2011.

  1. Offline


    Pressure Ports - Step on a Pressure Plate, Warp
    Version: 1.3

    Since i started working with java some days ago and announced this to my server users it didn't took long till the first requests came. One was simple enough for my skills and sounded funny (and it is, oh lol!), so i started working on the idea.

    It is simple: You step on a pressure plate and get teleported somewhere. Due to the mass of pressure plates on my server i decided to add a required block (lapis) under it. So here is how you set up the PressurePlate:

    Place a Lapis-BLock​
    Place a Stone Pressure Plate on it​
    Walk somewhere, enter /ppset​

    Now everybody can step on your awesome PressurePort and get ported to somewhere else :D

    For everyone who doesn't get the text, dubstein made a short but cool explanation video:

    (Thanks bro!)
    Please ignore the "kid", i am 23 years old. :D

    Let's you create an automatic Warp system without using portals or commands for your users.

    PressurePorts v 1.3
    Source Code is a mess at the moment, maybe i will make it public for later versions.

    Things to know (open)

    Config File:
    The config file is generated automaticly when running the plugin the first time. If you have any problems create a file called config.yml in the PressurePorts-Dir and fill it with the following text:

        PlateType: STONE_PLATE
        BlockType: LAPIS_BLOCK
        Player: true
        Mobs: true
        Minecarts: true
            Break: true
            Create: true
            Use: false
    Short explanation of the settings:
    PlateType MUST be STONE_PLATE or WOOD_PLATE, everything else will be overridden with STONE_PLATE by the plugin.
    BlockType MUST be a placeable block, everything else will be overridden with LAPIS_BLOCK by the plugin.

    Legal BlockTypes (open)

    You CAN NOT use Block-IDs as a BlockType. So using 42 for Iron Blocks for example will reset the config to LAPIS_BLOCK. Here is a list of what can be used as BlockType:


    The ShowErrors decide wether or not there will be an error message shown if the user doesn't have the permission. I suggest to take the standard-settings, so your users can still use PressurePorts as regular Pressure Plates without being annoyd.

    Permission Nodes:
    I am now using the modern technology "permissions". Every player in the ops.txt can still perform every action, everybody else can be edited using the following permission nodes:

    PressurePort.Use - Wether or not the player might use PressurePorts.
    PressurePort.Break - The user can Break PressurePorts.
    PressurePort.Build - The user can build and set PressurePorts.
    Since this is my first work with permissions and i felt a little bit lost during the process there might be bugs. I tested everthing that came to my mind and it all worked, but maybe you find something that shouldn't happen. Please excuse and report those bugs!

    Version 1.3
    • Fixed a bug where PlateType: WOOD_PLATE would be treated as illegal config.
    • Fixed a bug where entering anything than a legit Material would crash the plugin
    • Fixed a bug where not using Permissions would crash the plugin.
    Version 1.2
    • Fixed a bug when that crashed the plugin when creating the config-file
    • Added support to warp mobs :D
    Version 1.1
    • Fixed a bug where people with PressurePort.Build couldn't use the command.
    • Fixed a bug where placing an illegal material in the config crashed the plugin.
    Version 1.05
    • Added configuration file
    • Added permission support
    • Added Multiworld support
    Version 1.0
    • Release, yeah!
    To come:
    • different store format
    • use exisiting warps from various warp-plugins as target
    • iConomy-Support (working on this)
    • Warp Minecarts & Mobs.
    • your suggestion here
    Known Problems:

    • When creating some plates in row, where you get ported from 1 to 2 to 3 and so on you might get kicked because of flying.
    • Sometimes, when warping away, the plate stays pressed. For me, this seems to be lagrelated, but i'm not sure.
    Support me:
    I am looking for the storeage-files for the following warp-plugins:
    • Warpz0r
    • Essentials Warp
    If you use one of them, please upload the file somewhere and message me or write in the thread. Also, if i'm missing some important warp-plugins, feel free to tell me!

    (BIG thanks to my awesome mate 4treyu who wasn't annoyed by my ton of java-related questions :D and to Leonlas for the idea)
    Leavy, MrTofuhero and kahlilnc like this.
  2. Offline


    This problem is related to #818, multiworld-teleports are broken at the moment in some cases. #819 is out, which fixes this issue, but it's not recommended, so not tested by me. Don't expect to much support by me :S

    I will take a look at the world-guard-problem in the next update.
  3. Offline


    When others step on the plate they wont tp. :( I have the permissions set up. It only works for me and I dont get a error either?
  4. Offline


    I got a problem when the plugin works fine but i set up a pressure port to another world and it is not accurate it is a sphereworld so they really have to tp on the right place but they are spawning random in that world :S and not on the location i specified :( do you know how to fix this?
  5. Offline


    Show your permissions.yml please. Also, any errors?
  6. Offline


    PlateType: STONE_PLATE
    BlockType: LAPIS_BLOCK
    Player: true
    Mobs: true
    Minecarts: true
    Break: true
    Create: true
    Use: false
    Does only work for OPs can you fix it please?
  7. Offline


    Use Permissions!
  8. Offline


    i hate permissions...
  9. Offline


    Okay, there seems to be a bug where in newer bukkit-version the port also is op only. Sorry, wasn't aware of this ;) Can you please tell me which Bukkit-Version you are using so i can try to find the error
  10. Offline


    Should problem read the command like this. Was having an unknown command problem and this fixed it:

    if (cmd.getName().equalsIgnoreCase("ppset"))
  11. Offline


    Can you allow players on servers without Permissions to use the plates through a config? A very important plugin I use conflicts with Permissions. :(
  12. Offline


    I just started playing with this plugin because warping is cooler if you don't have to type anything :)

    I'm having a problem where the chunk that I am warping into doesn't load, and I inevitably fall through the world and die horribly to void damage... and I'm assuming this isn't a feature (although I wish this was a toggleable option for some users on the server!) :)

    I'm not experiencing any lag anywhere else, and all of the chunks around the chunk I'm porting into do load fine. Using a /jumpto command I can jump outside of the chunk onto an adjacent loaded chunk. If I do this then the chunk I was tping into never loads until I restart the client (the server seems fine, and other users can see the chunk).

    Edit: I should mention that I can TP around without any problems using CommandBook's /tp <x,y,z>. I don't have any trouble with chunks loading using that.

    Any help is appreciated!
  13. Offline


    Look into bananachunk. It'll load the chunk your in. Its been working Perfectly for me. Especially tied with this mod :D

    As for the plugin, I'm having the same problem as defaulting to op. Permissions aren't giving access to the ports....Only ops. We just realized that this problem was occuring and we've based our main world around them. (They tp us everywhere lol)

    If theres anyway you can help out with this. It would be Greatly appreciated.

    Btw....I'm using CB# 820
  14. Offline


    Thanks :D Must be related to the Bukkit-Version, 818 works fine. I will release a unofficial fix for this tomorow, but a new official version will be released with a new recommended. Hope this is okay for you ;) Sorry for the delay, but my RL owns me a little bit at the moment!

    And yeah, the chunk-load-problem isn't related to the plugin. BananaChunk will do the job.
  15. Offline


    Np, Thanks for the speedy reply :D
  16. Offline


    Ahh... awesome. Thanks. Bananachunk fixes this issue :)
  17. Offline


    Hey - I love this plugin. It's exactly what I am looking for. I have one suggestion.

    When you create the destination, would you be able to make it so you face the direction you were facing when you created it? Something like this happens in essentials spawn when you set a spawn location. That would be fantastic.
  18. Offline


    Yeah, thought about that, too. Will be part of the next "big update" ;)

    @Bloodykittens @Hyphe @fobsi @kahlilnc
    Here is the version with the op-fix. Seems like this wasn't related to bukkit, but result of my poor coding skills :D
    Here it is: http://dl.dropbox.com/u/27758241/PressurePort.jar

    Again, sorry for the delay, but real life... you know the deal :D I will start working on the next big update now, which will bring some usefull changes.
    kahlilnc likes this.
  19. Offline


    :D Thank you VERY much.
  20. Offline


    Is it just me or do mobs not get ported between worlds, it seems like it just deletes the mob.
    Also I'm not sure if its caused by 818 but using a pressureport from the main world to the nether does not seem to work correctly, it sends me somewhere other than the location in the nether where I used /ppset.
  21. Offline


    It doesn't work for me...i did everything right (and it is soooooo simple) but when i do /ppset, walk back to the plate, and step on the plate... NOTHING HAPPENS

    -i DO get the messages in-game saying "walk to a different location and type /ppset" and "port stored"

  22. Offline


    Same problem here, using 818build.
    I do get the messeges that my port has been stored etc. but when stepping on them, nothing happens.
  23. Offline


    Me Too.
    This looks so cool aswel.
    I even made a bukkit account just to try and get some help on this.
  24. Offline


    When i write - PressurePort.Use in my groups.yml file
    the reload my server it disapeares :( any help?
  25. Offline


    I seem to be having the same problem as Choashawk. I am an op, and I can change the stuff in the yml file, and it all works, but when I get on the plate, no teleport. It doesn't give an error message, it just doesn't teleport you. I'm guessing it doesn't like something I'm running. Currently I am using the Borderguard plugin (I don't think that it is the problem) and I am running either 818, or 860. I'm not entirely sure, I tried both to get Bukkit to run, and I forgot to note which version actually worked (they aren't named so that I can distinguish). Thanks for any help, hopefully you can fix it (or yell at me for doing something wrong) so that I can start official construction on my next project.

  26. Offline


    Well, for some reason it just doesn't work for me. I put the pressure pad down on a Lapis block as it should be, and then type /ppset on a location, all that goes fine. Its when i stand on the pad nothing seems to happen. I only have WorldEdit and Fastmining as my other mods at the moment, so what could be the problem? :<
  27. Offline


    Well, I got the plugin to work. You MUST have the permissions plugin. You also have to config class settings (the default admin allows everything). Then, you have to write the script to make your character a user, and assign him a class (admin). Then it should work fine. See the guys tutorial. I'd make a ling, but I'm lazy. Search for it or harass me a bit.
  28. Offline


    I was getting the same problems where only ops could use them. Occasionally non-ops could use them but not reliably. I updated to the op-fix update, and now they don't work for anyone at all. I went back to 1.3, and they still don't work for anyone. I turned on error reporting for use, and I get the message "You are not allowed to use Pressure Ports." Hope that helps you track down the problem. I am really hoping to avoid having to set up Permissions plugin.

    Edit: I feel kind of bad with the first thing I've said about them is that they're broken, so: Good job, I really like this plugin.
  29. Offline


    Question.. Can i place more than one portal, and if so.. How?
  30. Offline


    Ah, I figured out why going back to 1.3 didn't fix the problem introduced by going to the op-fix version. I was using the 1.3 download link, which currently IS the op-fix version. Is there anyway we can get a download of the original 1.3, since this update doesn't work at all for me?
  31. Offline


    Damn, We can't use our ports at all :( wether you have permissions or Op

Share This Page