[INACTIVE][FUN] TextCraft v1.5 "Sontaran" (Easy text creation) [BROKEN, update coming soon]

Discussion in 'Inactive/Unsupported Plugins' started by DrinQ, Jan 23, 2011.

  1. Offline



    TextCraft is a plugin that allows you to make big text over your house without all the jumping around.;)

    Select the starting point (lower left corner) by right clicking with a diamond.
    Then type for example:
    This will create "TEXTCRAFT" in "big" iron letters, starting from your selected point in the direction you have chosen (n stands for North). The last parameter sets the size of the text. Check out the download button below to see the difference between the two current standard sizes, 1 & 2. (If the last one isn't set, it will just assume you want size 1.)
    Installation instructions can be found in the Readme.txt file.

    The commands in short:

    This command creates regular horizontal text.

    This one makes vertical text instead. Use the same parameters as /tc.

    Undoes your last TextCraft action.

    Latest version: 1.5 Sontaran
    Updated: 28/1-2011


    Download here​

    CREDITS to Toi for:
    permission, properties & TargetBlock classes.​

    Let me know if you have found a bug, have feature suggestions, or if you just liked it. :)
  2. Offline


    You will get "unknown command" if the user isn't in the permissions file.
  3. Offline


    Im in the permissions file and everything. And yet I get no confirmation of my right click the starting point and the command is unknown in the console. Not sure why. Any suggestions?
  4. Offline


    No errors? Like I said before. The only thing I can think of is that you haven't written your name correctly in the TextCraft.perms file. (It's case-sensitive)
  5. Offline


    do you know if the works on the most recent build lets say 169 or do i need to downgrade?
  6. Offline


    Running on 168.

    The file TextCraft.perm ist recreated everytime the server is started. So when i entered the names, the entered names are gone everytime I start the server, so no one can access TextCraft. I set chmod to 444, the names then stay in the file, but TextCraft doesn't do a thing.

    Seems to be a bug, that the Check routine, if the file is there does not work correctly?!


    oh and by the way TextCraft 1.5
  7. Offline


    It works in build 186 (newest one when posting this).

    Are you running Linux? I have only tried it briefly on ubuntu and it seemed to work there...
  8. Offline


    Yeap, running on a fresh Ubuntu 10,10 x64 installation.
  9. Offline


    Aha, I will take a look at it tomorrow(GMT+1).
  10. Offline


    No Problemo... don't hurry :) I'll also test it with the newest bukkit version tomorrow.. Greets
    --- merged: Feb 1, 2011 9:40 AM ---
    Ok, I tested it now with 186. Just doing its job now.

  11. Offline


    not working now. latest bukkit build.
  12. Offline


    it lets me select a starting point but when i type the command nothing happens
  13. Offline


    Havent tested yet but I did look at the letters and they are great dont get me wrong but they dont look like the ingame letters. which Would look cooler. I can see that it is editable. maybe i'll play with that and see what i come up with :)
    I'll test it out when I get back home shortly :)
  14. Offline


    I got this error when I tested with CB300, i had been using fine with earlier Builds of BUKKIT
    I am using ver 1.5 of textcraft.
    I hope u can get it working again I really like this plugin for sever signage.

    2011-02-14 16:57:39 [INFO] anklesneeze tried command: tc TEST E 89
    Feb 14, 2011 4:58:43 PM org.bukkit.plugin.SimplePluginManager callEvent
    SEVERE: Could not pass event PLAYER_COMMAND to TextCraft
    java.lang.NoSuchMethodError: org.bukkit.Server.getWorlds()[Lorg/bukkit/World;
    at com.drinq.bukkit.TextCraft.functions.createBlock(functions.java:99
    at com.drinq.bukkit.TextCraft.RegularText.Draw(RegularText.java:154)
    at com.drinq.bukkit.TextCraft.TCPlayerListener.onPlayerCommand(TCPlay
    at org.bukkit.plugin.java.JavaPluginLoader$5.execute(JavaPluginLoader
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManage
    at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:602)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:575)
    at net.minecraft.server.Packet3Chat.a(SourceFile:24)
    at net.minecraft.server.NetworkManager.a(SourceFile:232)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:72)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:104)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:317)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:232)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:512)

    Thanks anklesneeze
  15. Offline


    Same here.
    --- merged: Feb 15, 2011 4:47 AM ---
    I am in the perms file and i still get this error. using this to try to write as a test: right click with diamond, it tells me that the detination has been set. then, use the following command no quotes: "/tc niftyapple n 42 1"

    to my understand this should write "niftyapple" going north, in iron block, in text size 1. Is there something im missing?
  16. Offline


    Thanks a ton for that command line. I was having all sorts of problem. Much appreciated
  17. Offline


    Really wanted to use this although when I did I setup everything correctly. However when I try create text, no response :O
  18. Offline


    same here....
  19. Offline


    I have same problem !!!

    When i set point with diamond, it's ok.
    next step : "/tc Test s 1 1"

    Nothing happend, but in console:
    SEVERE: Could not pass event PLAYER_COMMAND to TextCraft
  20. Offline


    I added permissions for me to use /tc command, and I'm able to select a starting point, but the "Could not pass event PLAYER_COMMAND to TextCraft" message still remains.

    Any help?
  21. Offline


    just got a new error from 416..

    2011-02-22 17:37:29 [WARNING] Plugin 'TextCraft' (ver 0.1) is registering events
    before it is enabled. It may be misbehaving and the author needs to fix this.
    --- merged: Feb 22, 2011 11:46 PM ---
    are you by chance using a server wrapper like simpleserver? im just checking to see if thats whats causing it or it is straight plugin issues...
  22. Offline


    Not really.
  23. Offline


    This interferes with Towny :( Can you create aliases please?
  24. Offline


    Please update this to the recommended builds. I'm getting a whopping TWO errors from this plugin: that it's registering events early and that I should nag you about removing a stupidly long constructor.
  25. Offline


    its not working for me :(
    --- merged: Mar 1, 2011 1:52 PM ---
  26. Offline


  27. Offline

    Jake Radcliff

    When will this be updated?
  28. Offline


    Is this alive at all? ;[
  29. Offline


    No, DrinQ last seen Mar 2, 2011. Crappy I know. Wish i could use it.

Share This Page