[INACTIVE][ECON] BankAccount v.0.5.1 - Shared Bank Accounts [860]

Discussion in 'Inactive/Unsupported Plugins' started by TAT, Mar 4, 2011.

  1. Offline


    [​IMG]BankAccount v0.5.1
    IRC @ irc.esper.net/#BankAccount
    Team: TAT

    Download 0.5.1 (JAR, TAR.GZ, ZIP)
    Earlier versions: 0.2-0.5
    Source Code @ Github

    BankAccount enables the players to open shared bank accounts with each other.
    The players with access to an account can deposit, withdraw and transfer money.

    Searching for coders and testers
    If you are interested in code and/or test BankAccount, please send a PM to TAT.

    Error reporting and feature requests
    Please use our Redmine system for this: http://redmine.earthgame.dk
    Requirements (open)

    • iConomy, BOSEconomy or Essentials Economy
    • mysql-connector-java-bin (Found here) (NOTE: must be included to Java ext folder - instructions included in Readme)
    • sqlitejdbc-v056 (Found here) (NOTE: must be included to Java ext folder - instructions included in Readme)
    Features (open)

    • Open a shared bank account between each other
    • Deposit/withdraw money between economy account and shared bank account
    • Transfer money between shared bank accounts
    • Password protect shared bank accounts (Case-sensitive)
    • Amounts on accounts can gain interest over time
    • Use commands global or in bank areas
    • Loan system
    Todo (open)

    • NPC??? (Perhaps)
    Permissions Nodes (open)
    Commands (open)
    Admin commands
    • /account help [page]
    • /account open <accountname> [players]
    • /account info <accountname>
    • /account list
    • /account balance <accountname>
    • /account adduser <accountname> <player>
    • /account removeuser <accountname> <player>
    • /account password <accountname> [password]
    • /account deposit <accountname> <amount>
    • /account withdraw <accountname> <amount> [password]
    • /account transfer <from account> <to account> <amount> [password]
    • /account loan <amount>
    • /account pay <amount>
    • /account close <accountname> [password]
    • /account select
    • /account setarea <areaname>
    • /account removearea <areaname>
    Documentation @ GitHub
    Howto videos (open)
    Basic Setup (open)
    MySQL Setup (open)
    Area Setup (open)
    Features planned for next release (open)

    • Separate banks with separate accounts (like in reality) [option]
    Changelog (open)
    Version 0.5.1
    • Added permissionnode for list command (Included in basic permission)
    • Added possibility to disable interest and loan debug output
    • Accounts no longer case-sensitive
    • Code clean-up
    • Changed to use Register [GitHub Commit: 2071011cca5d89940f310dc39273be8bb7e517bc]
      • Now supports following economy plugins (iConomy preferred)
        • iConomy 4
        • iConomy 5
        • BOSEconomy
        • Essentials Economy
    • Updated to CraftBukkit #860
    • Removed response to multiple banks config
    • API changes
    Full changelog
    NEO and artimas22 like this.
  2. Offline


    Im running SQLite.
    But overall I love your plugin!
  3. Offline


    having a small issue with the interest, but i think it's just a problem with my MySQL because i had to manually create the bankarea table as well...

    this is the error i get every time interest tries to collect on the accounts

     12:34:21 [WARNING] BankAccount: Couldn't execute interest
     12:34:21 [INFO] BankAccount: java.sql.SQLException: Operation not allowed after ResultSet closed
    just wondering if you (or anyone) knew of a way to fix this issue

    [edit] and TAT i'm running ubuntu as well the folder location is in fact /usr/lib/jvm/java-6-openjdk/jre/lib/ext/
  4. i think i know what the problem is now (not sure) but as this was a 64-bit it refused to install a java.1.6 ver and only showed 1.5 so i had to install a openjdk ver (tried on 3 sep machines (might be me having bad luck)) and as i forgot this and been looking for a java 6 folder i put it in the wrong place (facepalm :p) and seems to work well so far been able to get interest on one bank account (1 made so far) so ill test the rest while playing with it.
    Forgot to add, you might want to put both 32 and 64 bit java directorys in the readme as it is a little confuzling :p
  5. Offline


    Guess you talk about java directorys for linux, would you please write them here, as I right now is a bit confused which folders it is? :)

    Interest do not work correct for versions up to 0.3b
    It only update one account and with wrong percent

    EDIT: Now fixed in v. 0.3c - Please update :)

    Version 0.3c out!

    • Fixed wrong percentage in interest
    • Now showing decimals
    • Now showing if running interest on loadConfiguration
    • Now write to console when running interest

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  6. Offline


    Updated and got a whole list of severe errors.

    Attached Files:

  7. Offline


    well if your running open JDK on Ubuntu 64-bit it's definitely filesystem/usr/lib/jvm/java-6-openjdk/jre/lib/ext/
  8. Offline


    This plugin interferes with LWC.
  9. Offline


    Version 0.3d out!

    • Fixed FORWARD_ONLY for SQLite
  10. Just to say i will be working on a Website based view of the bank stuff in php, this is my first proper php project so dont expect much :p designs would be nice and credit will be given if design or picture is used.
  11. Offline

    AnToN Ronsjö

    Hey m8 about the new version 0.3d my Server gets an error that says it cant connect to sqlite and when i took the old version it could connect but im also receving lots of errors when i wanna load help page 2 to config the area!
  12. Offline


    I run Bukkit 516 and my OS is Windows 7.

    20:17:32 [INFO] BankAccount version 0.3d is enabled!
    20:17:32 [INFO] BankAccount: Config file found!
    20:17:32 [INFO] BankAccount: Permission system found.
    20:17:32 [INFO] BankAccount: Running interest every 5 minutes by 0.1%
    20:17:32 [INFO] BankAccount: Properties Loaded
    20:17:32 [WARNING] BankAccount: Failed to connect to SQLite
    20:17:32 [WARNING] BankAccount: java.sql.SQLException: SQLite only supports CONC
    UR_READ_ONLY cursors
    20:17:32 [INFO] BankAccount: Shuting down
    20:17:32 [INFO] BankAccount is disabled!

    This is probably my fault, but any ideas how to fix it?

    This also happens only when I have BankAccount.

    20:35:40 [SEVERE] Could not pass event PLUGIN_ENABLE to iConomy
    java.lang.NoClassDefFoundError: com/nijikokun/bukkit/Permissions/Permissions
            at com.nijiko.coelho.iConomy.iConomy$Listener.onPluginEnabled(iConomy.ja
            at org.bukkit.plugin.java.JavaPluginLoader$31.execute(JavaPluginLoader.j
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:83)
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:61)
            at org.bukkit.craftbukkit.CraftServer.reload(CraftServer.java:205)
            at org.bukkit.command.SimpleCommandMap$ReloadCommand.execute(SimpleComma
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:80
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:1
            at net.minecraft.server.MinecraftServer.b(MinecraftServer.java:381)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:366)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.lang.ClassNotFoundException: com.nijikokun.bukkit.Permissions.Pe
            at java.net.URLClassLoader$1.run(Unknown Source)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.net.URLClassLoader.findClass(Unknown Source)
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.
            at java.lang.ClassLoader.loadClass(Unknown Source)
            at java.lang.ClassLoader.loadClass(Unknown Source)
            ... 16 more
  13. Offline


    It's not your fault, I'm aware of this error and working on a fix.

    I don't think it's about BankAccount.
    Caused by: java.lang.ClassNotFoundException: com.nijikokun.bukkit.Permissions.Permissions

    Searching people that want to test the newest fix before it's release.
    EDIT: Version 0.3e out! Testing ended

    When reporting back, please include the following (if you know them).
    • CraftBukkit version
    • Tested SQLite and/or MySQL (Is written when BankAccount starts up)
    • OS (Windows XP, Windows 7, Ubuntu, Debian etc.)
    • 32-bit or 64-bit

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  14. Offline


    CraftBukkit 516
    Windows 7

    No more errors, and it seems to be working perfectly fine.
  15. CraftBukkit 516
    No errors and with a test from the previous version seems to start faster :D (as in from 0.4 to 0.3 :p )
  16. Offline


    Do you mean that 0.3d is faster than 0.3INDEV?
  17. Offline


    I'm not exactly one to say, but I believe they meant that 0.3INDEV starts faster than 0.3d.
  18. on mine it comes up "Started in 0.435secs" now it says "Started in 0.362secs" and i restarted it and the only difference is about 0.002 :p
    Idea (may be a long shot) on a loan if they dont pay back soon enough you should have it turn that player to PvP so anyone can kill him and maby get a bounty :p
  19. Offline


    Version 0.3e out!

      • Change from int to double in ATM
      • Update to match deprecation of iConomy.save
      • Fixed check for admin if UsePermissions is true but Permissions isn't running
      • Fixed SQLite errors
      • Added SuperAdmins (Give admins access to all accounts)
  20. Offline


    I have a ton of errors when I load plugin with LWC
  21. Offline


    Please post the bugs and the informations requested in the opening post
  22. Offline


    hi i become this message
    2011-03-17 20:35:17 [WARNING] BankAccount: Created table bankaccounts
    2011-03-17 20:35:17 [WARNING] BankAccount: Created table bankareas
    2011-03-17 20:35:17 [WARNING] BankAccount: Could not upgrade tables to v.0.3c
    2011-03-17 20:35:17 [WARNING] BankAccount: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'DOUBLE( 255,2 ) NOT NULL DEFAULT '0')' at line 1
  23. Offline


    I'm guessing that you're using MySQL (because of the error) but I don't know anything else. Please update your post with more informations (See my opening post or this post)
  24. Offline


    what do you must know?
    this is a message create by your plugin oO
    looks like a bug by creating the tables, a wrong sign or something else
  25. Offline


    CraftBukkit 531
    BankAccount lastest version (0.3e)
    Using MySQL
    Windows 2003 Datacenter
    32 bits

    Errors with LWC (ton of errors when loading plugin)
  26. Offline


    There are some differences between linux and windows.
    The error happens when trying to upgrade your MySQL tables to 0.3c, you can do that manually by change amount in your account table to DOUBLE( 255,2 )

    EDIT: After the manual change, just delete the SQLUpgrade03c file

    Please post the errors here or on http://pastebin.com/ and post link in here so I can see the errors

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  27. it seems there are a few problems, after restarting i get this http://pastebin.com/aKD1Lfsf. on the iConomy forum there is a thing about plugin developers need to change stuff (dont know if you noticed or not)
  28. Offline


    As I can see it, it have nothing to do with BankAccount.
    BankAccount gets disabled in the start
    21:44:01 [INFO] BankAccount is disabled!
    It more looks like some of the other plugins have problem with Permissions
    21:44:02 [SEVERE] Could not pass event PLUGIN_ENABLE to iConomy
    java.lang.NoClassDefFoundError: com/nijikokun/bukkit/Permissions/Permissions
    You also aren't using the latest version
    21:44:00 [INFO] BankAccount version 0.3INDEV is enabled!
    I'm having no problem using LWC

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  29. Offline


    I'm getting the following error when the interest is given to the accounts.
    Anything else works.

    13:27:21 [WARNING] BankAccount: Couldn't execute interest
    13:27:21 [INFO] BankAccount: com.mysql.jdbc.NotUpdatable: Result Set not updatable (references no primary keys).This result set must come from a statement that was created with a result set type of ResultSet.CONCUR_UPDATABLE, the query must select only one table, can not use functions and must select all primary keys from that table. See the JDBC 2.1 API Specification, section 5.6 for more details.
    13:27:21 [INFO] BankAccount: Total given 40.0 PX in interest
    The user has the right to update the database.

    ubuntu server 64Bit
    BankAccount v0.3e
  30. Offline


    Phil2812 likes this.
  31. once again to self (FACEPALM) :p
    tried the new version and still came up with all the errors even the ones about permissions (everything has been set and i am not using permissions as that is outdated and not used anymore so i use groupmanager and fakepermmisions which is the version that came with essentials). if i take BA off all the errors go away. (sorry if this is an idiot thing and i have done something wrong, still new to java :p )

Share This Page