[INACTIVE][DEV] Persistence v0.76 - Data-Driven Bukkit [677]

Discussion in 'Inactive/Unsupported Plugins' started by NathanWolf, Jan 29, 2011.

  1. Offline

    NathanWolf

    Persistence - Data-Driven Bukkit

    PLEASE NOTE
    Persistence is a developer API and framework- NOT a game or admin plugin.

    If you've come here looking for plugin/admin support for Spells, Wand, NetherGate or any other plugin that uses Persistence- please turn around and go back to that thread. Thank you for your cooperation!

    If you're a dev, then check the Persistence wiki for information on using the Persistence framework.

    View changelog on github
     
    Duccis likes this.
  2. Offline

    Color42

  3. Offline

    Jademalo

    Somethings up - any time that i move i gt spammed to death with error messages. So many they crash the server console. Well, make it unresponsive. the server itsself works though.
     
  4. Offline

    NathanWolf

    Should be fixed in 0.54 - please update.

    0.55 is right around the corner, to kill Groups, else I would've announced this, sorry :)
    --- merged: Mar 4, 2011 6:46 PM ---
    Uh.... bleh! That's ugly... let me look at latest... I'm testing permissions support out now, I don't want to break that again.
    --- merged: Mar 4, 2011 6:46 PM ---
    Oh, also- make sure you update all my plugins to latest when you update- they all changed (NetherGate and Persistence, at least). Will again in the next update, too, unfortunately.
     
  5. Offline

    Jademalo

    I have been updating both of them. I managed to get a bit of the error:

    Code:
    18:53:46 [SEVERE] Caused by: java.lang.IllegalArgumentException: [email protected]
    18:53:46 [SEVERE]     at sun.reflect.GeneratedMethodAccessor27.invoke(Unknown Source)
    18:53:46 [SEVERE]     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    18:53:46 [SEVERE]     at java.lang.reflect.Method.invoke(Method.java:616)
    18:53:46 [SEVERE]     at com.elmakers.mine.craftbukkit.persistence.core.PersistedField.set(PersistedField.java:108)
    18:53:46 [SEVERE]     ... 29 more
    18:53:46 [SEVERE] com.elmakers.mine.bukkit.persistence.exception.InvalidDataException: com.elmakers.mine.bukkit.persistence.exception.InvalidDataException: java.lang.IllegalArgumentException: [email protected]
    18:53:46 [SEVERE]     at com.elmakers.mine.craftbukkit.persistence.core.PersistedClass.checkLoadCache(PersistedClass.java:634)
    18:53:46 [SEVERE]     at com.elmakers.mine.craftbukkit.persistence.core.PersistedClass.checkLoadCache(PersistedClass.java:608)
    18:53:46 [SEVERE]     at com.elmakers.mine.craftbukkit.persistence.core.PersistedClass.get(PersistedClass.java:368)
    18:53:46 [SEVERE]     at com.elmakers.mine.craftbukkit.persistence.Persistence.get(Persistence.java:210)
    18:53:46 [SEVERE]     at com.elmakers.mine.bukkit.persistence.dao.LocationData.updateWorld(LocationData.java:414)
    18:53:46 [SEVERE]     at com.elmakers.mine.bukkit.persistence.dao.LocationData.update(LocationData.java:384)
    18:53:46 [SEVERE]     at com.elmakers.mine.bukkit.persistence.dao.LocationData.<init>(LocationData.java:38)
    18:53:46 [SEVERE]     at com.elmakers.mine.bukkit.persistence.dao.PlayerData.update(PlayerData.java:60)
    18:53:46 [SEVERE]     at com.elmakers.mine.bukkit.persistence.dao.PlayerData.update(PlayerData.java:74)
    18:53:46 [SEVERE]     at com.elmakers.mine.bukkit.utilities.PluginUtilities.getPlayer(PluginUtilities.java:85)
    18:53:46 [SEVERE]     at com.elmakers.mine.bukkit.plugins.nether.NetherManager.getPlayerData(NetherManager.java:142)
    18:53:46 [SEVERE]     at com.elmakers.mine.bukkit.plugins.nether.NetherManager.onPlayerMove(NetherManager.java:390)
    18:53:46 [SEVERE]     at com.elmakers.mine.bukkit.plugins.nether.NetherPlayerListener.onPlayerMove(NetherPlayerListener.java:27)
    18:53:46 [SEVERE]     at org.bukkit.plugin.java.JavaPluginLoader$7.execute(JavaPluginLoader.java:155)
    18:53:46 [SEVERE]     at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
    18:53:46 [SEVERE]     at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:225)
    18:53:46 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:123)
    18:53:46 [SEVERE]     at net.minecraft.server.Packet10Flying.a(SourceFile:126)
    18:53:46 [SEVERE]     at net.minecraft.server.NetworkManager.a(SourceFile:230)
    18:53:46 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    18:53:46 [SEVERE]     at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    18:53:46 [SEVERE]     at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:357)
    18:53:46 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
    18:53:46 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    18:53:46 [SEVERE] Caused by: com.elmakers.mine.bukkit.persistence.exception.InvalidDataException: java.lang.IllegalArgumentException: [email protected]
    18:53:46 [SEVERE]     at com.elmakers.mine.craftbukkit.persistence.core.PersistedField.set(PersistedField.java:112)
    18:53:46 [SEVERE]     at com.elmakers.mine.craftbukkit.persistence.core.PersistedField.load(PersistedField.java:239)
    18:53:46 [SEVERE]     at com.elmakers.mine.craftbukkit.persistence.core.PersistedClass.load(PersistedClass.java:765)
    18:53:46 [SEVERE]     at com.elmakers.mine.craftbukkit.persistence.core.PersistedClass.createInstance(PersistedClass.java:777)
    18:53:46 [SEVERE]     at com.elmakers.mine.craftbukkit.persistence.core.PersistedClass.loadCache(PersistedClass.java:709)
    18:53:46 [SEVERE]     at com.elmakers.mine.craftbukkit.persistence.core.PersistedClass.loadCache(PersistedClass.java:692)
    18:53:46 [SEVERE]     at com.elmakers.mine.craftbukkit.persistence.core.PersistedClass.checkLoadCache(PersistedClass.java:627)
    18:53:46 [SEVERE]     ... 23 more
    18:53:46 [SEVERE] Caused by: java.lang.IllegalArgumentException: [email protected]
    18:53:46 [SEVERE]     at sun.reflect.GeneratedMethodAccessor27.invoke(Unknown Source)
    18:53:46 [SEVERE]     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    18:53:46 [SEVERE]     at java.lang.reflect.Method.invoke(Method.java:616)
    18:53:46 [SEVERE]     at com.elmakers.mine.craftbukkit.persistence.core.PersistedField.set(PersistedField.java:108)
    18:53:46 [SEVERE]     ... 29 more
    
    Still happening as of the latest version of both plugins.
     
  6. Offline

    NathanWolf

    Ok- I'm releasing updates of everything now. It's been working fine for me in dev- let me get released, test on my public server, and get back to you.
    --- merged: Mar 4, 2011 7:32 PM ---
    Persistence 0.55 Released

    Groups is dead- bad idea!

    Well, not really a bad idea, but just an unnecessary split-up, I think, for something that's going to get blown to bits eventually anyway, if/when it gets integrated.

    Persistence 0.55 now supports Permissions via PermissionsSupport.jar. Even if I had wanted to integrate Permissions directly with Persistence, Yeti's change to using non-static methods makes it impossible for it to be optional- so screw that.

    The support jar is absolutely as thin as thin can be- it's just there to depend on Permissions.jar, more or less, and proxy its handler.

    Persistence 0.55 also has internal permissions support. This is where things get "iffy". I've brought the user/groups manager back over from Groups, and I have ... how shall I say this? Well, I've "borrowed" the bukkit.permissions code.

    This is with consent, in at least the most basic sense. However, this is in now way endorsed by the Bukkit team! Clearly, they reserve the right to change this system before release, or it would be released.

    However, personally, I want to start playing with it, now, in production, on my public server- running an actual CB RB.

    So, I stole and re-classpathed the code. Persistence will look for a single permissions.yml config (in the "Persistence" plugin folder) on startup- if present, that will be used for permissions.

    I still need to test all this- I'm honestly not entirely confident that it works, since I did no lifting of the code that looks for you plugin's YML registration. I'm honestly hoping that part is optional! :)

    I'll come back and report once I've tested internal permissions- but I have tested Permissions support and it does work- so I'm releasing!
     
  7. Offline

    RytoEX

    Persistence failed to initialize on CB440. Server startup and error message below:

    Code:
    2011-03-04 19:08:21 [INFO] Starting minecraft server version Beta 1.3
    2011-03-04 19:08:21 [INFO] Loading properties
    2011-03-04 19:08:21 [INFO] Starting Minecraft server on *:25565
    2011-03-04 19:08:21 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-458
    -g557f3d2-b440jnks (MC: 1.3)
    2011-03-04 19:08:21 [INFO] Preparing level "world"
    2011-03-04 19:08:21 [INFO] Preparing start region
    2011-03-04 19:08:22 [INFO] [Permissions] version [2.5.2] (Phoenix) was Initialized.
    2011-03-04 19:08:22 [INFO] PushBlock version 2.5 is enabled!
    2011-03-04 19:08:22 [INFO] CraftBukkitUpToDate version 2.0.1 is enabled!
    2011-03-04 19:08:22 [INFO] [Permissions] version [2.5.2] (Phoenix)  loaded
    2011-03-04 19:08:22 [INFO] CButD: CraftBukkit is up to Date
    2011-03-04 19:08:22 [INFO] [HELP] 6 extra help entries loaded
    2011-03-04 19:08:22 [INFO] [HELP] Permissions enabled using: Permissions v2.5.2
    2011-03-04 19:08:22 [INFO] [HELP] Help 0.1 enabled
    2011-03-04 19:08:22 [INFO] LoginMessage 0.5_3 enabled
    2011-03-04 19:08:22 [INFO] MeasuringTape v0.7d by DiddiZ enabled
    2011-03-04 19:08:24 [INFO] [MYHOME]: 2 homes loaded
    2011-03-04 19:08:24 [INFO] [MYHOME] Permissions enabled.
    2011-03-04 19:08:24 [INFO] [MYHOME] 'Help' support enabled.
    2011-03-04 19:08:24 [INFO] MyHome 1.9.2 enabled
    2011-03-04 19:08:24 [INFO] [MYWARP]: 2 warps loaded
    2011-03-04 19:08:24 [INFO] [MYWARP] Permissions enabled.
    2011-03-04 19:08:24 [INFO] [MYWARP] 'Help' support enabled.
    2011-03-04 19:08:24 [INFO] MyWarp 1.10.3 enabled
    2011-03-04 19:08:24 [INFO] [OddGive] 0.3 enabled
    2011-03-04 19:08:24 [INFO] [OddItem] 0.2 enabled
    2011-03-04 19:08:24 [INFO] [OddItem] Parsed 0 entries.
    2011-03-04 19:08:24 [INFO] Persistence version 0.55 failed to initialize
    2011-03-04 19:08:24 [SEVERE] java.lang.NullPointerException
    2011-03-04 19:08:24 [SEVERE]    at com.elmakers.mine.bukkit.plugins.persistence.Persistenc
    ePlugin.getUtilities(PersistencePlugin.java:152)
    2011-03-04 19:08:24 [SEVERE]    at com.elmakers.mine.bukkit.plugins.persistence.Persistenc
    ePlugin.getPermissions(PersistencePlugin.java:162)
    2011-03-04 19:08:24 [SEVERE]    at com.elmakers.mine.bukkit.plugins.persistence.Persistenc
    ePlugin.initialize(PersistencePlugin.java:137)
    2011-03-04 19:08:24 [SEVERE]    at com.elmakers.mine.bukkit.plugins.persistence.Persistenc
    ePlugin.onEnable(PersistencePlugin.java:93)
    2011-03-04 19:08:24 [SEVERE]    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin
    .java:140)
    2011-03-04 19:08:24 [SEVERE]    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(Ja
    vaPluginLoader.java:426)
    2011-03-04 19:08:24 [SEVERE]    at org.bukkit.plugin.SimplePluginManager.enablePlugin(Simp
    lePluginManager.java:187)
    2011-03-04 19:08:24 [SEVERE]    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServ
    er.java:79)
    2011-03-04 19:08:24 [SEVERE]    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftSer
    ver.java:60)
    2011-03-04 19:08:24 [SEVERE]    at net.minecraft.server.MinecraftServer.e(MinecraftServer.
    java:187)
    2011-03-04 19:08:24 [SEVERE]    at net.minecraft.server.MinecraftServer.a(MinecraftServer.
    java:174)
    2011-03-04 19:08:24 [SEVERE]    at net.minecraft.server.MinecraftServer.d(MinecraftServer.
    java:120)
    2011-03-04 19:08:24 [SEVERE]    at net.minecraft.server.MinecraftServer.run(MinecraftServe
    r.java:227)
    2011-03-04 19:08:24 [SEVERE]    at net.minecraft.server.ThreadServerApplication.run(Source
    File:366)
    2011-03-04 19:08:24 [INFO] Rune blacklist with 0 runes loaded.
    2011-03-04 19:08:24 [INFO] Loaded 1 waypoints, 1 teleporters, 0 position runes, 2 player d
    ata sets.
    2011-03-04 19:08:24 [INFO] Loaded 0 block runes.
    2011-03-04 19:08:24 [INFO] Runecraft 2.4.4 initialized.
    2011-03-04 19:08:24 [INFO] Runecraft plugin version 0.1 is enabled!
    2011-03-04 19:08:24 [INFO] [SignEdit] 1.4 enabled.
    2011-03-04 19:08:24 [INFO] Spells version 0.99 is enabled
    2011-03-04 19:08:24 [INFO] Wand version 0.65 is enabled
    2011-03-04 19:08:24 [INFO] Done (3307909560ns)! For help, type "help" or "?"
    2011-03-04 19:08:32 [INFO] CButD: Plugin-Update-Check started
    2011-03-04 19:08:33 [INFO] No source for BlockPush.jar ask the Author to give me one
    2011-03-04 19:08:33 [INFO] No source for LoginMessage.jar ask the Author to give me one
    2011-03-04 19:08:33 [INFO] No source for OddGive.jar ask the Author to give me one
    2011-03-04 19:08:33 [INFO] No source for OddItem.jar ask the Author to give me one
    2011-03-04 19:08:34 [INFO] No source for SignEdit.jar ask the Author to give me one
    2011-03-04 19:08:34 [INFO] CButD: Plugin-Update-Check finished
    
    Plugins (version numbers given if console reports them incorrectly):
    BlockPush (PushBlock)
    CraftBukkitUpToDate
    Help
    LoginMessage
    MeasuringTape
    MyHome
    MyWarp
    OddGive 0.4
    OddItem 0.4
    Permissions
    Persistence
    Runecraft 2.4.5
    SignEdit
    Spells
    Wand

    Persistence 0.53 worked. Is PermissionsSupport.jar required for Spells/Wand/Persistence if we have Permissions installed?
     
  8. Offline

    NathanWolf

    Only if you want to use Permissions with those plugins- it's not required otherwise, and certainly shouldn't cause an error on startup.

    I'll check it out- I've tested this all in dev, but I can't get Permissions to load on startup on my public server - it's throwing an NPE.
     
  9. Offline

    oriany

    IM A NOOB WHAT DO I DO PLZ HELP ME !!
    Code:
    2011-03-04 17:56:14 [INFO] Persistence version 0.55 failed to initialize
    2011-03-04 17:56:14 [SEVERE] java.lang.NullPointerException
    2011-03-04 17:56:14 [SEVERE]    at com.elmakers.mine.bukkit.plugins.persistence.
    PersistencePlugin.getUtilities(PersistencePlugin.java:152)
    2011-03-04 17:56:14 [SEVERE]    at com.elmakers.mine.bukkit.plugins.persistence.
    PersistencePlugin.getPermissions(PersistencePlugin.java:162)
    2011-03-04 17:56:14 [SEVERE]    at com.elmakers.mine.bukkit.plugins.persistence.
    PersistencePlugin.initialize(PersistencePlugin.java:137)
    2011-03-04 17:56:14 [SEVERE]    at com.elmakers.mine.bukkit.plugins.persistence.
    PersistencePlugin.onEnable(PersistencePlugin.java:93)
    2011-03-04 17:56:14 [SEVERE]    at org.bukkit.plugin.java.JavaPlugin.setEnabled(
    JavaPlugin.java:140)
    2011-03-04 17:56:14 [SEVERE]    at org.bukkit.plugin.java.JavaPluginLoader.enabl
    ePlugin(JavaPluginLoader.java:426)
    2011-03-04 17:56:14 [SEVERE]    at org.bukkit.plugin.SimplePluginManager.enableP
    lugin(SimplePluginManager.java:187)
    2011-03-04 17:56:14 [SEVERE]    at org.bukkit.craftbukkit.CraftServer.loadPlugin
    (CraftServer.java:79)
    2011-03-04 17:56:14 [SEVERE]    at org.bukkit.craftbukkit.CraftServer.loadPlugin
    s(CraftServer.java:60)
    2011-03-04 17:56:14 [SEVERE]    at net.minecraft.server.MinecraftServer.e(Minecr
    aftServer.java:187)
    2011-03-04 17:56:14 [SEVERE]    at net.minecraft.server.MinecraftServer.a(Minecr
    aftServer.java:174)
    2011-03-04 17:56:14 [SEVERE]    at net.minecraft.server.MinecraftServer.d(Minecr
    aftServer.java:120)
    2011-03-04 17:56:14 [SEVERE]    at net.minecraft.server.MinecraftServer.run(Mine
    craftServer.java:227)
    2011-03-04 17:56:14 [SEVERE]    at net.minecraft.server.ThreadServerApplication.
    run(SourceFile:366)
     
  10. Offline

    Jademalo

    Ive been having a problem with a bug that causes a lot of console spam, And NetherGate didnt work due to it. So i updated to the latest versions, and deleted my databases.
    Now, when i created the worlds for my alternate servers, it labeled them as nether servers, even though the maps already existed. So after i set them, I went into the database and changed the values to correctly set them.
    Since doing this, I've gotten the console spam again, and again, no worlds are working.
    The console spam happens any time I walk.

    The same thing happens with regards to Crowd Control too, It just stops working.
     
  11. Offline

    Marshton

    I also have the same problem after I updated:

    Version: 0.55 and build 496

    Code:
    12:17:11 [INFO] Starting minecraft server version Beta 1.3
    12:17:11 [INFO] Loading properties
    12:17:11 [INFO] Starting Minecraft server on *:25566
    12:17:11 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-496-
    g1d925e2-b497jnks (MC: 1.3)
    12:17:11 [INFO] Preparing start region
    12:17:12 [INFO] Preparing spawn area: 77%
    12:17:12 [INFO] [Permissions] version [2.5.2] (Phoenix) was Initialized.
    12:17:12 [INFO] [ChatStamp]     ChatStamp V1.03 started
    12:17:12 [INFO] [ColorMe] v1.1 has been enabled.
    12:17:12 [INFO] CraftBukkitUpToDate version 2.0.2 is enabled!
    12:17:12 [INFO] [Permissions] version [2.5.2] (Phoenix)  loaded
    12:17:13 [INFO] CButD: CraftBukkit is up to Date
    12:17:13 [INFO] Minecart Mania Chest Control version 1.01 is enabled!
    12:17:13 [INFO] Minecart Mania Core version 1.01a is enabled!
    12:17:13 [INFO] Minecart Mania Sign Commands version 1.01 is enabled!
    12:17:13 [INFO] NextStation: Version 0.1 enable.
    12:17:13 [INFO] Persistence version 0.55 failed to initialize
    12:17:13 [SEVERE] java.lang.NullPointerException
    12:17:13 [SEVERE]       at com.elmakers.mine.bukkit.plugins.persistence.Persiste
    ncePlugin.getUtilities(PersistencePlugin.java:152)
    12:17:13 [SEVERE]       at com.elmakers.mine.bukkit.plugins.persistence.Persiste
    ncePlugin.getPermissions(PersistencePlugin.java:162)
    12:17:13 [SEVERE]       at com.elmakers.mine.bukkit.plugins.persistence.Persiste
    ncePlugin.initialize(PersistencePlugin.java:137)
    12:17:13 [SEVERE]       at com.elmakers.mine.bukkit.plugins.persistence.Persiste
    ncePlugin.onEnable(PersistencePlugin.java:93)
    12:17:13 [SEVERE]       at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlug
    in.java:118)
    12:17:13 [SEVERE]       at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(
    JavaPluginLoader.java:414)
    12:17:13 [SEVERE]       at org.bukkit.plugin.SimplePluginManager.enablePlugin(Si
    mplePluginManager.java:188)
    12:17:13 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftSe
    rver.java:83)
    12:17:13 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftS
    erver.java:61)
    12:17:13 [SEVERE]       at net.minecraft.server.MinecraftServer.e(MinecraftServe
    r.java:204)
    12:17:13 [SEVERE]       at net.minecraft.server.MinecraftServer.a(MinecraftServe
    r.java:191)
    12:17:13 [SEVERE]       at net.minecraft.server.MinecraftServer.d(MinecraftServe
    r.java:131)
    12:17:13 [SEVERE]       at net.minecraft.server.MinecraftServer.run(MinecraftSer
    ver.java:246)
    12:17:13 [SEVERE]       at net.minecraft.server.ThreadServerApplication.run(Sour
    ceFile:366)
    12:17:13 [INFO] Portcullis 1.0a was sucessfully loaded!
    12:17:13 [INFO] Done (0.187s)! For help, type "help" or "?"
    >
     
  12. Offline

    NathanWolf

    Clearly I broke something- no idea why it's looking for Permissions within Persistence, but it should not be. That's the whole point of PermissionsSupport- to get that out of Persistence.

    I'll get this fixed, I'm assuming that since it binds in onEnable, this break everything.

    Also, please note (before freaking out when something breaks after upgrade) that I keep all my old versions around, here:

    http://www.elmakers.com/minecraft

    So, even if you didn't back up your plugins before upgrading (yeah, you should be doing that, by the way!)- I've got 'em.
     
  13. EDIT: Meh, writing this post took so long that I haven't noticed that you've already answered and acknowledged that something's not working. :p Oh well, maybe this will help somewhat.

    Alright, I will try to be as specific as possible. I've tried to use your CrowdControl plugin and I simply can't get it to work. I've also tried to run the Spells plugin just to figure out if it's something with CC or Persistance and as Spells gives me the exact same errors I take it it's Persistance's fault.

    Basically when I try to use /cast, /crowd, /group or any other commands associated with your plugins in the game I get a: "An internal error occured while attempting to perform this command."
    And on the console: http://pastebin.com/fsjuvV98

    After I start the server and log in to it I get (every time): http://pastebin.com/mn1ZkNCd
    I'm no expert but I'd be guessing something with the Permissions support is not working correctly.

    I have all of your plugins in the up to date versions. 0.55 Persistance, 0.18 CC, 0.1 PermissionsSupport.
    Here is my startup log: http://pastebin.com/2AHNZicD
    Here is my permissions file: http://pastebin.com/H5hkLjYV

    I've tried to use the permissions.yml method (the internal permissions thingy) but I just can't figure out how that file should be constructed correctly as you haven't given any tips on it aside from something along the lines of "it's similar to bukkit.permissions" which tells me exactly nothing. And google doesn't help with it either.

    I've also tried using the console commands, but /group create <name> returns me this:
    Code:
    16:20:22 [WARNING] Persistence: Can't find callback method onCreateGroup of com.
    elmakers.mine.bukkit.plugins.persistence.PersistenceCommands for sender org.bukk
    it.craftbukkit.command.ColouredConsoleSender
    And /crowd control creeper gives me:
    Code:
    16:21:34 [INFO] World unknown is unknown
    I've tried using 'epsilon' as world parameter (my world's name), I've tried default, normal, all variations that could come to my mind and every one of them gives me this message.

    Tried all of this on two CB versions: 493 & 496.

    Any help would be greatly appreciated as I simply cannot move to 1.3 without a working plugin to disable the goddamn slimes.
     
  14. Offline

    Jademalo

    Sorry, I was in a bit of a bad mood earlier - I apologise for that.
    The remaining half of the post still applies though - And thats a walk through of everything that I did to get the errors. Im fairly sure the problem is not with NG, and its with Persistence, since when this error occurs it also locks out all of the other Persistence based addons. Also, all of the errors that are gotten are to do with Persistence.

    Again, im really sorry about that previous post - but I did get a bit frustrated earlier.
     
  15. Offline

    NathanWolf

    I've heard about the slime issue in 1.3, I didn't know it was such a big problem!

    To be perfectly honest, I haven't tested CrowdControl since 1.3 :(

    Been too busy trying to get Spells and (mainly) NetherGate un-broken, get this permissions crap sorted, etc...

    I'll try and get it tested/fixed today.
    --- merged: Mar 5, 2011 2:13 PM ---
    For what it's worth, I've tried removing Permissions and PermissionsSupport, and everything still starts up fine. Not sure why you're both getting that exception :(

    I'm re-uploading Persistence 0.55 now, just in case. Maybe try re-downloading it, I guess?

    Failing that, go back a version I suppose.
    --- merged: Mar 5, 2011 2:15 PM ---
    I understand, I got woken up at 4am and made some angry posts myself :)

    So, try a re-download- it just finished, and that's the version I'm running now without errors. Maybe I uploaded a bad one? Persistence is really not supposed to have a single reference to Permissions in it, that exception really bothers me :p
    --- merged: Mar 5, 2011 2:16 PM ---
    Hm- the creating worlds as the wrong type thing is odd- did you specify "normal" at the end of the "create world" command?

    I'm not sure that changing the type in the db will do anything, unfortunately, once the world has been created.
     
  16. Offline

    Jademalo

    Actually - This worked a few versions ago. And.. No, i didnt know you could spesify normal >__<

    Ill have another go with the newest versions of everything
     
  17. Well, I don't really have a problem with the plugin itself not loading, it's the thing with commands failing most probably due to the plugin not setting the permissions for itself correctly.

    You're saying the plugin works fine for you without Permission, I'd be willing to give that a try (removing the PermissionsSupport.jar and running the internal permissions) but could you perhaps provide a permissions.yml file for demonstration?

    EDIT: Rolled back to the previous version, fiddled a bit with Permissions, deleted PermissionsSupport and it's working now. :) Now more slime infestation, hell yes. :D
     
  18. Offline

    NathanWolf

    Well, you have to specify normal- nether is the default. I should change this to make it a required parameter, I think- I'll do that in the next release.
    --- merged: Mar 5, 2011 4:11 PM ---
    Whew! Glad to hear it! I want to get the latest version working, but if it's broken I'm glad rolling back worked :)
     
  19. Offline

    Triggjo2

    Can you fix this plugin it crashes my server and doesn't save the players items or last location when it crashes it.
    Please Fix This Plugin!
     
  20. Offline

    Killburner

    Getting "Persistence version 0.55 failed to initialize" logged at the console. CrowdControl commands don't work as a result. I'd post errors, but the MC servers are down right now.
     
  21. Offline

    kexus

    So, this isn't actually compatible with the Permissions plugin, right? It uses Groups?
     
  22. Offline

    NathanWolf

    I suggest you remove it if you think it's doing that.
    --- merged: Mar 5, 2011 9:35 PM ---
    No, Groups is dead. Permissions support is provided by PermissionsSupport.jar, which is only a plugin in the loosest sense. It's really only there because, unfortunately, Yeti broke my ability to use Permissions optionally- it's all or nothing now, at a dependency level :p
    --- merged: Mar 5, 2011 9:36 PM ---
    I still need to look at CC- I'll post about it there. Spells and NetherGate are working fine (far as I know), so I have no reason to believe this is directly a Persistence issue- you do need to update CC as well, though. Assuming you've done that? (0.18 is current, I think)
     
  23. Offline

    Triggjo2

    Nathan i can't remove it cause its required for the Spells plugin and the Wand and that
     
  24. Offline

    NathanWolf

    Well, sorry, then. If you seriously think it's crashing your server, remove it and all plugins that depend on it. That's about all I can tell you. I've got no problems like this on my public server, and no amount of data corruption should cause your server to die.

    I assume that you've removed these plugins to make sure your server starts up fine without them, right?
     
  25. Offline

    godgodgodgo

    Help please :)
    Btw it's not cause juggernaut failed to load because I tried it without that.

    Code:
    2011-03-06 14:24:23 [INFO] Starting minecraft server version Beta 1.3
    2011-03-06 14:24:23 [INFO] Loading properties
    2011-03-06 14:24:23 [INFO] Starting Minecraft server on *:25565
    2011-03-06 14:24:23 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-497-gea319d1-b499jnks (MC: 1.3)
    2011-03-06 14:24:23 [INFO] Preparing level "foo"
    2011-03-06 14:24:23 [INFO] Preparing start region
    2011-03-06 14:24:24 [SEVERE] Could not load plugins\JuggernautSpirit.jar in plugins: null
    org.bukkit.plugin.InvalidPluginException
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:56)
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:130)
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:95)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:59)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:204)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:191)
        at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:131)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.io.FileNotFoundException: Jar does not contain plugin.yml
        ... 9 more
    2011-03-06 14:24:24 [INFO] LWC    [v1.57]    Loading shared objects
    2011-03-06 14:24:24 [INFO] Config    [v1.57]    Loaded 13 config entries
    2011-03-06 14:24:24 [INFO] LWC    [v1.57]    Native library: plugins/LWC/lib/native/Windows/x86/sqlitejdbc.dll
    2011-03-06 14:24:24 [INFO] WorldGuard loaded.
    2011-03-06 14:24:24 [INFO] ChatBukkit v0.0.1 is enabled!
    2011-03-06 14:24:24 [INFO] [Cleaner] version [1.7] (Hit) loaded
    2011-03-06 14:24:24 [INFO] CraftBookCommon 3.0-alpha1 enabled.
    2011-03-06 14:24:24 [INFO] CraftBookCircuits 3.0-alpha1 enabled.
    2011-03-06 14:24:24 [INFO] CraftBookMechanisms 3.0-alpha1 enabled.
    2011-03-06 14:24:24 [INFO] CraftBookVehicles 3.0-alpha1 enabled.
    2011-03-06 14:24:24 [INFO] CraftBukkitUpToDate version 2.0.2 is enabled!
    2011-03-06 14:24:24 [INFO] GroupManager - INFO - Scheduled Data Saving is set for every 10 minutes!
    2011-03-06 14:24:24 [INFO] GroupManager version 1.0(pre-alpha-3) is enabled!
    2011-03-06 14:24:24 [INFO] Fake Permissions version 2.5.2 is enabled!
    2011-03-06 14:24:24 [INFO] CButD: CraftBukkit is up to Date
    2011-03-06 14:24:24 [INFO] ┬žeLoaded Essentials build 2.0.263 maintained by Zenexer, ementalo, Aelux, Brettflan, KimKandor, and snowleo
    2011-03-06 14:24:24 [INFO] Loaded EssentialsBan build 2.0.263 by Zenexer, ementalo, Eris, and EggRoll
    2011-03-06 14:24:24 [INFO] Loaded EssentialsChat build 2.0.263 by Zenexer, ementalo, Aelux, Brettflan, KimKandor, and snowleo
    2011-03-06 14:24:24 [INFO] Loaded EssentialsEco build 2.0.263 by Zenexer, ementalo, Aelux, Brettflan, KimKandor, and snowleo
    2011-03-06 14:24:24 [INFO] Loaded EssentialsGod build 2.0.263 by Zenexer, ementalo, Eris, and EggRoll
    2011-03-06 14:24:24 [INFO] Fake Permissions version 2.5 is enabled!
    2011-03-06 14:24:24 [INFO] Loaded EssentialsHelp build 2.0.263 by Zenexer, ementalo, Eris, and EggRoll
    2011-03-06 14:24:24 [INFO] Loaded EssentialsHome build 2.0.263 by Zenexer, ementalo, Aelux, Brettflan, KimKandor, and snowleo
    2011-03-06 14:24:24 [INFO] Loaded EssentialsProtect build 2.0.263 maintained by Zenexer, ementalo, Aelux, Brettflan, KimKandor, and snowleo
    2011-03-06 14:24:26 [INFO] EssentialsServerlist version 2.0.263 by Vimae Development enabled.
    2011-03-06 14:24:26 [INFO] Loaded EssentialsSpawn build 2.0.263 maintained by Zenexer, ementalo, Aelux, Brettflan, KimKandor, and snowleo
    2011-03-06 14:24:26 [INFO] Loaded EssentialsTele build 2.0.263 by Zenexer, ementalo, Aelux, Brettflan, KimKandor, and snowleo
    2011-03-06 14:24:26 [INFO] Loaded EssentialsWarp build 2.0.263 by Zenexer, ementalo, Aelux, Brettflan, KimKandor, and snowleo
    2011-03-06 14:24:26 [INFO] FindMe 1.2.4 loaded.
    2011-03-06 14:24:26 [INFO] [GODMODE] 0.1.6 is enabled!
    2011-03-06 14:24:26 [INFO] iSee is using permissions!
    2011-03-06 14:24:26 [INFO] iSee version 0.2 is enabled!
    2011-03-06 14:24:26 [INFO] A simple demo plugin as proof for showing other people's inventories.
    
    2011-03-06 14:24:26 [INFO] Config    [v1.57]    Loaded 13 config entries
    2011-03-06 14:24:26 [INFO] LWC    [v1.57]    Loaded command: /lwc -admin
    2011-03-06 14:24:26 [INFO] LWC    [v1.57]    Loaded command: /lwc -create
    2011-03-06 14:24:26 [INFO] LWC    [v1.57]    Loaded command: /lwc -free
    2011-03-06 14:24:26 [INFO] LWC    [v1.57]    Loaded command: /lwc -info
    2011-03-06 14:24:26 [INFO] LWC    [v1.57]    Loaded command: /lwc -p
    2011-03-06 14:24:26 [INFO] LWC    [v1.57]    Loaded command: /lwc -modify
    2011-03-06 14:24:26 [INFO] LWC    [v1.57]    Loaded command: /lwc -unlock
    2011-03-06 14:24:26 [INFO] LWC    [v1.57]    Loaded command: /lwc -owners
    2011-03-06 14:24:26 [INFO] LWC    [v1.57]    -> PLAYER_QUIT
    2011-03-06 14:24:26 [INFO] LWC    [v1.57]    -> ENTITY_EXPLODE
    2011-03-06 14:24:26 [INFO] LWC    [v1.57]    -> BLOCK_INTERACT
    2011-03-06 14:24:26 [INFO] LWC    [v1.57]    -> BLOCK_DAMAGED
    2011-03-06 14:24:26 [INFO] LWC    [v1.57]    -> BLOCK_BREAK
    2011-03-06 14:24:26 [INFO] LWC    [v1.57]    -> BLOCK_PLACED
    2011-03-06 14:24:26 [INFO] LWC    [v1.57]    -> REDSTONE_CHANGE
    2011-03-06 14:24:26 [INFO] LWC    [v1.57]    Using Nijikokun's permissions plugin for permissions
    2011-03-06 14:24:26 [INFO] LWC    [v1.57]    Loading SQLite
    2011-03-06 14:24:26 [INFO] PhysDB    [v1.57]    Creating physical tables if needed
    2011-03-06 14:24:26 [INFO] MemDB    [v1.57]    Creating memory tables
    2011-03-06 14:24:26 [INFO] SQLite    [v1.57]    Using: Pure
    2011-03-06 14:24:26 [INFO] Minecart Mania Core version 1.01a is enabled!
    2011-03-06 14:24:26 [INFO] Persistence version 0.55 failed to initialize
    2011-03-06 14:24:26 [SEVERE] java.lang.NullPointerException
    2011-03-06 14:24:26 [SEVERE]     at com.elmakers.mine.bukkit.plugins.persistence.PersistencePlugin.getUtilities(PersistencePlugin.java:152)
    2011-03-06 14:24:26 [SEVERE]     at com.elmakers.mine.bukkit.plugins.persistence.PersistencePlugin.getPermissions(PersistencePlugin.java:162)
    2011-03-06 14:24:26 [SEVERE]     at com.elmakers.mine.bukkit.plugins.persistence.PersistencePlugin.initialize(PersistencePlugin.java:137)
    2011-03-06 14:24:26 [SEVERE]     at com.elmakers.mine.bukkit.plugins.persistence.PersistencePlugin.onEnable(PersistencePlugin.java:93)
    2011-03-06 14:24:26 [SEVERE]     at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:118)
    2011-03-06 14:24:26 [SEVERE]     at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:414)
    2011-03-06 14:24:26 [SEVERE]     at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:188)
    2011-03-06 14:24:26 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:83)
    2011-03-06 14:24:26 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:61)
    2011-03-06 14:24:26 [SEVERE]     at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:204)
    2011-03-06 14:24:26 [SEVERE]     at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:191)
    2011-03-06 14:24:26 [SEVERE]     at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:131)
    2011-03-06 14:24:26 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246)
    2011-03-06 14:24:26 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    2011-03-06 14:24:26 [INFO] ScrapBukkit version 0.2.1 is enabled!
    2011-03-06 14:24:26 [INFO] [SendGift] version 1.0 by lonelydime is enabled!
    2011-03-06 14:24:26 [INFO] SlowHealth 2.3 enabled! Rate: 20.0s | Amount: 1
    2011-03-06 14:24:26 [INFO]  | Max: 20
    2011-03-06 14:24:26 [INFO] [TELEPLUS] Permissions enabled.
    2011-03-06 14:24:26 [INFO] TelePlus 1.5.5 enabled
    2011-03-06 14:24:26 [INFO] WorldEdit 4.0-beta6 enabled.
    2011-03-06 14:24:26 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-03-06 14:24:26 [INFO] WorldGuard: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-03-06 14:24:26 [INFO] WorldGuard: Single session is enforced.
    2011-03-06 14:24:26 [INFO] WorldGuard: TNT ignition is blocked.
    2011-03-06 14:24:26 [INFO] WorldGuard: Lighters are PERMITTED.
    2011-03-06 14:24:26 [INFO] WorldGuard: Lava fire is blocked.
    2011-03-06 14:24:26 [INFO] WorldGuard: All fire spread is disabled.
    2011-03-06 14:24:26 [INFO] WorldGuard 4.0-alpha1 enabled.
    2011-03-06 14:24:26 [INFO] Done (0.290s)! For help, type "help" or "?"
    2011-03-06 14:24:34 [INFO] CButD: Plugin-Update-Check started
    2011-03-06 14:24:35 [INFO] No source for chatbukkit.jar ask the Author to give me one
    2011-03-06 14:24:35 [INFO] No source for Cleaner.jar ask the Author to give me one
    2011-03-06 14:24:35 [INFO] No source for CraftBook.jar ask the Author to give me one
    2011-03-06 14:24:35 [INFO] No source for CraftBookCircuits.jar ask the Author to give me one
    2011-03-06 14:24:35 [INFO] No source for CraftBookMechanisms.jar ask the Author to give me one
    2011-03-06 14:24:35 [INFO] No source for CraftBookVehicles.jar ask the Author to give me one
    2011-03-06 14:24:38 [INFO] No source for EssentialsUpdate.jar ask the Author to give me one
    2011-03-06 14:24:38 [INFO] No source for FindMe.jar ask the Author to give me one
    2011-03-06 14:24:38 [INFO] No source for GodMode.jar ask the Author to give me one
    2011-03-06 14:24:38 [INFO] No source for iSee.jar ask the Author to give me one
    2011-03-06 14:24:40 [INFO] No source for scrapbukkit.jar ask the Author to give me one
    2011-03-06 14:24:41 [INFO] No source for TelePlus.jar ask the Author to give me one
    2011-03-06 14:24:41 [INFO] No source for WorldEdit.jar ask the Author to give me one
    2011-03-06 14:24:41 [INFO] No source for WorldGuard.jar ask the Author to give me one
    2011-03-06 14:24:41 [INFO] CButD: Plugin-Update-Check finished
    2011-03-06 14:26:47 [INFO] CONSOLE: Stopping the server..
    2011-03-06 14:26:47 [INFO] Stopping server
    2011-03-06 14:26:47 [INFO] [Cleaner] version [1.7] (Hit) disabled
    2011-03-06 14:26:47 [INFO] Fake Permissions version 2.5 is disabled!
    2011-03-06 14:26:47 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-03-06 14:26:47 [INFO] WorldGuard: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-03-06 14:26:47 [INFO] GroupManager - INFO - Scheduled Data Saving is disabled!
    2011-03-06 14:26:47 [INFO] GroupManager version 1.0(pre-alpha-3) is disabled!
    2011-03-06 14:26:47 [WARNING] EssentialsProtect Disabled, protection deactivated
    2011-03-06 14:26:47 [INFO] EssentialsServerlist version 2.0.263 disabled.
    2011-03-06 14:26:47 [INFO] FindMe 1.2.4 unloaded.
    2011-03-06 14:26:47 [INFO] [GODMODE] Disabled
    2011-03-06 14:26:47 [INFO] LWC    [v1.57]    Freeing SQLite
    2011-03-06 14:26:47 [INFO] Fake Permissions version 2.5.2 is disabled!
    2011-03-06 14:26:47 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-03-06 14:26:47 [INFO] WorldGuard: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-03-06 14:26:47 [INFO] [SendGift] Disabled
    2011-03-06 14:26:47 [INFO] Goodbye world!
    2011-03-06 14:26:47 [INFO] WorldGuard 4.0-alpha1 disabled.
    2011-03-06 14:26:47 [INFO] Saving chunks
    
     
  26. Offline

    NathanWolf

    Persistence is certainly "blowing up"- but I have to say, it's in a really weird place. I know it says 0.55 in your log, but I did re-upload yesterday, thinking maybe people had a bogus version... can you try re-downloading?

    Juggernaut seems to be dying, too, but I can't imagine they're related at all.
     
  27. Offline

    godgodgodgo

    hmm I re downloaded it but it does the same thing.
     
  28. Offline

    NathanWolf

    Well, thanks for trying that :(

    Hrm- the "utilities" reference is built-in and created on demand- I must've missed a reference, and I guess things are getting initialized for you in a different order? That's a bummer :(

    Let me get this reproduced- I'll download all the plugins you've got if I have to :)

    Offhand, I'm guessing it's a FakePermissions thing, whatever the hell that is :p
     
  29. Offline

    godgodgodgo

    ha yeh its an updated permissions thing or something :D
     
  30. Offline

    lastof

    I'm getting the same issue, with literally nothing but Persistence (The plan was to disable everything and re-enable 1 by 1 to ensure something else wasn't doing something funky and causing it). Brand new copy, etc.

    Code:
    [email protected]:~/bukkit$ java -Xincgc -Xmx700M -jar craftbukkit-0.0.1-SNAPSHOT.jar nogui
    15:40:20 [INFO] Starting minecraft server version Beta 1.3
    15:40:20 [INFO] Loading properties
    15:40:20 [INFO] Starting Minecraft server on *:25565
    15:40:20 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-493-g8b5496e-b493jnks (MC: 1.3)
    15:40:20 [INFO] Preparing level "SFFS Minecraft Server"
    15:40:20 [INFO] Preparing start region
    15:40:21 [INFO] Persistence version 0.55 failed to initialize
    15:40:21 [SEVERE] java.lang.NullPointerException
    15:40:21 [SEVERE]    at com.elmakers.mine.bukkit.plugins.persistence.PersistencePlugin.getUtilities(PersistencePlugin.java:152)
    15:40:21 [SEVERE]    at com.elmakers.mine.bukkit.plugins.persistence.PersistencePlugin.getPermissions(PersistencePlugin.java:162)
    15:40:21 [SEVERE]    at com.elmakers.mine.bukkit.plugins.persistence.PersistencePlugin.initialize(PersistencePlugin.java:137)
    15:40:21 [SEVERE]    at com.elmakers.mine.bukkit.plugins.persistence.PersistencePlugin.onEnable(PersistencePlugin.java:93)
    15:40:21 [SEVERE]    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:118)
    15:40:21 [SEVERE]    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:414)
    15:40:21 [SEVERE]    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:187)
    15:40:21 [SEVERE]    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:83)
    15:40:21 [SEVERE]    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:61)
    15:40:21 [SEVERE]    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:204)
    15:40:21 [SEVERE]    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:191)
    15:40:21 [SEVERE]    at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:131)
    15:40:21 [SEVERE]    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246)
    15:40:21 [SEVERE]    at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    15:40:21 [INFO] Done (0.092s)! For help, type "help" or "?"
    >stop
    15:40:32 [INFO] CONSOLE: Stopping the server..
    15:40:32 [INFO] Stopping server
    15:40:32 [INFO] Saving chunks
     
  31. Offline

    NathanWolf

    Ok, not a FakePermissions thing, and fixed in 0.56.

    Sorry about that, it was actually a plugin-load-order dependent thing, so kind of hard to reproduce :p

    Permissions skirts this sort of thing by requesting that you enabling it manually before using it- you're not supposed to have to do that for Persistence, for what that's worth.
    --- merged: Mar 6, 2011 4:01 PM ---
    Yeah- the "problem" was that it doesn't seem to happen with NetherGate installed :p At least, for me.

    When I removed NG, I guess Persistence is the next thing to load (alphabetical order?). And the bug only happened if the Persistence plugin itself was the thing to initialize the persistence engine. Yeah, kind of a weird bug :p
     

Share This Page