[INACTIVE][ADMN/INFO] BukkitUpdater v0.2.7.57 - Shows outdated plugins and more [1060]

Discussion in 'Inactive/Unsupported Plugins' started by zauberstuhl y33, Jul 19, 2011.

  1. Offline

    zauberstuhl y33

    wassilij and BadgerLove like this.
  2. O.O Do I undertand you right? The version switched from 7.1 to 0.7.1? Than bukkitUpdater tells you the only logic consequence: The devs of BOSEcon are crazy... :confused:

    ...Seeing next: Windows 93, the next generation... :D
  3. Offline


    Version never switched. Version has always been 0.x.x, the more likely answer is a typo in the updater process. Could be a typo on our end some place as well... but since I dont use updater I dont know. Just reporting what somebody told me.
  4. Offline

    zauberstuhl y33

    thanks riuthamus my script works correctly it parses the title of the plugin page and the title of your BOSEcon shows
    if you change your title to 0.7.1 i can change it manuelly on the database
  5. Offline


    Lol your script pulls from a forum post. Epic fail! Okay ill update the title thanks! Furthermore read the title .7.1 that means .7 If you understood how numbers work that would mean there is a 0 before the .

    Just saying! Maybe try not to be an ass and call people out when they actually have the correct setup. Its just your script pulling from forum titles that causes the problem. Not my problem.

    Lol i came to your place because somebody bitched about it not working. I dont give two shits if your plugin works for my plugin or not. Your backass way of managing it with a topic title is your problem not mine. Your the one who made this into a fight because of your negative attitude. Again, i dont need your plugin, somebody else wanted to use it and had a problem. You could have very easily notified me through a PM saying that the purpose of the problem was the title and I could fix it by doing the following. My response to you would have been agreeable and we could have moved along smartly.

    Instead you come off like an ass and when I correct you, you try to make yourself some high and mighty punk ass. End of the day your goal should be to support the player base and not your EGO. Grow up son.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  6. Code:
    2011-08-04 20:33:12 [INFO] LWC: At version: 3.31-git-LWC-b9ea01e8c2f66480ada443ba9084dfbe9832f06e-b81jnks
    2011-08-04 20:33:12 [INFO] [Tombstone] Using LWC (v3.31)
    2011-08-04 20:33:12 [INFO] [AdminCmd] Plugin Enabled. (version 5.6.23)
    2011-08-04 20:33:12 [INFO] [AdminCmd] bal_extinguish has all his alias already registered. Command deactivated
    2011-08-04 20:33:12 [INFO] [AdminCmd] Disabled Alias(es) for bal_repair : repair,
    2011-08-04 20:33:12 [INFO] [AdminCmd] Disabled Alias(es) for bal_memory : mem,
    2011-08-04 20:33:12 [INFO] [AdminCmd] Disabled Alias(es) for bal_home : home,
    2011-08-04 20:33:12 [INFO] [AdminCmd] Disabled Alias(es) for bal_sethome : sethome,
    2011-08-04 20:33:12 [INFO] [AdminCmd] Disabled Alias(es) for bal_extinguish : ex, extinguish,
    2011-08-04 20:33:12 [INFO] [AdminCmd] Disabled Alias(es) for bal_undo : undo,
    2011-08-04 20:33:12 [INFO] [AdminCmd] Successfully linked with Yeti's Permissions.
    2011-08-04 20:33:12 [INFO] Server permissions file permissions.yml is empty, ignoring it
    2011-08-04 20:33:12 [INFO] Reload complete.
    2011-08-04 20:33:13 [INFO] [Volcano] load Jehus
    2011-08-04 20:33:13 [INFO] [Volcano] load Jesus
    2011-08-04 20:33:20 [INFO] despized [/] logged in with entity id 539 at ([world] -160.75, 69.0, 71.90625)
    2011-08-04 20:33:23 [SEVERE] java.util.NoSuchElementException
    2011-08-04 20:33:23 [SEVERE]     at java.util.Scanner.throwFor(Unknown Source)
    2011-08-04 20:33:23 [SEVERE]     at java.util.Scanner.next(Unknown Source)
    2011-08-04 20:33:23 [SEVERE]     at zauberstuhl.BukkitUpdater.ThreadHelper.sendData(ThreadHelper.java:61)
    2011-08-04 20:33:23 [SEVERE]     at zauberstuhl.BukkitUpdater.Async.Overview.u2d(Overview.java:91)
    2011-08-04 20:33:23 [SEVERE]     at zauberstuhl.BukkitUpdater.Async.Overview.run(Overview.java:53)
    2011-08-04 20:33:23 [SEVERE]     at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    2011-08-04 20:33:23 [SEVERE]     at java.lang.Thread.run(Unknown Source)
    2011-08-04 21:23:58 [INFO] [iConomyChestShop] despized bought 64 FEATHER with durability of 0 from AdminShop for 128.0 derps
    2011-08-04 21:29:31 [INFO] nodrop: CREATURE_ZOMBIE
    2011-08-04 21:29:31 [INFO] [HeroicDeath] despized burned to death
    2011-08-04 21:33:11 [INFO] [MineBackup] Starting backup...
    2011-08-04 21:33:11 [INFO] [MineBackup]  * world
    2011-08-04 21:33:12 [INFO] [MineBackup]  * world_nether
    2011-08-04 21:33:12 [INFO] [MineBackup] Compressing...
    2011-08-04 21:33:16 [INFO] [MineBackup] Done !
    2011-08-04 21:33:37 [INFO] despized: Forcing save..
    2011-08-04 21:33:37 [INFO] despized: Save complete.
    2011-08-04 21:33:43 [INFO] despized lost connection: disconnect.quitting
    2011-08-04 21:33:43 [INFO] Connection reset
    2011-08-04 21:34:00 [INFO] BukkitUpdater version 0.2.6
    2011-08-04 21:34:00 [INFO] Fetching information...
    2011-08-04 21:34:04 [SEVERE] java.util.NoSuchElementException
    2011-08-04 21:34:04 [SEVERE]     at java.util.Scanner.throwFor(Unknown Source)
    2011-08-04 21:34:04 [SEVERE]     at java.util.Scanner.next(Unknown Source)
    2011-08-04 21:34:04 [SEVERE]     at zauberstuhl.BukkitUpdater.ThreadHelper.sendData(ThreadHelper.java:61)
    2011-08-04 21:34:04 [SEVERE]     at zauberstuhl.BukkitUpdater.Async.Overview.u2d(Overview.java:91)
    2011-08-04 21:34:04 [SEVERE]     at zauberstuhl.BukkitUpdater.Async.Overview.run(Overview.java:53)
    2011-08-04 21:34:04 [SEVERE]     at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    2011-08-04 21:34:04 [SEVERE]     at java.lang.Thread.run(Unknown Source)
    2011-08-04 21:45:11 [INFO] Connection reset
    2011-08-04 21:45:11 [INFO] xpincushionx lost connection: disconnect.quitting
    2011-08-04 22:33:11 [INFO] [MineBackup] 2011.08.4 : 0 days ?
    2011-08-04 22:33:11 [INFO] [MineBackup]  + 0 backup(s) deleted
    2011-08-04 22:33:11 [INFO] [MineBackup] No players online, backup delayed
    2011-08-04 23:33:11 [INFO] [MineBackup] No players online, backup delayed
    2011-08-05 00:18:49 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
  7. Offline


    The following error occurs everytime an admin logs in.
    2011-08-07 00:38:57 [SEVERE] java.util.NoSuchElementException
    2011-08-07 00:38:57 [SEVERE]     at java.util.Scanner.throwFor(Scanner.java:838)
    2011-08-07 00:38:57 [SEVERE]     at java.util.Scanner.next(Scanner.java:1347)
    2011-08-07 00:38:57 [SEVERE]     at zauberstuhl.BukkitUpdater.ThreadHelper.sendData(ThreadHelper.java:61)
    2011-08-07 00:38:57 [SEVERE]     at zauberstuhl.BukkitUpdater.Async.Overview.u2d(Overview.java:91)
    2011-08-07 00:38:57 [SEVERE]     at zauberstuhl.BukkitUpdater.Async.Overview.run(Overview.java:53)
    2011-08-07 00:38:57 [SEVERE]     at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    2011-08-07 00:38:57 [SEVERE]     at java.lang.Thread.run(Thread.java:662)
  8. Offline

    Puma D. Ace

    I have the same problem as locksmyth

    14:19:02 [INFO] BukkitUpdater version 0.2.6
    14:19:02 [INFO] Fetching information...
    14:19:03 [SEVERE] java.util.NoSuchElementException
    14:19:03 [SEVERE]     at java.util.Scanner.throwFor(Scanner.java:838)
    14:19:03 [SEVERE]     at java.util.Scanner.next(Scanner.java:1347)
    14:19:03 [SEVERE]     at zauberstuhl.BukkitUpdater.ThreadHelper.sendData(ThreadHelper.java:61)
    14:19:03 [SEVERE]     at zauberstuhl.BukkitUpdater.Async.Overview.u2d(Overview.java:91)
    14:19:03 [SEVERE]     at zauberstuhl.BukkitUpdater.Async.Overview.run(Overview.java:53)
    14:19:03 [SEVERE]     at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    14:19:03 [SEVERE]     at java.lang.Thread.run(Thread.java:662)
  9. Offline


    oh, I meant that only 3 out of my 20 plugins are supported but now I see that It looks like I need to request the ones that I need right?
  10. Offline

    zauberstuhl y33

    Sorry guys i'm currently in holidays and i have no development environment right here :S

    But it looks like you have different user permissions.
    Make sure that the BukkitUpdater-folder has the same user permisssions as the Minecraft-server
    e.g you run the server with the user "minecraft":
    chown -R minecraft:minecraft plugins/
    After that reload your server:
    And have a look whether the BukkitUpdater created correctly the token (exists the BukkitUpdater/token.txt?)

  11. I tested this on a local test server, where the server itself is running as my user, yet i still get this error (same as the others, but posting it here so you wont have to look for it)
    06:56:25 [SEVERE] java.util.NoSuchElementException
    06:56:25 [SEVERE]     at java.util.Scanner.throwFor(Scanner.java:838)
    06:56:25 [SEVERE]     at java.util.Scanner.next(Scanner.java:1347)
    06:56:25 [SEVERE]     at zauberstuhl.BukkitUpdater.ThreadHelper.sendData(ThreadHelper.java:67)
    06:56:25 [SEVERE]     at zauberstuhl.BukkitUpdater.Async.Overview.u2d(Overview.java:95)
    06:56:25 [SEVERE]     at zauberstuhl.BukkitUpdater.Async.Overview.run(Overview.java:55)
    06:56:25 [SEVERE]     at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    06:56:25 [SEVERE]     at java.lang.Thread.run(Thread.java:680)
    1. It's being run as the same user and permission as the server
    2. It has a token in token.txt
    So I have no idea what i might be doing wrong.
  12. Offline


    permissions on the file system are correct and token.txt is being created.
  13. Offline


    please list your permissions node in your plugin.yml so we may extract them regularly and stay updated using permissionshelper

    which would also mean supporting superperms PLEASE!

    I will leave you with this delicious caek [cake]
  14. Offline


    i got this error while running u2d from the console

    19:41:58 [INFO] BukkitUpdater version 0.2.6
    19:41:58 [INFO] Fetching information...
    19:42:02 [SEVERE] java.util.regex.PatternSyntaxException: Dangling meta characte
    r '*' near index 0
    *Permissions v2.7.7*
    19:42:02 [SEVERE]       at java.util.regex.Pattern.error(Unknown Source)
    19:42:02 [SEVERE]       at java.util.regex.Pattern.sequence(Unknown Source)
    19:42:02 [SEVERE]       at java.util.regex.Pattern.expr(Unknown Source)
    19:42:02 [SEVERE]       at java.util.regex.Pattern.compile(Unknown Source)
    19:42:02 [SEVERE]       at java.util.regex.Pattern.<init>(Unknown Source)
    19:42:02 [SEVERE]       at java.util.regex.Pattern.compile(Unknown Source)
    19:42:02 [SEVERE]       at java.util.regex.Pattern.matches(Unknown Source)
    19:42:02 [SEVERE]       at java.lang.String.matches(Unknown Source)
    19:42:02 [SEVERE]       at zauberstuhl.BukkitUpdater.Async.Overview.blacklist(Ov
    19:42:02 [SEVERE]       at zauberstuhl.BukkitUpdater.Async.Overview.u2d(Overview
    19:42:02 [SEVERE]       at zauberstuhl.BukkitUpdater.Async.Overview.run(Overview
    19:42:02 [SEVERE]       at org.bukkit.craftbukkit.scheduler.CraftWorker.run(Craf
    19:42:02 [SEVERE]       at java.lang.Thread.run(Unknown Source)
  15. Offline


    23:46:57 [SEVERE] java.util.NoSuchElementException
    23:46:57 [SEVERE] at java.util.Scanner.throwFor(Unknown Source)
    23:46:57 [SEVERE] at java.util.Scanner.next(Unknown Source)
    23:46:57 [SEVERE] at zauberstuhl.BukkitUpdater.ThreadHelper.sendData(Threa
    23:46:57 [SEVERE] at zauberstuhl.BukkitUpdater.Async.Overview.u2d(Overview
    23:46:57 [SEVERE] at zauberstuhl.BukkitUpdater.Async.Overview.run(Overview
    23:46:57 [SEVERE] at org.bukkit.craftbukkit.scheduler.CraftWorker.run(Craf
    23:46:57 [SEVERE] at java.lang.Thread.run(Unknown Source)

    Using some dev version of craftbukkit.jar but Seeing that it's affecting other ppl too and I'm on Windows with correct permission, it's not that. Awesome idea though, looks like before this bug, it was pretty damn good. I'll have to check up on this :D
  16. Well, I'm getting the same error as others. I don't know about the others, but mine started happening when I installed WorldEdit and WorldGuard. Quite a long shot, but worth checking if others also have WorldEdit/WorldGuard.
  17. Offline

    zauberstuhl y33

    i found a few bugs and removed/corrected them.
    i had no change to test the plugin yet ....so i upload only a unstable version.

    the fixed version you can find here http://mc.zauberstuhl.de/bukkit_updater/BukkitUpdater-testing.jar
    and the stable version i'll release tonight ...

  18. Offline


    I'll wait for stable, thanks! your awesome BTW
  19. Updated to 0.2.7 (I take it this is the fixed version you mentioned above?), deleted the old BukkitUpdater folder (the token.txt, blacklist, backup etc), and generated a new one. Did this because I was taking the opportunity to switch to PermissionsBukkit (superperms). Still got the same error as before:
    18:46:29 [INFO] BukkitUpdater version 0.2.7
    18:46:29 [INFO] Fetching information...
    18:46:33 [SEVERE] java.util.NoSuchElementException
    18:46:33 [SEVERE]     at java.util.Scanner.throwFor(Scanner.java:838)
    18:46:33 [SEVERE]     at java.util.Scanner.next(Scanner.java:1347)
    18:46:33 [SEVERE]     at zauberstuhl.BukkitUpdater.ThreadHelper.sendData(ThreadHelper.java:67)
    18:46:33 [SEVERE]     at zauberstuhl.BukkitUpdater.Async.Overview.u2d(Overview.java:95)
    18:46:33 [SEVERE]     at zauberstuhl.BukkitUpdater.Async.Overview.run(Overview.java:55)
    18:46:33 [SEVERE]     at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    18:46:33 [SEVERE]     at java.lang.Thread.run(Thread.java:680)
    If you need, my config files (the stuff inside 'BukkitUpdater' folder):
    #  ++++++++++  #
    # Here you can write plugin names
    # seperated by ',' (without the quotes)
    # if they are not to be tested for their topicality.
    # e.g.:
    And a 'backup' folder, with nothing in it.

    This time, I'll give my full plugins list:
    and WorldGuard
    I might start trying the server without these one by one in turn, to see if it's a conflict problem (I did think that the problem seemed to start when I added WorldEdit and WorldGuard, not sure), unless there's a fix coming.

    Almost forgot! I'm using Bukkit 1060
  20. Offline

    zauberstuhl y33

    1th: thanks a lot for your support :)

    i couldn't reproduce this case ... :( but i think it is a problem with my sendData-function so i rebuilt it
    and wrote the function a bit nicer...

    louis058 in your case: can you download the testing version and verify that the bug is fixed or not?

  21. It works! However, there are some minor problems, some of which aren't even your fault I think.
    Firstly, the chat version of /u2d puts some random newlines between the plugin names:
    Fortunately, on the server it doesn't do that. I thought it was the client's line-wrapping at first, but there's so much space between the plugin names and the right side of the chat box that it seems unlikely. I don't know, you're the developer.

    Secondly, there are two plugins that can't be updated to the latest version, for different reasons. First is SpawnBed. It says that it is version 0.1, and the latest is 1.0:
    SpawnBed (L) 1.0 > 0.1
    However, according to the actual page, there doesn't seem to have ever been a version 0.1 (link), and it's at version 1.0 anyway. I suspect that's SpawnBed's developer's fault, not yours, but worth noting. Second, I'm running Superpermbridge, and BukkitUpdater is detecting it as Permissions 2.7, which is probably right. While I'm not suggesting to create a special rule to detect Superpermbridge, it may be worth considering the next featureset to include an option to ignore plugins that you don't want to update. /u2d ignore or something. Obviously, it's your choice, but I'd like to see it :)

    Finally, I noticed that even after updating my plugins, /u2d still showed up the last results, claiming that the same four plugins weren't updated. A restart of the server solved it, and maybe BukkitUpdater would have updated itself eventually if I hadn't, but maybe you could consider making BukkitUpdater update itself quietly when you update a plugin? Again, just an idea :)

    Otherwise, the plugin works again! Yay!
  22. Offline

    zauberstuhl y33

    i have a look at this thanks!

    This is a big problem many developer forget to change in the plugin.yml the version number :(
    Also the developer of SpawnBed:
    name: SpawnBed
    main: mats391.spawnbed.SpawnBed
    version: 0.1
    sorry but i have no influence to this problem.

    yip i will include a exception.

    There is already a function with this feature. Have a look at the blacklist.txt in the BukkitUpdater-folder.
    //EDIT: or do you mean a ingame command for the blacklist?

    i will add this as a bug-request.
    Much input for me but thanks for the feedback it will improve the BukkitUpdater :)

  23. Offline


    Great plugin!
    any chance you could expand the description within your jar file to be a bit more robust than

    I would appreciate it soooooo much as my server uses an auto generated plugin info plugin to generate a list with descriptions of plugins. I would appreciate it so much if you could take the time to do this!

  24. Oh yeah... I forgot about that. Though an in-game command for the blacklist would make sense yes.
  25. Offline


    I'm using permissionsBukkit as my permissions system. Think you could add support for it?
  26. Offline


    @zauberstuhl y33

    Yes, SuperpermsBridge is designed to imitate Permissions 2.7/3.x, as it then BRIDGES over the permissions, so that permissionsBukkit (aka Superperms) is able to have it in it's config.

    Hope i helped :D
  27. Offline

    zauberstuhl y33

    :D thanks i was a bit confused with all of these permission plugins ;)

    with the newest version (build 55) it is also possible to use BukkitUpdater with PermissionsBukkit.

  28. Offline


    2011-08-20 10:43:09 [INFO] Following plugins are not supported by BukkitUpdater:
    2011-08-20 10:43:09 [INFO] Spout v1.0.2.134
    2011-08-20 10:43:09 [INFO] FalseBookCore v0.87alpha DEV#3
    2011-08-20 10:43:09 [INFO] CFBanner v1.7
    2011-08-20 10:43:09 [INFO] FalseBookExtra v0.87alpha DEV#3
    2011-08-20 10:43:09 [INFO] LivingForest v10
    2011-08-20 10:43:09 [INFO] Coupon Codes v1.5
    2011-08-20 10:43:09 [INFO] WorldEdit v4.6
    2011-08-20 10:43:09 [INFO] CommandBook v1.5.2
    2011-08-20 10:43:09 [INFO] WorldGuard v5.2.2
    2011-08-20 10:43:09 [INFO] Flup_p1 v1.7.2
    2011-08-20 10:43:09 [INFO] PluginInfo v0.1.3
    2011-08-20 10:43:09 [INFO] FalseBookBlock v0.87alpha DEV#3
    2011-08-20 10:43:09 [INFO] TimeRank v0.1.0b
    2011-08-20 10:43:09 [INFO] Stackable v0.5.1
    2011-08-20 10:43:09 [INFO] creaturebox v0.7.6
    2011-08-20 10:43:09 [INFO] iChat v2.3.3-p3
  29. I'm going to test the new version a little, but if you're struggling for a name for the ignore command btw, you could separate it into two commands: /u2d ban and /u2d allow, for better clarity. Unless that's more difficult to code, in which case /u2d blacklist might do.
  30. Offline


    Can we have a /u2d update -all command?
  31. Please no!
    If/when you (magischer hocker... xD...) are planning to do something like that then full wildcard support! So we can use
    /u2d update *
    /u2d update a*
    /u2d update *crazy*plugins*with*similar*names*

Share This Page