[INACTIVE][ADMN] DefaultPermissions v0.3.4 - OBSOLETE AS OF CB1060 [1000]

Discussion in 'Inactive/Unsupported Plugins' started by Celtic Minstrel, Apr 3, 2011.

  1. Offline

    Celtic Minstrel

    DefaultPermissions - Make default commands compatible with Permissions
    Version: v0.3.4

    NOTE: As of recommended build 1060, this functionality is present within CraftBukkit (ie without this plugin) provided you are not using GroupManager or Permissions. See here for details.

    Have you ever wanted to give a trusted user or group access to vanilla Minecraft commands, such as /kick or /whitelist? Have you ever wanted to restrict access to the CraftBukkit commands, such as /plugins? This plugin lets you do that with permissions.

    Use: Just add the relevant permissions to whichever user or group you want to give them to in your permissions config, and voila! That user will be able to use them.

    NOTE: Most Minecraft commands are restricted to ops for a very good reason, since they can allow a user to effectively seize control of the server until someone with console access shows up. Do not give these permissions lightly. If you give your Default group access to ban and kick, and some griefer shows up and destroys your server, don't come complaining here.

    • minecraft.<command> - Gives permissions for a single Minecraft command. Supported commands are: help, kick, ban, pardon, ban-ip, pardon-ip, op, deop, tp, give, tell, stop, save-all, save-off, save-on, list, say, time, whitelist, me. Note that some commands may be overridden by other plugins; if this is the case, the relevant permission will have no effect.
    • minecraft.time.set, minecraft.time.add - Finer-tuned control to the vanilla /time command; controls access to /time set and /time add respectively.
    • minecraft.whitelist.<command> - Finer-tuned control to the /whitelist command. Supported commands are: on, off, add, remove, list, reload
    • bukkit.version, bukkit.plugins, bukkit.reload - Controls access to the respective Bukkit commands.

    Download (alt link; may not be up-to-date)


    Version 0.3.4
    • Fixed a bug with superperms compatibility.

    Version 0.3.3
    • Supports aliases for CraftBukkit commands.
    • Supports Bukkit superperms.

    Version 0.3.2
    • Fixed the issue with DefPerms$PlayerOverride being shown in place of a player's name when using /tell.

    Version 0.3.1
    • Commands are now intercepted regardless of case.

    Version 0.3
    • A config file is now used to decide whether to even attempt intercepting the commands. Commands not listed in the config file will never be intercepted by the plugin. Note that it still only works for built-in commands.

    Version 0.2
    • Command feedback now appears to the user instead of in the console.
    • Replaced craftbukkit.* with bukkit.*
    • Don't check for subcommands if permission for the main command was found.
    • If the player is an op, allow the command to complete normally.

    Version 0.1
    • Initial release
    Taranis01 and Niles like this.
  2. Offline

    Celtic Minstrel

    That has nothing to do with this plugin.

    It should work with PermissionsEX since it supports both Niji-Permissions and Bukkit-Permissions. Ask in the PermissionsEX thread how you can make it work with plugins that support the latter two.

    @JackTDawson – Well, the only thing I can see in the log is a conspicuous lack of "DefaultPermissions enabled"... but I can't remember if that should be there anyway. Your permissions yml looks fine too. I was under the impression that imjake did not remove support for permissions, and there's no reason this should not work with CraftBukkit 1000 (I should've updated the topic awhile ago). In short, I have no idea why it doesn't work for you.

    @jmcneely – For some reason, it's looking for Permissions and can't find it. I assume you need to either tell it not to look for Permissions or just go and install it. Presumably @imjake9 can tell you how to do this; maybe he can help JackTDawson as well...
  3. Offline


    @JackTDawson – Your problem seems like it can have either an easy solution, or a very hard one. The easy (aka obvious) problem is that you didn't put usebukkitpermissions: false in the config file. It defaults to true, and that means it's ignoring Permissions and using Bukkit "superperms" instead. Just set it to false and your problems should be solved!

    @jmcneely – Your problem is much stranger. Can you tell me the exact version of the Permissions you're using? Also, is it Permissions 2/3, is it PermissionsEX, Permissions Plus, etc.? Thanks.
  4. Offline


  5. Offline


    Ah, thank you. Make sure usebukkitpermissions is set to true in the config file. If yes, it's an easy fix. If no, then I'll need to look into it more.
  6. Offline


    @imjake9 - Um, what config file? I don't see any config file for defaultcommands, I'm guessing I create it? I create a folder named "DefaultPermissions" and create a config.yml file inside of it with the line "usebukkitpermissions: true" Right?

    Edit: Nevermind, I found it. It was at the bottom next to all the .jar file instead of at the top with all the other folders.

    Anyways, usebukkitpermissions is already set to true.
  7. Offline


    Okay, try this version:

    I haven't actually tested it yet, but it should work. Please tell me the outcome. Thanks!
  8. Offline


    Just wanted to confirm this is working with bPermission
  9. Offline


    it don't work for me, I have it correcly installed but it keep saying: you don't have permission for that, although I have put the permissions minecraft.give.use and minecraft.tp.use in the right group, what am i doing wrong ? plz answer ... thanks ...
  10. Offline


    Those two permissions should be without .use:
  11. Offline


    @imjake9 - Yea, v0.3.4 seems to be working perfectly. Thanks alot :) I wouldn't know what to do without this plugin.
  12. Offline


    Awesome, glad it works. I've submitted a Pull Request on GitHub.
  13. Offline


    Doesn't work for me.

    permissions.build: true
    minecraft.give: true
    - admin
    minecraft.give: true
    permissions.build: true
    permissions.*: true
    - user
    permissions.build: true
    coolplugin.item: true
    - default
    build: '&cYou do not have permission to build here.'
  14. Offline


    You should probably provide more info then that. But looking at your file set up I'm guessing your using permissionsbukkit, in which case you should download the version imjake9 posted above.

    If that doesn't work then you'll need to provide more information about the problem
  15. Offline


    @Celtic Minstrel Just wanted to let you know that the plugin is version 0.3.4 and the thread title and version number you write is 0.3.3. I hope you update this information :)
  16. Offline


    When the .jar file is in my "plugins" folder and i start the server it makes no attempt to make a new folder
  17. Offline


    I'm using the lates version of permissions (http://forums.bukkit.org/threads/ad...-1-official-default-groups-plugin-1000.26785/) and I have the latest defaulpermissions. I noticed whenever I start the server, I get the following error,

    11:33:51 [SEVERE] Could not load 'plugins/PermissionsBukkit-1.1.jar' in folder 'plugins':
    while scanning for the next token
    found character '\t' that cannot start any token
    in "<reader>", line 40, column 1:
    minecraft.give: true

    at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(ScannerImpl.java:360)
    at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:183)
    at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(ParserImpl.java:564)
    at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:163)
    at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:148)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:228)
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:122)
    at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105)
    at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:124)
    at org.yaml.snakeyaml.Yaml.load(Yaml.java:264)
    at org.bukkit.util.config.Configuration.load(Configuration.java:82)
    at org.bukkit.plugin.java.JavaPlugin.initialize(JavaPlugin.java:157)
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:175)
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:207)
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:130)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:128)
    at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:97)
    at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigurationManager.java:51)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:132)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    11:33:51 [INFO] [SuperpermBridge] Superperm/Permissions bridge initialized

    Edit: Do you think its because I use TextEdit on Mac? Is it easier to mess up the file? I have Parallels 6 with Windows 7 and I could try Notepad++ if you think that will work better..

    UPDATE: I used notepad++ on win7 and it cleared the big long error up and now it completely works..... I guess your not supposed to use TextEdit...
  18. Offline


    the error you were getting is saying you you using tabs somewhere in your file. that's what the first bit means:
    while scanning for the next token
    found character 	'\t' that cannot start any token
     in "<reader>", line 40, column 1:
        	    minecraft.give:    true
  19. Offline

    Celtic Minstrel

    @cyberdude – Naturally I will; I was just away for a couple of days and only now discovered that imjake had posted a fix.
  20. Offline


    Lol, sorry. I had forgotten(didn't realize) that I had fetched the fixed version from imjake. ;)..
  21. Offline

    Celtic Minstrel

    Well, the primary download link is imjake's build; the alt link is the version I uploaded, which is currently an older version. So, by fetching from the primary download link you're getting imjake's version possibly without even realizing it's his.
  22. Offline

    G1R Productions

    This plugin doesnt even load when i place it in my plugins folder
  23. Offline

    Celtic Minstrel

    Well, that's not enough info to help you on. Do you get an error in the console?
  24. Offline


  25. Offline

    Celtic Minstrel

    Depends partly on imjake. If it were solely up to me, I'd probably discontinue it not with the next recommended build but with the one after that, to give people time to switch.
  26. Offline


    im using Essentials Group Manager (pretty much permissions) and the plugin doesnt seem to be working when i try to add minecraft.* to the moderator permissions, the main permission i want is /give for moderators (i tried adding minecraft.give but it didnt work either, what am i doing wrong?

  27. Offline

    Celtic Minstrel

    Um, are you running both General and Essentials? Anyway, if you're running either one of them, they control the /give command rather than this plugin, so you'd need something like general.give or essentials.give.
  28. Offline


    Yeah, this one is going out. I think I'll wait two RBs. Then it's done (there'd be no point!).
    Unless someone can think of a good reason to continue this, that's my plan.
  29. Offline


    I have been scouring the net for this. Thanks a lot! Great attention to playing nice with other plugins too!
  30. Offline


    I realize a default bukkit replacement is on the way, but I still can't get this to work. For some reason everyone on my server, permissions node or not, op or not can use every command. I have set the bukkitpermissions to false in config, because I'm using Permissions 3.x. Any help?
    I set usebukkitpermissions to true and now ops can use all commands, and non ops get a "You don't have permission for that" message.
  31. Offline


    I updated to new recommended build 1060 and ur plugin threw this error when someone tried to use the teleport (/tp) command:
    Enjoy :)

Share This Page