[INACTIVE][ADMN] DefaultPermissions v0.3.4 - OBSOLETE AS OF CB1060 [1000]

Discussion in 'Inactive/Unsupported Plugins' started by Celtic Minstrel, Apr 3, 2011.

  1. Offline

    Celtic Minstrel

    DefaultPermissions - Make default commands compatible with Permissions
    Version: v0.3.4

    NOTE: As of recommended build 1060, this functionality is present within CraftBukkit (ie without this plugin) provided you are not using GroupManager or Permissions. See here for details.

    Have you ever wanted to give a trusted user or group access to vanilla Minecraft commands, such as /kick or /whitelist? Have you ever wanted to restrict access to the CraftBukkit commands, such as /plugins? This plugin lets you do that with permissions.

    Use: Just add the relevant permissions to whichever user or group you want to give them to in your permissions config, and voila! That user will be able to use them.

    NOTE: Most Minecraft commands are restricted to ops for a very good reason, since they can allow a user to effectively seize control of the server until someone with console access shows up. Do not give these permissions lightly. If you give your Default group access to ban and kick, and some griefer shows up and destroys your server, don't come complaining here.

    • minecraft.<command> - Gives permissions for a single Minecraft command. Supported commands are: help, kick, ban, pardon, ban-ip, pardon-ip, op, deop, tp, give, tell, stop, save-all, save-off, save-on, list, say, time, whitelist, me. Note that some commands may be overridden by other plugins; if this is the case, the relevant permission will have no effect.
    • minecraft.time.set, minecraft.time.add - Finer-tuned control to the vanilla /time command; controls access to /time set and /time add respectively.
    • minecraft.whitelist.<command> - Finer-tuned control to the /whitelist command. Supported commands are: on, off, add, remove, list, reload
    • bukkit.version, bukkit.plugins, bukkit.reload - Controls access to the respective Bukkit commands.

    Download (alt link; may not be up-to-date)


    Version 0.3.4
    • Fixed a bug with superperms compatibility.

    Version 0.3.3
    • Supports aliases for CraftBukkit commands.
    • Supports Bukkit superperms.

    Version 0.3.2
    • Fixed the issue with DefPerms$PlayerOverride being shown in place of a player's name when using /tell.

    Version 0.3.1
    • Commands are now intercepted regardless of case.

    Version 0.3
    • A config file is now used to decide whether to even attempt intercepting the commands. Commands not listed in the config file will never be intercepted by the plugin. Note that it still only works for built-in commands.

    Version 0.2
    • Command feedback now appears to the user instead of in the console.
    • Replaced craftbukkit.* with bukkit.*
    • Don't check for subcommands if permission for the main command was found.
    • If the player is an op, allow the command to complete normally.

    Version 0.1
    • Initial release
    Taranis01 and Niles like this.
  2. Offline


  3. Offline

    Celtic Minstrel

    I think it shouldn't need updating. Have you tried it?
  4. Offline


    I think it might do, from what I've tried neither tp's nor changing the time work on my server
  5. Offline

    Celtic Minstrel

    And you're sure you have no plugins that override those commands? This plugin won't even try to control them if some other plugin has claimed them
  6. Offline


    I'm running iConomy, ChestShop, iOP, Lockette, MyHome, Permissions, PlgLogCmd, SimpleSpleef, World Guard and World Edit. The problems only just started happening around the time of the latest update
  7. Offline

    Celtic Minstrel

    Yeah, doesn't look like it's that... and if it only happened in the latest update I doubt it could be a misconfiguration. I suppose I should ask if tp and time works without DefaultPermissions installed when you have op status. If so, I'll try to find some time to take a look at it.
  8. Offline


    I just reinstalled the plugin and it seems to work perfectly now. Sorry for wasting your time :p Thanks for replying though, its always nice to have a developer respond to my questions :)
  9. Offline


    It disables /plugins but not /pl
  10. Offline

    Celtic Minstrel

    Ah, yes, I think CraftBukkit has also added one or two additional commands that I'll need to update for eventually. At least, I vaguely remember such a thing; it might've been my imagination.
  11. Offline


    Has the DefPerms$PlayerOverride issue issue with /tell been fixed?
  12. Offline

    Celtic Minstrel

    No, it has not, and it's unlikely it will be (at least by me). I don't have much interest in maintaining this plugin, to be honest.
  13. Offline


    I am willing to maintain this if it goes inactive. Do if you ever feel the need to get rid of it, I'll take it up. I know General's your main priority right now.
  14. Offline


    I really would be glad to see this Plugin alive :)
  15. Offline


    Same, it's an essential one on my server.
  16. Offline


    Is someone else taking this up and I'm missing something? This seems like a very basic plugin everyone should have, and I'd love to have it!
  17. Offline

    Celtic Minstrel

    It should work more or less as it is. If someone updates it and puts in a pull request, I'll pull it and update the topic, or if someone wants to take over altogether, that's fine too.

    It's true that this is a very basic plugin, but I really think most people shouldn't need most of what it does, either because they have plugins overriding the commands or because the commands are normally restricted to ops for a reason.
  18. Offline


    I have made an update to DefaultPermissions... *drumroll please*

    I have fixed the DefPerms$PlayerOverride issue! Huzzah! Okay, maybe that was a little too celebratory, but either way, it's fixed. Get it here. I want to make a few other changes, then I'll submit a pull request.

    EDIT: Okay I added a few other new things as well. First, it now supports the new aliases for the CraftBukkit commands (/pl, /rl, etc.).

    Also, it now supports Bukkit "superperms". If you want to use it, set "usebukkitpermissions" in the config file to true. The new system means a slightly different config file format, but if you're using the old one, it will auto-convert it for you. Also, if you were using the old format, "usebukkitpermissions" will be set to false by default. Otherwise it'll be set to true.

    The link is still the same, so download away!
    Taranis01 likes this.
  19. Offline


    thanks, but can u tell me why the filesize changed from 5,6kb to 14,5kb? :confused:
  20. Offline


    To be honest, I have no idea. I blame NetBeans: its file compression must suck. Anyway, I recompressed it and now it's considerably smaller. Redownload if you like.

    However, I will point out that a few KB isn't actually all that much...
  21. Offline

    Celtic Minstrel

    Bah, I dislike skipping version numbers... :| ...anyway, I'll get around to pulling this soon.
  22. Offline


    This plugin doesn't work. =[ (using imjak9e's version)

    For one, I don't see it when the server starts up but when I check /plugins it's listed green.

    I've tried using minecraft.* and mincraft.give, minecraft.time, etc but I still cannot use the commands.

    [EDIT] I see the plugin being loaded but still cannot use commands.

    [EDIT2] NEVER MIND! The plugin defaulted to usepluginpermissions to true but I'm still using the other plugin! =D
  23. Offline

    Celtic Minstrel

    Ah, this reminds me that I still haven't pulled imjake's changes. <_< I'll go do that right now the easy way.
  24. Offline


    I have a problem.
    I try to set permission but not klapt.
    can someone help me
    if so drop me a message.
    [email protected] this is my e-mail address
  25. Offline


    Are you going to update to support the new superperms? I really need this plugin.
  26. Offline

    Celtic Minstrel

    Already done, though I think I forgot to update the link. (The alt link is the updated version.)
  27. Offline


    Whenever i try to build, the block just dissapears...:(

    I like to put [creeper] in a [furnace] so i can have [cake]!
  28. Offline


  29. Offline


    The whole reason I got this plugin was to get it so that I do not have to OP people.. but the plugin JUST DOES NOT WORK. I have worldguard, worldedit, permissions, permissionsplus, essentials and this plugin. But it refuses to allow my admins ( who are not opped ) to use the commands I want them to use. I have set to use bukkit commands to true and false. No change. All the commands to intercept are set to true.. I tested it with true and false. no difference. I still get "Your are not permitted to use this command" in red. So its pretty frustrating that there is no example above to see how this looks in the YML file. I have tried both - minecraft.time and - 'minecraft.time' as well as - minecraft.time.set and stuff like this in the permissions file. Nothing .. no changes.. nothing. I take the plugin out and set everyone to OP and everything works like normal. but they still have access to that stupid STOP command. The whole purpose I wanted this plugin was so I don't have to OP people and they cannot use that STOP command which is stupid of Notch to allow that IN GAME in the first place !

    Is there something in one of the other plugins that is preventing this plugin from working ? Or is this plugin a bust ?

    151 recipes
    16 achievements
    11:53:18 [INFO] Starting minecraft server version Beta 1.7.3
    11:53:18 [INFO] Loading properties
    11:53:18 [INFO] Starting Minecraft server on *:25565
    11:53:18 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-958-
    g65a55ba-b1036jnks (MC: 1.7.3)
    11:53:18 [INFO] MLog clients using java 1.4+ standard logging.
    11:53:18 [INFO] [Permissions] (Yeti) was initialized.
    11:53:18 [INFO] [Permissions] version [3.1.6] (Yeti)  loaded
    11:53:18 [INFO] [P2] version 3.2 has been enabled.
    11:53:19 [INFO] [P2Aliases] 1.3 Enabled.
    11:53:19 [INFO] Preparing level "rpgbuilder"
    11:53:19 [INFO] Preparing start region for level 0 (Seed: 6019624344872846482)
    11:53:19 [INFO] Enabled DefaultPermissions v0.3.3
    11:53:19 [INFO] Loaded Essentials build 2.5.6 by [Zenexer, ementalo, Aelux, Bret
    tflan, KimKandor, snowleo, ceulemans, Xeology]
    11:53:19 [INFO] Loaded EssentialsChat build 2.5.6 by essentials team
    11:53:19 [INFO] Loaded EssentialsGeoIP build 2.5.6 by essentials team
    11:53:19 [INFO] This product includes GeoLite data created by MaxMind, available
     from http://www.maxmind.com/.
    11:53:19 [INFO] Initializing c3p0- [built 21-May-2007 15:04:56; debug? tr
    ue; trace: 10]
    11:53:20 [INFO] Loaded EssentialsProtect build 2.5.6 by essentials team
    11:53:20 [INFO] Loaded EssentialsSpawn build 2.5.6 by essentials team
    11:53:20 [INFO] [Permissions] SQL Interface enabled!
    11:53:20 [INFO] WorldEdit 4.6 enabled.
    11:53:20 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin
     for permissions.
    11:53:20 [INFO] WorldGuard: Permissions plugin detected! Using Permissions plugi
    n for permissions.
    11:53:20 [INFO] WorldGuard: Blacklist loaded.
    11:53:20 [INFO] WorldGuard: (rpgbuilder) Single session is enforced.
    11:53:20 [INFO] WorldGuard: (rpgbuilder) TNT ignition is blocked.
    11:53:20 [INFO] WorldGuard: (rpgbuilder) Lighters are PERMITTED.
    11:53:20 [INFO] WorldGuard: (rpgbuilder) Lava fire is blocked.
    11:53:20 [INFO] WorldGuard: (rpgbuilder) Fire spread is UNRESTRICTED.
    11:53:20 [INFO] WorldGuard: Loaded configuration for world 'rpgbuilder"
    11:53:20 [INFO] WorldGuard: Unable to register missing event type SNOW_FORM
    11:53:20 [INFO] WorldGuard 5.2.2 enabled.
    11:53:20 [INFO] Server permissions file permissions.yml is empty, ignoring it
    11:53:20 [INFO] Done (0.109s)! For help, type "help" or "?"
    Here is the startup screen, in case you can see something that I obviously cannot.

    # Permissions has AntiBuild, which prevents a player from destroying/placing blocks.
    # To prevent a group of players then set the build: flag to false (build: false).
    # If you want a group to be able to build then set it to true. 
    # Groups can inherit from other groups.
    #   To make a group inherit the permissions and info nodes from another
    #   group, simply place the groups name in the "inheritance:" like so:
    #   Example:
    #       inheritance:
    #           - Default
    #   Wildcard Permission settings:
    #       You can have wildcard nodes which encompass all nodes that match it.
    #       For example, the node "modplugin.*" matches "modplugin.kick", "modplugin.ban",
    #       "modplugin.settings.view", and so on.
    #   A single asterisk means that this user/group has all permissions.
    #       - '*'
    #   Negated nodes are created by prefixing a normal node with "-".
    #   They prevent less specific wildcard nodes from matching the negated node.
    #   For example:
    #   permissions:
    #       - 'foo.*'
    #       - '-foo.bar'
    #   In this case, the user/group will have "foo.foo", "foo.foobar", and so on, but not "foo.bar".
    #   prefix: and suffix: do not do anything on their own.  You need another outside plugin
    #   such as iChat or HeroChat in order for these to do anything.
    #   For more info, visit https://github.com/TheYeti/Permissions/wiki/Guide-to-creating-YAML-configs
            default: true
                prefix: '[NOOB]'
                suffix: '[/]'
                build: false
                - essentials.afk
                - essentials.back
                - essentials.back.ondeath
                - essentials.help
                - essentials.info
                - essentials.list
                - essentials.mail
                - essentials.mail.send
                - essentials.me
                - essentials.motd
                - essentials.msg
                - essentials.rules
                - essentials.tpaccept
            default: false
                prefix: '[BUILDER]'
                suffix: '[/]'
                build: true
                - Noob
                - essentials.balance
                - essentials.clearinventory
                - essentials.compass
                - essentials.depth
                - essentials.getpos
                - essentials.home
                - essentials.home.others
                - essentials.ignore
                - essentials.kit
                - essentials.nick
                - essentials.pay
                - essentials.ping
                - essentials.protect
                - essentials.seen
                - essentials.sell
                - essentials.sethome
                - essentials.signs.create.protection
                - essentials.signs.create.trade
                - essentials.signs.break.protection
                - essentials.signs.break.trade
                - essentials.signs.use.balance
                - essentials.signs.use.buy
                - essentials.signs.use.disposal
                - essentials.signs.use.free
                - essentials.signs.use.heal
                - essentials.signs.use.mail
                - essentials.signs.use.protection
                - essentials.signs.use.sell
                - essentials.signs.use.trade
                - essentials.signs.use.warp
                - essentials.spawn
                - essentials.tpa
                - essentials.tpahere
                - essentials.tpdeny
                - essentials.warp
                - essentials.warp.list
                - essentials.worth
                - essentials.item
                - minecraft.help
                - minecraft.tp
            default: false
                prefix: '[MOD]'
                suffix: '[/]'
                build: true
                - Builder
                - essentials.helpop
                - essentials.portal
                - essentials.powertool
                - essentials.signs.use.time
                - essentials.signs.use.weather
                - essentials.r
                - essentials.setxmpp
                - essentials.xmpp
                - minecraft.ban
                - minecraft.kick
                - minecraft.time.set
            default: false
                prefix: '[ADMIN]'
                suffix: '[/]'
                build: true
                - Mod
                - minecraft.pardon
                - minecraft.save-off
                - minecraft.plugins
                - minecraft.give
                - minecraft.save-all
                - minecraft.ban-ip
                - minecraft.list
                - minecraft.version
                - minecraft.time
                - minecraft.save-on
                - minecraft.say
                - minecraft.me
                - minecraft.tell
                - minecraft.reload
                - minecraft.pardon-ip
                - minecraft.whitelist
            default: false
                prefix: '[OWNER]'
                suffix: '[/]'
                build: true
                - '*'
    Here is my globalgroups.yml file.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  30. Offline


    I did the alt download link and the other one and I get this same error:

    15:47:21 [INFO] Enabled DefaultPermissions v0.3.3
    15:47:21 [SEVERE] Error occurred while enabling DefaultPermissions v0.3.3 (Is it
     up to date?): com/nijikokun/bukkit/Permissions/Permissions
    java.lang.NoClassDefFoundError: com/nijikokun/bukkit/Permissions/Permissions
            at ca.celticminstrel.permissions.DefPerms.onEnable(DefPerms.java:86)
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:162)
            at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:146
            at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:284)
            at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:271)
            at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:148)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.ClassNotFoundException: com.nijikokun.bukkit.Permissions.Pe
            at java.net.URLClassLoader$1.run(Unknown Source)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.net.URLClassLoader.findClass(Unknown Source)
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.
            at java.lang.ClassLoader.loadClass(Unknown Source)
            at java.lang.ClassLoader.loadClass(Unknown Source)
            ... 11 more
  31. Offline


    After reading this thread again.. I realize that newest bukkit and Permissions is not supported apparently.. it only shows the older version to have worked with this plugin. :/

Share This Page