[INACTIVE][ADMN] BackupPlugin v0.8.8 (Backups & Maps - Fork from MysticX's plugin) [670]

Discussion in 'Inactive/Unsupported Plugins' started by _Oni_, Mar 5, 2011.

  1. Offline


    Version: v0.8.8

    This plugin allows you to create world backups or to generate world maps automatically or via ingame command.
    It's a fork of MysticX's BackupPlugin : http://forums.bukkit.org/threads/895/


    • /backup <force> (optional) - backups your world data
    • /map <force> (optional) - generates map(s) of your world
    • /breload - reloads BackupPlugin configuration file
    • /loglevel <level> - sets log level
    Valid arguments for force are true & false. Using a command with true will result in a forced cache rebuilt, useful if you want to avoid the cache-lifetime for any reason.

    Valid arguments for log level are FINEST, FINE, INFO, WARNING or SEVERE (case sensitive!), default is INFO. FINE & FINEST will generate debug output.
    Valid arguments for time unit are SECONDS, MINUTES, HOURS, DAYS (case sensitive!), default is MINUTES.


    This plugin will generate a properties file in your server home (BackupPlugin.properties)
    Here are two examples:

    Standard properties (0.8.5, I guess) file (for mcmap): here
    MysticX's properties file (0.8.5) (for c10t): here


    My version supports Permissions (from 2.0, if you have a problem with Permissions plugin report this) and GroupManager (1.0)
    • BackupPlugin.backup : for /backup command
    • BackupPlugin.map : for /map command
    • BackupPlugin.admin : for /loglevel and /breload
    Donwload and Source Code
    Download last version
    Source Code

    Show Spoiler

    Version 0.8.8
    • Fix Backup History
    • Improve how calc first run time (could fix some date problem)
    Version 0.8.7
    • Change method to save world in disk before backup/mapping
    • Fix mapping
    • Remove debug option (use loglevel FINEST instead)
    Version 0.8.6
    • Command can use in console server now
    • Try to do save-all before backup and mapping (I have to change this, it's not ok, I think)
    • Add a debug option
    • Cleaning code again
    Version 0.8.5-SNAPSHOT
    • Some fix for recent build of craftbukkit
    • Move from GroupUsers plugin to Permissions plug
    • Move BackupPlugin.properties to plugins/BackupPlugin/config.properties
    • Add a temp-path option to define temp folder for cache
    • Cleaning code

    • Add a multiworld support (WiP)
    PS : I know, I did much copy-paste from MysticX's thread but It was only a fork from his code and I didn't much change, for the moment. ;)
    DiddiZ, MasterMeNL, IndianaX and 2 others like this.
  2. Offline


    This was absolutely lifesaving!
    Call me a philistine, but can you elaborate on the config?
  3. Offline


    Elaborate on the config? What you mean?
    You have 2 examples files for config (in properties section), and the standard properties have comment ;)

    Otherwise sorry, it's around 6 am here, maybe I start to be tired :p
  4. Offline


    Well, i figured it out anyways, but i was referring to what the options do :p
    Can't get the mapping to work though, but i suppose it's the parameters passed to mcmap, so I'll look into that.
  5. Offline


    Well i just tried the newest version here but does not work with the newer versions.

    2011-03-06 00:54:29 [SEVERE] Could not load plugins/BackupPlugin.jar in plugins: null
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:80)
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:129)
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:94)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:59)
        at org.bukkit.craftbukkit.CraftServer.reload(CraftServer.java:205)
        at com.earth2me.essentials.commands.Commandreloadall.run(Commandreloadall.java:27)
        at com.earth2me.essentials.commands.EssentialsCommand.run(EssentialsCommand.java:42)
        at com.earth2me.essentials.Essentials.onCommand(Essentials.java:535)
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:31)
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:80)
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:183)
        at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:619)
        at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:582)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:576)
        at net.minecraft.server.Packet3Chat.a(SourceFile:24)
        at net.minecraft.server.NetworkManager.a(SourceFile:230)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:357)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.lang.NoSuchMethodException: com.mysticx.bukkit.backupplugin.BackupPlugin.<init>()
        at java.lang.Class.getConstructor0(Class.java:2723)
        at java.lang.Class.getConstructor(Class.java:1674)
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:75)
  6. Offline


    Use loglevel FINEST to see what wrong with mcmap ;)
    Which version of Craftbukkit you have?
    Try to redownload BackupPlugin and update Craftbukkit on last recommended build (#493)
  7. Offline


    How do i restore a backup? I'm used to the hmod backup where it would make zip files that actually contained the world.

    So far this is just making small zip files that contain useless txt information....

    OOps... im retarded...

    Still not used to bukkit and how it works. Hmod has a much larger world file similar to single player worlds.
  8. Offline


    Thank you so much for re-doing this plugin, I've been looking for an update for the longest time!
  9. how would I go about configuring this for tectonicus? since it's a .jar do I call it directly, or use java.exe and put -jar pathtotectonicus as the argumentline?
  10. Offline


    Second solution, I think but maybe I need more time to see this... ;)
  11. Offline


    Thank you very much _Oni_. [​IMG] Wonderful work. [​IMG]
  12. Offline


    im brand new to bukkit, can some one help me on how to use this XD soz im really new
  13. Offline


    Thank you for continuing development of this plugin Oni!
  14. thnx! Can't wait for the MultiWorld update :)
  15. i am extremely sad to say that i get this error
    13:31:30 [WARNING] [BackupPlugin]  Failed to parse firstRun, disabled automatic execution
    java.text.ParseException: Unparseable date: "10"
        at java.text.DateFormat.parse(Unknown Source)
        at com.mysticx.bukkit.backupplugin.BackupPlugin.calcNextPointOfTime(BackupPlugin.java:237)
        at com.mysticx.bukkit.backupplugin.BackupPlugin.load(BackupPlugin.java:168)
        at com.mysticx.bukkit.backupplugin.BackupPlugin.onEnable(BackupPlugin.java:77)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:118)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:414)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:187)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:83)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:61)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:204)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:191)
        at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:131)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    This is my most used plugin, so i can't wait to get it back :D
  16. Offline

    Matt L

    I cannot even get this plugin to work on my server. My server refuses to see the BackupPlugin.jar file... I know how to install plugins, have been doing it for months. When i start the server it doesn't load, and when im in game /plugin load BackupPlugin returns cannot find the specified plugin, did you type it right?

    Why is this? To see my current build info, see my post on this page...
  17. Offline


    Have you got an error in server log? Try to redownload plugin could fix it maybe...
  18. Offline

    Matt L

    Tried this and the plugin directly from Mystic, and nothing. The server log is empty, its not even attempting to load it. just says the plugin doesnt exist...
  19. Offline


    Which build of CraftBukkit do you use?
  20. Offline


    I just used this addon and my world is on exept the part i was standing on! Any ways to fix this?
  21. Offline

    Matt L

    it was on my post i linked.

    CB Version : git-Bukkit-0.0.0-493-g8b5496e-b493jnks (MC: 1.3)

    • BorderGuardLit (square) v2.1
    • Essentials build 233
      • Main Jar only
    • HeroChat v4.1.5
    • iSee v0.2
    • ItemId v1.12
    • LWC v1.57
    • MagicCarpet v1.4.3
    • MCBans v2.6.8
    • MinecraftRKitPlugin (remote toolikit for, allows scheduled server restarts and in game commands to restart server. runs minecraft server in a wrapper) v0.31b
    • Minequery v1.5
    • MyHone v1.9.2
    • MyWarp v1.10.3
    • Nether v1.1
    • NoCheat v06.3 (with the following checks: moving speedhack airbuild bedteleport )
    • Permissions v2.5.2
    • SpawnControl v0.6.3
    • TelePlus v1.5.5
    • Vanish v1.5
    • WorldEdit v4.0-beta8
    • WorldGuard v4.0-alpha1
    • Yeditor v1.2
    If you have any questions about my build, let me know!

    Server Specs

    -CentOS 5.5 64bit
    -2 dedicated CPU core
    -30 Gbs of Disk Space
    -3 Gb of Dedicated RAM
    -6 Gb of Swap RAM
    -100 Mbit connection (usually)
  22. Offline


    While it's not in the description, think you could add support for various other plugins that store data, like MCMMO, towny, iconomy and so on, so it backs those up too?

    It'd be pretty neat if ya could :D

    Also, sometime I get an error while the autobackup is running, and it fails to store (But not create) the backup rar, resulting in a 0 mb large file, will post it if it happens again.

    04:59:55 [SEVERE] [BackupPlugin]  Error while zipping temp folder!
    java.util.zip.ZipException: ZIP file must have at least one entry
            at java.util.zip.ZipOutputStream.finish(Unknown Source)
            at java.util.zip.DeflaterOutputStream.close(Unknown Source)
            at java.util.zip.ZipOutputStream.close(Unknown Source)
            at com.mysticx.bukkit.backupplugin.IOHelper.zipDirectory(IOHelper.java:6
            at com.mysticx.bukkit.backupplugin.CacheControl.persistCache(CacheContro
            at com.mysticx.bukkit.backupplugin.BackupUnit.run(BackupUnit.java:61)
            at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
            at java.util.concurrent.FutureTask$Sync.innerRunAndReset(Unknown Source)
            at java.util.concurrent.FutureTask.runAndReset(Unknown Source)
            at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.
    access$101(Unknown Source)
            at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.
    runPeriodic(Unknown Source)
            at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.
    run(Unknown Source)
            at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
            at java.lang.Thread.run(Unknown Source)
    04:59:55 [WARNING] [BackupPlugin]  Backup failed
  23. Offline


    It's look like a wrong value in cofiguration file, can you post this?
    Hummm, maybe I will do a update later
    Sorry, I forget that
    Can you redownload the plug to try... Can you post you server log, maybe I could find a error in this ;)

    It can be a good idea, I see this later (I already start to work on multiworld support :D)
    For the error, I see this later today, if I have time... ;)
  24. Offline

    Matt L

    alright ill post my log here in a sec
    It started working, unbelievable lol. It must have been remote toolkit. That puts a wrapper on the craftbukkit.jar so it can restart the server...
    im not using that anymore...
  25. Offline


    Does this properly do commands in this order now?


    Good to hear someone takes care of this plugin. :)
  26. Offline


    Yes but is not the good way to force save with bukkit API... I need to work about this...
  27. Offline


    any chance other users on the server can be alerted to the fact that a backup is taking place?
    i also attempted to install c10t and it claims to start making a map, but i never get any other notice afterward. no error on "fine" level of logging. is it not working? am i giving up too soon?
  28. Offline


    It's when you do a manualy backup (with /backup), maybe I will add a option for automatic backup ;)
    Otherwise, use FINEST level of logging to see c10t output
  29. Offline


    thanks. i don't know the absolute directory path to a folder on Root as I'm just FTP'ing into a VPS. how do i do relative path? what's it relative to?

    2011-03-08 13:31:29 [WARNING] [BackupPlugin] Disabled MapperUnit, mapper_path invalid: world-maps\c10t-1.6\c10t.exe
    I have in my .properties file (and have /breload'ed)
    where "world-maps" is in root directory where craftbukkit.jar sits. And the c10t file I found I renamed it to include a .exe after. what am I doing wrong?
  30. Offline


    Try with c10t-1.6\\c10t.exe

Share This Page