IllegalStateException: Entity is already tracked!

Discussion in 'Bukkit Help' started by Todrias, Apr 3, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    I'm getting this error on my server, it happens at random:

    [WARNING] Failed to handle packet: java.lang.IllegalStateException: Entity is already tracked!
    java.lang.IllegalStateException: Entity is already tracked!
        at net.minecraft.server.EntityTracker.a(
        at net.minecraft.server.EntityTracker.a(
        at net.minecraft.server.EntityTracker.a(
        at net.minecraft.server.WorldManager.a(
        at net.minecraft.server.World.b(
        at net.minecraft.server.WorldServer.b(
        at net.minecraft.server.World.a(
        at net.minecraft.server.Chunk.d(
        at net.minecraft.server.ChunkProviderServer.c(
        at net.minecraft.server.PlayerInstance.<init>(
        at net.minecraft.server.PlayerManager.a(
        at net.minecraft.server.PlayerManager.c(
        at net.minecraft.server.ServerConfigurationManager.b(
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.Packet10Flying.a(SourceFile:126)
        at net.minecraft.server.NetworkManager.a(
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(
  2. Offline


    Looks like a chunk error! Are you running mine cart mania by any chance?
  3. Offline


    No, i'm not. This started happening after i updated to 1.4.
  4. Offline


    Backup the map you have right now and then create a new one and see If it works on that one.
  5. Offline


    Ok, so I've created a new map, and this keeps happening every once in a while, maybe it's caused by some plugin?

    I'm also getting this message every time my server starts (after loading world): "[INFO] Invalid config file found and converted to proper name/format.", I don't know if it has anything to do with this error, but it happened with every world I used since v1.4.
  6. Offline


    did you update your plugins to 1.4
  7. Offline


    your using permissions 2.5.5 and you didnt rename your config file to match your world name. go to permissions thread and read the set up instructions to get it working properly.

    then search for chunkster and run that on your map and you should be good to go.
  8. Offline


    Of course I updated my plugins to 1.4, they wouldn't be working otherwise. I also renamed mi config file on permissions, but I don't think it has anything to do with this error, and I have also used chunkster but it didn't find any errors.
  9. Offline


    OK, so no errors with chunkster, it throws the same error with a new map, name in config is correct.

    so the only thing to do is fill this out

    then go through the standard admin error protocol, remove all your plugins to vanilla, does the error occur then?

    if it still occurs and with a new map, post a bug report, if it doesn't occur add the plugins in one at a time until you find the one that causes the problem.

    Make sure your java is 1.6.0_24. and oracle not open.

    sorry if this doesn't seem very helpful and if you have already tried all of this and it is still happening all I can say is good luck.
Thread Status:
Not open for further replies.

Share This Page