How to Install Bukkit (Newb-Friendly!)

Discussion in 'Bukkit Help' started by TheArcher, Jan 7, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    The same thing has been happening to me, though it seems like on this thread nobody has replied to help you :p If somebody could it would help more people than just him. Thanks :)
  2. Offline


    Why do we have 1 file on the first page now instead of 2? Just curious because I saw the change.

    Maybe someone could explain to me because i see of their test page where it says the bukkit test is reliant on the craftbucket testing. I read that bukkit is the api? while craftbucket is the wrapper? If someone is bored could they explain this to me? I'm not an idiot just not such a great programmer.
  3. Offline


    Anyone know how to install Bukkit in a server using McMyAdmin? Do I just put it in the addons folder? As that is what I tried, but I think it was outdated at the time, so I will try again once Bukkit and CraftBukkit are updated :D
  4. Offline


    To Install on mac...

    Step 3: follow the linux instructions

    Step 4:
    In Terminal, type:
    "chmod u+x <filepath>"
    So if the the file was on your desktop(and your .sh file is named Server it would be:
    "chmod u+x /Users/<username>/Desktop/Server\"
    what this does is it will allow the owner of the file (you) to run the commands you to execute it.

    Step 5:
    Right click the .sh file, select open with, change the "Enable:" menu from "Recommended Applications" to "All Applications", locate Terminal (its in the Utilities folder) and check the box at the bottom that says "Always open with".
    You can then either make an alias (right click the file, select make Alias) and move that to a convenient location, or you can just drag the file to the right side of the dock and click it from there
  5. Offline


    Wtf No chat commands on final build? or groups or Users lolz or Warps, Home, Sethome ahahaha all those gone =( plz add them in :D
  6. Offline


    Id also like thoese commands...or if there is a list of new commandos ((like loading plugins up without restarting the server...thought that was possible.))
  7. Offline


    what we need here is a fully working bundled package of the server... Anybody want me to do it???
    --- merged: Jan 15, 2011 10:40 AM ---
    ok fully bundled and fully working bukkit server!

    credits in readme and how-to also in readme and you MUST READ THE README!!!!!
    --- merged: Jan 15, 2011 10:40 AM ---
    I hope this helps
    --- merged: Jan 15, 2011 10:42 AM ---
    also I heard there is a new craftbukkit version update if you want; the version I used works fine for me though

    Attached Files:

  8. Offline


    Ok that mac tutorial did not work. 1 when i type chmod then drag my file then type u+x it says Invalid file mode. I dont know what this means, but then i tried typing chmod u+x then draging my file in, and then it just said new host, so i supposed it worked. Then when i went to open it in terminal, it didnt let me, there was no way to click it.
  9. Offline


    cant seem to change the ram allocation for the server. the batch file wont open. just a quick blink and its gone
  10. Offline


    I can't set up my server.
    I have a Debian Root and tryed the Windows and Linux way...
    On Linux i always get this error:
  11. Offline


    You don't need Bukkit to run a server, just CraftBukkit. Therefore, I removed the Bukkit download.

    You have to be more specific if you want help.
  12. Offline


    I had the same problem with changing the memory so I will explain.

    On the notepad file that we copy and paste depending on os, where is says the 1024, I changed that to double in both places then saved. Tried to run server and the batch file just blinks then goes away. Changed it back no problems. Is this the correct place to set the designated memory and if so what gives. I have 4 gb of memory installed and tried setting it to 2048.
    --- merged: Jan 15, 2011 6:23 PM ---
    @Archer, thanks for the reply, I figured out what the Bukkit and craftbukkit are. Just took all night reading forums but now I understand most of it, maybe enough I can start doing some mods as well.
  13. Offline


    i went in to the xms and xmx lines and changed them to 2048, then tried xms 1024 and xmx 2048.
    clicking the serverstart.bat no longer starts the server as long as those arent both set to 1024. the command screen will blink on for a second then immediately close. I dont get any errors...nothing. just closes. am i just really dumb and missing something obvious here?
  14. Offline


    Any reason why I am getting :permission denied. in linux?
  15. Offline


    You do not have enough RAM.
  16. Offline


    i have 10 gigs -.-
  17. Offline


    add pause or stop to the bottom of the text

    @echo off
    Java -Xms12288M -Xmx12288M -jar craftbukkit-0.0.1-SNAPSHOT.jar

    That way we can see what is wrong with it.

    my guess is that you renamed the craftbukkit-0.0.1-SNAPSHOT.jar or are allocation too much ram to Java.
    The maximum amount of RAM 32 bit Java can use is 1.5GB i think. If you have a 64 bit computer make sure you are using 64 bit Java.
    --- merged: Jan 15, 2011 8:30 PM ---
    You're not using 64 bit java. I have 16 gigs

    Change your directory location to

    C:\Program Files\Java\jre6\bin\java.exe
  18. Offline


    at step 3, when i make bat file it just disapear when i double click on it, i copy/paste like this for x64

    @echo off
    "%ProgramFiles(x86)%\Java\jre6\bin\java.exe" -Xms1024M -Xmx1024M -jar craftbukkit-0.0.1-SNAPSHOT.jar nogui
  19. Offline


    Hi, Im using windows 7 and did everything i was spossed to, I followed the directions. But it comes up as a vanilla server? I get an error that says "The exeption was: Address already in use: JUM_bind
    Perhaps a server is already running in that port"

    ??? I can connect, however its vanilla and no commands work. Plz help?
  20. Offline


    so i did all this and i have some plugins but that shouldn't affect anything, in my in the line of ip address what do i put there? because my friends cant log into my server, it says cannot connect, my port (25565) is forwarded so >< im so confused. thanks in advance
  21. Offline


    just use this its easier

    @echo off
    "%ProgramFiles(x86)%\Java\jre6\bin\java.exe" -Xms1024M -Xmx1024M -jar craftbukkit-0.0.1-SNAPSHOT.jar

    @echo off
    java -Xms1024M -Xmx1024M -jar craftbukkit-0.0.1-SNAPSHOT.jar nogui
  22. Offline


  23. Offline


    Yes, I know there are instances like that, and I even ran into one myself (when working on a small side project). I also realize that the need to run 32-bit binaries on 64-bit systems is largely constrained to server and business networking environments. For an average end user who just wants to play minecraft though, they don't need to worry about that. My point was that Windows somewhat forces them to worry about that since a lot of the programs are still only 32-bit (being closed source in nature tends to slow down development in most cases).

    On a side note, I've used Xen on my servers, and Virtual Box on my clients (window and Linux) for my VM needs, and I've had no problems. Though Virtual Box will only run 64-bit OSes when the computer supports hardware virtualization.

    Yes, my tutorial was heavily biased against windows, possibly to the extent of making me look like a fanboy. However, I'll state that since moving to Linux, my frustration with Windows not being able to do it's job properly and consistently is rising quite steadily on a daily basis. Managing a small network of Windows machines with a CentOS server and Windows Server 2008 running in a Xen VM has only served to increase my animosity.
    The lone Ubuntu machine on that network never has problems. Ever. The windows machines, on the other hand, I have to fight on an almost daily basis.

    I did tone down the tutorial a bit, but maybe I'll do it some more.
  24. Offline


    I've recently been having problems getting my plugin commands to work. Everything worked fine using older builds (11, 12), but now, using the jar posted in the first post, I am getting the error
    *Or Teleplus, or MyHome, or General
    Does anyone know what is causing this, or how i could fix it?
  25. Offline


    i can't use any commands, i type them in, but they don't do anything, i have tried with alot of plugins, some released today and reported to be working, please help me, i followed everything step by step
  26. Offline


    Sheesh why do ppl keep on reposting my Hmod recycled code? No offense
  27. Offline


    So, why is Bukkit so much more confusing and hard to use then hMod ever was.. I completely disagree with the "ease of use" that was advertised. >.>
  28. Offline


    Yea, sorry I typed that wrong it is chmod u+x <filepath> !!!
    And to open it with terminal, change the drop down menu from "Recommended Applications" to "All applications"

    edited the post, sorry for the errors!!!
  29. Offline


    First of all, thanks for the server and the tutorial. But my problem is:
    I'm getting the following error:


    WTF am I doing wrong? Seriously I followed every single one of your steps.
  30. Offline


    Quick question. If I were to download build #33, which BUKKITMAIN would I have to use ?
Thread Status:
Not open for further replies.

Share This Page