How to Install Bukkit (Newb-Friendly!)

Discussion in 'Bukkit Help' started by TheArcher, Jan 7, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    uhh i feel stupid.. when it says do you want to update? (y/n) I put y and it says it doesnt understand and assume it means no. I opened up the script and it says if UPDATE ==y or UPDATE ==Y then activate the update script. I tried it in caps too, it just doesnt work. Im on mac btw
  2. Offline


    First off, you don't have to quote the entire thread to reply. It's a waste of space. Second, you don't need to fill out surveys. If it says you need to do one, refresh the page and wait to press the "Skip Ad" button.

    You didn't read the "Read Me" file. It clearly says to first download the CraftBukkit .jar file then click on "CraftBukkit Starter".
  3. links are not allowed on
  4. Offline


    Nod.32 blocks the url... it's says is something harmfull for my computer
  5. Offline


    It's a false positive. There aren't any viruses/trojans/adware of any kind. I'm not sure why I should even need to say this, don't you think that it would be safe if 25 pages of people before you didn't have trouble with it?
  6. Offline


    3 things,

    !st, Love the idea awesome!
    2nd, the mac osx launcher is broken becuase #'s where used instead of $'s to compare variables.
    3rd, could you add features such as seed input, whether to turn on or off nether, monsters, and animals, world name, max players, and just about everything else in the

  7. Offline


    Thanks for the feedback. PierreLouis manages the Mac OS X download, please take it up with him. As for all of the options, you can easily configure those in the server's .properties file as soon as you follow the instructions for your respective setup. Besides, I'd rather keep the downloads as small as possible.
  8. Offline


    Says cant locate C:users/tom/desktop/CraftBucket/craftbucket-0.0.1snapshot.jar
  9. Offline


    I am trying to download this so that we can use our single player commands on the server, but no matter how many times I click the link, I get the AdFly page with a survey, I've done it over 100 times tonight, and that is all I get. Could I please get a direct download link? I'm not going to fill out a spam survey just to install this, I'm not sure why it is only linking me to survey pages.
  10. Offline


    just skip add or if u have team viwer i can give it
  11. Offline


    it wouldn't let me skip the add lol. it was giving me the survey one. but I finally got it resolved :)
  12. Offline


    nvm now it cant acess
  13. Offline


    Hello, I've set up my server. I can't access it though. I put :25565 in the ip address, is that wrong? It always says "Bad Login". I am also using Windows Vista
  14. Offline


    Same problem here, It says "25565" for me too... mabye it's the wrong ip... ?
    But then what's the right ip?
  15. Offline


    I am on a Mac. When I try to run it, it says: The file “Mac OS X CraftBukkit Setup.command” could not be executed because you do not have appropriate access privileges. To view or change access privileges, select the file in the Finder and choose File > Get Info.

    I have changed the settings to public and stuff and it still won't work. I am the admin on my computer. How can I fix this?
  16. Offline


    Make sure the CraftBukkit .jar is downloaded and put into the same folder as the .bat file.

    To access your server, you can either type in "localhost", "", or the IP the server is running on (found here).

    Please refer to the post below me.
  17. Offline


    Looks like my post from yesterday isn't here anymore...
    Sometimes Mac OS X breaks permissions on batch files, this pops up:

    If you have that problem, follow these easy steps:
    • Please open, and paste:
    chmod 777 
    (with a space after 777).
    • Drag and drop the installer, and press enter.

    Now everyone can read and right on the installer... That includes you. Please try to install again.
  18. Offline


    Thank you PierreLouis :)
    But can anyone tell me please why updating isn't working for me? I'm on a Mac and when I press y/Y or any other letter nothing happens... I have to press enter to get to the next step and regardless of what letter I have entered I get the message "Did not recognize input. Input assumed as No."
    I reinstalled and checked all the stuff but it still doesn't work. Everything else works fine. (Thanks btw)
  19. Offline


    Hey bukkit people i had a regular server up without any mod or anything and i wanted to put some in so i download this i got eveything working but i wanted to transfer my pervious world into the new server but the files are differant is there something i can do cause it isnt working when i just move it over
  20. Offline


    I installed the .jar file and made the .bat file. Everything seems to work, but when I try to connect it says "bad login." Please help. I don't know what this means.
  21. Offline


    If you want to transfer over your world, copy the "world" (or whatever the "world" folder was renamed to) into the new server directory. If there is already a world file be sure to delete it first.

    Please search before asking what may be a common problem.
  22. Offline


    I am running on Mac OS X Lion. I downloaded your Bukkit installer and it is running nicely, but when it asks me to update i press "y" and enter. It then tells me that it doesn't recognize the input and it wont update. What do I do?
  23. Offline


    Download the new Mac OS X CraftBukkit setup and try again. :cool:
  24. Offline


    Well, I don't wanna be annoying but the problem remains...
    Btw, the Readme.txt is empty.
    And like Alxzter, I am also running Mac OS X Lion.
  25. Offline


    Mac OS X Setup fixed...again.
  26. Offline


    The LaunchServer.command in the Mac OS X setup is incorrect in the parameters of the choices. You need to have $UPDATE instead of %UPDATE since it's using Unix, not DOS / batch. So in the instructions I do believe you'd need to tell the user to replace all #'s with $'s. I do not own a Mac OS X myself, but I found out while remoting into one for support purposes of helping out with a Bukkit server that it was not recognizing any input because of this error.
    Degi3000 likes this.
  27. Offline


    I've just made a major update to the thread and all of the setups. The problem should be fixed for the last time, hopefully.
  28. Offline


    whenever i try to go to the download for craftbukkit it says "the system could not find the file specified" and it does the same thing when i move the starter to a folder, so i cant really do anything. :(
  29. Offline


    this is the only thing i ever use when i want to set up a local server! and i always delete it! and i always have to find the bugfixes but then it works!

  30. Offline


    @TheArcher links are banned, didn't you know? I'd suggest you remove yours before a moderator deletes your entire post
Thread Status:
Not open for further replies.

Share This Page