How to Install Bukkit (Newb-Friendly!)

Discussion in 'Bukkit Help' started by TheArcher, Jan 7, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    XD lol. Imputing: Yes, YES, Y, and yes, don't work?
  2. Offline


    ok so i got this up and running, but i cannot get anyone to join the dam server and im starting to get a little bit annoyed, and ive port forwarded too :mad: any help people?
  3. Offline


    Start a conversation maybe I can help :)
  4. Offline


    i could help by testing
    Do you know the right IP, its different outside your house.
  5. Offline


    I'm 99% sure I did something wrong, and I have no idea how to rectify the issue: there is no craftbukkit.jar or craftbukkit-0.0.1-snapshot.jar file anywhere (and nothing with Search).


    I followed the Read Me file. I tried the RUN.bat multiple times to no avail - I get the "Unable to access jarfile (etc etc)". The RUN.bat was with all the files in the screenshot; I deleted it. I have tried redownloading, but I get the same result.

    Are all the folders shown in my screenshot meant to be in the .jar file?

    The location of the files has all permissions granted. (Or should it be with the server files? I'd rather not have a lot of things there since the computer does not have a lot of memory (10GB available of 38.2), hence the use of the external hard drive.)

    I might be just a little confused.
  6. Offline


    Redownload, and try again. It should be fixed.

  7. Offline


    It clearly says in the "Read Me" to click on "Latest CraftBukkit Download" and download the CraftBukkit .jar file to the folder with the "CraftBukkit Starter". You must not have followed the Read Me as well as you thought you did. :)
  8. Offline


    Ah, I see what I was doing wrong. I was extracting the .jar file to the folder instead of just placing it there. Facepalm of the day. Thank you for your help. :)
  9. Offline


    When I click this link I get taken to some desktop wallpaper website!
  10. Offline


    Any time, just make sure that you follow the instructions carefully before asking for help.

    Did you press "Skip Ad" in the top right corner when it loaded?
  11. Offline


    Nope. I have add blocker. I didn't see any add. Just some website with wall-papers. Perhaps the file links should be pointed to a more download friendly location. Just a thought.
  12. Offline


    After clicking on the link, all you have to do is wait five seconds before clicking on "Skip Ad" and going directly to the download. If you can't figure that out...well, I'm afraid I can't help you as much as I want to.

    Oh, and you may want to change "add" to "ad". They aren't called "addvertisements". :D
  13. Offline


    The title of the post is NEWB FRIENDLY. If you have to give people instructions on how to figure out how to download it .. it's NOT friendly!!

    Oh, and thanks for teh speling leson.
  14. Offline


    You should say "Thanks for the spelling lesson.
  15. Offline


    I'm trying my best to help you out but you're the only one who has been unable to comprehend such simple instructions.
  16. Offline


    HELP whenever I launch the Mac OS X CraftBukkit Setup.Command I'm admin and have no idea why this is happening " The file Mac OS X CraftBukkit Setup.command could not be executed because you do not have appropriate access privileges

    never mind I got it needed the good ol chmod 755

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  17. Offline


    It said outdated. what did i do wrong. im on a windows vista and a 32 bit
    kirie63 likes this.
  18. Offline


    "The file Mac OS X CraftBukkit Setup.command could not be executed because you do not have appropriate access privileges" I keep getting this. Can anyone help?

    I have Mac OS X 10.6.8 and I had an older version of this but I wanted to update it and now it doesn't work.
  19. Offline


    Wait a few hours, than update your CraftBukkit .jar and try again.
  20. Offline


    I put the starter file and the .jar in the same folder but the batch file does absolutely nothing. No error message, just nothing. I'm running 64 bit windows 7.

  21. Offline


    when is the update coming? :)
  22. Offline


    Hi people, I have a problem on The installation of Bukkit on my mac, I have downloaded the latest build, i have registered a command file: java -Xms1024M -Xmx1024M -jar craftbukkit.jar and the console say that:
    /Users/antoinodj/Desktop/Bukkit\ Server/Starter.command ; exit;
    iMac-di-antoinodj:~ antoinodj$ /Users/antoinodj/Desktop/Bukkit\ Server/Starter.command ; exit;
    Unable to access jarfile craftbukkit.jar

    [Processo completato]

    What i've to do???

    Problem Solved

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  23. Offline


    Okay, here's the deal. I have installed Bukkit successfully. The CraftBukkit Starter works fine, it opens up and tells me the spawn location is working and all that. But when I try to connect to the server I just made, it constantly comes up with the message 'Connection timed out: Connect'.

    Is there something I'm doing wrong? I have port forwarded, I have even gone into my firewall and allowed the ports there.

    (Just looked at that 'what we need to know' sticky, so heres some more info)

    - I am running Windows 7 64-bit
    - I am using the latest version of CraftBukkit
    - I am on version 1.7.2 of Minecraft

    Comment if you need more info.

    Help please!


    Taken from my thread...
  24. Offline


    Try right clicking and pressing "Open". If it still does nothing, send me a personal message.

    When it's done. :)

    I am not directly involved in the CraftBukkit development process, though.

    I believe that it is a Minecraft bug. It has happened to me as well, I usually just continue reconnecting until it works. If that doesn't fix the problem, I restart the server and try to connect again.
  25. Offline


    I have tried what you said multiple times, nothing has worked.
  26. Offline


    Are you sure the port you chose is forwarded? Have you tried updating CraftBukkit?
  27. Offline


    When ever i try to open "Mac OS X CraftBukkit Setup.command" it says: The file “Mac OS X CraftBukkit Setup.command” could not be executed because you do not have appropriate access privileges.
    Please help. Oh, and I'm not very good with computers. I've done this once before but I forgot how.
  28. Offline


    uhm... why are the links make me do surveys? ive done like 4 surveys now and it never unlocks!!!
  29. Offline


    hey, i downloaded the newest version, but clicking on it does nothing, and i dont know what to do, im probably making a stupid mistake, but im honestly lost

    the name of the file i downloaded is 'craftbukkit-0.0.1-SNAPSHOT.jar'

    i use windows 7 64 bit
  30. Offline


    ok ill try it thank you
Thread Status:
Not open for further replies.

Share This Page