How to Install Bukkit (Newb-Friendly!)

Discussion in 'Bukkit Help' started by TheArcher, Jan 7, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Hm, I must have messed up the mac updater... in the meantime simply download the 1.5 server jar from
  2. Offline


    ya, but then i cant get the bukket mods :( oh well. do you think its something i might have done wrong or not had, or a problem with the thing itself?

    Oh I must have, ok


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  3. Offline


    Oh wait, Bukkit hasn't been updated to 1.5 yet I don't think...
  4. Offline


    oh that makes so much more sense now. thanks for the help, I might have just given up on it in general if not for the feedback. haha, I've had a bad history with hosting servers
  5. Offline


    Yeah, stay on 1.4 for the time being.

    1.5 is apparently pretty buggy so the Bukkit devs are hesitant to release a build until the imminent 1.5_01 patch is released by Mojang.

    Any players on your server will need to downgrade their clients as well, if they've updated. So I hope they backed up their old 1.4 jar.
  6. Offline


    Ok, so bukkit updated to 1.5, but when i updated mine, it still said running beta 1.4, and after it loaded it said
    08:35:29 [WARNING] The exception was: Address already in use
    08:35:29 [WARNING] Perhaps a server is already running on that port?
    I dont get it, I closed out of the server first.

    Oh, wait, nevermind, it says its done but not yet ready, but that still doesnt explain why it says im using another server when im not....

    ok, so now it doesnt say the old error message, it doesnt even open the server, it just says invalid maximum heap size no matter what i put into the spot for that.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  7. Offline


    It's not finished yet, but it's downloading the latest version of it for you.
  8. Offline


    Dude your links aren't working...
  9. Offline


    I'm mad T_T first i had the Hmod + Hamachi= worked (only when i start Mincraft_Server.exe from but cound't install plugins...
    Now, I install CraftBukkit+ Hamachi= still only work with the .exe Server BUT when I CraftBukkit Starter it "install" my plugins but when i want to connect it crash!
    any help? I'm really at my end...
  10. Offline


    I saw the same error when users running 1.5 tried to connect to my 1.4 server. Bukkit hasn't been updated to 1.5 OFFICIALLY yet, so I suggest waiting to prevent world-melting consequences.
  11. Offline


    i tried to use the server and this happened....
    /Users/deladieralmeida/Desktop/Bukkit\ Server/LaunchServer.command ; exit;
    Error occurred during initialization of VM
    Could not reserve enough space for object heap
    Could not create the Java virtual machine.

    [Process completed]

    Any help?
  12. Offline


    Once you have set up the server how do you find out what ip address to give to someone so they can join ? [cake]
  13. Offline


    it says "unable to access jarfile C:\Windows\system....craftbukkit-0.0.1-snapshot.jar.
    i am probably doing something really stupid here, but its not really working. And i need help.
  14. Offline


    you can find out your ip just by theying "my ip" into google and click on one of the top links.

    i have one question tho it followed the guid and all is well but once i run the starter i get

    "perhaps a server is already running on that port?"

    well i do host a privet server for my friends but how can i get this to work. i understand it gets anoying answering peoples questions, so id be grateful if you could take the time to answer myn. thankyou.
  15. Offline


    I just attempted to start a server, and followed the directions of the setup to a tee, have ports forwarded, all that. When I try to access the server in the Minecraft client I get the following error over and over and over again:

    internal exception: Read timed out

    without even actually getting into the game. I also asked someone outside of my IP/network to try and access the server and they got a "Connection Lost - End of stream" error before actually being able to get into the game as well.

    I had an old version of the client and decided to get the newest version, also have the most up-to-date version of Java for Mac. Still didn't work after updating the client.

    General System information
    What operating system are you running? Mac OSX 10.6.7
    Are you running a 64 bit or 32 bit version of your OS? 32 bit
    What version of Java are you running (java -version)? 13.4.0
    How much RAM do you have on the system? 8gb (2gb x 4)
    What are the specs of your CPU? Intel Core i5, 3.6 GHz
    What video card do you have? ATI Radeon HD 5670
    What video card drivers are you using? none, as far as I know
    What network card do you have? Airport, I guess?
    What network card drivers are you using? none, as far as I know
    What firewall or other security software is running? none
    Are you directly connected to your router or on a network? on a network
    Are you playing the game via a wireless (WiFi) or wired connection? wireless, and will be running the server wirelessly as well
    What is your ISP? Time Warner

    Minecraft Client Information
    What version of Minecraft are you running? 1.5_01
    Are you running Minecraft through the browser or directly on your computer? computer client
    Are you using any client mods (if so, list them and their versions)? no
    What action were you performing in game when the error occurred? attempting to log into my server
    Do you still have these problems when you run Minecraft without any mods? N/A (or rather, yes)
  16. Offline


    If you're looking for help, you're going to need to provide much more information than that. What is your operating system? How much RAM do you have? This is a good, general template that lists information I may need, so try to use it whenever you have a problem.

    As "sillylewis" states, there are plenty of sites that help you find your IP. I tend to use this one.

    That answer usually comes up when you have more than one server running on your computer (perhaps you started the Minecraft server twice accidentally?). Otherwise, the simple solution is to change your port.

    Thank you for all of that information, but the simple answer is that the Mac OS X setup was dysfunctional. Please re-download the setup and try again.
  17. Offline


    The file “Mac OS X Setup.command” could not be executed because you do not have appropriate access privileges.
    this message comes when i try to open it.
  18. Offline


    <Edit by Moderator: Redacted mediafire url>
    -Back to my version! :p
    -Makes you OP/Admin
    -Better updater (doesn't update when you aren't connected to the internet)

    Try again with my link!
    Last edited by a moderator: Dec 15, 2016
  19. Offline


    YAY thx for the newb friendly download I is a newb
  20. Offline


    I just made a tool recently that will get you up an going within a minute. It downloads the latest CraftBukkit build and includes an updater. It is for Windows only right now. Come check it out please!
  21. Offline


    Its probably in plain sight, but it would be nice if someone could direct me to the updater for Mac OSX? The Wiki said there was an updater for Mac...
  22. Offline


    I would have no clue. I don't have any computer to program for MAC.
  23. Offline


    When installing with this, you get an updater.
  24. Offline


    So if I run the installer for Mac, it'll act as an updater?
  25. Offline


    Im getting this error, and don't know how to fix it:

            at net.minecraft.server.StatisticCollector.<clinit>(SourceFile:5)
            at net.minecraft.server.StatisticList.<clinit>(SourceFile:31)
            at net.minecraft.server.MinecraftServer.main(
            at org.bukkit.craftbukkit.Main.main(
    Caused by: java.lang.NullPointerException
            at java.util.Properties$LineReader.readLine(Unknown Source)
            at java.util.Properties.load0(Unknown Source)
            at java.util.Properties.load(Unknown Source)
            at net.minecraft.server.StatisticStorage.<init>(SourceFile:17)
            at net.minecraft.server.StatisticStorage.<clinit>(SourceFile:8)
            ... 4 more
    Press any key to continue . . .
    How do I fix it?
  26. Offline


    I would love to help you, but please go here first.
  27. Offline


    No, when installing, it makes you an updater.
    If you would like to use it, make a new server with this script, and move your server's files to "Bukkit Server" on your desktop.
    Then the updater should work!
  28. Offline


    Ok so when i click LaunchServer.command i get this:

  29. Offline


    That's because you need to remove the % signs if you edit the MB value.
  30. Offline


    im having an issue with it saying server overloaded has time changed this is the bat commands using to launch @ECHO OFF
    SET BINDIR=%~dp0
    CD /D "%BINDIR%"
    "%ProgramFiles%\Java\jre6\bin\java.exe" -Xincgc -Xmx1G -jar craftbukkit-0.0.1-SNAPSHOT.jar
    is there away to specify how much memory to use that i can insert into this to make it force the ram amount to use ?
Thread Status:
Not open for further replies.

Share This Page