How to Install Bukkit (Newb-Friendly!)

Discussion in 'Bukkit Help' started by TheArcher, Jan 7, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    The download links are back up! Also, I've updated the header.

    Edit: I've done a lot of changes (the link the amazing header I created broke :() including monetizing all links (they will show an advertisement for a few seconds). All feedback is appreciated.
  3. Offline


    help me i followed all the steps but got this error:
    Unable to access jarfile C:\Users\CAL(AD~1\AppData\Local\Temp\Rar$DI42.672\craft
    Press any key to continue . . .
  4. Offline


    Make sure the CraftBukkit .jar file is in the same folder as the .bat file and named, exactly, "craftbukkit-0.0.1-SNAPSHOT.jar".
  5. Offline


    thanks ill do it over my holiday!!!! cya dudes be back in 5 days
  6. Offline


    i did not get any instructions at all. it just opened to terminal and that is all it did.
  7. Offline


    Please provide more information than that. Are you using Mac OS X or Linux? How did you open the file?

    While you may not know it, by simply clicking on the links in the thread you are supporting me. Thank you for your support, it is much appreciated and encourages me to keep this thread updated (however I would keep it so nevertheless).
  8. Offline


    got this error...again and i put the starter and craftbukkit into the craftbukkit setup/craftbukkit:
    Unable to access jarfile C:\Users\CAL(AD~1\AppData\Local\Temp\Rar$DI44.920\craft
    Press any key to continue . . .
  9. Offline


    Please post a picture of the inside of your folder.
  10. Offline


    That sounds to me like they didn't un-rar the file. Try extracting the files to a folder.
  11. Offline


    dw i fixed it i moved craftbukkit... to appdata/local/temp/rar$DI44.920

    but now how do i log on to my server? i dont know how to port forward D:
  12. Offline


    First, start the server. Once it is running, start up Minecraft and select "Multiplayer". In the box, type either "localhost" or "". If it doesn't work, you probably haven't portforwarded. In that case, let me google that for you.
  13. Offline


    Yeah sorry about that >.< I got frustrated and it was quite late.

    I use a mac running Mac OS X.

    At first it did not let me open the file, so then I went to Get Info and opened it with text edit. I have a hard time understand how to read the file (most likely because of my low level of computer language skills?)

    I already installed CB, but I do not think I have the latest one. Also I see there is an updater on here so I was planning to re-tackle this once again. Though as I am saying, I am having a hard time to read the file.
  14. Offline


    Alright I need some help I am running on a Mac OS X and when I try to run my server it says
    Last login: Sat Apr 16 17:55:16 on ttys000
    /Users/lmcanfield/Desktop/Bukkit\ Server/LaunchServer.command ; exit;
    Michelle-Canfields-iMac:~ lmcanfield$ /Users/lmcanfield/Desktop/Bukkit\ Server/LaunchServer.command ; exit;
    Invalid maximum heap size: -Xmx[1024]M
    Could not create the Java virtual machine.

    [Process completed]
    My older version (617) works fine but 677 keeps giving me this error. Can anyone help me out here?
  15. Offline


    It appears as though there is a lot of trouble with the Mac OS X setup. I've switching the setup to Sunlis'.
  16. Offline



    Whenever I try to download the Mac OS X Version, I get the following error:
    Screen shot 2011-04-19 at 16.41.50.png

    Does anybody know how to solve this? Sorry if this has been posted before.

    Thanks in advance!

    PS: I have looked in the 'Get Info' screen, but it said I had all privileges (read & write). I even tried opening it with TextEdit and make it into a .command file myself.

    Attached Files:

  17. Offline

    Captain Seasick

    I honestly only have three complaints so far.

    First off, the general pace at which updates to the server-files are produced is painstakingly slow. Oftentimes, I end up having to shut down my own server for days on end until the new files can be properly installed.

    Second, the link to the Windows setup file does not work/has not worked for me for some time. It simply bounces me off to some damned advertisement site. And no, there is no "Skip this ad" button. I have no idea what's up with this one, really.

    And last but not least... Well, this is mainly a general grumble of discontentment, rather than an actual complaint; there seems to be no GOOD way of accessing a list of the available in-game commands. The /help-function in-game only lists a partial amount of the commands available, much to my own dismay.

    Other than these three, and the fact that the basic non-plugin modified version of a server barely seems any different whatsoever from a regular, vanilla server in terms of basic customizability and performance, CraftBukkit is great!

    EDIT: I realize now that this might not've been the best place to offer my criticism in... But eh, whatever works, I suppose.
  18. Offline


    Make sure you are using an account with administrative priviledges.

    I'm simply providing a tutorial for the software, I have not actually personally developed it. However, I am a bit experienced.

    What server files are you talking about? You have to be specific. Are the server files you are talking about the ones that appear when you first start up the server and it produces all of the files such as "ops" and "server"? This process if very fast and should never take more than a few seconds. This means that your computer is most certainly at fault (or you just didn't properly assign your RAM).

    The setup downloads are working fine, upon clicking them you are sent to a page where you wait for five seconds before a large, yellow, "SKIP AD" button comes up in the top-right. If you've waited five seconds and it still hasn't appeared, it may be your browser.

    As for the commands, had you read my "Read Me" thoroughly you would have realized that you can access plugins that provide additional commands (it even had a link to the plugin section). I can name three off of the top of my head: Essentials, General, and PlgEssentials. CraftBukkit itself is meant to be as bare-bones as possible for the people that want it that way. It's fully customizable, all of the functionality you need is found in the plugins you choose.

    It's obvious that you are new to CraftBukkit. I'm happy to help newbies, but try to get at least some knowledge of how the server works before blaming the developers (or me). Hope you have a nice stay at the forum.
  19. Offline


    you might want to update your download links. files deleted!
    SH00X likes this.
  20. Offline


    Yes please update the links :)
  21. Offline


    If you read my post, you'd see that I háve administrative privileges. I have only one account on this Mac and it's an administrator. Screen shot 2011-04-20 at 19.49.45.png
  22. Offline


    when i run the batch file it cannot find the directory, the trick to mine is i have multiple harddrives and the server software is in one, java is installed on another, my OS drive with java is on "C" and im running the server on "G"
    im not sure how to tell it this in the batch file

    here is what it currently has
    SET BINDIR=%~dp0
    CD /D "%BINDIR%"
    "%ProgramFiles%(x86)\Java\jrex7\bin\java.exe" -Xincgc -Xmx1G -jar craftbukkit-0.0.1-SNAPSHOT.jar
  23. Offline


    It seems that the execute permissions have been screwed up somehow. Launch Terminal and type (without the quotes): "chmod +x " (notice the space at the end) then drag and drop the setup file onto the Terminal window and hit enter. You should now be able to open the command file.

    Screenshots (open)
    Screen shot 2011-04-20 at 5.00.05 PM.png Screen shot 2011-04-20 at 5.00.26 PM.png Screen shot 2011-04-20 at 5.00.43 PM.png

    EDIT: Alternatively,
  24. Offline


    Nowhere on your post did it say anything about being an administrator. You may want to be sure you've read your post before complaining about how you think I haven't read it.

    Follow Sunlis' advice to solve your problem. Next time, if you want help, please be more polite. Otherwise, your post will be ignored.

    @Sunlis I've added you to the Credits and uploaded your Mac OS X CraftBukkit setup (with some minor changes). Thanks!
  25. Offline


    If you could fix the spelling that would be great. ;)
  26. Offline


    not realy norton is one of the best anyway i tried a virus scanner on the internet and they scanned it
    and it still said its a virus so
    also i tried to scan it with windows defender
  27. Offline


    Thanks to you both, Sunlis & TheArcher! Sorry if it looked like I wasn't polite; I didn't mean to be. :)

    EDIT: I've also stumbled upon a problem! Whenever I run the application, it doesn't create the folder in the desktop like it should, and therefore just throws the files on the desktop. When opening the code with TextEdit, I see:

    if [ -d "Bukkit Server" ] ; then
    mkdir "Bukkit Server"

    which is clearly what creates the folder. I don't know much of the language, so could you have a look at this?

  28. Offline


    Ok, downloads work again but when i run the starter with latest build i get this error in command prompt

    java.lang.UnsatisfiedLinkError: C:\Users\Orion\AppData\Local\Temp\jline_git-Bukk
    it-0_0_0-659-gc210f22-b684jnks.dll: Can't load AMD 64-bit .dll on a IA 32-bit pl
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    at java.lang.ClassLoader.loadLibrary0(Unknown Source)
    at java.lang.ClassLoader.loadLibrary(Unknown Source)
    at java.lang.Runtime.load0(Unknown Source)
    at java.lang.System.load(Unknown Source)
    at jline.WindowsTerminal.loadLibrary(
    at jline.WindowsTerminal.initializeTerminal(
    at jline.Terminal.setupTerminal(
    at jline.Terminal.getTerminal(
    at jline.ConsoleReader.<init>(
    at jline.ConsoleReader.<init>(
    at jline.ConsoleReader.<init>(
    at net.minecraft.server.MinecraftServer.<init>(
    at net.minecraft.server.MinecraftServer.main(
    at org.bukkit.craftbukkit.Main.main(
    Press any key to continue . . .

    when i hit a key it just closes
  29. Offline

    Captain Seasick

    While my computer is as far from the best available as it can be, it's not the particular creation of the server files upon running the software the first time, but rather updates to the CraftBukkit files themselves, i.e. server version, which is "at fault". As far as I can tell, I am still only able to run 1.4, while Minecraft itself has been using 1.5 for a good few days by now. I'm not sure if this is to be blamed on the developers of CB itself, or the fact that whatever servers the initial files are hosted upon are just painfully slow/unreliable, but it's a major "turn-off" for me when it comes to using CB.

    As I said before, I have no idea what's up with this one! Whenever I try to go for the Windows Install files, I end up getting shipped off to some site which advertises for restaurants or whatnot... It's a lesser nuisance, as I've still got the setup .exe file saved on my harddrive. The only reason I mentioned it was/is because someone else might've had or still have the same issue.

    I know about the fact that CraftBukkit is compatible with a veritable plethora of plugins by now, some bad, some good, and some in-between that. But the fact remains that the basic in-game commands (such as adding/giving items, changing the time of day, etc.) aren't all easily accessible/viewable through the /help-list in-game. It's a bother.

    I'm not blaming anyone; I'm simply stating that I've found some aspects of the whole mod that seriously puts one off on using CB. Constructive criticism, as I said before. I'm not "new" to using CB per se; I've used hMod before it for several months, and it's basically the same thing. That said, I've yet to work out ALL the kinks in it. I'm not sure if you must have a plugin to do so, but I remember there being a function in hMod which I sorely miss in CB: the ability to customize exactly what is featured on the server from the get-go, i.e. without the use of XX amount of plugins. I know this is kind of a stupid thing to say, but something like this ought to be an essential part of the base options at least, in my opinion.
  30. Offline


    I tried this, and when i launched it said running Beta 1.4. I tried updating, but it still says beta 1.4 afterwards, and im running 1.5. how do i fix this? and why wont the updater work? Im running from the terminal on a mac, like it said.
Thread Status:
Not open for further replies.

Share This Page