How to Install Bukkit (Newb-Friendly!)

Discussion in 'Bukkit Help' started by TheArcher, Jan 7, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    I don't understand the instructions in the README, could you please explain them in a better way?
  2. Offline


    what specifically don't you get? ie: where are you stuck?
  3. Offline


    Well, it doesnt really say what I should write in, when I should make a new folder and such..
    --- merged: Feb 19, 2011 11:21 AM ---
    Is there any updated Video tutorial for the new way to install it?
  4. Offline


    Unable to connect the Jarfile ... what should I do?
  5. Offline


    Just took a quick look at the Mac OS X script and it says linux ;)

    And instead of using "<font color="rgb(0, 0, 0)">/User/$USER</font>", you can use "<font color="rgb(0, 0, 0)">~</font>" which is the home directory.
    Also Mac OS X doesn't open .sh files with an executor.
    You need to use .command
    And when you output something, just put this:
    "Text" instead of "/n/t Text /n"

    All in all here is a "better" version:
    <Edit by Moderator: Redacted mediafire url>

    The installer can make whatever you type the ram amount; you should make something like

    if amountram ∉ {512;1024;1536;2560;3072;5120} then
    goto 2
    2 being:
    echo "Invalid amount, please enter a valid number from the folowing list:"
    echo " 512=512MB;  1024=1GB;  1536=1.5GB;  2560=2.5GB;  3072=3GB;  5120=5GB"
    goto 1
    Open and find:
    Tell me what is righten after the equal.
    Last edited by a moderator: Dec 15, 2016
  6. Offline


    Thanks for the setup, PierrreLouis, I've updated the thread and added you to the credits.
  7. Offline


    I'm gone for a week, but when I'll come back, I'll try to make the if thing real :)

    I was having fun making this:
    echo " _____   _____   __   _   _____        "
    echo "|  _  \ /  _  \ |  \ | | | ____|  |    "
    echo "| | | | | | | | |   \| | | |__    |    "
    echo "| | | | | | | | | |\   | |  __|   |    "
    echo "| |_| | | |_| | | | \  | | |___   |    "
    echo "|_____/ \_____/ |_|  \_| |_____|  O    "
    And I just saw I had made a mistake, and I don't have time to fix, upload etc...
    Please use the old version (Linux).
  8. Offline


    Where can I find 357
  9. Offline


    Stable builds have been introduced and will be in the next update to the setup. Stable builds are intended to make sure you have a build compatible with the majority of plugins on the forum that is crash-and-bug free.

    Are you referring to a build of Craftbukkit? If you want the latest stable build, download the setup again. If you've already downloaded it, you can use a plugin to make sure your build is up-to-date.
  10. Offline



    I have Windows 7 62bit with latest java and i run craftbukkit-0.0.1-SNAPSHOT everything went fine and then i try to log into the server with Minecraft beta 1.1_02

    i get this error in minecraft

    internal exception bad packet id 127
    and this in cmd

    2011-02-21 21:44:28 [INFO] Yeeey [/] logged in with entity id 50
    2011-02-21 21:44:28 [INFO] Player count: 1
    2011-02-21 21:44:28 [INFO] Yeeey lost connection: disconnect.endOfStream
    2011-02-21 21:44:28 [INFO] Yeeey lost connection: disconnect.endOfStream
    Thanks in advance! [​IMG]
  11. Offline


    Please use Google before posting. People have already had this error and if you use Google to search for the error, you will find the answer.
  12. I used this but now when i open minecraft it just says Connecting To Server............. for a couple minutes and then it times out

    Plz help
    --- merged: Feb 22, 2011 1:57 PM ---
    go to your ( open in notepad or textedit or another program) and check the server port and make sure you have the right port port forwarded
  13. Offline


    I have use google pretty much and did't find a solution that works. which java should i use? and is bukkit for alpha?

    EDIT: NVM, i tried 1.2 beta and it worked..
  14. Offline


    When I run the x64 file it does it's thing and then after generating server properties it stops the server. Is this because MC was updated to 1.3 and the Craftbukkit.jar is outdated? In the meantime I would like to know what should happen and where/how I would go about installing plugins.
  15. Offline


    Welcome to the forum, shane3x. When reporting errors, it's very useful to include a log of what happened. In this case, it would be a good idea to post a picture of the error(s) you are posting in order to get the help you want.

    Minecraft updates almost always break all moderations to the game, so please be patient if things don't seem to be working. You can get the latest recommended build if you are using Windows by clicking on "Latest CraftBukkit Download" (as the name states). Try regularly checking to see if CraftBukkit has been updated using this link if you are using the Windows setup.

    You can find plugins in the "Plugin Releases" section, which is easily discoverable on the forum's main hub. Follow the directions for each plugin to install it (the general instructions are to put them in your "plugins" folder).

    While I understand that you are new, all of the information above is easily findable; please do not waste other's time asking questions that you would find the answers to within five minutes of browsing the forum.

    Enjoy your stay.
  16. Offline


    I've been eagerly awaiting this update to try out craftbukkit, now here I am. I've set the server up fine, however, my problem lies with other players not being able to connect to the server. They get the connection refused message.

    Now, having run servers in the past (albeit a long time ago) I know for a fact that my specified port is forwarded, so I think it's safe to assume ports aren't the problem.

    Can anyone help? I have a feeling it's a really obvious thing that I'm just too much of a noob to realise. :p
  17. Offline


    These installers grab the latest recommended build of craftbukkit, which happens to be build #53.

    Build #53 is quite old, and doesn't support Minecraft Beta 1.3

    Currently, the best course of action would be for you to go to , download the latest build, and use that in place of the version which is installed for you by these installers.

    Don't forget to rename th file to craftbukkit.jar so your startup script will still work.
  18. Offline


  19. Offline


  20. Offline


    I loved this. It installed really easily. Just move the folder from program files to the desktop (windows) and run it. Then, you have bukkit, Also, it said for newbs, so if you are experienced its probably not for you.
  21. Offline


    Hi ,works fine at the beginning but now , when i want to connect it says :
    User not prenium
    What can i do ?!
  22. Offline


    Installed and works thank you!
  23. Offline


    It means you don't have a minecraft account, or your server isn't able to connect to the minecraft auth servers to authenticate the users who log on to it.


    These installers were designed to give people the absolute minimum set of options required to set up a bukkit server. That means it will grab the latest recommended build, and nothing else.

    The topic even states in its title that this is for newbs. If you want to use a different craftbukkit version, and know how to do so, clearly you're not a newb.

    However, if you want to use a different version of craftbukkit, and you don't know how to find it, you probably aren't competent enough to run your own server.
  24. Offline


    Thank you, it means a lot considering the vast amount of work I've put into creating this tutorial.

    These installers aren't absolute minimum at all, you have the ability to set your RAM, which is the only customization you can do to your server besides the build you use (and why wouldn't anyone not want to get the latest stable build?) and plugins.

    I tried to make the thread useful for newbs and experienced users, it has the options that both want (besides the ability to choose builds, but see above).

    I agree with this. If you interpreted his post correctly, you got most of the point across, but my goal is to make the tutorials both simple and customizable (in as many options as I can).
  25. Offline


    This might sound lazy but I don't feel like going through the 17 pages to see if this was ever posted but I downloaded the mac setup file and my computer tells me I don't have the privileges to use it and have to go to get info. Once there I'm completely lost. Please help.
  26. Offline



    Hmm, I suppose I misunderstood the nature of this thread? I thought it was strictly newb-only.
    Though on a side note, I would personally consider adjusting the RAM a necessary option in starting a server, as it directly affects the number of users you can serve.

    I also planned on adding a number of features to my Linux script to make it quicker for experienced users to install and optimize bukkit (and possibly install plugins as well), but I haven't gotten around to doing that yet. Though I appreciate the fact that you've kept my current script up to date.
  27. Offline


    And this topic isnt sticky'd...... Why? Hell, they should implement this as the way you install CB all the time.

    This is the only way I could get CB to work on my computer when I installed it about 2 weeks ago.

    TheArcher, I would like to thank and give you +100 internets. :D
  28. Offline



    It looks like the Bukkit wiki tutorial creator is trying to outdo me, using a single, 32/64-bit compatible launcher. Unfortunately for him, I am very competitive. I've updated the Windows setup, check the thread for more details!
  29. Offline


    I thought I'd pass it out that I had to correct some of the code myself.
    I'm running Kubuntu 10.10.
    The execute script has Xingc, it should be Xincgc (missing 'c').
    When I started the script to start craftbukkit, I assume it tried to download it and rename it, didn't work. The file remained the same, so the code was trying to open a non-existent file called craftbukkit.jar.
  30. Offline


    Meh, I get walls and walls of errors that never ever stop. I'm running on windows 7 x64. It just won't stop....GRAH!
Thread Status:
Not open for further replies.

Share This Page