How to Install Bukkit (Newb-Friendly!)

Discussion in 'Bukkit Help' started by TheArcher, Jan 7, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Still not working.
  2. Offline


    okay can someone help me? I need to install bukkit on a server using server hosting so how would I do this using a ftp? once again newb friendly please [​IMG]
  3. Offline


    I get a Unable to access jarfile craftbucket-0.0.1-SNAPSHOT.jar
    Press any key to continue...

    When running the Server Starter.bat I have windows and i put that code in, im pretty sure i did it right..
  4. Offline


    How do you get /item [id] [number] to work?? :)
  5. Offline


    Ok. Mac Tutorial=Fail
    After doing all that, in the end it said
    Unable to access craftbukkit-0.01-Snapshot.jar
    [Process Completed]
    O and theres some mistakes in the tutorial, such as when u type chmod u+x u have to type a space before dragging ur file in. O and i didnt understand the / above the chmod u+x, when i typed that it said bash / is a file or something like that, so i assue its a mistake.
    --- merged: Jan 17, 2011 5:15 PM ---
    O and yes, i agree with him. My craftbukkit was named exactly the same, and it still says cant access it.
  6. Offline


    WHEW! i got it to work =]
  7. Offline


    You have to get the "General Plugin". Its in the Plugin Releases area of the forums.
    --- merged: Jan 17, 2011 6:08 PM ---
    Thats what happened to me. Is your craftbukkit jar file named right? It's supposed to be named "craftbukkit-0.0.1-SNAPSHOT" exactly.
  8. Offline


    My file was named the same exact thing and i did all the steps right. Its probably a mac thing, but if u have a mac and its working for u pls explain how u got it working.
  9. Offline


    Lol, sorry, I dont own a mac.
  10. Offline


    I use the same text in a .command file (you don't need step 5), but you too need step 4.

    I made it with

    /chmod +ugx [Path of File Here]

    (I got it from a video for installing hey0s mod)

    Do u wrote the name correct? craftbukkit-0.0.1-SNAPSHOT.jar
  11. Offline


    I was talking to mac people in general, not just u. Im saying that if anyone has a mac and got Bukkit working, pls explain how.
    --- merged: Jan 17, 2011 8:02 PM ---
    Yup, thats what i meant
  12. Offline


    Im on a mac and its working great

    Tonys-MacBook-Pro:Downloads admin$ java -Xms1024M -Xmx1024M -jar craftbukkit-0-7.0.1-SNAPSHOT.jar
    2011-01-17 14:04:40 [INFO] Starting minecraft server version Beta 1.2_01
    2011-01-17 14:04:40 [INFO] Loading properties
    2011-01-17 14:04:40 [INFO] Starting Minecraft server on *:25565
    2011-01-17 14:04:40 [INFO] Preparing level "world"
    2011-01-17 14:04:40 [INFO] Preparing start region
  13. Offline


    hm.. did u follow tutorial exactly? Or did u change it alittle? O and thats not the newest craftbukkit, thats a different one, but anywho if u got it working HOW
  14. Offline


    I'm on mac and got it working too

    requires manual startup but personally i don't care, as long as i get it running
  15. Offline


    I keep getting the following error when trying to run my file

    Failed to load Main-Class manifest attribute from

    Any ideas? Trying to test out bukkit.

  16. Offline


    Are you using Linux / MAC / Windows ?
  17. Offline


    centOS 5.5 64 bit from linode
  18. Offline


    Make sure you can call Java from a Terminal window open a terminal window and type in java -version you should get in response the version you are running I run Opensuse and this is my response back

    java version "1.6.0_20"
    OpenJDK Runtime Environment (IcedTea6 1.9.2) (suse-0.2.1-i386)
    OpenJDK Server VM (build 17.0-b16, mixed mode)
    --- merged: Jan 18, 2011 6:09 AM ---
    You are not the first person to have issues with CentOS so in an effort to figure out what might be going on I am downloading and I am going to install CentOS 5.5 on a spare box I have and see if I run into the same issues and I will report back my findings. Just a note I hate CentOS always have but that is just MHO.
  19. Offline


    Used to have ubuntu however mc significantly increased performance on my 1gb node since the switch. Only reason I am using centOS. I am a debian guy myself. Let me know your findings.

    My java came back with the following.

    java version "1.6.0_17"
    OpenJDK Runtime Environment (IcedTea6 1.7.5) (rhel-1.16.b17.el5-x86_64)
    OpenJDK 64-Bit Server VM (build 14.0-b16, mixed mode)
  20. Offline


    Hmmm that all looks right weird I will report back soon grabbing the DVD ISO right now have about another 1 hour on the download and then what 30 to 45 min for minimal install GNOME !!!! LOL
  21. Offline


    For some reason the latest build of craftbukkit works ( i think, world loaded 100% anyways... since mc is being wierd post notch update i'll have to wait to test 100%). strange stuff.
  22. Offline


    If you get the message: "Unable to access file.... Blah blah blah." All you have to do is add a path in the starter such as: "/Users/(Your User)/Desktop/(Folder Name)/craftbukkit...."
  23. Offline


    Can you paste your full error - exactly what you see on your server console? Please also paste the contents of your file.
  24. Offline


    Wow it works! But today was an Update! Pls Update
  25. Offline


    If you running starting the server from inside the same folder you should I say should not have to call the absolute path to run. I am just about done on my install. About to spin up MC on CentOS I am doing this VM wise since the machine I chose decided to head south on me for some reason ... YAY

    Well I just got CentOS installed and my MC on that VM is running I did have to uninstall java version 1.4.2 and then reinstalled in this version
    java version "1.6.0"
    OpenJDK Runtime Environment (build 1.6.0-b09)
    OpenJDK Client VM (build 1.6.0-b09, mixed mode)

    And all worked well

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  26. Offline


    I too am getting the following error:
    Failed to load Main-Class manifest attribute from
    Press any key to continue . . .
    Im using 64bit Win7,

    My java version:

    java version "1.6.0_23"
    Java(TM) SE Runtime Environment (build 1.6.0_23-b05)
    Java HotSpot(TM) 64-Bit Server VM (build 19.0-b09, mixed mode)

    Both the bukkit and Minecraft jar's are in a common dir... not sure what's wrong here?
  27. Offline


    Can you post the lines from your .bat file ?
  28. Offline


    Paste a copy of your bat file, or the command itself you are running craftbukkit as.
  29. Offline


    @echo off
    java -Xms512M -Xmx512M -jar bukkit.jar nogui
  30. Offline


    Well geezzz TNT just step right on my toes and stuff .. I mean ... geezzz. I am of course kidding Yeah waiting for the .bat file I think he might be running bukkit and not Craftbukkit .
    --- merged: Jan 19, 2011 7:41 PM ---
    Change bukkit.jar to craftbukkit-0.0.1-SNAPSHOT.jar and you should golden.
Thread Status:
Not open for further replies.

Share This Page