[GEN/TP/ADMN] CommandBook 1.7 - Essential and useful commands (/item, etc.) [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by sk89q, Feb 28, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    General commands as used on my server since '10. Warping, item giving, time changing, weather changing -- the usual.

    Thor command, one of many (video by Rubenbeebl):

    Note: You can remove any of these commands from CommandBook using the download link below.
    • General:
      • item [-d] <item[:data]> [amount]
      • give [-d] <target> <item[:data]> [amount]
      • more [-a] [-i] <target>
      • online [filter]
      • motd
      • intro (play intro music)
      • midi (play a MIDI file for yourself)
      • rules
      • setspawn [destination]
      • time [world] <time>
      • weather <'stormy'|'sunny'> [duration] [world]
      • thunder <'on'|'off'> [duration] [world]
      • spawnmob [-p] [-d] [-i] [-r] <mob> [count] [location]
      • kit <kit> [target]
    • Teleportation:
      • spawn
      • tp [target] <destination>
      • bring <target>
      • put <target>
      • call <target> (request a teleport)
    • Messaging:
      • broadcast <message>
      • say <message>
      • me <message>
      • msg <target> <message...>
      • reply <message...>
      • mute <target>
      • unmute <target>
    • Player:
      • whereami
      • compass
      • clear [-a] [target]
      • slap [-s] [-h|-v] [-d] [target]
      • rocket [-s] [-h] [target]
      • barrage [-s] [target]
      • shock [-s] [target]
      • thor [target] (get Thor's hammer)
      • unthor [target] (revoke Thor's hammer)
      • whois [target]
    • Utilities:
      • ping
      • debug info
      • debug clock (very accurate server lag benchmark)
    • Bans:
      • kick <target> [reason...]
      • ban [-e] <target> [reason...]
      • unban <target> [reason...]
    Complimentary plugins:


    [​IMG] CommandBook 1.7
    Requirements: Java 6+, WorldEdit, Bukkit build 753+

    You need WorldEdit: Install WorldEdit. If you don't want WorldEdit, put WorldEdit.jar in the root folder of your server or in the plugins/CommandBook folder.​

    If you find CommandBook useful, [​IMG]

    How to Use

    Check out my server too!

    [​IMG] (CommandBook is open source!)
    dragon8510, Psychoma, Goodi and 26 others like this.
  2. Offline

    Geoff Winans


    Spam the minecraft.net forums with the request. Last thing we need is even more retarded fracturing of server daemons and plugin devs. It's hard enough to keep plugin devs interested as it is. Huge number of plugin devs make a plugin and vanish. Crap like this just makes it worse.

    Also, wait'll it's at least as capable as bucket, eh?

    He doesn't even have water flow implemented.
  3. Offline


    I noticed a problem when using world edit and im sure it would be a problem with /i here:

    When you use //l to look for id's and stuff it don't show what you named the colors for the wool data values i spent ages trying to work out what it was (2 lazy to go get the wiki) Should be an easy fix if you could just make all the names for the data values come up when you search like color or wool that would be handy same with the slab's although they pretty much explain them self.

    About to install this now I'm over hukkle and its complex setup iv never had a problem from world edit or world guard that was not fixed with a simple update or an error caused by me with the permissions. always stable and can always count on them to work Even with the versions you don't recommend.
  4. Offline


    I just wanted to say that I'm having a much better experience with commandbook than I did with essentials. [​IMG]
  5. Offline


    I really like your plugin, but I'd like to see in the plugin a few more commands: /kick and /ban
  6. Offline


    Yer also im missing /s as an alias for /bring kick and ban Just basic for now would be nice.

    could work on time bans later. Just very basic stuff That ever server needs Thats what makes IT GEN

    I really don't want another dependency for my server 12 is plenty ....
  7. Offline


    When i run the server it all works and im the admin with all commands but i type /msg <username> <Msg> (im not filing them in for the purpose of this but on the server i do) also /spawn, /setspawn, /motd, /who, /i 4 5

    stuff like this and in the console it says "unknown command" or something along those lines, i have set up permissions and the other plugins i am running is;
    bedrock control

    also CommandBook.jar did not create a commandbook folder, is that normal?
  8. Offline


    I will look into those problems.

    @FreelyGun: It sounds like CommandBook is not loading at all. Check your server startup console.
  9. Offline


    @sk89q Thanks bro, i just restarted it a few times and then it finally recognized it and made a file so im good now. Thanks for the fast reply.
  10. Offline


    Uh I need some kind of world management Just loading and an admin command to go to them Just so it loads them on start up You gave us all these nice world wise and related commands and no way to load the worlds I can handle getting my players 2 and from with another plugin but I still need loading and a raw way to get there so i can set up the other plugin...
  11. Offline


    @sk89q Did you have any time yet to look into the issues with flat file permissions? (link) Thanks for the great work so far!
  12. Offline


    /item -1 49
    lost connection bad packet id 49

    Add check pls
  13. Offline


    Does WorldEdit load if you put it into plugins/?

    What do you mean?


    /spawn should send you exactly to the target.

    You should be able to just use /setspawn without needing to provide coordinates.

    I will look into this.

    With stone? That should work properly.

    In which way is it wrong?

    Post the entire error log.

    On the todo list.

    What would this do?

    Put this in your configuration file:

        tree: 17
        redstone: 331

    Though I never tested it.

    Will add.

    You can just do /i wool:red and whatnot.

    I recommend a separate multi-world plugin.

  14. Offline


    <-- awaiting 1.2 commandbook
    /tell,/me,/love! :D
  15. Offline


  16. Offline


    Hi we have got some problems with commandbook.
    2011-03-09 18:07:17 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'list' in plugin CommandBook v1.1
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:80)
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:183)
        at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:619)
        at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:582)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:576)
        at net.minecraft.server.Packet3Chat.a(SourceFile:24)
        at net.minecraft.server.NetworkManager.a(SourceFile:230)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:357)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.lang.NullPointerException
        at com.sk89q.bukkit.migration.ConfigurationPermissionsResolver.hasPermission(ConfigurationPermissionsResolver.java:104)
        at com.sk89q.bukkit.migration.ConfigurationPermissionsResolver.hasPermission(ConfigurationPermissionsResolver.java:99)
        at com.sk89q.bukkit.migration.PermissionsResolverManager.hasPermission(PermissionsResolverManager.java:86)
        at com.sk89q.commandbook.CommandBookPlugin.hasPermission(CommandBookPlugin.java:288)
        at com.sk89q.commandbook.CommandBookPlugin$1.hasPermission(CommandBookPlugin.java:122)
        at com.sk89q.commandbook.CommandBookPlugin$1.hasPermission(CommandBookPlugin.java:119)
        at com.sk89q.minecraft.util.commands.CommandsManager.hasPermission(CommandsManager.java:372)
        at com.sk89q.minecraft.util.commands.CommandsManager.executeMethod(CommandsManager.java:302)
        at com.sk89q.minecraft.util.commands.CommandsManager.execute(CommandsManager.java:256)
        at com.sk89q.commandbook.CommandBookPlugin.onCommand(CommandBookPlugin.java:161)
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
        ... 12 more
    we're using bukkit build 506
    AlphaChest, ChatBukkit, CommandBook, CraftBukkitUpToDate,
    dynmap, InfChests, MyWarp, ScrapBukkit, WorldEdit, WorldGuard
    Our Server has 8GB Ram but we let bukkit just use 6GB and now our server is using the hole ~6 gb with ~20 players
  17. Offline


    It didn't dawn on me till the other day that the time shown is the game time, not Real world time. Sorry for this mistake.

    I will mention that I'm having issues using the /setspawn command. I get an error telling me to look at the console log. If I may ask, when was the last time you updated the plugin? (Kinda wish most plugin authors would put dates next to their version numbers. Easier to keep track.)
  18. Offline


    1. i tried many things such as lime lightgreen ect and they did not work i just wanted a full list so i know what they are..
    2. like what multi verse is crap its outdated and it makes so much lag half its stuff never worked. looked under the world management section of late theres not 1 plugin in that section to do with loading worlds. Not quite sure why multi verse is not in that section.. Any 1 point me in the right direction here?

    theres a bunch of other General plugins that do it but if i was to use them i would drop this Uh no thanks.

    This Plugin is dead Im sorry but it is no1 wants it because its missing Basic General things Kick/ban And world loading (the world loading is not that important but still.)

    I know you have a lot of plugins 4 or 5 now And i know you don't have a whole lot of time to work on them due to school but a few more basic commands would be nice.
  19. Offline


    I absolutely love this plugin, light weight and just works. Rusty its not dead.

    I def need the /kick and /ban commands please, for my server mods.

  20. Offline


  21. Offline

    Boon Pek

    a /kick /ban /kickall /banip etc... would be a GREAT addition to this. Much simpler that Essentials with the addition of stability :)
  22. Offline


    What Boon mentioned...is it possible for you to add some of the OP commands to this, so we can allow or deny them through Permissions, such as /kick, /ban, /ban-ip, /pardon and so on, pretty please sk89q. This would be awesome to be able to create groups with limited OP commands without using yet another plugin. Many seem to be requesting this...
  23. Offline


    I installed everything and it doesnt work!

    Help! :(
  24. Offline


    Might want to put a bit more detail of why you suspecting it not working. What is the serverlog saying about commandbook?

    In my case, I am running a clean installed server for testing plugin updates and craftbukkit updates. I just used craftbukkit 531 and got the following with commandbook:

    [SEVERE] Could not load plugins\CommandBook.jar in plugins: null
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:113)
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:159)
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:107)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:59)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:204)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:191)
        at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:131)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.lang.NoClassDefFoundError: com/sk89q/minecraft/util/commands/CommandPermissionsException
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Unknown Source)
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:105)
        ... 8 more
    Caused by: java.lang.ClassNotFoundException: com.sk89q.minecraft.util.commands.CommandPermissionsException
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(Unknown Source)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:30)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        ... 11 more
  25. Offline


    Welcome all.

    I'm new and green in Maincraft Server and rest of this, but I tried to have my private server.
    I'm using:

    Bukkit 0.531
    WorldEdit 4.1
    CraftBook 3.0 Alpha
    CommandBook 1.1

    my problem is probably easy, but I have no idea how to solve it...

    I want to install


    but when I'm using CommandBook I can't use MyWarp and Myhome...
    I don't know what is wrong.
    If you need any info please ask me, because I have no idea what else info you need.

    Big thanks for any help // sorry for my english, but this is not my first language.
  26. Offline


    Did you install WorldEdit?

    Will fix.

    Give me the error.

    Will fix.

    Give me more information.

    Got WorldEdit still installed?

    Do the commands conflict?
  27. Offline


    2011-03-12 102622 [INFO] Starting minecraft server version Beta 1.3
    2011-03-12 102622 [INFO] Loading properties
    2011-03-12 102622 [INFO] Starting Minecraft server on
    2011-03-12 102622 [INFO] This server is running Craftbukkit version git-Bukki
    -0.0.0-447-g84246c4-b428jnks (MC 1.3)
    2011-03-12 102622 [INFO] Preparing level Notches World
    2011-03-12 102622 [INFO] Preparing start region
    2011-03-12 102623 [SEVERE] Could not load pluginsCommandBook.jar in plugins
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManage
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java55)
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java187)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java174)
    at net.minecraft.server.MinecraftServer.d(MinecraftServer.java120)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java227)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile366)
    Caused by java.lang.NoClassDefFoundError comsk89qminecraftutilcommandsCo
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Unknown Source)
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.
    ... 8 more
    Caused by java.lang.ClassNotFoundException com.sk89q.minecraft.util.commands.
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    ... 11 more
    2011-03-12 102623 [WARNING] Using the stupidly long constructor com.bukkit.cr
    z.PlayerList.PlayerList(PluginLoader, Server, PluginDescriptionFile, File, File
    ClassLoader) is no longer recommended. Go nag the plugin author of PlayerList
    o remove it! (Nothing is broken, we just like to keep code clean.)
    2011-03-12 102623 [INFO] LoginMessage 0.5_4 enabled
    2011-03-12 102623 [INFO] [MultipleHomes] Settings Loaded!
    2011-03-12 102623 [INFO] [MultipleHomes] MultipleHomes version 0.51 is enable
    2011-03-12 102623 [INFO] PlayerList version 1.1 is enabled!
    2011-03-12 102623 [INFO] Done (1088904190ns)! For help, type help or
  28. Offline


    I love using sk89q's plugins, including this one. Works just perfect.
    This, of course, is pure awesome. Thanks a lot sk89q for the hard work you put in.
  29. Offline

    Boon Pek

    I salute you, sk89q for the plugins that you and your development team have put into your plugins (namely WorldEdit and WorldGuard). Thank you very much for the work you put into this!
    There are though, a few bugs that I stumbled upon whilst testing this.
    1) Giving yourself an infinite number of [block] and breaking a block of that type that wasn't placed from that stack causes the [block] to disappear from your inventory/hand and not appear where you 'placed' it but if you break a block you placed from that stack you took, it works fine. There are no errors in the console.
    2) If you use the /i or /give command and end with a string instead of an integer you'll get this error:
    2011-03-12 23:09:09 [SEVERE] com.sk89q.minecraft.util.commands.WrappedCommandException: java.lang.NumberFormatException: For input string: "a"
    2011-03-12 23:09:09 [SEVERE]     at com.sk89q.minecraft.util.commands.CommandsManager.executeMethod(CommandsManager.java:353)
    2011-03-12 23:09:09 [SEVERE]     at com.sk89q.minecraft.util.commands.CommandsManager.execute(CommandsManager.java:256)
    2011-03-12 23:09:09 [SEVERE]     at com.sk89q.commandbook.CommandBookPlugin.onCommand(CommandBookPlugin.java:161)
    2011-03-12 23:09:09 [SEVERE]     at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    2011-03-12 23:09:09 [SEVERE]     at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:80)
    2011-03-12 23:09:09 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:183)
    2011-03-12 23:09:09 [SEVERE]     at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:645)
    2011-03-12 23:09:09 [SEVERE]     at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:608)
    2011-03-12 23:09:09 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:602)
    2011-03-12 23:09:09 [SEVERE]     at net.minecraft.server.Packet3Chat.a(SourceFile:24)
    2011-03-12 23:09:09 [SEVERE]     at net.minecraft.server.NetworkManager.a(SourceFile:230)
    2011-03-12 23:09:09 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:76)
    2011-03-12 23:09:09 [SEVERE]     at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    2011-03-12 23:09:09 [SEVERE]     at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:357)
    2011-03-12 23:09:09 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
    2011-03-12 23:09:09 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    2011-03-12 23:09:09 [SEVERE] Caused by: java.lang.NumberFormatException: For input string: "a"
    2011-03-12 23:09:09 [SEVERE]     at java.lang.NumberFormatException.forInputString(Unknown Source)
    2011-03-12 23:09:09 [SEVERE]     at java.lang.Integer.parseInt(Unknown Source)
    2011-03-12 23:09:09 [SEVERE]     at java.lang.Integer.parseInt(Unknown Source)
    2011-03-12 23:09:09 [SEVERE]     at com.sk89q.minecraft.util.commands.CommandContext.getInteger(CommandContext.java:79)
    2011-03-12 23:09:09 [SEVERE]     at com.sk89q.commandbook.GeneralCommands.item(GeneralCommands.java:67)
    2011-03-12 23:09:09 [SEVERE]     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    2011-03-12 23:09:09 [SEVERE]     at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    2011-03-12 23:09:09 [SEVERE]     at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    2011-03-12 23:09:09 [SEVERE]     at java.lang.reflect.Method.invoke(Unknown Source)
    2011-03-12 23:09:09 [SEVERE]     at com.sk89q.minecraft.util.commands.CommandsManager.executeMethod(CommandsManager.java:343)
    2011-03-12 23:09:09 [SEVERE]     ... 15 more
    Other than those two stated above, the plugin works fine though there are a few suggestions ;)
    1) a /kit <kitname> <player> command - to dispense kits to players (as this is basically /i /give but at a larger scale)
    2) a /locktime <time> <world> - lock the world's time to this time
    3) setting a default value (via config) to the /i /give commands when none are specified (so /i water would give what the default is)
    4) a database (on worldedit) that users can edit to add custom names for custom items
    5) default support for /help by tkelly
    6) /clear to have more arguments - /clear for everything (armour and on-hand inclusive), /clear <-a|armour, -i|inventory, -h|hand>
    7) TP accepting/denying
    There is nothing else that I can think of that isn't in the issue tracker ;) A great plugin overall; simple, custmisable and minimal. Also, I particularly like the outputs. Clean and aesthetically pleasing :)
  30. Offline


    Fffuuu celticministrel stole all of my plugin's ideas for his own.

    But anyway, on to support!

    @Apasalic: Install WorldEdit.
    @Boon Pek: (1) that's odd (2) will fix

    (1) sure,
    (2) will add I suppose
    (3) you mean default quantity?
    (4) this exists... it's just not documented anywhere. I plan to fix this
    (5) will add when I get time, but not a high priority
    (6) will add
    (7) considering this
  31. Offline


    Ah, I did forget the worldedit while setting up the test server. My apologies.

    I attempted to run the command on the test server, it worked. So my guess is, since the real server hasn't had a chance to update craftbukkit where it could get all of it's plugins working at the same time, the version I'm using is causing the issue. If so, just ignore my problem.

    2011-03-12 12:47:38 [SEVERE] com.sk89q.minecraft.util.commands.WrappedCommandException: java.lang.NoSuchMethodError: org.bukkit.World.setSpawnLocation(III)Z
    2011-03-12 12:47:38 [SEVERE]     at com.sk89q.minecraft.util.commands.CommandsManager.executeMethod(CommandsManager.java:353)
    2011-03-12 12:47:38 [SEVERE]     at com.sk89q.minecraft.util.commands.CommandsManager.execute(CommandsManager.java:256)
    2011-03-12 12:47:38 [SEVERE]     at com.sk89q.commandbook.CommandBookPlugin.onCommand(CommandBookPlugin.java:161)
    2011-03-12 12:47:38 [SEVERE]     at org.bukkit.command.PluginCommand.execute(PluginCommand.java:31)
    2011-03-12 12:47:38 [SEVERE]     at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:79)
    2011-03-12 12:47:38 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:183)
    2011-03-12 12:47:38 [SEVERE]     at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:619)
    2011-03-12 12:47:38 [SEVERE]     at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:582)
    2011-03-12 12:47:38 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:576)
    2011-03-12 12:47:38 [SEVERE]     at net.minecraft.server.Packet3Chat.a(SourceFile:24)
    2011-03-12 12:47:38 [SEVERE]     at net.minecraft.server.NetworkManager.a(SourceFile:230)
    2011-03-12 12:47:38 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    2011-03-12 12:47:38 [SEVERE]     at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    2011-03-12 12:47:38 [SEVERE]     at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:357)
    2011-03-12 12:47:38 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
    2011-03-12 12:47:38 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    2011-03-12 12:47:38 [SEVERE] Caused by: java.lang.NoSuchMethodError: org.bukkit.World.setSpawnLocation(III)Z
    2011-03-12 12:47:38 [SEVERE]     at com.sk89q.commandbook.GeneralCommands.setspawn(GeneralCommands.java:392)
    2011-03-12 12:47:38 [SEVERE]     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    2011-03-12 12:47:38 [SEVERE]     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    2011-03-12 12:47:38 [SEVERE]     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    2011-03-12 12:47:38 [SEVERE]     at java.lang.reflect.Method.invoke(Method.java:616)
    2011-03-12 12:47:38 [SEVERE]     at com.sk89q.minecraft.util.commands.CommandsManager.executeMethod(CommandsManager.java:343)
    2011-03-12 12:47:38 [SEVERE]     ... 15 more
Thread Status:
Not open for further replies.

Share This Page