[GEN/TP/ADMN] CommandBook 1.7 - Essential and useful commands (/item, etc.) [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by sk89q, Feb 28, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    General commands as used on my server since '10. Warping, item giving, time changing, weather changing -- the usual.

    Thor command, one of many (video by Rubenbeebl):

    Note: You can remove any of these commands from CommandBook using the download link below.
    • General:
      • item [-d] <item[:data]> [amount]
      • give [-d] <target> <item[:data]> [amount]
      • more [-a] [-i] <target>
      • online [filter]
      • motd
      • intro (play intro music)
      • midi (play a MIDI file for yourself)
      • rules
      • setspawn [destination]
      • time [world] <time>
      • weather <'stormy'|'sunny'> [duration] [world]
      • thunder <'on'|'off'> [duration] [world]
      • spawnmob [-p] [-d] [-i] [-r] <mob> [count] [location]
      • kit <kit> [target]
    • Teleportation:
      • spawn
      • tp [target] <destination>
      • bring <target>
      • put <target>
      • call <target> (request a teleport)
    • Messaging:
      • broadcast <message>
      • say <message>
      • me <message>
      • msg <target> <message...>
      • reply <message...>
      • mute <target>
      • unmute <target>
    • Player:
      • whereami
      • compass
      • clear [-a] [target]
      • slap [-s] [-h|-v] [-d] [target]
      • rocket [-s] [-h] [target]
      • barrage [-s] [target]
      • shock [-s] [target]
      • thor [target] (get Thor's hammer)
      • unthor [target] (revoke Thor's hammer)
      • whois [target]
    • Utilities:
      • ping
      • debug info
      • debug clock (very accurate server lag benchmark)
    • Bans:
      • kick <target> [reason...]
      • ban [-e] <target> [reason...]
      • unban <target> [reason...]
    Complimentary plugins:


    [​IMG] CommandBook 1.7
    Requirements: Java 6+, WorldEdit, Bukkit build 753+

    You need WorldEdit: Install WorldEdit. If you don't want WorldEdit, put WorldEdit.jar in the root folder of your server or in the plugins/CommandBook folder.​

    If you find CommandBook useful, [​IMG]

    How to Use

    Check out my server too!

    [​IMG] (CommandBook is open source!)
    dragon8510, Psychoma, Goodi and 26 others like this.
  2. Offline


    Hey you,
    pls add Shears and Pistons.
  3. Offline


    He's working on it. You can follow the progress here.
  4. Offline


    Is there any way to log the /msg command? I used to be able to do it with Essentials I think.
  5. Offline


    I get this too. Someone knows why?
  6. Offline


    I moved yesterday from Essentials and I think CommandBook is great :)
    But there is a problem with TooManyItems, items are invisible oO
    It works with /item in chat, but not with this mod.
  7. Offline


    fyi: LWC is the plugin that provides /cprivate - and LWC was not in his list of installed plugins, anyway. i'd reply directly to him, but i can't seem to find his original post.
  8. Offline


    How to create an alias name for a wooden slab?
    Or any other item ID with a damage value?
  9. Offline


    Put it in the config file:
    Wait, you are snowy...
    What's the problem then?

    EDIT 2:
    Oh the damage value.
    Did you try a colon?
  10. Offline


    I've been using comlog . logs every command.
  11. Offline


    I'm curious if it is possible with current config to make it so that certain groups cannot receive items with the /give command. If you blacklist items using permissions and item-permissions-only, would someone WITH permissions still be able to give to someone WITHOUT permission? My server has creative and survival worlds, and I haven't been able to turn on the give command for a long time because of this issue.
  12. Offline


    This seems to be interfering with MyWarp on the server I admin on. Can you possibly tell us if this is possible to fix? Thanks.
  13. Offline


    The problem is indeed that i can't add items with damage values.

    I already tried things like
    bonemeal: 351:15
    bonemeal: "351:15"
    bonemeal: '351:15'
    bonemeal: 351;15
    bonemeal: 351.15

    and also with other items with damage values but it keeps giving me an error that the ID isn't correct when i try to spawn the item.
    It would be great if my users could just type in /item bonemeal instead of /item 351:15
    Same for other items with damage values.
  14. Offline


    Maybe try dye:15?
  15. Offline


    I'm getting that too. I think it's conflicting with a new warp/home feature of CommandBook.
  16. Offline


    Is there a way to block the /tp and related commands from working across worlds? I haven't seen anything in the config, or permissions nodes. It could be that I'm just missing it however.
  17. Offline


    If you have Permissions you can use the separate world config files. Otherwise you can disable them all together with the customizable version.
  18. Offline


    Seperate world config files? I only have a master config for command book. World guard comes with per-world configs, but world guard doesn't help me. If your saying to just disable the commandbook.teleport and commandbook.teleport.other nodes on certain worlds, I would still like them to be able to /tp within their own world.
  19. Offline


    Ok. We actually got it fixed now, but as I said, I'm only an admin and can't use the ssh agent to manage the server, so I don't know what they did.
  20. Offline


    I've got a problem. Commandbook is working good, but my moderators can't spawn mobs. I gave 'em the permission 'commandbook.spawnmob', but they can't spawn any mobs actually... Do I need another permission?
  21. Offline


    Permissions (the separate plugin) has per-world configuration, but I don't think CommandBook does. I'm not sure you can disable between-world teleportation.

    @zaklampje, you need per-mob permissions, e.g., commandbook.spawnmob.pig, commandbook.spawnmob.*
  22. Offline


    No thats not working either.
    when using
    bonemeal: 351:15
    i get the error "Non-existent item specified.

    When i use any of the others i get 'No item type known by 'bonemeal''
    Am i the only one with this problem?
    Please don't tell me its impossible to use damage values at this time....
  23. Offline


    I don't know what to tell you. I guess we'll just have to wait for a fix from sk89q...
  24. Offline


    Citizen-s cannot use commandbook.who . I have tried without the brackets but still "You do not have permission to do that appears when a Citizen tries /who, /list etc

    Edit. And they CAN open fence gates...
    Permissions (part of) globalGroup:
            default: true
                prefix: ''
                suffix: ''
                build: false
            - commandbook.who
            default: false
                prefix: '[Builder]'
                suffix: ''
                build: true
            - Default
            - warpplugin.warp
            - econplugin.basic.*
            default: false
                prefix: '[Moderator]'
                suffix: ''
                build: true
            - Member
            - modplugin.ban
            - modplugin.kick
            - modplugin.unban
            default: false
                prefix: '[Admin]'
                suffix: '[/b]'
                build: true
            - '*'
            default: false
                prefix: ''
                suffix: ''
                build: true
            - Guest
            - warpplugin.warp
            - econplugin.basic.*
            - -craftbook.mech.gate
            - "commandbook.who"
    Commandbook config:
    # Give ops all permissions
    op-permissions: true
    use-display-names: true
    online-on-join: true
        colored-names: true
        grouped-names: true
        show-max-players: true
    verify-name-format: true
    Can some1 tell me where the error is?
  25. Offline


    ok, thanks, like I said, i wasn't sure if it was even a possibility

    and Riddle,
    all of your nodes under permissions:, need to have be formatted like this - 'perm.iss.ions' with a single quote, or asterisk

        default: false
            prefix: ''
            suffix: ''
            build: true
            - Guest
            - 'warpplugin.warp'
            - 'econplugin.basic.*'
            - '-craftbook.mech.gate'
            - 'commandbook.who'
  26. Offline


    CommandBook is interfering with xWarp as well, and its bad enough that even disabling the permissions isn't enough :/ Not sure, but on the default world, I removed commandbook.warp.* and it still comes up... I use multihome as well, and CB is interfering with that too.

    Is it possible that you could add those commands to the customizer, so that we can remove them?
  27. Offline


    Hey guys, how can I disable beds saving your location if you die. Apparently you can with CommandBook.

    also, my /setspawn is NOT working all of a sudden. Help? :p

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  28. Getting an odd error... It started happening randomly... At server start this plugin says it's disabling some commands (/r and /who are the commands I find to not be working) due to a bad server wrapper. When this first started happening we weren't even using a server wrapper, just running Bukkit from the cmd line. We then started using McMyAdmin today and the problem still persists. I can't seem to find what's causing the problem, perhaps BukkitContrib? But anyway, it disables 2 of the most used commands, /r and /who and it's really rather annoying. If there's any way you could fix this that'd be great, if not I'd gladly accept help into fixing this issue myself. I hope that it isn't to do with BukkitContrib, because I need that for LogBlock.
  29. Offline


    Sorry but how would i get a wonderful server banner like yors. and what does bukkit contrib do for logblock?
  30. mcserverstatus.com

    As for BukkitContrib, it makes LogBlock able to log what's put in and taken out of chests.
  31. Offline


    Why dont you juse get lockette so your users can lock there chest .
Thread Status:
Not open for further replies.

Share This Page