[GEN/TP/ADMN] CommandBook 1.7 - Essential and useful commands (/item, etc.) [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by sk89q, Feb 28, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    General commands as used on my server since '10. Warping, item giving, time changing, weather changing -- the usual.

    Thor command, one of many (video by Rubenbeebl):

    Note: You can remove any of these commands from CommandBook using the download link below.
    • General:
      • item [-d] <item[:data]> [amount]
      • give [-d] <target> <item[:data]> [amount]
      • more [-a] [-i] <target>
      • online [filter]
      • motd
      • intro (play intro music)
      • midi (play a MIDI file for yourself)
      • rules
      • setspawn [destination]
      • time [world] <time>
      • weather <'stormy'|'sunny'> [duration] [world]
      • thunder <'on'|'off'> [duration] [world]
      • spawnmob [-p] [-d] [-i] [-r] <mob> [count] [location]
      • kit <kit> [target]
    • Teleportation:
      • spawn
      • tp [target] <destination>
      • bring <target>
      • put <target>
      • call <target> (request a teleport)
    • Messaging:
      • broadcast <message>
      • say <message>
      • me <message>
      • msg <target> <message...>
      • reply <message...>
      • mute <target>
      • unmute <target>
    • Player:
      • whereami
      • compass
      • clear [-a] [target]
      • slap [-s] [-h|-v] [-d] [target]
      • rocket [-s] [-h] [target]
      • barrage [-s] [target]
      • shock [-s] [target]
      • thor [target] (get Thor's hammer)
      • unthor [target] (revoke Thor's hammer)
      • whois [target]
    • Utilities:
      • ping
      • debug info
      • debug clock (very accurate server lag benchmark)
    • Bans:
      • kick <target> [reason...]
      • ban [-e] <target> [reason...]
      • unban <target> [reason...]
    Complimentary plugins:


    [​IMG] CommandBook 1.7
    Requirements: Java 6+, WorldEdit, Bukkit build 753+

    You need WorldEdit: Install WorldEdit. If you don't want WorldEdit, put WorldEdit.jar in the root folder of your server or in the plugins/CommandBook folder.​

    If you find CommandBook useful, [​IMG]

    How to Use

    Check out my server too!

    [​IMG] (CommandBook is open source!)
    dragon8510, Psychoma, Goodi and 26 others like this.
  2. Offline


    No default player command for spawn? :(
  3. Offline


    Fantastic plugin, provides some very useful commands with no hassle.
    One suggestion, some sort of /timefreeze command, to stop the day/night cycle would be very useful.
  4. Offline


  5. Offline


    Do you think its possible to have Commandbook and WorldGuard to work together to prevent some of the given commands done?
    Such example is:
    Prevent TNT (ID 46) from being used with the /give or /i command.
    I've tried a few commands with the item-blacklist in WorldGuard but it doesn't appear to block /give commands (unless I didn't know what command did what even though WorldGuard has examples)

    Or even just have item-blacklisting in Commandbook would be nice too :)
  6. Offline


    I personally think its best to keep them separate.
  7. Offline


    Yeah, probably. (seeing as maybe not all want WorldGuard)
    Probably still possible to have an item-blacklisting on Commandbook itself.
  8. Offline


    /setspawn [coords] does not work!

    says t"too many arguements"
  9. Offline


    Are you using spaces in your /setspawn command? e.g. /setspawn x,y,z where x,y,z are the coords?

    Also, sk89q, Is /spawn supposed to take the y co-ordinate (depth/height) into account? I've set a spawn point inside a 'safe-house', but when I do /spawn, I always land on the roof?

    Running Craftbukkit (Recommended) build #493 & CommandBook v1.1.

    Am LOVING not having to run that other plugin that became so damned bloated and couldn't keep up with the number of versions it released. This plugin keeps it simple, and also am a really big fan of the customisation ability.

    Cheers :-D
  10. Offline


    Ok my mistake.
    I changed the file name 'config.yml' in the name of my world and everything works. :)
  11. Offline


    I typed /whereami to get the coords. Than put /setspawn [coords (with spaces) here]

    Am I doing something wrong? please give me a example of the cmd.
  12. Offline


    Suggestion: teleport to coordinates.
    I used teleplus plugin before but this is so much better :)
  13. Offline


    It seems that there is an issue when using flat file permissions. Could you please take a look at the following Exceptions? I tried running the command '/who' as a default user, running the latest (recommended) versions of CB and the plugins.

    I wanted to see how the plugin would handle a command request from a default user without the appropriate permissions specified in the 'perms_groups.txt' under the 'default' section. I guess it shouldn't throw any Exceptions? The in-game message is that 'An internal error occurred while attempting to perform this command'.

    Thanks in advance!

    18:04:23 [INFO] Starting minecraft server version Beta 1.3
    18:04:23 [WARNING] **** NOT ENOUGH RAM!
    18:04:23 [WARNING] To start the server with more ram, launch it as "java -Xmx102
    4M -Xms1024M -jar minecraft_server.jar"
    18:04:23 [INFO] Loading properties
    18:04:23 [INFO] Starting Minecraft server on *:25565
    18:04:23 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-493-
    g8b5496e-b493jnks (MC: 1.3)
    18:04:24 [INFO] Preparing level "world"
    18:04:24 [INFO] Preparing start region
    18:04:25 [INFO] LWC     [v1,57] Loading shared objects
    18:04:25 [INFO] Config  [v1,57] Loaded 12 config entries
    18:04:25 [INFO] LWC     [v1,57] Native library: lib/native/Windows/x86/sqlitejdb
    18:04:25 [INFO] WorldGuard loaded.
    18:04:25 [INFO] CommandBook 1.1 enabled.
    18:04:25 [INFO] CommandBook: perms_groups.txt and perms_users.txt detected! Usin
    g flat file permissions.
    18:04:25 [INFO] Config  [v1,57] Loaded 12 config entries
    18:04:25 [INFO] LWC     [v1,57] Loaded command: /lwc -admin
    18:04:25 [INFO] LWC     [v1,57] Loaded command: /lwc -create
    18:04:25 [INFO] LWC     [v1,57] Loaded command: /lwc -free
    18:04:25 [INFO] LWC     [v1,57] Loaded command: /lwc -info
    18:04:25 [INFO] LWC     [v1,57] Loaded command: /lwc -p
    18:04:25 [INFO] LWC     [v1,57] Loaded command: /lwc -modify
    18:04:25 [INFO] LWC     [v1,57] Loaded command: /lwc -unlock
    18:04:25 [INFO] LWC     [v1,57] Loaded command: /lwc -owners
    18:04:25 [INFO] LWC     [v1,57] -> PLAYER_QUIT
    18:04:25 [INFO] LWC     [v1,57] -> ENTITY_EXPLODE
    18:04:25 [INFO] LWC     [v1,57] -> BLOCK_INTERACT
    18:04:25 [INFO] LWC     [v1,57] -> BLOCK_DAMAGED
    18:04:25 [INFO] LWC     [v1,57] -> BLOCK_BREAK
    18:04:25 [INFO] LWC     [v1,57] -> BLOCK_PLACED
    18:04:25 [INFO] LWC     [v1,57] -> REDSTONE_CHANGE
    18:04:25 [INFO] LWC     [v1,57] Loading SQLite
    18:04:25 [INFO] PhysDB  [v1,57] Creating physical tables if needed
    18:04:25 [INFO] MemDB   [v1,57] Creating memory tables
    18:04:25 [INFO] SQLite  [v1,57] Using: Native
    18:04:25 [INFO] SimpleHome: Loading homelist...
    18:04:25 [INFO] done.
    18:04:25 [INFO] SimpleHome version 1.5 is enabled!
    18:04:25 [INFO] WorldEdit 4.0-beta8 enabled.
    18:04:25 [INFO] WorldEdit: perms_groups.txt and perms_users.txt detected! Using
    flat file permissions.
    18:04:25 [INFO] WorldGuard: perms_groups.txt and perms_users.txt detected! Using
     flat file permissions.
    18:04:25 [INFO] WorldGuard: Blacklist loaded.
    18:04:25 [INFO] WorldGuard: Single session is enforced.
    18:04:25 [INFO] WorldGuard: TNT ignition is blocked.
    18:04:25 [INFO] WorldGuard: Lighters are PERMITTED.
    18:04:25 [INFO] WorldGuard: Lava fire is blocked.
    18:04:25 [INFO] WorldGuard: Fire spread is UNRESTRICTED.
    18:04:25 [INFO] WorldGuard 4.0-alpha1 enabled.
    18:04:25 [INFO] Done (0,156s)! For help, type "help" or "?"
    18:04:37 [INFO] 143 recipes
    18:04:37 [INFO] MrGifted [/] logged in with entity id 150
    18:04:42 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'who'
     in plugin CommandBook v1.1
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:33)
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:80
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:1
            at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:619)
            at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:582)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:576)
            at net.minecraft.server.Packet3Chat.a(SourceFile:24)
            at net.minecraft.server.NetworkManager.a(SourceFile:230)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:357)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.lang.NullPointerException
            at com.sk89q.bukkit.migration.FlatFilePermissionsResolver.hasPermission(
            at com.sk89q.bukkit.migration.FlatFilePermissionsResolver.hasPermission(
            at com.sk89q.bukkit.migration.PermissionsResolverManager.hasPermission(P
            at com.sk89q.commandbook.CommandBookPlugin.hasPermission(CommandBookPlug
            at com.sk89q.commandbook.CommandBookPlugin$1.hasPermission(CommandBookPl
            at com.sk89q.commandbook.CommandBookPlugin$1.hasPermission(CommandBookPl
            at com.sk89q.minecraft.util.commands.CommandsManager.hasPermission(Comma
            at com.sk89q.minecraft.util.commands.CommandsManager.executeMethod(Comma
            at com.sk89q.minecraft.util.commands.CommandsManager.execute(CommandsMan
            at com.sk89q.commandbook.CommandBookPlugin.onCommand(CommandBookPlugin.j
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:31)
            ... 12 more
    Even by adding the, for example, 'commandbook.who' permission to the 'default' group in the 'perms_groups.txt' (see below), the same exceptions occur.
    default: commandbook.who
  14. Offline


    This is already in.. /tp X,Y,Z ie /tp 5,5,5
  15. Offline


    oh need the "," :) did not see that.
  16. Offline


    Thanks for another great plugin :)
  17. Offline


    When giving /i 1 -1 (infinite) this crashes your client - on reopening the infinite block does not appear.
  18. Offline


    I noticed on the Login Message part, the Current Time is wrong. Any way to control the time on the shown on login?
  19. Offline


    Could not load plugin CommandBook InvalidPluginException

    I had it working before but now it doesn't work. All I did before was edit my entry message, then it stopped working so I deleted everything and tried to reinstall it because I thought I broke something in the config and didn't know how to restore it but now it won't work at all.

    I really miss having the items I give to myself pop up in my inventory instead of in front of me where they could fall in a lava pit and force me to re-enter the command or someone else can take them...
  20. Offline


    Please add a permission based blacklist for what items can be spawned with /i and /give
  21. Offline


    Should make a /ban /kick command for this.
  22. Offline


    And /my
  23. Offline


    Given the trouble I've seen with Mcbans - I would support a ban/kick addition. Along with the necessary /me and /tell fixes.
  24. Hey, I have a little idea for you.
    What about making more data values which can be enabled or disabled?
    Just like instead typing /i woodstairs /i step:wood /i woodplate /i wooddoor, /i woodwhatever
    /i wood:stairs , /i wood:step, /i wood:plate, /i wood:door, /i wood:whatever
    This would be nice because you can also type: /i 5:stairs.
    Don't know if it's good, but maybe it is.
    And please change "tree" to be the base of the tree and not leaves, also please make redstone to redstonedust and redstonetorchon to redstonetorch/ rst. Even better would be an own item database you can edit :/

    Thank you for reading.
  25. Offline


    Blacklist for item spawns would be great. SpawnList did it nicely with per-group allow/disallow lists, but it hasn't been updated for 493 yet.

    WorldGuards blacklist might be able to suffice for now?
  26. Offline

    Jake Radcliff

    How do you define a region? I can't find it on the commands list. Is it //region? //define? How do you do that? Thanks in advance
  27. Offline


    I asked sk89q about a blacklist over his bug/feature tracker and got this reply:

    Hope that helps. I think this means just adding a "disallowed-items:" section to commandbook's config.yml file, but I haven't tried it yet.

    --- merged: Mar 8, 2011 12:18 AM ---
    it's documented in his wiki: http://wiki.sk89q.com/wiki/WorldEdit/Region_operations
  28. Offline


  29. Offline


    It'd be nice to add in a macro to display how many people are online. It'd be a great feature to have for the motd.
  30. Offline

    Geoff Winans

    Why must you spam the forum with this?

    Yes, lets have everyone learn another language (LUA) to port their plugin over to a Closed Source alternative server.

  31. Offline


    Well the main reason I like this server program because it runs 10X better than bukkit or the office mc server. Could have 20 players on and you'd be lucky to see cpu usage go to 5%.
Thread Status:
Not open for further replies.

Share This Page