[GEN/TP/ADMN] CommandBook 1.7 - Essential and useful commands (/item, etc.) [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by sk89q, Feb 28, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    General commands as used on my server since '10. Warping, item giving, time changing, weather changing -- the usual.

    Thor command, one of many (video by Rubenbeebl):

    Note: You can remove any of these commands from CommandBook using the download link below.
    • General:
      • item [-d] <item[:data]> [amount]
      • give [-d] <target> <item[:data]> [amount]
      • more [-a] [-i] <target>
      • online [filter]
      • motd
      • intro (play intro music)
      • midi (play a MIDI file for yourself)
      • rules
      • setspawn [destination]
      • time [world] <time>
      • weather <'stormy'|'sunny'> [duration] [world]
      • thunder <'on'|'off'> [duration] [world]
      • spawnmob [-p] [-d] [-i] [-r] <mob> [count] [location]
      • kit <kit> [target]
    • Teleportation:
      • spawn
      • tp [target] <destination>
      • bring <target>
      • put <target>
      • call <target> (request a teleport)
    • Messaging:
      • broadcast <message>
      • say <message>
      • me <message>
      • msg <target> <message...>
      • reply <message...>
      • mute <target>
      • unmute <target>
    • Player:
      • whereami
      • compass
      • clear [-a] [target]
      • slap [-s] [-h|-v] [-d] [target]
      • rocket [-s] [-h] [target]
      • barrage [-s] [target]
      • shock [-s] [target]
      • thor [target] (get Thor's hammer)
      • unthor [target] (revoke Thor's hammer)
      • whois [target]
    • Utilities:
      • ping
      • debug info
      • debug clock (very accurate server lag benchmark)
    • Bans:
      • kick <target> [reason...]
      • ban [-e] <target> [reason...]
      • unban <target> [reason...]
    Complimentary plugins:


    [​IMG] CommandBook 1.7
    Requirements: Java 6+, WorldEdit, Bukkit build 753+

    You need WorldEdit: Install WorldEdit. If you don't want WorldEdit, put WorldEdit.jar in the root folder of your server or in the plugins/CommandBook folder.​

    If you find CommandBook useful, [​IMG]

    How to Use

    Check out my server too!

    [​IMG] (CommandBook is open source!)
    dragon8510, Psychoma, Goodi and 26 others like this.
  2. Offline


    This plugin is workin' out p. good for me so far man, I really like the range of permissions on the /give command. Also /time is super useful and the coordinate-specific teleport as well.
  3. Offline


    YES! This plugin replaced all of the Essentials pack for me - thank god! +1 for you!
    Jaiden207 likes this.
  4. Offline


    I would like to request /help or some kind of variable of it. It would be so much easier to have a help command that prints a list I can edit, like there was in General. Essentially your /rules command, just named differently.
  5. Offline


    I use the most of this wonderful plugin, but for
    group-specific motd, help, rules etc. I use MCDocs (and My-TP/-Warp/-Home). Perfect team!
    And now, /who from interesting Places works too ;)
  6. Offline



    For help, you can use: http://forums.bukkit.org/threads/info-help-0-1-the-smart-help-menu-440.6536/
  7. Offline


    oh sweet! you added a ping :D
    --- merged: Mar 3, 2011 8:18 PM ---
    Is there any shot on adding timers to some of these commands? Something like /spawn would require 10 mins to reuse same with teleport etc? I'm configuring this now and adding in permissions - I'm very happy with the functionality
    --- merged: Mar 3, 2011 8:30 PM ---
    Another feature request - because I'm a massive nerd from EverQuest ....
    /tell - being the same as /msg - it fells better to tell someone than to whisper :p
  8. Offline


    Thanks [​IMG][​IMG]
  9. Offline


    I love your easter :p
    And I dun't like asian boys :'(

    I am sucha good tester.
  10. Offline


    Ah, very nice! Essentials was way too communist for me [​IMG] No offense to Zenexer though
  11. Offline


    K, I'll add that in.
  12. Offline


    Thank God. This is what it should be. I thought downloading essentials would be easier, but it seems to be more of a headache than downloading separate plugins.
  13. Offline


    Okay here's a bit of a request, is it possible / would it be possible to make it possible to turn off the automatic granting of all plugin permissions to ops? Like I have a couple people opped so they can kick/ban people if trollin/griefing goes down, but I don't necessarily need them being able to like, clear things or have the more-than-1-stack-at-a-time version of give, and that sort of thing.
  14. Offline


    this works perfectly wit cb #493, and the custom build is awesome, i unchecked tp+bring, since using tkellys teleplus.
    thanks a lot!

    btw: lol @ /pong
  15. Offline


    Are there any plans to add /ban, /kick, et al to this plugin? I had been using Essentials, but this (w/ MyHome, MyWarp) has replaced that... and the only thing I seem to be missing is kick/ban/unban.

    I tried finding a simple kick/ban plugin, but wasn't having any luck. Suggestions?
  16. Offline


    Try out Mcbans - its pretty good.
  17. Offline


    Yeah, I can change that.

    In addition to what Kainzo said, I thought MC has a ban system in place too?
  18. Offline


    Ugggghh... All I want is something to /setspawn! Craftessentials(or what ever its called) trashes the permission and your plugin does this:

    2011-03-03 23:34:03 [INFO] Loaded world: world
    2011-03-03 23:34:20 [SEVERE] com.sk89q.minecraft.util.commands.WrappedCommandException: java.lang.NoSuchMethodError: org.bukkit.World.setSpawnLocation(III)Z
    2011-03-03 23:34:20 [SEVERE]    at com.sk89q.minecraft.util.commands.CommandsManager.executeMethod(CommandsManager.java:353)
    2011-03-03 23:34:20 [SEVERE]    at com.sk89q.minecraft.util.commands.CommandsManager.execute(CommandsManager.java:256)
    2011-03-03 23:34:20 [SEVERE]    at com.sk89q.commandbook.CommandBookPlugin.onCommand(CommandBookPlugin.java:161)
    2011-03-03 23:34:20 [SEVERE]    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:19)
    2011-03-03 23:34:20 [SEVERE]    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:77)
    2011-03-03 23:34:20 [SEVERE]    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:176)
    2011-03-03 23:34:20 [SEVERE]    at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:638)
    2011-03-03 23:34:20 [SEVERE]    at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:601)
    2011-03-03 23:34:20 [SEVERE]    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:595)
    2011-03-03 23:34:20 [SEVERE]    at net.minecraft.server.Packet3Chat.a(SourceFile:24)
    2011-03-03 23:34:20 [SEVERE]    at net.minecraft.server.NetworkManager.a(SourceFile:230)
    2011-03-03 23:34:20 [SEVERE]    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:70)
    2011-03-03 23:34:20 [SEVERE]    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    2011-03-03 23:34:20 [SEVERE]    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:338)
    2011-03-03 23:34:20 [SEVERE]    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:253)
    2011-03-03 23:34:20 [SEVERE]    at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    2011-03-03 23:34:20 [SEVERE] Caused by: java.lang.NoSuchMethodError: org.bukkit.World.setSpawnLocation(III)Z
    2011-03-03 23:34:20 [SEVERE]    at com.sk89q.commandbook.GeneralCommands.setspawn(GeneralCommands.java:392)
    2011-03-03 23:34:20 [SEVERE]    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    2011-03-03 23:34:20 [SEVERE]    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    2011-03-03 23:34:20 [SEVERE]    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    2011-03-03 23:34:20 [SEVERE]    at java.lang.reflect.Method.invoke(Unknown Source)
    2011-03-03 23:34:20 [SEVERE]    at com.sk89q.minecraft.util.commands.CommandsManager.executeMethod(CommandsManager.java:343)
    2011-03-03 23:34:20 [SEVERE]    ... 15 more
    I log in, ran /setspawn and this popped up in the console.
  19. Offline


    I'll check out MCBans again... I may have given it too quick of a toss, thinking it strictly a global/net-based ban system. Wasn't too interested in that, but maybe it's okay.

    For the latter, as an OP, I can ban. But I preferred not giving OP to others and relying more on plugins to provide for non-owner permissions. (Actually, I would even prefer not op-ping myself, but there are a few administrative tasks that simply require op.)

    EDIT: Okay, MCBans installed; looks good. Guess I looked it over too quickly before.
  20. Offline


    You need to update your craftbukkit machete.
  21. Offline


    Issue #1:
    /me <msg> has not "command" system - all users on the server can use it despite not having the permissions.
    Can Commandbook wrap around this command so it can be a cmdbook.me permission?
  22. Offline


    from console, tried to give a player a pumpkin using item: item pumpkin player
    not a needed ability, but you should have some error-checking for that
  23. Offline


    Can't make it to work on my server. I've tried with the WorldEdit.jar in root, ./plugins and ./plugins/CommandBook as described in the OP.

    Removed all plugins, with only WorldEdit and CommandBook, same error.

    Bukkit Build 440 -> 493
    commandbook 1.1
    Worldedit 4.0b8

    Is it broken or am I missing something ?

    2011-03-04 07:22:57 [SEVERE] Could not load plugins/CommandBook.jar in plugins: null
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:80)
            at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:129)
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:94)
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:59)
            at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:204)
            at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:191)
            at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:131)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.lang.NoClassDefFoundError: com/sk89q/minecraft/util/commands/CommandPermissionsException
            at java.lang.Class.forName0(Native Method)
            at java.lang.Class.forName(Class.java:247)
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:72)
            ... 8 more
    Caused by: java.lang.ClassNotFoundException: com.sk89q.minecraft.util.commands.CommandPermissionsException
            at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:30)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
            ... 11 more
  24. Offline


    Does this work on CB 493?
  25. Offline


    Thanks! :) I'll do that
    --- merged: Mar 4, 2011 2:32 PM ---
    Wait a sec... isnt that for linux? I have the latest for windows.

    Hood on again... :-p I have it...
    craftbukkit-0.0.1-snapshot.jar right?
  26. Offline


    Go to ci.bukkit.org and get the latest one (493).
  27. Offline


    Tested against 493 - about 2 days ago. This works without error. Please remove essentials/general or any other plugin that would use the same commands.
  28. Offline


    Ok, So I downloaded lik you said. Now the server wont start. I get this message
    Exception in thread "main" java.lang.NoClassDefFoundError: joptsimple/OptionExce
    Caused by: java.lang.ClassNotFoundException: joptsimple.OptionException
            at java.net.URLClassLoader$1.run(Unknown Source)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.net.URLClassLoader.findClass(Unknown Source)
            at java.lang.ClassLoader.loadClass(Unknown Source)
            at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
            at java.lang.ClassLoader.loadClass(Unknown Source)
    Could not find the main class: org.bukkit.craftbukkit.Main. Program will exit.
    Unable to access jarfile C:\Program Files (x86)\Minecraft\bukkit\plugins\LWC.jar
    Unable to access jarfile C:\Program Files (x86)\Minecraft\bukkit\plugins\WorldGu
    Unable to access jarfile C:\Program Files (x86)\Minecraft\bukkit\plugins\iConomy
    Unable to access jarfile C:\Program Files (x86)\Minecraft\bukkit\plugins\WorldEd
    Unable to access jarfile C:\Program Files (x86)\Minecraft\bukkit\plugins\WorldGu
    Unable to access jarfile C:\Program Files (x86)\Minecraft\bukkit\plugins\Permiss
    Unable to access jarfile C:\Program Files (x86)\Minecraft\bukkit\plugins\iconomy
    Unable to access jarfile C:\Program Files (x86)\Minecraft\bukkit\plugins\towny.j
    Unable to access jarfile C:\Program Files (x86)\Minecraft\bukkit\plugins\Command
    Press any key to continue . . .
    I'm running windows server.
    --- merged: Mar 4, 2011 3:03 PM ---
    EDIT: Update! While you were posting this they updated to (494) so that what I had when I got these errors. I found (493). It is all working fine now including your pluging(which is awesome BTW).

    Thank you sooo much for the help. :D
  29. Offline


    Looks like an access problem - write permissions or something.
  30. Offline


    I cant use /setspawn :(
    But other command from Worldedit and CommandBoook works perfectly.

    CraftBukkit: 444
    Worldedit: newest

    Error in console:
    2011-03-04 17:55:15 [SEVERE] com.sk89q.minecraft.util.commands.WrappedCommandException: java.lang.NoSuchMethodError: org.bukkit.World.setSpawnLocation(III)Z
    2011-03-04 17:55:15 [SEVERE] at com.sk89q.minecraft.util.commands.CommandsManager.executeMethod(CommandsManager.java:353)
    2011-03-04 17:55:15 [SEVERE] at com.sk89q.minecraft.util.commands.CommandsManager.execute(CommandsManager.java:256)
    2011-03-04 17:55:15 [SEVERE] at com.sk89q.commandbook.CommandBookPlugin.onCommand(CommandBookPlugin.java:161)
    2011-03-04 17:55:15 [SEVERE] at org.bukkit.command.PluginCommand.execute(PluginCommand.java:19)
    2011-03-04 17:55:15 [SEVERE] at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:77)
    2011-03-04 17:55:15 [SEVERE] at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:177)
    2011-03-04 17:55:15 [SEVERE] at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:638)
    2011-03-04 17:55:15 [SEVERE] at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:601)
    2011-03-04 17:55:15 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:595)
    2011-03-04 17:55:15 [SEVERE] at net.minecraft.server.Packet3Chat.a(SourceFile:24)
    2011-03-04 17:55:15 [SEVERE] at net.minecraft.server.NetworkManager.a(SourceFile:230)
    2011-03-04 17:55:15 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:70)
    2011-03-04 17:55:15 [SEVERE] at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    2011-03-04 17:55:15 [SEVERE] at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:349)
    2011-03-04 17:55:15 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:264)
    2011-03-04 17:55:15 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    2011-03-04 17:55:15 [SEVERE] Caused by: java.lang.NoSuchMethodError: org.bukkit.World.setSpawnLocation(III)Z
    2011-03-04 17:55:15 [SEVERE] at com.sk89q.commandbook.GeneralCommands.setspawn(GeneralCommands.java:392)
    2011-03-04 17:55:15 [SEVERE] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    2011-03-04 17:55:15 [SEVERE] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    2011-03-04 17:55:15 [SEVERE] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    2011-03-04 17:55:15 [SEVERE] at java.lang.reflect.Method.invoke(Method.java:616)
    2011-03-04 17:55:15 [SEVERE] at com.sk89q.minecraft.util.commands.CommandsManager.executeMethod(CommandsManager.java:343)
    2011-03-04 17:55:15 [SEVERE] ... 15 more
  31. Offline


    To quote the OP.

    Update to the latest recommended build 493.
Thread Status:
Not open for further replies.

Share This Page