[GEN/TP/ADMN] CommandBook 1.7 - Essential and useful commands (/item, etc.) [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by sk89q, Feb 28, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    General commands as used on my server since '10. Warping, item giving, time changing, weather changing -- the usual.

    Thor command, one of many (video by Rubenbeebl):

    Note: You can remove any of these commands from CommandBook using the download link below.
    • General:
      • item [-d] <item[:data]> [amount]
      • give [-d] <target> <item[:data]> [amount]
      • more [-a] [-i] <target>
      • online [filter]
      • motd
      • intro (play intro music)
      • midi (play a MIDI file for yourself)
      • rules
      • setspawn [destination]
      • time [world] <time>
      • weather <'stormy'|'sunny'> [duration] [world]
      • thunder <'on'|'off'> [duration] [world]
      • spawnmob [-p] [-d] [-i] [-r] <mob> [count] [location]
      • kit <kit> [target]
    • Teleportation:
      • spawn
      • tp [target] <destination>
      • bring <target>
      • put <target>
      • call <target> (request a teleport)
    • Messaging:
      • broadcast <message>
      • say <message>
      • me <message>
      • msg <target> <message...>
      • reply <message...>
      • mute <target>
      • unmute <target>
    • Player:
      • whereami
      • compass
      • clear [-a] [target]
      • slap [-s] [-h|-v] [-d] [target]
      • rocket [-s] [-h] [target]
      • barrage [-s] [target]
      • shock [-s] [target]
      • thor [target] (get Thor's hammer)
      • unthor [target] (revoke Thor's hammer)
      • whois [target]
    • Utilities:
      • ping
      • debug info
      • debug clock (very accurate server lag benchmark)
    • Bans:
      • kick <target> [reason...]
      • ban [-e] <target> [reason...]
      • unban <target> [reason...]
    Complimentary plugins:


    [​IMG] CommandBook 1.7
    Requirements: Java 6+, WorldEdit, Bukkit build 753+

    You need WorldEdit: Install WorldEdit. If you don't want WorldEdit, put WorldEdit.jar in the root folder of your server or in the plugins/CommandBook folder.​

    If you find CommandBook useful, [​IMG]

    How to Use

    Check out my server too!

    [​IMG] (CommandBook is open source!)
    dragon8510, Psychoma, Goodi and 26 others like this.
  2. Offline


    One of my mods attempted a TP, then I attempted a /put:
    2011-05-12 09:05:09 [SEVERE] com.sk89q.minecraft.util.commands.WrappedCommandException: java.lang.NoClassDefFoundError: com/sk89q/commandbook/util/TeleportPlayerIterator
    2011-05-12 09:05:09 [SEVERE] 	at com.sk89q.minecraft.util.commands.CommandsManager.executeMethod(CommandsManager.java:353)
    2011-05-12 09:05:09 [SEVERE] 	at com.sk89q.minecraft.util.commands.CommandsManager.execute(CommandsManager.java:256)
    2011-05-12 09:05:09 [SEVERE] 	at com.sk89q.commandbook.CommandBookPlugin.onCommand(CommandBookPlugin.java:241)
    2011-05-12 09:05:09 [SEVERE] 	at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    2011-05-12 09:05:09 [SEVERE] 	at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:85)
    2011-05-12 09:05:09 [SEVERE] 	at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:278)
    2011-05-12 09:05:09 [SEVERE] 	at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:682)
    2011-05-12 09:05:09 [SEVERE] 	at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:645)
    2011-05-12 09:05:09 [SEVERE] 	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:639)
    2011-05-12 09:05:09 [SEVERE] 	at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:32)
    2011-05-12 09:05:09 [SEVERE] 	at net.minecraft.server.NetworkManager.a(NetworkManager.java:196)
    2011-05-12 09:05:09 [SEVERE] 	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    2011-05-12 09:05:09 [SEVERE] 	at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    2011-05-12 09:05:09 [SEVERE] 	at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:372)
    2011-05-12 09:05:09 [SEVERE] 	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:287)
    2011-05-12 09:05:09 [SEVERE] 	at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    2011-05-12 09:05:09 [SEVERE] Caused by: java.lang.NoClassDefFoundError: com/sk89q/commandbook/util/TeleportPlayerIterator
    2011-05-12 09:05:09 [SEVERE] 	at com.sk89q.commandbook.commands.TeleportCommands.teleport(TeleportCommands.java:101)
    2011-05-12 09:05:09 [SEVERE] 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    2011-05-12 09:05:09 [SEVERE] 	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    2011-05-12 09:05:09 [SEVERE] 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    2011-05-12 09:05:09 [SEVERE] 	at java.lang.reflect.Method.invoke(Unknown Source)
    2011-05-12 09:05:09 [SEVERE] 	at com.sk89q.minecraft.util.commands.CommandsManager.executeMethod(CommandsManager.java:343)
    2011-05-12 09:05:09 [SEVERE] 	... 15 more
    2011-05-12 09:05:09 [SEVERE] Caused by: java.lang.ClassNotFoundException: com.sk89q.commandbook.util.TeleportPlayerIterator
    2011-05-12 09:05:09 [SEVERE] 	at java.net.URLClassLoader$1.run(Unknown Source)
    2011-05-12 09:05:09 [SEVERE] 	at java.security.AccessController.doPrivileged(Native Method)
    2011-05-12 09:05:09 [SEVERE] 	at java.net.URLClassLoader.findClass(Unknown Source)
    2011-05-12 09:05:09 [SEVERE] 	at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
    2011-05-12 09:05:09 [SEVERE] 	at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
    2011-05-12 09:05:09 [SEVERE] 	at java.lang.ClassLoader.loadClass(Unknown Source)
    2011-05-12 09:05:09 [SEVERE] 	at java.lang.ClassLoader.loadClass(Unknown Source)
    2011-05-12 09:05:09 [SEVERE] 	... 21 more
    2011-05-12 09:05:12 [SEVERE] com.sk89q.minecraft.util.commands.WrappedCommandException: java.lang.NoClassDefFoundError: com/sk89q/commandbook/commands/TeleportCommands$2
    2011-05-12 09:05:12 [SEVERE] 	at com.sk89q.minecraft.util.commands.CommandsManager.executeMethod(CommandsManager.java:353)
    2011-05-12 09:05:12 [SEVERE] 	at com.sk89q.minecraft.util.commands.CommandsManager.execute(CommandsManager.java:256)
    2011-05-12 09:05:12 [SEVERE] 	at com.sk89q.commandbook.CommandBookPlugin.onCommand(CommandBookPlugin.java:241)
    2011-05-12 09:05:12 [SEVERE] 	at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    2011-05-12 09:05:12 [SEVERE] 	at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:85)
    2011-05-12 09:05:12 [SEVERE] 	at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:278)
    2011-05-12 09:05:12 [SEVERE] 	at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:682)
    2011-05-12 09:05:12 [SEVERE] 	at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:645)
    2011-05-12 09:05:12 [SEVERE] 	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:639)
    2011-05-12 09:05:12 [SEVERE] 	at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:32)
    2011-05-12 09:05:12 [SEVERE] 	at net.minecraft.server.NetworkManager.a(NetworkManager.java:196)
    2011-05-12 09:05:12 [SEVERE] 	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    2011-05-12 09:05:12 [SEVERE] 	at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    2011-05-12 09:05:12 [SEVERE] 	at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:372)
    2011-05-12 09:05:12 [SEVERE] 	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:287)
    2011-05-12 09:05:12 [SEVERE] 	at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    2011-05-12 09:05:12 [SEVERE] Caused by: java.lang.NoClassDefFoundError: com/sk89q/commandbook/commands/TeleportCommands$2
    2011-05-12 09:05:12 [SEVERE] 	at com.sk89q.commandbook.commands.TeleportCommands.put(TeleportCommands.java:163)
    2011-05-12 09:05:12 [SEVERE] 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    2011-05-12 09:05:12 [SEVERE] 	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    2011-05-12 09:05:12 [SEVERE] 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    2011-05-12 09:05:12 [SEVERE] 	at java.lang.reflect.Method.invoke(Unknown Source)
    2011-05-12 09:05:12 [SEVERE] 	at com.sk89q.minecraft.util.commands.CommandsManager.executeMethod(CommandsManager.java:343)
    2011-05-12 09:05:12 [SEVERE] 	... 15 more
    2011-05-12 09:05:12 [SEVERE] Caused by: java.lang.ClassNotFoundException: com.sk89q.commandbook.commands.TeleportCommands$2
    2011-05-12 09:05:12 [SEVERE] 	at java.net.URLClassLoader$1.run(Unknown Source)
    2011-05-12 09:05:12 [SEVERE] 	at java.security.AccessController.doPrivileged(Native Method)
    2011-05-12 09:05:12 [SEVERE] 	at java.net.URLClassLoader.findClass(Unknown Source)
    2011-05-12 09:05:12 [SEVERE] 	at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
    2011-05-12 09:05:12 [SEVERE] 	at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
    2011-05-12 09:05:12 [SEVERE] 	at java.lang.ClassLoader.loadClass(Unknown Source)
    2011-05-12 09:05:12 [SEVERE] 	at java.lang.ClassLoader.loadClass(Unknown Source)
    2011-05-12 09:05:12 [SEVERE] 	... 21 more
    2011-05-12 09:05:25 [SEVERE] com.sk89q.minecraft.util.commands.WrappedCommandException: java.lang.NoClassDefFoundError: com/sk89q/commandbook/util/TeleportPlayerIterator
    2011-05-12 09:05:25 [SEVERE] 	at com.sk89q.minecraft.util.commands.CommandsManager.executeMethod(CommandsManager.java:353)
    2011-05-12 09:05:25 [SEVERE] 	at com.sk89q.minecraft.util.commands.CommandsManager.execute(CommandsManager.java:256)
    2011-05-12 09:05:26 [SEVERE] 	at com.sk89q.commandbook.CommandBookPlugin.onCommand(CommandBookPlugin.java:241)
    2011-05-12 09:05:26 [SEVERE] 	at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    2011-05-12 09:05:26 [SEVERE] 	at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:85)
    2011-05-12 09:05:26 [SEVERE] 	at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:278)
    2011-05-12 09:05:26 [SEVERE] 	at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:682)
    2011-05-12 09:05:26 [SEVERE] 	at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:645)
    2011-05-12 09:05:26 [SEVERE] 	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:639)
    2011-05-12 09:05:26 [SEVERE] 	at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:32)
    2011-05-12 09:05:26 [SEVERE] 	at net.minecraft.server.NetworkManager.a(NetworkManager.java:196)
    2011-05-12 09:05:26 [SEVERE] 	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    2011-05-12 09:05:26 [SEVERE] 	at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    2011-05-12 09:05:26 [SEVERE] 	at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:372)
    2011-05-12 09:05:26 [SEVERE] 	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:287)
    2011-05-12 09:05:26 [SEVERE] 	at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    2011-05-12 09:05:26 [SEVERE] Caused by: java.lang.NoClassDefFoundError: com/sk89q/commandbook/util/TeleportPlayerIterator
    2011-05-12 09:05:26 [SEVERE] 	at com.sk89q.commandbook.commands.TeleportCommands.teleport(TeleportCommands.java:101)
    2011-05-12 09:05:26 [SEVERE] 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    2011-05-12 09:05:26 [SEVERE] 	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    2011-05-12 09:05:26 [SEVERE] 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    2011-05-12 09:05:26 [SEVERE] 	at java.lang.reflect.Method.invoke(Unknown Source)
    2011-05-12 09:05:26 [SEVERE] 	at com.sk89q.minecraft.util.commands.CommandsManager.executeMethod(CommandsManager.java:343)
    2011-05-12 09:05:26 [SEVERE] 	... 15 more
    I then expressed my upset:
    2011-05-12 09:05:28 [INFO] [ALL] UnimportantHero » OH WILLIES
    Version info:
    CB766, CommandBook 1.51 Customised
  3. Offline


    Each time i use "/thor" command, Worlguard make this error :
    13:11:26 [SEVERE] Could not pass event LIGHTNING_STRIKE to WorldGuard
    java.lang.NoSuchMethodError: org.bukkit.event.weather.LightningStrikeEvent.getLightning()Lorg/bukkit/entity/Entity;
            at com.sk89q.worldguard.bukkit.WorldGuardWeatherListener.onLightningStrike(WorldGuardWeatherListener.java:114)
            at org.bukkit.plugin.java.JavaPluginLoader$68.execute(JavaPluginLoader.java:647)
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:289)
            at net.minecraft.server.WorldServer.a(WorldServer.java:113)
            at org.bukkit.craftbukkit.CraftWorld.strikeLightning(CraftWorld.java:370)
            at com.sk89q.commandbook.CommandBookPlayerListener.onPlayerInteract(CommandBookPlayerListener.java:191)
            at org.bukkit.plugin.java.JavaPluginLoader$9.execute(JavaPluginLoader.java:280)
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:289)
            at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:162)
            at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:133)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:749)
            at net.minecraft.server.Packet18ArmAnimation.a(SourceFile:35)
            at net.minecraft.server.NetworkManager.a(NetworkManager.java:196)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:372)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:287)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
  4. Offline


    I'm using the latest worldedit and commandbook, (worldedit 4.4 and commandbook 1.5.1 respectively.)
    2011-05-12 01:30:07 [INFO] WorldEdit: IceMageAK: remove items 999
    2011-05-12 01:30:07 [SEVERE] java.lang.IllegalAccessError: tried to access class com.sk89q.worldedit.bukkit.BukkitWorld$1 from class com.sk89q.worldedit.bukkit.BukkitWorld
    2011-05-12 01:30:07 [SEVERE]     at com.sk89q.worldedit.bukkit.BukkitWorld.removeEntities(BukkitWorld.java:423)
    2011-05-12 01:30:07 [SEVERE]     at com.sk89q.worldedit.commands.UtilityCommands.remove(UtilityCommands.java:371)
    2011-05-12 01:30:07 [SEVERE]     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    2011-05-12 01:30:07 [SEVERE]     at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    2011-05-12 01:30:07 [SEVERE]     at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    2011-05-12 01:30:07 [SEVERE]     at java.lang.reflect.Method.invoke(Unknown Source)
    2011-05-12 01:30:07 [SEVERE]     at com.sk89q.minecraft.util.commands.CommandsManager.executeMethod(CommandsManager.java:343)
    2011-05-12 01:30:07 [SEVERE]     at com.sk89q.minecraft.util.commands.CommandsManager.execute(CommandsManager.java:272)
    2011-05-12 01:30:07 [SEVERE]     at com.sk89q.worldedit.WorldEdit.handleCommand(WorldEdit.java:966)
    2011-05-12 01:30:07 [SEVERE]     at com.sk89q.worldedit.bukkit.WorldEditPlayerListener.onPlayerCommandPreprocess(WorldEditPlayerListener.java:94)
    2011-05-12 01:30:07 [SEVERE]     at org.bukkit.plugin.java.JavaPluginLoader$5.execute(JavaPluginLoader.java:230)
    2011-05-12 01:30:07 [SEVERE]     at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
    2011-05-12 01:30:07 [SEVERE]     at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:257)
    2011-05-12 01:30:07 [SEVERE]     at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:669)
    2011-05-12 01:30:07 [SEVERE]     at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:640)
    2011-05-12 01:30:07 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:634)
    2011-05-12 01:30:07 [SEVERE]     at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:32)
    2011-05-12 01:30:07 [SEVERE]     at net.minecraft.server.NetworkManager.a(NetworkManager.java:195)
    2011-05-12 01:30:07 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:74)
    2011-05-12 01:30:07 [SEVERE]     at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    2011-05-12 01:30:07 [SEVERE]     at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:370)
    2011-05-12 01:30:07 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:285)
    2011-05-12 01:30:07 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:394
  5. Offline


    CommandBook fucks with the Whoareyou plugin. I blocked commandbook.who permissions and removed op permissions too, but it either blocks permissions for whoareyou too, or it just prioritizes itself so high that I can't access the whoareyou commands even though I have perms for them.
  6. Offline


    Well then why don't you customise it and remove /who from commandbook?
  7. Offline


    What?! How?
  8. Offline


    See the Opening post for the customisation link ;)
  9. Offline


    Suggestion. Got this idea from James Bond, well, kinda.
    Give someone a "Cigar" that explodes.
    Basically the chat would say: Player1 Gave Player2 a Cigar lit it.
    Then the player would get the reaction of a tnt exploding, but no area or entity damage. Just the push back.
  10. Offline

    robert stientra

    Could Someone plz help me im a dumbass and i dont know how to get permission to use commands could someone
    plz help me
  11. Offline


    Awesome plugin as always, sk89q. However, with your adding of the midi command, I've run into a conflict issue. Even with the customised version with it stripped out, it seems to override/block the usage of /midi by the plugin MidiBanks. We rely on this on our server, as it provides a more complete package for midi handling. I'm not sure why, with your customised version, it would still conflict. Any ideas?
  12. Offline


    03:08:38 [SEVERE] Nag author: '<NoAuthorGiven>' of 'CommandBook' about the following: This plugin is not properly shutting down its async tasks when it is being reloaded. This may cause conflicts with the newly loaded version of the plugin
  13. Offline


    Make sure that the midi command is really gone from the plugin.yml inside the CommandBook.jar. You might have forgotten to overwrite the file or something.
    Eh, it's fixed in 4.5.
  14. Offline


    Hi, I really love this plugin and was wondering if anyone could help me with getting coloured names in the online list working as many of my server's users find it useful.
    I have Permissions 2.7.3, HeroChat v4.10.3 and WorldEdit 4.4 installed along with CommandBook 1.5.
    Below is the permissions YML code (minus the users):
            system: default
            copies: null
            default: true
                prefix: '&b(Newbie) &a'
                suffix: ''
                build: false
                rank: 1
            inheritance: null
            permissions: null
            default: false
                prefix: '&a'
                suffix: ''
                build: true
                rank: 2
            inheritance: null
            permissions: null
            default: false
                prefix: '&6'
                suffix: ''
                build: true
            - Player
            - herochat.admin
            - p2.promote
            default: false
                prefix: '&c'
                suffix: ''
                build: true
            inheritance: null
            - '*'
    As you can see each group has been assigned a colour in the prefix with the exception of 'Newbie' which has a label as well.
    Below is the CommandBook YML code:
    # Give ops all permissions
    op-permissions: true
    use-display-names: true
    online-on-join: true
        colored-names: true
        grouped-names: false
        show-max-players: true
    verify-name-format: true
    motd: |
        Hello, %cname%`w.
        Welcome ********'s server.
        The time now is `Y%time%`w and you're in world '%world%'.
    rules: |
        - Be courteous and respect others.
        - Don't use any tools to give you an unfair advantage.
    # Force use of commandbook.items.<id> permissions for allowed/disallowed items
    item-permissions-only: false
    disallowed-items: []
    allowed-items: []
        goldblock: 41
        ice: 79
    # Makes /time and /weather broadcast a message
    broadcast-changes: false
    console-say-format: "<`r*Console`w> %s"
    broadcast-format: "`r[Broadcast] %s"
    default-item-stack-size: 1
    # As of writing, this does NOT fix spawning on first join (yet)
    exact-spawn: false
        # Example time lock:
    And here is the HeroChat YML:
        separate-chat-log: false
        incoming-tell-format: '&8From {player}: &d'
        - \bu+\W*m+a+d+(\W*br(a|o)+)?
        - fuck;fudge
        plugin-tag: '§e[HeroChat] '
        craftIRC-prefix: '#'
        outgoing-tell-format: '&8To {receiver}: &d'
        default-channel: Global
        default-message-format: '{color}[{nick}] {prefix}{player}{suffix}{color}: '
        craftIRC-message-format: '[{nick}] {player}: '
            local-distance: 100
            color: YELLOW
            nickname: l
                speak: []
                join: []
            message-format: '&f{prefix}{player}{suffix}{color}: '
                game-to-IRC: []
                IRC-to-game: []
            worlds: []
            password: ''
                bans: []
                moderators: []
                hidden: false
                shortcut-allowed: true
                auto-join: true
                local: true
                cross-world-chat: true
                join-messages: false
                forced: false
            color: LIGHT_GREEN
            nickname: staff
                speak: []
                - Admins
                - Moderator
            message-format: '{default}'
                game-to-IRC: []
                IRC-to-game: []
            worlds: []
            password: ''
                bans: []
                moderators: []
                hidden: true
                shortcut-allowed: true
                auto-join: true
                local: false
                cross-world-chat: true
                join-messages: true
                forced: false
            color: ROSE
            nickname: alert
                - Admins
                - Moderator
                join: []
            message-format: '&4[ALERT]{color}: '
                game-to-IRC: []
                IRC-to-game: []
            worlds: []
            password: ''
                bans: []
                moderators: []
                hidden: false
                shortcut-allowed: true
                auto-join: true
                local: false
                cross-world-chat: true
                join-messages: false
                forced: true
            color: LIGHT_GRAY
            nickname: g
                speak: []
                join: []
            message-format: '{default}'
                game-to-IRC: []
                IRC-to-game: []
            worlds: []
            password: ''
                bans: []
                moderators: []
                hidden: false
                shortcut-allowed: true
                auto-join: true
                local: false
                cross-world-chat: true
                join-messages: false
                forced: false
            color: LIGHT_BLUE
            nickname: h
                speak: []
                join: []
            message-format: '{default}'
                game-to-IRC: []
                IRC-to-game: []
            worlds: []
            password: ''
                bans: []
                moderators: []
                hidden: false
                shortcut-allowed: true
                auto-join: true
                local: false
                cross-world-chat: true
                join-messages: false
                forced: false
    Any and all advice and help would be much appreciated.
    Thanks in advance.
  15. Offline


    It was from a fresh install. Every update, I move my current version and config folder to a backup folder, incase there's an issue and I have to revert. I'll try it again though. Additionally, the no intro.mid warnings were still there from the customizer.

    Edit: Tried again. Still no luck. Unchecking both midi and intro in the customizer still has intro playing, but midi and intro commands return nothing. However, the midibank plugin's usage of /midi also returns nothing. I remove commandbook, it midibank's command works again. This is from another fresh install.
  16. Offline


    @ sk89q

    One suggestion .. can u please implement to the config Hide-players-from-list or somethin like that ?

    I'm hiting on feature of this plugin .

    This will be very usefull with vanish admins, stealth login, etc.

    Thank you, great hard work ! [cake]
  17. Offline


    Any chance of adding a "/ban-ip" command? Having players come back to grief with diff names after I logout is no fun.
  18. Offline


    Wait for the next release.
  19. awesome plugin bro but i only have one complaint srry my players and admin aren't albe to build at near places i use /setspawn anyway to fix this?:confused:
  20. Offline


    Any way to send the user a special message on first login?
  21. Offline


    Set your spawn-protection to 0 in your server.properties file.

    Edit - Do keep in mind that if you spawn in a block, you will take damage until you die over and over again.
    XCaptainDoogulsX likes this.
  22. Offline


    Does this work for the 766 version?
  23. Offline


    Using /midi <song> gives me this:
    17:32:35 [SEVERE] Exception in thread "JingleNotePlayer for yottabyte"
    17:32:35 [SEVERE] java.lang.NoSuchMethodError: org.bukkit.entity.Player.sendBlockChange(Lorg/bukkit/Location;IB)V
    17:32:35 [SEVERE]       at com.sk89q.jinglenote.JingleNotePlayer.run(JingleNotePlayer.java:36)
    17:32:35 [SEVERE]       at java.lang.Thread.run(Thread.java:636)
    Edit: Oh, I guess it's because I'm still on build 740 :oops:
  24. Offline


    Yep, he didn't add the code until 752 so you will need 753+.
  25. Offline


    Hello i have a request to add a command like /tban name reason time(in min) to temporarily ban someone Please post what you think. and can the plugin writer please add it :)
  26. Offline


    for some reason time is moving very slowly on my server, is this related to commandbook somehow?
  27. ty very much
  28. Offline


    disregard that, i figured out what the issue was
  29. Offline


    I suggest MCBans, they have temporary bans, local bans just on your server, and global bans that every server that uses mcbans can see. You can find the website here, and the download here.

    On topic: Yeah I got nothing except this looks like a great plugin I'm going to try out :D
  30. Offline


    2011-05-17 16:58:02 [SEVERE] Could not load 'plugins\CommandBook.jar' in folder 'plugins':
    unacceptable character #FFFD special characters are not allowed
    in "<reader>", position 346
     at org.yaml.snakeyaml.reader.StreamReader.checkPrintable(StreamReader.java:68)
     at org.yaml.snakeyaml.reader.StreamReader.update(StreamReader.java:159)
     at org.yaml.snakeyaml.reader.StreamReader.peek(StreamReader.java:117)
     at org.yaml.snakeyaml.reader.StreamReader.peek(StreamReader.java:106)
     at org.yaml.snakeyaml.scanner.ScannerImpl.scanToNextToken(ScannerImpl.java:964)
     at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(ScannerImpl.java:237)
     at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:183)
     at org.yaml.snakeyaml.parser.ParserImpl$ParseImplicitDocumentStart.produce(ParserImpl.java:200)
     at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:163)
     at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:148)
     at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:104)
     at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:124)
     at org.yaml.snakeyaml.Yaml.load(Yaml.java:264)
     at org.bukkit.util.config.Configuration.load(Configuration.java:73)
     at org.bukkit.plugin.java.JavaPlugin.initialize(JavaPlugin.java:158)
     at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:166)
     at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:191)
     at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:115)
     at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:100)
     at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:218)
     at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:205)
     at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:145)
     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:260)
     at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    who can help me?
  31. Offline


    Sorry but i have no more room for plugins really so i would rather this plugin to do it :)
Thread Status:
Not open for further replies.

Share This Page