[GEN/SEC/ECON/TP/ADMN] Essentials - A collection of useful commands

Discussion in 'Archived: Plugin Releases' started by EssentialsTeam, Apr 30, 2011.

  1. Offline


    Hello Essentials experts how disabled Nether portals or doing group permissions after MC 1.0 can all use them and I can not disable them
  2. Offline


    well i found the problem but now i my members cant pick it up how come?
    and i am wondering what permissions could cause these problem :/
  3. Offline


  4. Offline


    Ohh right butcher is worldedit/etc...

    Heres one slight bug... I'm an admin (owner) on my server. My Admin group is setup with the '*' as permissions, gives me all.. well not quite. Sure I have access to all the essentials commands, but it doesnt give me access to all my OTHER plugins. For example... im using a mod request tool and i cant use the moderator/admin parts of it. Even if i add - modtrs.* it doesnt let it work. I found out that if i REMOVE the - '*' from my permissions (which is really the only thing listed) it works, but then i cant use all the essentials commands... so slight bug.

    I can either deal with it and not use some of the other plugins, OR i have to manually add all the essentials groups onto the plugin list since the * doesnt work

    UPDATE: If i do essentials.* rather then the * it works fine it seems.

    So just noticed a big flaw in the latest dev release of essentials... when you do /sell hand - and you have an enchanted item such as a sword, it sells it but keeps it in your inventory and you can keep selling it

    I had one person who had an enchanted sword, he kept doing /sell hand and it kept giving him money and never took the item

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  5. Offline


    how do re-enables explosions?????? private message me please =D
  6. Offline


    can somebody maybe add a new feature about "warp" ?
    cause i just want allow to see players warps only not all warp points

    User can invite player to your warp point
    /warpinvite <WarpName> <UserName>

    User can uninvite player to your warp point
    /warpuninvite <WarpName> <UserName>

    And maybe the "essentials.warp.public" Vesion also ?

    i am inspired by MyHome :D

    nope, i wonna give that option to rightklick for users
    inspired by SpwanerAdjuster

    essentials.spawner.adjust.* neutral
    essentials.spawner.adjust.* enemy
    essentials.spawner.adjust.* config

    config text :
    # groups are allowed to change spawner manually by right klick them by essentials.spawner.config
    spawnerPig: true
    spawnerCow: true
    spawnerEnderman: true
    spawnerSpider: true

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  7. Offline


    were do we find all the commands
  8. Offline


    Having a bit of a problem with the essentials.gamemode permission, I gave it to my vips and gave essentials.gamemode.others to my admins. Buy mt vips can change other players gamemode. Ive check through my permissions config and everything is fine. I'm using groupmanager.
  9. Offline


    Im having problems with the plugin , im new in this plugin and bukkit thing , so ive installed essentials , and i wanna know :

    1.How do i set myself as an admin
    2.Why cant i do commands such as /bigtree or /setwarp .
  10. Offline


    I've installed Essentials and GroupManager. I've set up the permissions fine and every group can access the correct commands I've set.

    Building on the default account is Build: False which is what I want as I do not want them to be able to. It says that you do not have permission to build.

    However when I use the other groups including admin and owner it still does not allow me to build anything, but this time it doesn't say that I do not have permission to build. It just immediately takes away any block I place. The build is set to true.

    Essentials and GroupManager are the only plugins I have so it cannot be conflicting plugins. The blocks place fine when I set people to OP but for obvious reasons that defeats GroupManagers objective as it gives people access to every command.

    Does anyone know what's wrong or if I might be doing something wrong?

    Edit: Never mind I realised it was my own fault and I can't build in the spawn.
  11. Offline


    On the /spawner command, what are all the valid names for the Mobs? As /spawner blaze and /spawner snowgolem dont work. So can someone make a list of the mobs I can enter? Thanks!
  12. Offline


    So I'm using PermissionsEX with this, and I didn't have this problem with the other build of Essentials I was using, but when I upgraded to the latest recommended build, whenever I press tab, I get the prefix (group) next to someone's name instead. I copied the userdata from my old essentials to this new one, and it didn't go so well, even after I took them out. Here's a picture.


    Do you think updating to the latest Dev Build of CraftBukkit would fix this?
  13. Offline


  14. Offline


    @xBladeM6x It's fixed in the dev builds of Essentials
    @TheLegacyP7 In the dev builds of Essentials, /spawner returns a list of available Mobs.
  15. Offline


    ive had a major bug in my server: anyone can op themselves no matter what
  16. I run Citizens with GM and havn't seen this behavior. However, it is quite possible as Citizens creates fake players.
    If your Citizens is fully upto date and you are still experiencing this problem, then promote the Citizen NPC's to any group other than the default. This will stop the auto group addition upon login.
  17. Offline


    Bukkit doesn't allow me to use the /xp command anymore. I was going to use it to test out pickaxe enchantments. Any reason why?
  18. Offline


    Beds are not working with essentials spawn
  19. Offline


    Why doesnt my /give work?
    here is the error code: Error: org.bukkit.inventory.ItemStack.getEnchantments()Ljava/util/Map;
    my plugins are:
    and /give was working fine earlier, i have no idea whats wrong. Thanks
    ********************************* EDIT
    /spawnmob doesnt work too error code: could not initialize class com.earth2me.essentials.Mob
    ***********************************EDIT 2
    Yeah, fixed it, that new update breaks it, EVERYBODY dont download the new update that immenint fates craft bukkit tells you too, it breaks alot of commands
  20. Offline


    My /spawnmob is currently broken as of the last couple dev builds.

    Error: Unable to spawn mob. Nothing comes up in the log.

    It works fine while OP'd and yes I do have the correct permission assigned.
  21. Offline


    @gabe323 You need new permissions for /spawnmob and /spawner, read the changelog.

    @Teh_Burger_King Update both CraftBukkit and Essentials to their latest development versions
  22. Offline


    All fixed, thank you.
  23. Offline


    did ur team work on "Ban IP Range" ?
    cause i need a extra plugin only for that

    and, pls put the "Version Notes" in a Spoiler :eek:

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  24. Offline


    NVM helps if i download the dev build for 1.0 lol
  25. Offline


    Hey man, the /r command is the same as the /r for regios, you may want to fix this...
  26. Offline


    Using CB build #1550 and Essentials 2.7.116, /i hangs the server on 100% CPU for some reason. If one restarts the server, the item is received...
  27. Offline


    @essentialsteam To get prefixes/suffixes to work with PermissionsBukkit without EssentialsChat, does Essentials need to be updated to support PB or does PB need to be updated to support Essentials? or is this not possible with SuperPerms?

    Additional question(s). In the latest builds (2.7.116), unstackable items from kits are no longer given in stacks. Is this intentional and is there a way to get the old behavior back? For my higher ranks, I want them to be able to use timed kits that give them a stack of 10 pickaxes for convenience. Now, it just gives 10 individual pickaxes which defeats the purpose of the kit.

    Created tickets #1184 and #1185.
  28. Offline


    How do you switch pages on the commands? Because it tells me that there are 14 pages and I only go to page 1..
  29. Offline


  30. No wget compliant links on ci.earth2me.net ? Are you fucking kidding me ?​

Share This Page