[GEN/SEC/ECON/TP/ADMN] Essentials - A collection of useful commands

Discussion in 'Archived: Plugin Releases' started by EssentialsTeam, Apr 30, 2011.

  1. Offline


    No. I need it?..
    wiki says
    all my plugins (open)
    WorldEdit, FalseBookCore, PlgLogCmd, MinecartManiaCore, xAuth, FalseBookIC, BigBrother, MinecartManiaAutocart, Permissions, WorldGuard, FalseBookExtra, ChunkRegen, ChunkRegenerate, PlugMan, Jail, Essentials, SupplySign, CustomDifficulty, MinecartManiaStation, MinecartManiaChestControl, FalseBookBlock, MinecartManiaAdminControls, MinecartManiaAutomations, MinecartManiaSignCommands, DefaultPermissions, EssentialsSpawn, WorldBorder, LWC

    Update to 2.5.8 didn't help.
  2. Offline


    I need It for 1.8.1 Please release it fast PLEASE!!!!!!!!!!![diamond][diamond]
  3. Offline


    But I think you need the Eco plugin for the economy ones. I could be wrong though.
  4. Offline


    I'm not sure if this is a bug with essentials or Minecraft itself but one of my players discovered that you can get around the lava placing restriction by using a lava bucket on a sheep and possibly other animals, its easily reproducible.

    just thought I would throw it out there, you guys rock, thanks for all your hard work, I love this plugin.

  5. Offline


  6. Offline


    Can you make an option in the config that will disable the signs? because i have signshop and essentials keeps overlapping it.
  7. Offline


    Hmm, it seems it does not let me use commands such as /manuadd even I am the owner of the server and I have - '*' in my permissions. Is this a matter of the new Bukkit and the un-updated essentials?
  8. Offline


  9. Offline


    1.8.1 reccomended is out now will there be a build for it?

    you have to use the dev build of group manager located in their irc

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  10. Offline


    "Bukkit sad. Bukkit want you to access command, but bukkit cannot let you. Bukkit will leak tears :'( "
    Why am I getting this? I am an Admin and OP on the server yet I get this for almost every command I enter.
  11. Offline


    As do I. I cant use /setspawn either, I get a long error message :(
  12. Offline


    The Extras link does not work at the moment. I get an access denied message
  13. Offline


    I downloaded the new 2.6.1 Essentials and extras. Everything seems to be working fine but EssentialsXMPP is spitting out the following error.

    2011-09-22 11:06:20 [WARNING] Version mismatch! Please update EssentialsXMPP to the same version.

    Edit: Just noticed the main Essentials download link is still pointing to 2.5.8, that was the problem.
  14. Offline


    Odd. I installed a fresh CB and 2.6.1 Essentials. Craftbukkit seems to be working fine, but Essentials won't load. Anyone else get this problem? I'm going to try reinstalling it and see if that'll fix it.

    EDIT: That seems to have fixed it. I removed the Essentials folder and let it generate another fresh one and it started working. Odd :\
  15. Offline


    The "new" groupmanager diden't "fake" PermissionsBukkit, right?
  16. Hi,
    i have a problem with the GroupManager.
    My Group Guest can Build on my Server, but this Group have the right : Build: false .

    Her is my Config:

        default: true
        - essentials.help
        - essentials.helpop
        - essentials.list
        - essentials.motd
        - essentials.rules
        - essentials.spawn
        inheritance: []
          prefix: '&eGast-'
          build: false
          suffix: ''
    Sry for the bad english.

    Cu Lindi
  17. Offline


    Aweasom ,thanks :)
  18. Offline


    I think you are german :)

    Bei GroupManager kommt es nicht drauf an ob du build auf false hast, das wird nur von einem anderem Plugin verwendet, GroupManager hat keine eigene Funktion für das.
  19. Jup deutsch ^^
    was benutzt dann build?
  20. Offline


  21. Offline


    With CB 1185 I get
    2011-09-22 19:12:07 [SEVERE] Error occurred while enabling Essentials v2.6.1 (Is it up to date?): FOOD_LEVEL_CHANGE
    java.lang.NoSuchFieldError: FOOD_LEVEL_CHANGE
        at com.earth2me.essentials.Essentials.onEnable(Essentials.java:191)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:906)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:278)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:173)
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:156)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:297)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:284)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:152)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:348)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    2011-09-22 19:12:07 [INFO] Essentials: Using PermissionsBukkit based permissions.

  22. essentials Protect is the answer
  23. Is it normal that as an Op I can have a negative balance? I can buy as much as I like and my balance just goes negative without getting an error of not having cash. Is this configurable somewhere?
  24. Offline


    My group manager is a bit dodgy.
  25. Offline


    I've looked around, but haven't been able to find this, but... how do you change between the pages of a warp list? :S
  26. Offline


    did u continue GM?
  27. Offline


    I'm getting something bizarre with GM now. I re-edited our perms from last time, so i can have my own special group, but when i upload the perms, reload, and try to add myself to the Owner group(via console), it does, but i still have the color of my admins. When i go back to my FTP and check in there (i pay for hosting), it REFRESHED my groups file, erasing my new group and replacing it with the standard GM groups file. Any ideas...?

    I also tried restarting my server, changing it while its offline, reloading, eveything. I cant seem to add new groups without it resetting me.
  28. Offline


    For use with PermissionsBukkit, is there a node to enable all commands? I looked on the node page and there isn't one. So how can I enable all commands for essentials?
    I tried
    essentials.*: true
    but it didn't do anything.
    Sorry if this has been asked, I looked.
  29. using the latest 261, all my yml's are perfect

    can access /manu command? please help!
  30. Offline


    Hi there. I am getting this error in my console, and nothing with essentials is working at all. All commands typed in display "error: null"
    Here is the console:
    22.09 20:26:26 [Server] SEVERE    at java.lang.Thread.run(Unknown Source)
    22.09 20:26:26 [Server] SEVERE    at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    22.09 20:26:26 [Server] SEVERE    at com.gmail.nossr50.mcTimer.run(mcTimer.java:34)
    22.09 20:26:26 [Server] SEVERE    at com.gmail.nossr50.skills.Skills.monitorSkills(Skills.java:139)
    22.09 20:26:26 [Server] SEVERE    at com.gmail.nossr50.mcPermissions.herbalismAbility(mcPermissions.java:94)
    22.09 20:26:26 [Server] SEVERE    at com.gmail.nossr50.mcPermissions.permission(mcPermissions.java:64)
    22.09 20:26:26 [Server] SEVERE    at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.has(NijikoPermissionsProxy.java:163)
    22.09 20:26:26 [Server] SEVERE    at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.permission(NijikoPermissionsProxy.java:180)
    22.09 20:26:26 [Server] SEVERE java.lang.NullPointerException
    22.09 20:26:25 [Server] SEVERE    at java.lang.Thread.run(Unknown Source)
    22.09 20:26:25 [Server] SEVERE    at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    22.09 20:26:25 [Server] SEVERE    at com.gmail.nossr50.mcTimer.run(mcTimer.java:34)
    22.09 20:26:25 [Server] SEVERE    at com.gmail.nossr50.skills.Skills.monitorSkills(Skills.java:139)
    22.09 20:26:25 [Server] SEVERE    at com.gmail.nossr50.mcPermissions.herbalismAbility(mcPermissions.java:94)
    22.09 20:26:25 [Server] SEVERE    at com.gmail.nossr50.mcPermissions.permission(mcPermissions.java:64)
    22.09 20:26:25 [Server] SEVERE    at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.has(NijikoPermissionsProxy.java:163)
    22.09 20:26:25 [Server] SEVERE    at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.permission(NijikoPermissionsProxy.java:180)
    22.09 20:26:25 [Server] SEVERE java.lang.NullPointerException
    22.09 20:26:24 [Server] SEVERE    at java.lang.Thread.run(Unknown Source)
    22.09 20:26:24 [Server] SEVERE    at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    22.09 20:26:24 [Server] SEVERE    at com.gmail.nossr50.mcTimer.run(mcTimer.java:34)
    22.09 20:26:24 [Server] SEVERE    at com.gmail.nossr50.skills.Skills.monitorSkills(Skills.java:139)
    22.09 20:26:24 [Server] SEVERE    at com.gmail.nossr50.mcPermissions.herbalismAbility(mcPermissions.java:94)
    22.09 20:26:24 [Server] SEVERE    at com.gmail.nossr50.mcPermissions.permission(mcPermissions.java:64)
    22.09 20:26:24 [Server] SEVERE    at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.has(NijikoPermissionsProxy.java:163)
    22.09 20:26:24 [Server] SEVERE    at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.permission(NijikoPermissionsProxy.java:180)
    22.09 20:26:24 [Server] SEVERE java.lang.NullPointerException
    22.09 20:26:23 [Server] SEVERE    at java.lang.Thread.run(Unknown Source)
    22.09 20:26:23 [Server] SEVERE    at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    22.09 20:26:23 [Server] SEVERE    at com.gmail.nossr50.mcTimer.run(mcTimer.java:34)
    22.09 20:26:23 [Server] SEVERE    at com.gmail.nossr50.skills.Skills.monitorSkills(Skills.java:139)
    22.09 20:26:23 [Server] SEVERE    at com.gmail.nossr50.mcPermissions.herbalismAbility(mcPermissions.java:94)
    22.09 20:26:23 [Server] SEVERE    at com.gmail.nossr50.mcPermissions.permission(mcPermissions.java:64)
    22.09 20:26:23 [Server] SEVERE    at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.has(NijikoPermissionsProxy.java:163)
    22.09 20:26:23 [Server] SEVERE    at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.permission(NijikoPermissionsProxy.java:180)
    22.09 20:26:23 [Server] SEVERE java.lang.NullPointerException
    22.09 20:26:22 [Server] SEVERE    at java.lang.Thread.run(Unknown Source)
    22.09 20:26:22 [Server] SEVERE    at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    22.09 20:26:22 [Server] SEVERE    at com.gmail.nossr50.mcTimer.run(mcTimer.java:34)
    22.09 20:26:22 [Server] SEVERE    at com.gmail.nossr50.skills.Skills.monitorSkills(Skills.java:139)
    22.09 20:26:22 [Server] SEVERE    at com.gmail.nossr50.mcPermissions.herbalismAbility(mcPermissions.java:94)
    22.09 20:26:22 [Server] SEVERE    at com.gmail.nossr50.mcPermissions.permission(mcPermissions.java:64)
    22.09 20:26:22 [Server] SEVERE    at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.has(NijikoPermissionsProxy.java:163)
    22.09 20:26:22 [Server] SEVERE    at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.permission(NijikoPermissionsProxy.java:180)
    22.09 20:26:22 [Server] SEVERE java.lang.NullPointerException
    22.09 20:26:21 [Server] SEVERE    at java.lang.Thread.run(Unknown Source)
    22.09 20:26:21 [Server] SEVERE    at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    22.09 20:26:21 [Server] SEVERE    at com.gmail.nossr50.mcTimer.run(mcTimer.java:34)
    22.09 20:26:21 [Server] SEVERE    at com.gmail.nossr50.skills.Skills.monitorSkills(Skills.java:139)
    22.09 20:26:21 [Server] SEVERE    at com.gmail.nossr50.mcPermissions.herbalismAbility(mcPermissions.java:94)
    22.09 20:26:21 [Server] SEVERE    at com.gmail.nossr50.mcPermissions.permission(mcPermissions.java:64)
    22.09 20:26:21 [Server] SEVERE    at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.has(NijikoPermissionsProxy.java:163)
    22.09 20:26:21 [Server] SEVERE    at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.permission(NijikoPermissionsProxy.java:180)
    22.09 20:26:21 [Server] SEVERE java.lang.NullPointerException
    22.09 20:26:20 [Server] SEVERE    at java.lang.Thread.run(Unknown Source)
    22.09 20:26:20 [Server] SEVERE    at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    22.09 20:26:20 [Server] SEVERE    at com.gmail.nossr50.mcTimer.run(mcTimer.java:34)
    22.09 20:26:20 [Server] SEVERE    at com.gmail.nossr50.skills.Skills.monitorSkills(Skills.java:139)
    22.09 20:26:20 [Server] SEVERE    at com.gmail.nossr50.mcPermissions.herbalismAbility(mcPermissions.java:94)
    22.09 20:26:20 [Server] SEVERE    at com.gmail.nossr50.mcPermissions.permission(mcPermissions.java:64)
    22.09 20:26:20 [Server] SEVERE    at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.has(NijikoPermissionsProxy.java:163)
    22.09 20:26:20 [Server] SEVERE    at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.permission(NijikoPermissionsProxy.java:180)
    22.09 20:26:20 [Server] SEVERE java.lang.NullPointerException
    22.09 20:26:19 [Server] SEVERE    at java.lang.Thread.run(Unknown Source)
    22.09 20:26:19 [Server] SEVERE    at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    22.09 20:26:19 [Server] SEVERE    at com.gmail.nossr50.mcTimer.run(mcTimer.java:34)
    22.09 20:26:19 [Server] SEVERE    at com.gmail.nossr50.skills.Skills.monitorSkills(Skills.java:139)
    22.09 20:26:19 [Server] SEVERE    at com.gmail.nossr50.mcPermissions.herbalismAbility(mcPermissions.java:94)
    22.09 20:26:19 [Server] SEVERE    at com.gmail.nossr50.mcPermissions.permission(mcPermissions.java:64)
    22.09 20:26:19 [Server] SEVERE    at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.has(NijikoPermissionsProxy.java:163)
    22.09 20:26:19 [Server] SEVERE    at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.permission(NijikoPermissionsProxy.java:180)
    22.09 20:26:19 [Server] SEVERE java.lang.NullPointerException
    22.09 20:26:18 [Server] SEVERE    at java.lang.Thread.run(Unknown Source)
    22.09 20:26:18 [Server] SEVERE    at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    22.09 20:26:18 [Server] SEVERE    at com.gmail.nossr50.mcTimer.run(mcTimer.java:34)
    22.09 20:26:18 [Server] SEVERE    at com.gmail.nossr50.skills.Skills.monitorSkills(Skills.java:139)
    22.09 20:26:18 [Server] SEVERE    at com.gmail.nossr50.mcPermissions.herbalismAbility(mcPermissions.java:94)
    22.09 20:26:18 [Server] SEVERE    at com.gmail.nossr50.mcPermissions.permission(mcPermissions.java:64)
    22.09 20:26:18 [Server] SEVERE    at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.has(NijikoPermissionsProxy.java:163)
    22.09 20:26:18 [Server] SEVERE    at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.permission(NijikoPermissionsProxy.java:180)
    22.09 20:26:18 [Server] SEVERE java.lang.NullPointerException
    22.09 20:26:17 [Server] SEVERE    at java.lang.Thread.run(Unknown Source)
    22.09 20:26:17 [Server] SEVERE    at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    22.09 20:26:17 [Server] SEVERE    at com.gmail.nossr50.mcTimer.run(mcTimer.java:34)
    22.09 20:26:17 [Server] SEVERE    at com.gmail.nossr50.skills.Skills.monitorSkills(Skills.java:139)
    22.09 20:26:17 [Server] SEVERE    at com.gmail.nossr50.mcPermissions.herbalismAbility(mcPermissions.java:94)
    22.09 20:26:17 [Server] SEVERE    at com.gmail.nossr50.mcPermissions.permission(mcPermissions.java:64)
    22.09 20:26:17 [Server] SEVERE    at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.has(NijikoPermissionsProxy.java:163)
    22.09 20:26:17 [Server] SEVERE    at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.permission(NijikoPermissionsProxy.java:180)
    22.09 20:26:17 [Server] SEVERE java.lang.NullPointerException
    22.09 20:26:16 [Server] SEVERE    at java.lang.Thread.run(Unknown Source)
    22.09 20:26:16 [Server] SEVERE    at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    22.09 20:26:16 [Server] SEVERE    at com.gmail.nossr50.mcTimer.run(mcTimer.java:34)
    22.09 20:26:16 [Server] SEVERE    at com.gmail.nossr50.skills.Skills.monitorSkills(Skills.java:139)
    22.09 20:26:16 [Server] SEVERE    at com.gmail.nossr50.mcPermissions.herbalismAbility(mcPermissions.java:94)
    22.09 20:26:16 [Server] SEVERE    at com.gmail.nossr50.mcPermissions.permission(mcPermissions.java:64)
    22.09 20:26:16 [Server] SEVERE    at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.has(NijikoPermissionsProxy.java:163)
    22.09 20:26:16 [Server] SEVERE    at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.permission(NijikoPermissionsProxy.java:180)
    22.09 20:26:16 [Server] SEVERE java.lang.NullPointerException
    22.09 20:26:15 [Server] SEVERE    at java.lang.Thread.run(Unknown Source)
    22.09 20:26:15 [Server] SEVERE    at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    22.09 20:26:15 [Server] SEVERE    at com.gmail.nossr50.mcTimer.run(mcTimer.java:34)
    22.09 20:26:15 [Server] SEVERE    at com.gmail.nossr50.skills.Skills.monitorSkills(Skills.java:139)
    22.09 20:26:15 [Server] SEVERE    at com.gmail.nossr50.mcPermissions.herbalismAbility(mcPermissions.java:94)
    22.09 20:26:15 [Server] SEVERE    at com.gmail.nossr50.mcPermissions.permission(mcPermissions.java:64)
    22.09 20:26:15 [Server] SEVERE    at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.has(NijikoPermissionsProxy.java:163)
    22.09 20:26:15 [Server] SEVERE    at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.permission(NijikoPermissionsProxy.java:180)
    22.09 20:26:15 [Server] SEVERE java.lang.NullPointerException
    22.09 20:26:14 [Server] SEVERE    at java.lang.Thread.run(Unknown Source)
    22.09 20:26:14 [Server] SEVERE    at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    22.09 20:26:14 [Server] SEVERE    at com.gmail.nossr50.mcTimer.run(mcTimer.java:34)
    22.09 20:26:14 [Server] SEVERE    at com.gmail.nossr50.skills.Skills.monitorSkills(Skills.java:139)
    22.09 20:26:14 [Server] SEVERE    at com.gmail.nossr50.mcPermissions.herbalismAbility(mcPermissions.java:94)
    22.09 20:26:14 [Server] SEVERE    at com.gmail.nossr50.mcPermissions.permission(mcPermissions.java:64)
    22.09 20:26:14 [Server] SEVERE    at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.has(NijikoPermissionsProxy.java:163)
    22.09 20:26:14 [Server] SEVERE    at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.permission(NijikoPermissionsProxy.java:180)
    22.09 20:26:14 [Server] SEVERE java.lang.NullPointerException
    22.09 20:26:13 [Server] SEVERE    at java.lang.Thread.run(Unknown Source)
    22.09 20:26:13 [Server] SEVERE    at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    22.09 20:26:13 [Server] SEVERE    at com.gmail.nossr50.mcTimer.run(mcTimer.java:34)
    And so on and so forth for a long ass time. Any help?

Share This Page