[GEN] General 3.6.2 (Webern) -- A plugin for general commands, now on BukkitDev! [1060]

Discussion in 'Inactive/Unsupported Plugins' started by Celtic Minstrel, Mar 6, 2011.

  1. Offline

    Celtic Minstrel

    General 3.6.2 [Webern]
    NOTE: If you are updating from 3.4.1 or earlier, you must copy the aliases section from the sample config file into your own config file. If you don't do this, many commands will not work.
    Download from the BukkitDev page (Older versions | Source)

    General provides a small set of basic commands for your server. See more details on the BukkitDev page.

    General is a fork of Nijikokun's plugin. It adds a few commands to the original set provided by General.

    Without Nijikokun's original General plugin, this plugin would never have been possible. Or at least, I would not have made it. General Essentials (the source of the /kit command) was created by wjykk and has had some input from cjc343. The SpawnMob plugin, from which I adapted the code for the /mobspawn command, was created by xmlns and is now maintained by jordanneil23.

    I recommend using sk89q's CommandHelper in conjunction with this plugin. Starting from 3.4.5, there is a command-helper.txt file included with the download which you can copy to CommandHelper's config.txt for some handy aliases, such as /spawn and /home.

    Differences from cjc343's now-inactive fork
    • Does not detect that another plugin has registered the same command.
    • /playerlist and /who are two separate commands
    • Different items.db format
    • Does not support setting or viewing the raw time.
  2. Offline

    Celtic Minstrel

    In 3.6. If you want a preview version, I can get you one; the only reason I haven't released it yet is because I did a fairly major overhaul of how commands are handled and wanted to be sure that I didn't break any commands.

    That goes for anyone, actually; if you want a preview copy of 3.6, just say the word and I'll upload one and post the link here.
  3. Offline


    Hi, I'd love to see /day as a shortcut for /time day if that's possible. Thanks
  4. Offline

    Celtic Minstrel

    If you use CommandHelper, add this line to its config.txt:
    /day = /time day
  5. Offline


    Hi having trouble getting general going.
    Permissions 3.1.6

    2011-08-19 11:30:25 [SEVERE] [General-3.5.1] There was a big problem loading permissions system [Permisions]! Please report this error!
    2011-08-19 11:30:25 [SEVERE] java.lang.ClassNotFoundException: net.craftstars.general.security.PermisionsPermissionsHandler
    2011-08-19 11:30:25 [SEVERE]     at java.net.URLClassLoader$1.run(Unknown Source)
    2011-08-19 11:30:25 [SEVERE]     at java.security.AccessController.doPrivileged(Native Method)
    2011-08-19 11:30:25 [SEVERE]     at java.net.URLClassLoader.findClass(Unknown Source)
    2011-08-19 11:30:25 [SEVERE]     at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
    2011-08-19 11:30:25 [SEVERE]     at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
    2011-08-19 11:30:25 [SEVERE]     at java.lang.ClassLoader.loadClass(Unknown Source)
    2011-08-19 11:30:25 [SEVERE]     at java.lang.ClassLoader.loadClass(Unknown Source)
    2011-08-19 11:30:25 [SEVERE]     at net.craftstars.general.General.setupPermissions(General.java:188)
    2011-08-19 11:30:25 [SEVERE]     at net.craftstars.general.General.loadAllConfigs(General.java:129)
    2011-08-19 11:30:25 [SEVERE]     at net.craftstars.general.General.onEnable(General.java:115)
    2011-08-19 11:30:25 [SEVERE]     at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
    2011-08-19 11:30:25 [SEVERE]     at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:878)
    2011-08-19 11:30:25 [SEVERE]     at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:272)
    2011-08-19 11:30:25 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:162)
    2011-08-19 11:30:25 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:146)
    2011-08-19 11:30:25 [SEVERE]     at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:284)
    2011-08-19 11:30:25 [SEVERE]     at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:271)
    2011-08-19 11:30:25 [SEVERE]     at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:148)
    2011-08-19 11:30:25 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
    2011-08-19 11:30:25 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    2011-08-19 11:30:25 [SEVERE] Error occurred while enabling General v3.5.1 (Is it up to date?): null
        at net.craftstars.general.General.setupPermissions(General.java:206)
        at net.craftstars.general.General.loadAllConfigs(General.java:129)
        at net.craftstars.general.General.onEnable(General.java:115)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:878)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:272)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:162)
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:146)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:284)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:271)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:148)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
  6. Offline

    Celtic Minstrel

    You misspelled Permissions in the config file.
  7. Offline



    i'm just changing from general 2.2.1 (Chernobyl) to this version. All is working fine and all Permissions (Done with "Permissions 3.1.6") work (was a bit of things to do to change them to the new "General"-syntax but worked well :) ). Except one .. I cant get "/setspawn" to running.

    I have added this two lines to the other ones:

                - 'general.setspawn'
                - 'general.setspawn.to.spawn'
    in the groups.yml, but it doenst work.

    I also tried to use just one of them, but also didnt work.

    Maybe i have overseen something ? :)

    Thanks for your help and for this very good general plugin :)
  8. Offline

    Celtic Minstrel

    The permissions for the /setspawn command are essentially the same as for the teleport command; that is, with Permissions 3, you need a minimum of three permissions to be able to set the spawn. Add 'general.setspawn.world' in addition to those two and it should work. You'll probably also want to use a different to.* permission since 'general.setspawn.to.spawn' basically lets you set the spawn only to where it already is, which isn't much use; to.player is probably the most useful one.

    Summary: Give these three permissions:
    - general.setspawn
    - general.setspawn.world
    - general.setspawn.to.player
  9. Offline


    OK thx !

    I will try in few minutes ...

    The problem ist ... This ".world" thing isnt declined anywhere :D ... I have looked here : http://redmine.craftstars.net/projects/general/wiki/Permissions ... And i thought this was "all" i had to know :)

    But Thanks for your help ! I will come back if it doesnt work :D


    Ok .. sorry for that, but I'm back :) ...

    Now i have set following:

                - 'general.setspawn'
                - 'general.setspawn.world'
                - 'general.setspawn.to.player'
    but ... it doenst work (I get the "You dont't have permission to set the spawn location to other players" message) ... And additional i get this error in the server console :

    02:54:11 [INFO] [General-3.5.1] [DEBUG] Checking more permission...

    So hope you can again help me with this :)

    Thanks for your help !

    Besides: ... i tried to execute "/setspawn test" ...

    and got that error:

    02:58:12 [SCHWERWIEGEND] [General-3.5.1] Full command string: [setspawn test]
    02:58:12 [SCHWERWIEGEND] java.lang.ArrayIndexOutOfBoundsException: 1
    02:58:12 [SCHWERWIEGEND]        at net.craftstars.general.command.teleport.setspawnCommand.fromPlayer(setspawnCommand.ja
    02:58:12 [SCHWERWIEGEND]        at net.craftstars.general.command.CommandBase.runCommand(CommandBase.java:23)
    02:58:12 [SCHWERWIEGEND]        at net.craftstars.general.General.onCommand(General.java:263)
    02:58:12 [SCHWERWIEGEND]        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    02:58:12 [SCHWERWIEGEND]        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129)
    02:58:12 [SCHWERWIEGEND]        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:352)
    02:58:12 [SCHWERWIEGEND]        at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:737)
    02:58:12 [SCHWERWIEGEND]        at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:701)
    02:58:12 [SCHWERWIEGEND]        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:694)
    02:58:12 [SCHWERWIEGEND]        at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    02:58:12 [SCHWERWIEGEND]        at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    02:58:12 [SCHWERWIEGEND]        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:89)
    02:58:12 [SCHWERWIEGEND]        at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    02:58:12 [SCHWERWIEGEND]        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:454)
    02:58:12 [SCHWERWIEGEND]        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:363)
    02:58:12 [SCHWERWIEGEND]        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    I know that "test" is not a "good" location .. but i think this errors should not occur :D


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  10. Offline

    Celtic Minstrel

    Yeah, looks like the wiki is missing a few things.
    The [DEBUG] is not at the same time as the other error? What are you trying to set the spawn to?

    One thing you could try is replacing any "general.setspawn" with the older "general.spawn.set". Not sure how well that would work though.
  11. Offline


    Yes, the "Debug" error is just when trying to give "/setspawn" (and gettin the error i wrote above)

    I have now tried with "general.spawn.set" in the yml -> same error on screen ... and same "debug" error on console. (Other General things are working, like "general.time.set" ..)

    The other error was just a hint and has nothing to do with that i think :) ..

    BTW: The wiki for the "Permissions" is not linked in the topic-thread :) Dont know if you should link it - but i had to search for it :)
  12. Offline


    is it possible to disable bed-sethome feature and respawn at home after death? I know the essentials can do that, but i would like to make it with general if possible.
  13. Offline

    Celtic Minstrel

    At present you'll respawn at your "home" only if there's a bed there. I have no plans to change that in the near future.
  14. Offline


    Im getting a bunch of null errors in the command window. Its probably my fault and not yours, all I did was take the items in the .zip and paste it in plugins. Is there anymore I need to do?
  15. Offline

    Celtic Minstrel

    No idea, what's the error?
  16. Offline


    Hello, can you add a node for give items to others users ?
    I have a pvp world and a creative world. On the creative all players have the /give command, and they give some items in the pvp :/

    Thanks :)
  17. Offline

    Celtic Minstrel

    I think the node exists; did you try general.give.other?
  18. Offline


  19. Offline

    Celtic Minstrel

    No, don't do that. This plugin supports Bukkit permissions already.
  20. Offline


  21. Offline

    Celtic Minstrel

    Probably, but expect 3.6 in the next day or so... as soon as I test teleport warmup and various cooldowns and figure out why /who is not working.
  22. Offline

    Celtic Minstrel

    Version 3.6 is released. Get it from BukkitDev. I will no longer be updating this thread's opening post with updates, so I recommend subscribing on BukkitDev if you have a curse.com account. Please direct all issues and feature requests there as well.
  23. Offline


    how? :(
    my users dont have the permission to tp,
    (in log it says: using worldedit for permissions
    last i got :p

    btw is /spawn not working? :O
  24. Offline

    Celtic Minstrel

    You can either use /tele spawn, or install CommandHelper and the aliases for it included in the default configs folder in the General download.
  25. Offline


    ok, but i detected, that my worldeedit permissions dont work ,
    so how to set config to permissions?
  26. Offline

    Celtic Minstrel

    If you're using Permissions 2.x or 3.x, just find WorldEdit in the config.yml and change it to Permissions.
  27. Offline


    thanks :)

    but one more think, whats the (new) command for:
    /tphere <playername>

    what are all the permissions, that my players can teleport
    to the spawn (but only there?)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  28. Offline

    Celtic Minstrel

    /tphere <player> is now /tp <player> here.

    The permissions are listed on the BukkitDev pages. For your specific case, you'll need to give 'general.teleport.to.spawn' and 'general.teleport.self'. You may also need 'general.teleport', which doesn't grant any permissions on its own but is required to use the /tp command at all (I need to change that).
  29. Offline


    My 3¢ worth... /afk should not require an away message, it should just toggle the state. Please note how we're trying to use it and change the implementation to meet our expectations. I had multiple users who independently tried to use /afk to go away from keyboard and they each told me it was broken.


    You should probably make this an example on the wiki. This one situation, enabling users to only teleport themselves to spawn, caused me days of difficulty because it's highly unusual to require three permissions to perform one action. In other words, this was not intuitive. Write a little "How do I...?" FAQ with examples.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  30. Offline

    Celtic Minstrel

    Not requiring a message goes against what I expect, being used to IRC, but it wouldn't be too hard to do. I'll consider doing it; not sure if it'll be an option or if I'll just make it the regular behaviour.

    I intend to make it only require two permissions in future, but the suggestion of putting in examples is a good one.
    Zathras likes this.

Share This Page