[GEN] General 3.6.2 (Webern) -- A plugin for general commands, now on BukkitDev! [1060]

Discussion in 'Inactive/Unsupported Plugins' started by Celtic Minstrel, Mar 6, 2011.

  1. Offline

    Celtic Minstrel

    General 3.6.2 [Webern]
    NOTE: If you are updating from 3.4.1 or earlier, you must copy the aliases section from the sample config file into your own config file. If you don't do this, many commands will not work.
    Download from the BukkitDev page (Older versions | Source)

    General provides a small set of basic commands for your server. See more details on the BukkitDev page.

    General is a fork of Nijikokun's plugin. It adds a few commands to the original set provided by General.

    Without Nijikokun's original General plugin, this plugin would never have been possible. Or at least, I would not have made it. General Essentials (the source of the /kit command) was created by wjykk and has had some input from cjc343. The SpawnMob plugin, from which I adapted the code for the /mobspawn command, was created by xmlns and is now maintained by jordanneil23.

    I recommend using sk89q's CommandHelper in conjunction with this plugin. Starting from 3.4.5, there is a command-helper.txt file included with the download which you can copy to CommandHelper's config.txt for some handy aliases, such as /spawn and /home.

    Differences from cjc343's now-inactive fork
    • Does not detect that another plugin has registered the same command.
    • /playerlist and /who are two separate commands
    • Different items.db format
    • Does not support setting or viewing the raw time.
  2. Offline


    I'm having the same issue mentioned above by Ethan where General is returning an NPE on load, except I'm running the beta version. I also don't have an items.yml, but in the past that wasn't necessary. This isn't the cause is it?
  3. Offline

    Jan Tojnar

    So what about using partial names in tele command? It was working before 3.4 and it was very useful e.g. /tele mara instead of /tele maradabingon.

    And /spawn command. I don't need to know where is spawn i just need to get there. Can you change it to /getspawn and return original function (/tele spawn is too long).

    Also there are two teleport notifications.

    Can you add mass taking items from inventory (like /items but inverted). Now i have to write /take dirt, /take cobble, /take glowdust. /mtake dirt cobble glowdust would be better.

    Sorry for the post form i am sleepy now. Maybe someone have posted something of this or maybe not so sorry for bothering you.
  4. Offline


    Following up on my last post, it seems the parsing of items.yml is pretty bugged.
    2011-05-25 19:15:44 [WARNING] [General-3.4b3] The names section of items.yml is missing or invalid.
    2011-05-25 19:15:44 [WARNING] [General-3.4b3] No aliases were defined in items.yml.
    2011-05-25 19:15:44 [SEVERE] Error occurred while enabling General v3.4b3 (Is it up to date?): null
    This is the output generated regardless of whether items.yml exists. It appears that the plugin is overwriting the items.yml file even if it already exists. Also, I'm not sure if this is supposed to occur or not, but the file that is automatically generated consists of only one line:
    I hope this helps with your debugging.
  5. Offline

    Celtic Minstrel

    You don't technically need an items.yml if you have the items.db; however, 4.0 will require an items.yml instead of items.db. General automatically converts the items.db into items.yml though, so provided that works you shouldn't need to take any action to do it manually.

    Uh, I thought I had that... did you try /tele marad? If it can't uniquely resolve the name, it won't try to guess who you mean.

    Eh, you have a point... I'll consider it, I guess.

    I am aware. This only occurs when you teleport yourself, and due to the way I've done it I'm not sure how to avoid the double notifications.

    Uh, sure, why not. I don't think it'll get into 3.4 though.

    Oh, and I have fixed the NPE that occurs when items.yml is missing or empty (at least, I'm pretty sure I have). It won't fix the core problem, but at least it'll allow the other features of General to work despite that error.
  6. Offline

    Jan Tojnar

    Actualy it was /tele wa and i am pretty sure there was only one player with 'wa' in name.
    Yes i was teleporting myself.
    What about adding following before line 40 in net/craftstars/general/command/teleport/goCommand.java
    if(args.length == 2)
    Ok thanks that is probably all for now.
  7. Offline

    Celtic Minstrel

  8. Offline

    Jan Tojnar

    I don't understand why should be this:
    snowed instead of this (edit: btw this was original message i think):
    You know you teleported yourself so you don't need to see who teleported you.
    Otherwise you will need to add sender argument to Target.teleport() and then compare it with every victim Sth like that:
    85: if(victim instanceof Player && sender.getName() != victim.getName()) {
  9. I'd really like this too, as i want my players to be able to return to spawn, not be able to teleport to anyone or any world.

    For my server, i'd like it to always return to my main world's spawn, even while in the Nether. Maybe you could add an option in the config to choose between the individual player's spawn and the current world spawn?

    EDIT: Just found the permission nodes that only allow you to teleport to spawn. Using /spawn to teleport there would be much easier for my players though.
  10. Offline

    Celtic Minstrel

    ...you know, on second thoughts, neither of those messages are right. What I want to show in that event is this:
    Yeah, I think I'll revert the meaning of /spawn in the next version; I'll consider it an alias of the teleport command with an implicit argument.

    I hope to finally introduce customizable aliases into General 3.4.1, due to some careful reflective work. It was actually not as hard as I anticipated; now I just have to test it before release.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  11. Offline


    Getting this error: Build 818
    [General-3.4] There was a big problem executing command [info.who]! Please report this error!
    2011-06-03 12:19:19 [SEVERE] [General-3.4] Full command string: [who]
    2011-06-03 12:19:19 [SEVERE] java.util.IllegalFormatConversionException: d != java.lang.Double
    2011-06-03 12:19:19 [SEVERE]     at java.util.Formatter$FormatSpecifier.failConversion(Formatter.java:3999)
    2011-06-03 12:19:19 [SEVERE]     at java.util.Formatter$FormatSpecifier.printInteger(Formatter.java:2709)
    2011-06-03 12:19:19 [SEVERE]     at java.util.Formatter$FormatSpecifier.print(Formatter.java:2661)
    2011-06-03 12:19:19 [SEVERE]     at java.util.Formatter.format(Formatter.java:2433)
    2011-06-03 12:19:19 [SEVERE]     at java.util.Formatter.format(Formatter.java:2367)
    2011-06-03 12:19:19 [SEVERE]     at net.craftstars.general.command.info.whoCommand.formatLocation(whoCommand.java:66)
    2011-06-03 12:19:19 [SEVERE]     at net.craftstars.general.command.info.whoCommand.getInfo(whoCommand.java:55)
    2011-06-03 12:19:19 [SEVERE]     at net.craftstars.general.command.info.whoCommand.fromPlayer(whoCommand.java:28)
    2011-06-03 12:19:19 [SEVERE]     at net.craftstars.general.command.CommandBase.runCommand(CommandBase.java:23)
    2011-06-03 12:19:19 [SEVERE]     at net.craftstars.general.General.onCommand(General.java:242)
    2011-06-03 12:19:19 [SEVERE]     at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    2011-06-03 12:19:19 [SEVERE]     at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:128)
    2011-06-03 12:19:19 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:281)
    2011-06-03 12:19:19 [SEVERE]     at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:718)
    2011-06-03 12:19:19 [SEVERE]     at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:684)
    2011-06-03 12:19:19 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:677)
    2011-06-03 12:19:19 [SEVERE]     at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:32)
    2011-06-03 12:19:19 [SEVERE]     at net.minecraft.server.NetworkManager.b(NetworkManager.java:217)
    2011-06-03 12:19:19 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    2011-06-03 12:19:19 [SEVERE]     at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    2011-06-03 12:19:19 [SEVERE]     at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:401)
    2011-06-03 12:19:19 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:311)
    2011-06-03 12:19:19 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
  12. Only plugin I'm waiting for to update :) Thanks for your hard work on it :D
  13. Offline


    When teleporting to others many times the target chunk is missing where the other player ist located in. All other chunks around load properly. Is this a General issue or not?

    Moreover this also happens when teleporting in genral on CB 818

    Finally I got an exception:
    05:31:57 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'tele' in plugin General v3.4
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:128)
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:281)
            at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:718)
            at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:684)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:677)
            at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:32)
            at net.minecraft.server.NetworkManager.b(NetworkManager.java:217)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:401)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:311)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.NoSuchMethodError: net.minecraft.server.EntityPlayer.K()Lnet/minecraft/server/ChunkCoordinates;
            at net.craftstars.general.teleport.Destination.homeOf(Destination.java:182)
            at net.craftstars.general.teleport.Destination.get(Destination.java:98)
            at net.craftstars.general.command.teleport.goCommand.fromPlayer(goCommand.java:29)
            at net.craftstars.general.command.CommandBase.runCommand(CommandBase.java:23)
            at net.craftstars.general.General.onCommand(General.java:242)
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
            ... 12 more
  14. Offline


    nice, going to use for tpmc
  15. Offline

    Celtic Minstrel

    It's likely not necessary to wait; chances are that most functions will work just fine in Minecraft 1.6.

    I'm not sure. I'd guess not, but really, not sure.

    This is because you're trying to /tele home on Minecraft 1.6; this is one of about three things that will not work on 1.6 until I get around to updating (the other I recall is spawning angry pig zombies, and I think there was a third as well).

    As for the formatter error in /who, I can see what the problem is and it will be trivial to fix.
  16. Offline


    Furhtermore many of my players die randomly (me including) when teleporting to locations, other players or spawn. Mysterious things happen these days on my server ^.^ Don't like 1.6. 1.5 was much better.

    Also seen this one today
    17:51:03 [SEVERE] [General-3.4] There was a big problem executing command [info.who]! Please report this error!
    17:51:03 [SEVERE] [General-3.4] Full command string: [who]
    17:51:03 [SEVERE] java.util.IllegalFormatConversionException: d != java.lang.Double
    17:51:03 [SEVERE]       at java.util.Formatter$FormatSpecifier.failConversion(Formatter.java:3999)
    17:51:03 [SEVERE]       at java.util.Formatter$FormatSpecifier.printInteger(Formatter.java:2709)
    17:51:03 [SEVERE]       at java.util.Formatter$FormatSpecifier.print(Formatter.java:2661)
    17:51:03 [SEVERE]       at java.util.Formatter.format(Formatter.java:2433)
    17:51:03 [SEVERE]       at java.util.Formatter.format(Formatter.java:2367)
    17:51:03 [SEVERE]       at net.craftstars.general.command.info.whoCommand.formatLocation(whoCommand.java:66)
    17:51:03 [SEVERE]       at net.craftstars.general.command.info.whoCommand.getInfo(whoCommand.java:55)
    17:51:03 [SEVERE]       at net.craftstars.general.command.info.whoCommand.fromPlayer(whoCommand.java:28)
    17:51:03 [SEVERE]       at net.craftstars.general.command.CommandBase.runCommand(CommandBase.java:23)
    17:51:03 [SEVERE]       at net.craftstars.general.General.onCommand(General.java:242)
    17:51:03 [SEVERE]       at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    17:51:03 [SEVERE]       at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:128)
    17:51:03 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:281)
    17:51:03 [SEVERE]       at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:718)
    17:51:03 [SEVERE]       at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:684)
    17:51:03 [SEVERE]       at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:677)
    17:51:03 [SEVERE]       at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:32)
    17:51:03 [SEVERE]       at net.minecraft.server.NetworkManager.b(NetworkManager.java:217)
    17:51:03 [SEVERE]       at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    17:51:03 [SEVERE]       at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    17:51:03 [SEVERE]       at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:401)
    17:51:03 [SEVERE]       at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:311)
    17:51:03 [SEVERE]       at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
  17. Offline


    2 questions =)

    1) Will you ever add a /reply | /r function for messaging to reply to the last private message?

    2) Will this work with permissions 3.1 soon?

    Thanks for the great plugin!
  18. Offline


    Same error here
    Also im using a Multiverse Portal, or respawn after die.
    I must disconnect from Server. when reconnect all chunks are loadet
  19. Offline


    When this excelent plugin become compatible with 1.6.6 (bukkit ver. 818)? I need to update my server which use this plugin, but experiencing the same issues as described above.
    Thank you in advance
    happy user dog.big
  20. Offline


    Did the permissions for teleporting change?
    i used to give a level of player then general.teleport node, and all was well.
    which stopped working in 3.4, ive been fiddling with it for a good hour to no avail, if i give them general.teleport.* then it still doesnt work, just the permissions message changes from "permission to teleport yourself" to "permission to teleport"

    any ideas?

  21. Offline


    i think when giving permission to general.teleport.* doesn't give you access to general.teleport??
    try having both lines in the permissions file, that might be a temp fix
  22. Offline


    Can we have the old commands back such as /spawn? Changing the commands has broken the usefulness of this plugin.
  23. Offline


    Works for b860 ?
  24. Offline


    i have yet to find any combination of permission nodes that will let them use /teleport, aside from -"*"

  25. Offline

    Celtic Minstrel

    I don't know... probably not. Maybe a "magic name" which expands to the last person to message you (so, you say /msg @ blahblahblah to reply). I'll think about this.

    No idea. Is permissions 3 not compatible with the earlier versions?

    It has been compatible all along.

    Yes, dramatically. Check the permissions section of the wiki. In general, if you want to give them all teleport permissions, you should be able to do it with "general.teleport" and "general.teleport.*", though I wouldn't recommend this. I suppose I should add some sort of "general.teleport.basic" permission at some point.

    The /spawn command still exists in the form of /tele spawn. I'm planning to revert the function of /spawn later.

    Okay, version 3.4.1 is now released.
    • Partial name matching for players is now case-insensitive.
    • The /who command once again works.
    • The /tele home function has been fixed (it broke due to the 1.6 update; it's the only thing that did, in fact).
    • It is now possible to choose any aliases you like for each command. See the included config file to see how it's done.
  26. Offline

    Jan Tojnar

    This was probably cause of my problem with teleportation to long name
    Are 1.6 items included?
    And what about setting home? Could you make /sethome as alias of /setspawn self? And what is the part with "see your home location" i thought it was setting home. And /home for /tele home would be cool too.
    edit: 3.4.1 broke teleport, list and mobspawn commands; nothing in condole or chat
  27. Offline


    Thank you so much, I have missed the /who command. I will update it today on my server.
  28. Offline

    Celtic Minstrel


    I believe so, yes. Adding those is just a config file change for the most part, though. I haven't tested whether shrubs and long grass work.

    I don't really want to use /home and /sethome since that could conflict with other plugins. I think sk89q's CommandHelper would be able to define these as aliases though.

    All three work for me on 3.4.1. There's a section in the config that you need to copy over to get the command aliases, since they are no longer being defined in the plugin.yml; maybe that's your issue?

    Also, I just realized that I never did post a changelog for 3.4, so here it is. Changes between 3.4b1 and 3.4:

    • Fix the NullPointerException that would occur if the items.yml file lacked a hooks section.
    • Added /general save to save all the config settings, including config.yml.
    • The /general reload command no longer disables and re-enables the plugin; instead, it merely reloads the config files.
    • Fixed an error when checking if a user is allowed to get a particular item.
    • Fixed inaccessible command constructors.

    And changes from 3.3.3 to 3.4b1:

    • Experimental support for iConomy 5 and BOSEconomy.
    • Some refactoring of permissions checking, separating it from informing the user of a lack of permissions.
    • The /who command now shows a player's home location if show-coords is enabled.
    • A limit to how many items can be given with /give has been instated; bypassable with the give.mass permission, and configurable in config.yml.
    • The /items command now respects whether the player is allowed to receive each item.
    • Added /weather thunder as a toggle command; it may or may not actually work though.
    • Spawning mobs with data requires special permissions.
    • Fine control of teleport permissions.
    • Improved player matching, and increased use of this functionality. Generally speaking, partial name matching should now work anywhere a player name is expected; previously, I believe it only worked in the teleport commands. A similar algorithm for matching world names was also introduced.
    • Human-friendly durations in /weather.
    • The /spawn command now only shows the spawn location rather than teleporting you there. [NOTE: This command will soon be removed altogether.] You can still teleport there using the teleport command.
    • The /setspawn command has been reintroduced for setting spawn locations. It can also set your home location; note that sleeping in a bed also does this.
    • Vastly improved /teleport command. You can now teleport to a number of special locations, and you can teleport nearby mobs or a mob under your cursor. See the documentation for details.
    • The /who command now shows the player's IP if show-ip is enabled globally and the player has permission to see it; players have permission to see their own IP automatically, and the general.who.ip permission is required to see the IP of other people.
    • Vastly improved /mobspawn command, with more data options. Saddled pigs, tamed/angry wolves, angry pig zombies, and powered creepers are now available. You can even summon a tamed wolf belonging to another player.
    • The /weather command requires permissions.
    • The plugin no longer assumes that the command is from the console if it's not from a player. This is a potential security hole if you have a plugin that defines its own type of command sender. I don't know if there are any such plugins yet, but it's possible.
  29. Offline

    Jan Tojnar

    Just one problem with teleportation i told you some time ago. But i think it was caused by case sentitibity so it should work now. I will test it tomorrow.
    I will test it tomorrow, i think it wasnt working in 3.4 but i haven't tried since then.
    Many of your commands can interfere with other plugins but this is general plugin so it is fine.
    That is odd solution of conflicts but ok, i copied that config section. I will try it tomorrow.
    Could you make autoupdating config file so we don't have to compare config with config in zip.
    You can make it like stargate plugin.
    Also is it possible to detect java packages and determine which permission plugin to use (like some other plugins do with economy plugins)?
    If you don't have enough time i can try to make mass item take command tomorrow but i won't promiss anything because i know java just a little.
    Ad 2: not working - /i tallgrass produces 1 is not a valid data type for Tall Grass
    Ad 4: this is working
  30. Offline

    Celtic Minstrel

    Version 3.4.2

    • Fixed /give whitelist/blacklist not working.
    • Added general.teleport.basic permission node.
  31. Offline

    Jan Tojnar

    Ok i tried to create /mtake command, but i dont get these aliases (i had only few time) so it is /mt for this time.
    Command is /mt item1 item2 … itemn and you can add playername after it optionally (see source). It is fine if last argument is some string not matching any player (item name, some random text) but when it matches (Toolbox.matchPlayer()) there is NullPointerException. It can be called from console with same result:
    console (open)
    >mt ghoe lisured
    23:22:38 [SEVERE] [General-3.4.2] There was a big problem executing command [inven.mtake]! Please report this error!
    23:22:38 [SEVERE] [General-3.4.2] Full command string: [mt ghoe lisured]
    23:22:38 [SEVERE] java.lang.NullPointerException
    23:22:38 [SEVERE] 	at java.util.regex.Matcher.getTextLength(Matcher.java:1151)
    23:22:38 [SEVERE] 	at java.util.regex.Matcher.reset(Matcher.java:308)
    23:22:38 [SEVERE] 	at java.util.regex.Matcher.<init>(Matcher.java:228)
    23:22:38 [SEVERE] 	at java.util.regex.Pattern.matcher(Pattern.java:905)
    23:22:38 [SEVERE] 	at java.util.regex.Pattern.matches(Pattern.java:946)
    23:22:38 [SEVERE] 	at net.craftstars.general.items.Items.validate(Items.java:347)
    23:22:38 [SEVERE] 	at net.craftstars.general.command.inven.mtakeCommand.fromConsole(mtakeCommand.java:35)
    23:22:38 [SEVERE] 	at net.craftstars.general.command.CommandBase.runCommand(CommandBase.java:25)
    23:22:38 [SEVERE] 	at net.craftstars.general.General.onCommand(General.java:244)
    23:22:38 [SEVERE] 	at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    23:22:38 [SEVERE] 	at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:128)
    23:22:38 [SEVERE] 	at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:279)
    23:22:38 [SEVERE] 	at net.minecraft.server.MinecraftServer.b(MinecraftServer.java:428)
    23:22:38 [SEVERE] 	at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:413)
    23:22:38 [SEVERE] 	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:309)
    23:22:38 [SEVERE] 	at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    23:22:38 [INFO] /mt item1 item2 … itemn [player]

    ingame (open)
    23:32:08 [SEVERE] [General-3.4.2] There was a big problem executing command [inven.mtake]! Please report this error!
    23:32:08 [SEVERE] [General-3.4.2] Full command string: [mt item Lisured]
    23:32:08 [SEVERE] java.lang.NullPointerException
    23:32:08 [SEVERE] 	at java.util.regex.Matcher.getTextLength(Matcher.java:1151)
    23:32:08 [SEVERE] 	at java.util.regex.Matcher.reset(Matcher.java:308)
    23:32:08 [SEVERE] 	at java.util.regex.Matcher.<init>(Matcher.java:228)
    23:32:08 [SEVERE] 	at java.util.regex.Pattern.matcher(Pattern.java:905)
    23:32:08 [SEVERE] 	at java.util.regex.Pattern.matches(Pattern.java:946)
    23:32:08 [SEVERE] 	at net.craftstars.general.items.Items.validate(Items.java:347)
    23:32:08 [SEVERE] 	at net.craftstars.general.command.inven.mtakeCommand.fromPlayer(mtakeCommand.java:57)
    23:32:08 [SEVERE] 	at net.craftstars.general.command.CommandBase.runCommand(CommandBase.java:23)
    23:32:08 [SEVERE] 	at net.craftstars.general.General.onCommand(General.java:244)
    23:32:08 [SEVERE] 	at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    23:32:08 [SEVERE] 	at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:128)
    23:32:08 [SEVERE] 	at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:287)
    23:32:08 [SEVERE] 	at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:712)
    23:32:08 [SEVERE] 	at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:678)
    23:32:08 [SEVERE] 	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:671)
    23:32:08 [SEVERE] 	at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:32)
    23:32:08 [SEVERE] 	at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    23:32:08 [SEVERE] 	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    23:32:08 [SEVERE] 	at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    23:32:08 [SEVERE] 	at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:399)
    23:32:09 [SEVERE] 	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:309)
    23:32:09 [SEVERE] 	at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)

    Sorry i am java beginner but i really want this command.

    Source: https://github.com/jtojnar/General/commit/4d7e3200a70310c51f3acb6982f1948f322d3deb
    Download: http://dl.dropbox.com/u/1189439/General.jar

Share This Page