Inactive [GEN] Essentials v2.1 [?]

Discussion in 'Inactive/Unsupported Plugins' started by Zenexer, Jan 19, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    I posted here because server data is rather...


  3. Offline


    i need some help!

    C:\Users\.lenovo\Desktop\Bukkit>java -server -Xmx3072M -Xms3072M -XX:+UseConcMar
    kSweepGC -XX:+UseParNewGC -XX:+CMSIncrementalPacing -XX:parallelGCThreads=2 -XX:
    +AggressiveOpts -jar craftbukkit-0.0.1-SNAPSHOT.jar
    2011-02-15 21:48:45 [INFO] Starting minecraft server version Beta 1.2_01
    2011-02-15 21:48:45 [INFO] Loading properties
    2011-02-15 21:48:45 [INFO] Starting Minecraft server on *:25565
    2011-02-15 21:48:45 [INFO] This server is running Craftbukkit version git-Bukkit
    -0.0.0-334-g20193fc-b257 (MC: 1.2_01)
    2011-02-15 21:48:45 [INFO] Preparing level "world"
    2011-02-15 21:48:45 [INFO] Preparing start region
    2011-02-15 21:48:46 [INFO] Preparing spawn area: 20%
    2011-02-15 21:48:47 [INFO] Preparing spawn area: 69%
    2011-02-15 21:48:48 [INFO] Preparing spawn area: 73%
    2011-02-15 21:48:49 [INFO] [Healthy] version [1.0] (Apple) loaded
    2011-02-15 21:48:49 [INFO] [iConomy] version [2.2] (Aime) loaded
    2011-02-15 21:48:49 [INFO] [Permissions] version [2.0] (Handler) loaded
    2011-02-15 21:48:49 [INFO] WorldEdit 3.2.2 loaded.
    2011-02-15 21:48:49 [INFO] WorldEdit: Permissions plugin detected! Using Permiss
    ions plugin for permissions.
    AutoRepair version 1.51 is enabled!
    2011-02-15 21:48:49 [INFO] BukkitToDate: Using Permissions plugin...
    2011-02-15 21:48:49 [INFO] BukkitToDate: Loaded at version 0.2
    2011-02-15 21:48:49 [INFO] BukkitToDate: This plugin is here for monitoring upda
    tes and in game commands.
    2011-02-15 21:48:49 [INFO] BukkitToDate: Loading settings...
    Loading Plugin Settings...
    2011-02-15 21:48:49 [INFO] BukkitToDate: Auto-Update: ENABLED
    2011-02-15 21:48:49 [INFO] BukkitToDate: Update-Monitor: ENABLED
    2011-02-15 21:48:49 [INFO] BukkitToDate: Current Server Build: 326
    Feb 15, 2011 9:48:49 PM org.bukkit.craftbukkit.CraftServer loadPlugins
    SEVERE: org.bukkit.Server.getWorlds()Ljava/util/List; (Is it up to date?)
    java.lang.NoSuchMethodError: org.bukkit.Server.getWorlds()Ljava/util/List;
    at com.earth2me.essentials.Essentials.onEnable(
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at net.minecraft.server.MinecraftServer.e(
    at net.minecraft.server.MinecraftServer.c(
    at net.minecraft.server.MinecraftServer.d(
    2011-02-15 21:48:49 [INFO] Done! For help, type "help" or "?"

    is there anything wrong? conflicting plugins? please help!
    [edit]sorry fixed. realised i needed the latest build, not the safe build.
  4. Offline


    For Permissions its
    - 'essentials.item'
    Then that group will be able to use /i or /item.
  5. Offline


  6. Offline


    Ok... What is 'trukkit'?
  7. Offline


    I apologize in advance if someone has already posted a similar issue.... I tried to search the posts, but could find anything... Anyway, I am having issues with the "help" command. When users sign into my server and attempt to list permissions, i.e. /help, they are prompted with a screen that shows "help page 1 of 0". No commands are shown. How can I fix this? Here is a copy of my config.yml

      permissions: {system: default}
        default: true
        info: {prefix: '&8[&0Guest&8]&8', suffix: '&8', build: false}
        inheritance: []
        permissions: [essentials.spawn, essentials.list,, essentials.motd,
          essentials.rules, essentials.msg, essentials.helpop]
        default: false
        info: {prefix: '&8[&6User&8]&e', suffix: '&f', build: true}
        inheritance: [Default]
        permissions: [essentials.clearinventory, essentials.getpos, essentials.whois,
          essentials.mail, essentials.mail.send,, essentials.realname,
          essentials.compass, essentials.depth, essentials.home, essentials.sethome]
        default: false
        info: {prefix: '&8[&3SuperUser&8]&b', suffix: '&f', build: true}
        inheritance: [User]
        permissions: [, essentials.nick]
        default: false
        info: {prefix: '&2[&aV&2I&aP&2]&a', suffix: '&f', build: true}
        inheritance: [SU]
        permissions: [essentials.heal,, essentials.jump]
        default: false
        info: {prefix: '&8[&4Mod&8]&4', suffix: '&f', build: true}
        inheritance: [VIP]
        permissions: [essentials.kick, essentials.ban, essentials.unban, essentials.unbanip, essentials.banip]
        default: false
        info: {prefix: '&4[&1Admin&4]&9', suffix: '&a', build: true}
        inheritance: [Mod]
        permissions: [essentials.*]
        default: false
        info: {prefix: '&1[&4Owner&1]&4', suffix: '&f', build: true}
        inheritance: [Admin]
        permissions: ['*']
        group: Owner
        permissions: ['*']
  8. Offline


    I have a problem.
    I have bin a loyal mod/admin on a server for 6 months.
    And now sins essentials i cant :{.
    As you can see my nick is fully out of numbers.
    And essentials dus not take it.
    Please help.

  9. Offline


    15-Feb-2011 1:37:35 PM org.bukkit.plugin.SimplePluginManager callEvent
    SEVERE: Could not pass event PLAYER_JOIN to Essentials
    java.lang.ClassCastException: java.lang.String cannot be cast to java.util.List
    at com.earth2me.essentials.Essentials.getLines(
    at com.earth2me.essentials.Essentials.getMotd(
    at com.earth2me.essentials.EssentialsPlayerListener.onPlayerJoin(
    at org.bukkit.plugin.RegisteredListener.callEvent(
    at org.bukkit.plugin.SimplePluginManager.callEvent(
    at net.minecraft.server.ServerConfigurationManager.a(
    at net.minecraft.server.NetLoginHandler.b(
    at net.minecraft.server.NetLoginHandler.a(
    at net.minecraft.server.NetworkListenThread.a(SourceFile:91)
    at net.minecraft.server.MinecraftServer.h(
  10. Offline


    where can i find latest release build versionnumber? in thread is 188, in wiki is 192.
    and does the devbuild work without hard bugs?
  11. Offline


    Great plugin, however I have a request.

    Is there any way for a "Normal" gate to be built automatically at the spawn of the Nether world? One of the players said Nether spawned them on top of lava which killed them and sent them on top of bed rock somewhere, instead of a spawn point as well.

  12. Offline


    i have problem with the command /n if I tipe /n MYNAME theNameIwhant
    nothing happens just a red message pops up showing me ne command: /n <player> [nickname:eek:ff]
  13. Offline


    It's really cool plugin and it's really handy for bulding and stuff.
    yeah i like it. Keep up the good work
  14. I have the Essentials.jar and EssentialsHome.jar on my server, and added the following for my default group.
    - 'essentials.home'
    - 'essentials.sethome'

    However the players say that neither /home or /sethome works, I wonder why? Everything seems to be just fine, but it gives errors for the players that they do not have permission for this command.
  15. Offline


    Group spawns simply do not work, I tried to set them to Reg, Mod and Admins, but everyone just reverted to the Default spawn.
  16. Offline


    Yeah, I'm getting the same thing. Great idea...doesn't function.
    --- merged: Feb 15, 2011 11:56 PM ---
    Do you have any other plugins running with a home feature? Like General?
    And make sure that it's not disabled in the config.yml in your Essentials folder.
  17. Offline


    Did you check your config under disable commands?
    It disables it on default.
  18. Offline


    You should try /nick instead of the shorter /n and what version of essentials are you running?
    --- merged: Feb 16, 2011 12:01 AM ---
    I found that trips to the nether through portals will take you to the coordinates of your real world spawn. If you don't like where you end up you can delete the nether folder from your server and restart. That will give you a whole new nether to play with. I also asked about the nether portal situation and ementalo said they would work on it over the next few days.
  19. Offline


  20. Offline


    Feature creep? Seems more and more stuff is getting added while basics such as help still arent working fully.

    2011-02-16 00:20:23 [INFO] [PLAYER_COMMAND] ssechaud: /help
    at org.bukkit.command.PluginCommand.execute(
    at org.bukkit.command.SimpleCommandMap.dispatch(
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    at net.minecraft.server.NetServerHandler.c(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.Packet3Chat.a(SourceFile:24)
    at net.minecraft.server.NetworkManager.a(SourceFile:232)
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.NetworkListenThread.a(SourceFile:104)
    at net.minecraft.server.MinecraftServer.h(
  21. Offline

    Michael Murphy

    Please, please, pleeeeeease make the economy system a seperate modular jar that is not part of the core system for those of us using iConomy.
  22. Offline


    Is there something you can do to make Essentials not conflict with MCDocs when using /rules and /motd?
  23. Offline


    If /mod isn't working for you:

    I spent a few hours troubleshooting this. It's like, you know the permission nodes are set correctly, so why can't our mods use /mod?

    Ops.txt. You have to add them to the Ops.txt, and then make sure to check the Essentials config if you don't want them to be red, you'll have to delete the '&c'

    I hope this helps someone.

    Apparently Ops.txt plays a big role in higher up permissions (also changing nicknames of others) so make sure to check that if you're having permissions issues.
  24. Offline


    /spawn doesn't work without Permissions. Why?
  25. Offline


    I suggest anyone who is having problems with kits or just general issues with understanding how to modify the config.yml file, please take a look at the new tutorial here: Config File Tutorial
  26. Offline


    @Zenexer , Did protection get finished yet and anything about logging yet. Was hoping to go live in 12 hours or less but might not be a good time yet.
  27. Offline


    For the color of the admins names is there a way to set the colors for just one person.
  28. Offline


    getting endless errors for the EssentialsProtect jar... possible yml issue being null?
  29. Offline


    Hmmm... why is everything worth $1? How can I fix this and is the essentials currency integrated with iConomy?
  30. Offline


    Does anyone else get a client crash when trying to use /plugin list? This must've been recent, I was running a bukkit build 186 with Essentials 133 last time I had a stable bukkit server. Did not have this issue then.

    EDIT: Forgot to include my bukkit version. I'm using 323 w/ latest Essentials core. Here's the crash report from my client.

    --- BEGIN ERROR REPORT a1dce528 --------
    Generated 2/15/11 11:25 PM

    Minecraft: Minecraft Beta 1.2_02
    OS: Windows 7 (x86) version 6.1
    Java: 1.6.0_23, Sun Microsystems Inc.
    VM: Java HotSpot(TM) Client VM (mixed mode), Sun Microsystems Inc.
    LWJGL: 2.4.2
    OpenGL: ATI Radeon HD 4800 Series version 3.3.10188 Compatibility Profile Context, ATI Technologies Inc.

    java.lang.StringIndexOutOfBoundsException: String index out of range: 70
    at java.lang.String.charAt(Unknown Source)
    at nh.a(SourceFile:152)
    at nh.a(SourceFile:119)
    at pe.a(SourceFile:238)
    at ll.b(SourceFile:346)
    at Source)
    --- END ERROR REPORT 5deb121c ----------
Thread Status:
Not open for further replies.

Share This Page