Inactive [GEN] Essentials v2.1 [?]

Discussion in 'Inactive/Unsupported Plugins' started by Zenexer, Jan 19, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline

    Gene Myers

    No plugins are working any more

    Istick, Magiccarpet..Essentials Minecart mania

    I dont understand whats going on.

    Please i will donate $20 to someone who can FTP and try to fix this.

    Like i said, im not new to this stuff.. its the oddest thing ive ever seen happen.

    Im not getting errors in my server logs, whats going on is that my plugins folder is not being reconzied by my sever for some odd reason..

    [edit] World Edit works.. Thats it though. Please help, My server is tottaly down now because of this.
  3. Offline


    If you can come to chat we will be happy to help you get it going.
  4. Offline


    Could someone tell me what is in EssentialsProtect/ what it does? Looked on the wiki, read last few pages, can't seem to find any info. I have seen the config file from some people that have it, but I was hoping for more info to avoid possible compatibility problems.

    EDIT: Got an answer on IRC, its still in development. Just in case anyone else was wondering. (out of the few people who actually read the information about the plugins they use)
  5. Offline


    How do you page down on the help menu in game... All I see is some of the commands and it says "Page 1 of 8"

    Sorry for the newb question... [​IMG]
  6. Offline


    Type /help (page number)
  7. Offline


    Sweet. Thanks.
  8. Offline


    /getpos should really say what world you're on.
    similarly, /tppos x y z world ? :)
  9. Offline


    Is there a way to disable Nether world generation?
  10. Offline


    Yes, delete the nether folder turn the nether off in the essentials config.yml, it will not generate when restarted
  11. Offline


    I'm getting this error
    2011-02-14 20:48:53 [INFO] Starting minecraft server version Beta 1.2_01
    2011-02-14 20:48:53 [INFO] Loading properties
    2011-02-14 20:48:53 [INFO] Starting Minecraft server on *:25565
    2011-02-14 20:48:53 [INFO] This server is running Craftbukkit version git-Bukkit
    -0.0.0-406-g7b86244-b325 (MC: 1.2_01)
    2011-02-14 20:48:53 [INFO] Preparing level "world"
    2011-02-14 20:48:53 [INFO] Preparing start region
    2011-02-14 20:48:54 [INFO] Preparing spawn area: 8%
    2011-02-14 20:48:55 [INFO] Preparing spawn area: 20%
    2011-02-14 20:48:56 [INFO] Preparing spawn area: 44%
    2011-02-14 20:48:57 [INFO] Preparing spawn area: 73%
    2011-02-14 20:48:58 [INFO] Preparing spawn area: 93%
    2011-02-14 20:48:59 [INFO] [iChat] version [1.5] (Maria Holic) loaded
    2011-02-14 20:48:59 [INFO] [iConomy] version [2.2] (Aime) loaded
    2011-02-14 20:48:59 [INFO] [Permissions] version [2.0] (Handler) loaded
    14.feb.2011 20:48:59 com.earth2me.essentials.Essentials loadData
    SEVERE: null
    java.lang.ClassCastException: java.lang.String cannot be cast to java.util.Map
            at com.earth2me.essentials.Essentials.loadData(
            at com.earth2me.essentials.Essentials.reload(
            at com.earth2me.essentials.Essentials.onEnable(
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(
            at net.minecraft.server.MinecraftServer.e(
            at net.minecraft.server.MinecraftServer.c(
            at net.minecraft.server.MinecraftServer.d(
    Preparing spawn area for nether, 36%
    Preparing spawn area for nether, 73%
    2011-02-14 20:49:01 [INFO] Loaded Essentials build 190 by Zenexer, ementalo, Eri
    s, and EggRoll
    2011-02-14 20:49:01 [INFO] Loaded EssentialsBan bTeamCity by Zenexer, ementalo,
    Eris, and EggRoll
    2011-02-14 20:49:01 [INFO] Loaded EssentialsHelp b184 by Zenexer, ementalo, Eris
    , and EggRoll
    2011-02-14 20:49:01 [INFO] Loaded EssentialsHome build 184 by Zenexer, ementalo,
     Eris, and EggRoll
    2011-02-14 20:49:01 [INFO] Loaded EssentialsSpawn b184 by Zenexer, ementalo, Eri
    s, and EggRoll
    2011-02-14 20:49:01 [INFO] Loaded EssentialsWarp build 184 by Zenexer, ementalo,
     Eris, and EggRoll
    iMonster for iConomy version 1.6 is enabled!
    Permission plugin detected - you must have iMonster.User
    2011-02-14 20:49:02 [INFO] KitPlugin version 1.06 is enabled!
    2011-02-14 20:49:03 [INFO] Persistence: Found Permissions, using it for permissi
    2011-02-14 20:49:03 [INFO] Persistence version 0.35 is enabled
    2011-02-14 20:49:03 [INFO] Done! For help, type "help" or "?"
    What could it be?

    EDIT: I fixed it by moving all the Essentials plugin except Essentials.jar started the server, stopped it, added one of them started the server then stopped it and did that on each of them. So now it's working :D
  12. Offline

    Andrew Walden

    It loaded but I also get this error:
  13. Offline


    I'm having an issue with EssentialsHelp. I'm using build 191 and craftbukkit 332. Right now the only other plugins on the server are Permissions and the Essentials pack.

    When I type /help I get the default bukkit help system, when I do /plugin list EssentialsHelp is in red.

    I'm not getting any errors in the server.log

    ** EDIT **
    I take it back, the problem is with EssentialsSpawn. Its causing w/e plugins are typically loaded behind it to not load. I added WorldEdit and noticed that it was doing the same thing as help. So I backed everything out and added them one at a time to figure out which one was failing. It was EssentialsSpawn, I removed it and everything else works.
  14. Offline


    Hey can I have some help please?
    I have essentials and permissions running now and I have given my groups the essentials nodes I want them to have including the "" so they should have the help menu right? Wrong.... kinda. All they have is a blank help menu showing "Page 1 of 0"

    Can you please help? I have reverted to putting the commands on signs in the spawn... [​IMG]

    Btw they can use the commands I have assigned them...
  15. Offline


    Lately, I've been trying to use Spawn List with Essentials. Unfortunately, they seem to conflict with each other. I talked to Lego6245 (the plugin developer), and he said...
    So I was wondering if there was anything you could do about that, like some coding stuff, or split it into another plugin, like you've been doing lately.
  16. I have checked in a fix for this, it is in current dev build and will be in next release
  17. Offline


    can u please help me anyone?my /msg doesnt work for anyone and i got permissions working fine is just says ERROR 1 and gives me template on how to send the message also the /ban kicks u outta the game
  18. We cannot intercept any commands, because he has the same command as us then they conflict. This is a bukkit thing. Options are they rename command or we split it out, but splitting it out won't be for a while if we choose to.
    --- merged: Feb 14, 2011 11:14 PM ---
    What version of essentials do you have
  19. Offline


    Thanks man.
  20. Offline


    @ementalo Repost since you're online. A couple more requests. I don't want to give everyone "/world" permissions, so can you make it so setting a portal in the nether points it at whatever world is at "/world normal" please? Also, when I setup a portal in the normal world it took me to the spawn location for my normal world, but in the nether...which was over lava. I have a spawn point set in the nether so if you could make the portals point there it would be great. Also, when I go to "/world nether" I land at the spawn point I set while I was there...this is great since I have a shelter in place there, but when I "/world normal" it puts me in the area of my normal world spawn, but not on the exact location. Almost as if I died under the old system and it just puts you in the general area. Seems like a "/setspawn <worldname>" might help clear up the locations. Last thing, I messaged you a while back about global announcements for /afk. You said it wouldn't be much trouble but I'm assuming you forgot about it after that. Thanks.

    Edit: New problem (or maybe you 'fixed' it) now when I do "/spawn" in the nether it takes me to the spawn in the normal world. And if I set spawn while in the nether, that becomes the /spawn for all worlds. Have to say I liked it better when each world had their own.
  21. Offline


    Is it possible to put a command prefix like "s" so then when I type in a essentials command i have to type /sitem.
  22. Offline


    I am on CB build 326. I just downloaded the file from the wiki and installed the 4 JARs I use, Essentials, EssentialsBan, EssentialsHelp, and EssentialsSpawn. Commands like /plugins work, however the /plugins disable does not, as well as /reload, so I assume the main Essentials JAR is working as well as before, but /help, /spawn, and /who do not work. Just letting you know.
  23. Offline


    I dont think the OP meets the guide lines Not any where can i see what builds it works for. Is it hidden in a link some where

    Im still using general but due to a lack of updates im looking at other ways..
  24. Offline


    Running CB build #320, Essentials build #191 (according to console @ startup) & MCDocs v5.1

    Running Essentials with MCDocs, I prefer to use MCDocs for things such as MOTD, rules, etc. as these can be done on the fly, and I quite like features such as getpos, compass, etc. (all Essentials CORE). I disabled 'motd' & 'rules' in Essentials' config.yml so that I could use the MCDocs stuff instead. Low & behold, when I try typing /motd or /rules in-game, nothing happens. I remove the Essentials plugin and the commands work fine.

    Why is it that Essentials is disabling commands SERVER-WIDE, instead of just those associated with it's own plugin? I SHOULD be able disable the Essentials version of these commands in the config.yml and have other plugins commands work, instead of having to delve into the .JAR & remove the /motd & /rules commands from Essentials. If this is something from the CraftBukkit API, then I'd be more than happy to log a fault on your behalf to get this fixed.

    Another couple of notes/requests:
    - Not sure if it's just me or not, but is /ping missing from the commands wiki? (Aelux/chill1977 maybe?)
    - No where does it tell us what version we're downloading that I can find & given I downloaded build 191 roughly 18-24 hours ago, then the OP is definitely not kept up to date.

    To the guys & gals that have put much effort into this, please don't get me wrong. I'm using it & loving it. Just feels a bit like we're flying blind and not getting all the info we need to be able to administer our servers & get the right versions of this plugin.

    BTW, kudos to zhilan on the IRC channel for helping me out earlier this arvo :)
  25. Offline


    I've got the same situation regarding my server. What I did, was simply commenting out the motd and rules in the config. This leaves only an error when a player connects, but nothing serious - at least it lets me use MCDocs instead.

    But I do agree that by adding a command to the disabled list in the Essentials config file should not disable that command server-wide, but disabling it for that current addon only. I think a list to disable a command server-wide could be handy either way, so I'd like to see a list of locally (plugin-only) disabled commands, and one for server-wide (all plugins) disabled commands.

    And yes, the /ping is missing from the wiki, allthough I am very sure I saw it there not long ago.

    And yes again, I too feel that it's hard to know what's the newest version of Essentials when there's no such information in the main post.
  26. Offline


    We are glad you like Essentials. You must understand that the new wiki is still under construction, but I understand that it does not list the build you are downloading as it just has links to get the newest builds and I will address this now. We have not released a build since 191 due to the major conflicts with other plugind and craftbukkit breaking a few things that we are working on. We want the next release to be working, not half working. Please bear with us while we get everything set up as this is for your benefit.
  27. Offline


    i need help with a permissions problem
    i wonna make a group only allowed to build and use the /i command
    but i can't get it to work i have tried with these to be allowed to use it.
    - 'ICommand'
    - 'I'
    - 'Essentials.ICommand'
    - 'Essentials.I'
    can any tell me what i'm doing wrong?
    so far only admin and op's can use essentails

  28. I will be looking into the whole spawing over the next few days, so I will take into account this in mind. And yeah I forgot about the afk thing heh, I will do that today
    --- merged: Feb 15, 2011 9:48 AM ---
  29. Offline


    Hi, great plugin you have here. Don't know if this should be a new plugin request or if it is even possible, but here goes:

    It would be fantastic if this could every X-minutess poll the server for various data and output it into some kind of human readeable format.

    Data I would love is:

    • Average idle ram
    • Avergae idle CPU
    • Current ram useage
    • Current CPU useage
    • Number of connected players
    • Chunks loaded
    • Avg ram per player
    • Avg cpu use per player
    There's probably more useful data too, but if that was possible, it'd be simply awesome.
  30. Offline


    That is a lack of bukkit features. It only allows one plugin for each command. So it uses first come first serve. Every other plugin that's trying to reserve a command will only get the fallback command (which is <Pluginame>:<Command>).

    If you have ideas how to fix this issue you could comment in this issue.


    PS: Will the /time command come to get the ingame time in the console?
  31. Offline


    Sounds to me like a diffenrent plugin, maybe you could make it. ;) lol
Thread Status:
Not open for further replies.

Share This Page