Inactive [GEN] Essentials v2.1 [?]

Discussion in 'Inactive/Unsupported Plugins' started by Zenexer, Jan 19, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    I agree!!!! I don't use that stupid economy crap on my server nor the bans, and would love for this plugin to be entirely modular as @mattekure suggests in his post!
  3. Offline


    /world nether still puts me in the normal world D:

    I have the latest Craftbukkit build.

    Also, after typing /world nether, when I die I spawn in the void and gets killed every time. I think it's because I run BiomeTerrainMod.

    *More: After disabling the BiomeTerrainMod, I still run into the same problem. So it's definitely not that wrapper causing the problem.
  4. Offline


    If u have essentials, do /god and do /world nether but no matter wut u do, any portals, etc. u will get sufficated. Btw, the degreif stick will help u dearly in the nether, as when u spawn in teh nether, u are on bedrock. with the stick, dig down
    M1sT3rM4n likes this.
  5. Offline


    In dev build #252, typing /help does not provide any output. The console output is:
    2011-02-09 00:00:18 [INFO] Ganzor tried command: help

    I tried adding the EssentialsHelp.jar plugin with it, but that one displays 19 pages of help when members only have permissions to use 2 pages of commands. Is this an intended behavior or a bug, and how would I fix it?
  6. Offline


    First of all, Dev builds will not be "officially" supported, but you can make bug reports for them.

    Second of all. The help command is not bugged, but incapable (because of the way Bukkit handles commands now) of deciding which command goes with which group/user. Thus you get all of the information for all plugins.
  7. Offline


    I have this same problem... I deleted the "normal" world, but still have the "world" folder... so nether is "/world 0" and "world" is "/world 1"

    I don't know how to get the "normal" back... if that's the source of the problem.
  8. Offline


    The reason I switched to the dev build is because I am experiencing the same issue with the #172 release build.

    In terms of the second point, I'm saying typing /help does absolutely nothing. It is as if the command does not exist, though typing any of the specific Essentials commands does work. Also, you can remove commands from the help menu by editing them out of the plugin.yml, or at least I was able to when the help menu was working.

    This is what my server is running:
    CraftBukkit build #289
    Essentials Build #252 currently, also tested on #172 with same issue
    Permissions 2.0
    Minecart Mania 0.80
    LWC 1.491
    SlowHealth 2.3
    MyHome 1.8
    SpawnControl 0.5.4
    WorldEdit 3.2.2

    Thanks for the help, this plugin is awesome.

    Edit: Reverting to the previous essentials file allows the help menu to work again. With permissions used along side essentials, the help menu even lists just the commands each group can view. I'm not sure on the build number, but the build date for the version which is working for me is 2/5/2011 at 1:39pm.
  9. Offline

    Kelly Becker

    Hey so i was wondering if there was a way to disable the multi world function all together... i know i can disable the command but i want to fully disable the generation of the nether and the loading of it into memory.
  10. Offline


      enabled: false
    Should prevent it from being loaded.
    --- merged: Feb 9, 2011 9:57 AM ---
    For help to work you need EssentialsHelp.jar. I would suggest sticking with CraftBukkit build 280 as it is the most stable build with the current Release build 172 of Essentials.
  11. Offline


    Hi there

    First thing first: I use CraftBukkit build 290 ( I need 288+ for Minecart Mania)
    I think EssentialsHelp has some kind of bug, because it always lists all commands which are available on the server, instead of only those for which the player has permissions (Using permissions plugin).
    I tried using developer version and release version but both show all commands, even those that return a "You don't have permission to use this command" or something similar.

    It's no big problem with the plugins which do not have a lot of commands, but when using WorldEdit everybody has 15 or 16 pages of help with 1/9 commands per page useable .... and this is kinda annoying :)
  12. Offline


    Please read all threads before posting a new one about the same question. Go HERE to see why /help displays all commands.
  13. Offline


    I seem to have a little problem and hope somebody can help :)

    First of all using cb 290 + 172essentials. And Nether = True

    But here comes the tricky part, portal to nether works fine, i get in and boom im in nether.

    WHEN i have to go back from nether, the portal tells me "teleporting through portal" and then just sit's me on top of nether portal ? and not back to normal world ? what am i doing wrong here ? ^,-

    EDIT: also people cant use my portal to go through ? do they have to make their own, or i need to set permissions ? and also it seems to drop me off random in nether taking huge falldamage ?
  14. We are addressing all these issues, multiworld spawning is buggy, we are looking at how to approach this.
  15. Offline


    I'd be careful with digging down on bedrock, you may fall through the void! :p I usually use the /unstuck command to get me out of any situation...
  16. Offline


    Anyone managed to get this work with the latest MyHome plugin (1.8) ?
  17. Offline


    Was splitting this plugin up into 5 different plugins necessary? This will be a pain to update now.
  18. Offline

    Sondre Berntsen

    Um, how does the /bigtree command work? I tried using just /bigtree, but i got this "Usage: /bigtree [tree:redwood]" which I have no idea what means..
  19. Offline


    I can't get in to the irc chat in my browser.. what's the info?
  20. Offline


    The [tree:redwood] are your command options you may use after /bigtree, essentially. So, you can use "/bigtree redwood". or "/bigtree tree".

    Also, i've only had luck with that command by being surrounded by a rather large amount of dirt/grass. It seems placement is random based on your location.
  21. Offline


    My essentials has stopped working so i downloaded it again hoping for a newer update + i think you have updated it but now i see loads of folders and i dont know what to do with them? Do i need to update Bukkit at all? Please reply ASAP
  22. Offline


    Hmm, I can't use the help command anymore and warp, but I did put it in the permissions(And it worked on the earlier version)
    Has it been changed?
  23. do you have the EssentialsHelp and EssentialsWarp
  24. Offline


    CB Version: 289

    • WorldGuard 3.2.2
    • WorldEdit 3.2.2
    • Permissions 2.0
    • Essentials 172
      • EssentialsCore
      • EssentialsBan
      • EssentialsHelp
      • EssentialsHome
      • EssentialsWarp
    • Vanish 1.3.4
    • CraftIRC v1.70b BETA
    • Reserved 2.0.2
    • iChat 1.5
    • AutoMessage Version 1.2
    • Remote Toolkit Plugin V0.11b
    A /world normal command issued from within the nether halted the server. I got a java heap error message, running on 1024M. Does this mean, 1024M is not enough to handle nether?
  25. Offline


    is it possible to make so that when typing kit,the plugin checks the inventory,and leaves out tools already present?
  26. Offline


    I'm getting the following error. It maybe a confiliction plugin but I have no idea:-

    Error: Only in-game players can use ping.
    Error: Only in-game players can use ping.
    Error: Only in-game players can use ping.
    Error: Only in-game players can use ping.
    Error: Only in-game players can use ping.
    Error: Only in-game players can use ping.
    Error: Only in-game players can use ping.
    Error: Only in-game players can use ping.
    Error: Only in-game players can use ping.
    2011-02-09 17:12:00 [INFO] [CONSOLE] Saving world data. Expect lag for a short w
    Error: Only in-game players can use ping.
    2011-02-09 17:12:00 [INFO] CONSOLE: Forcing save..
    2011-02-09 17:12:02 [INFO] CONSOLE: Save complete.
    2011-02-09 17:12:02 [INFO] [CONSOLE] Save Complete
    2011-02-09 17:12:02 [WARNING] Can't keep up! Did the system time change, or is t
    he server overloaded?
    Error: Only in-game players can use ping.
    Error: Only in-game players can use ping.
    Error: Only in-game players can use ping.
    Error: Only in-game players can use ping.
    Error: Only in-game players can use ping.

    Does anybody have any ideas?
  27. Offline


    @ghj290 - need to post your CB version, all plugins installed, and versions... otherwise really can't help at all.
  28. Offline


    Simply pick the jars out of the folders that you want and place them inside your plugins directory. If you're upgrading from a version which did NOT have the separate jars, you need to backup your config.yml and allow the Essentials.jar to generate a new one for you.
    --- merged: Feb 9, 2011 5:27 PM ---
    Use the bug report system and mark it as an enhancement.
  29. Offline


    Just pondering.. with E172 and CB289 - Set nether=false in essentials config.yml, but users still able to access nether through portals now. Were the portals added by the CB build? Anyway to disable and/or restrict by user rank?
  30. do you have something that uses ping?
  31. Offline


    To restrict /world use, use the permission. Once a world is spawned, it is permanent. Setting nether=false just prevents it from generating on server load if not previously generated. Since your nether world is already generated, it exists. No, Zenexer was able to develop the portal functionality himself, now that entering worlds works (CraftBukkit created hooks for entering worlds).
Thread Status:
Not open for further replies.

Share This Page