Inactive [GEN] Essentials v2.1 [?]

Discussion in 'Inactive/Unsupported Plugins' started by Zenexer, Jan 19, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    @chill1977 Does the warp command in essentials support public and private warps? If it does not, then it's not exactly a MyWarp replacement for me...
  3. Offline


    I totally understand that but if you chose to use both plugins then you have to disable the commands for one plugin or the other, just leaving them open is not an option when people have the '*' permission as both plugins try to do the same thing and it causes problems. I tell people to use oe or the other rather than trying to explain how to disable commands ;) there is enouygh they don't understand as it is.
  4. Offline


    Very true, I just disable the warp and setwarp for essentials, very simple.
  5. Offline


    Essentials is easy to disbale commands since they actually give you the option in the config file, but most of these plugins don't give you that option
  6. Offline


    Zen, ty for an amazing mod.

    I was wondering, since you have a /spawnmonster like command, do you know if is it currently possible to spawn a HumanEntity? is there a method within bukkit for it ?
  7. Offline


    @Zenexer: Could you add an option that when I promote a user to another group, eg. "/mod UserName VIP", everyone gets a chat message "User UserName was promoted to VIP"? That way, I wouldn't have to every time tell explicitly the users about the change.
  8. Offline


    Fixed it. Looks like I needed to get a clue :)
  9. Offline


    It's ok sometimes a little reading goes a long ways lol
  10. Offline


    I forgive you :p, Seems craftbukkit build 167 and 168 both suffer the same issue just wait it out :(
  11. Offline


    can you break up the /plugin commands? i would like to give visiting users access to '/plugin list' but not '/plugin reload/enable/disable/ect' commands.

    also sending the '/version' and '/plugin list' is currently crashes the client when running 16 plugins. I believe its due to too much information being sent via chat. With little or no plug-ins i can send the '/version' command and with less than 16 plug-ins i can send the '/plugin list' command without the client crashing.

    sorry if i have posted in the wrong place, love the plugin.
  12. Offline


    the /version has a problem for some reason and I believe you are talking about Permissions to set groups with certain commands
  13. Offline


    Well, at least it's clear that Bukkit broke something. I wish they'd post a changelog on the mainpage or something containing all fixes / bugs / changes every time they update, just to keep the amount of "YOUR PLUGIN WRECKED MY SERVER D:"-posts down.

    I'm also a tad bit annoyed with the "ESSENTIALS BROKE MY PERMISSION FILE D:" spamming. People need to read (or perhaps OP can add a FAQ to his original post, assuring people that all is well and it still works!)
    The syntax for the Permissions is, in my opinion, not even that 'hard' to understand. People need to understand that programming in general brings along syntax at times that many will be annoyed by, but once you get the hang of it, it's not such a big deal. I'm busy making a Wiki revolving around MineCraft / Bukkit / Essentials so people can look up info there about handy mods, add-ons and tools. Also want to add a section on setting up Permissions, although that might not be needed.

    P.S. Essentials FTW! @Zenexer thank you for the quick fixes you keep on posting. Really gives me the idea that you take us seriously :)

    P.P.S. I read that the Permissions system is going to be changed completely with integrated Pemissions in Bukkit itself. Has this been taken into consideration for future development?
  14. Offline


    Yeah well it has to happen first, you cant really count of something that big until it takes effect.
  15. Offline


    Zenexer, comments for your newest builds:

    - 1st of all, please update the release tag already and with each build; it is utterly annoying & confusing to get at server restart the text "Loaded Essentials b129...", after loading build #175 of your plugin...

    - secondly: no changes for the /help system. I have enabled in Permissions config only 15 commands for my default users, still when they type /help, they get 12 pages of commands (of which, they only have a permission to use these 15...). I don't know if it is your plugin or what is causing this: but here it has at least been discussed.

    * * *

    Would anyone happen to know what plugin might cause this:

    2011-01-30 14:09:02 [INFO] [MYHOME] Permissions enabled.
    I do not have myhome plugin!
  16. Offline


    The most recent versions of bukkit broke nearly every command....
  17. Offline


    Chill, could you post your config file for me? I'm not quite sure what you meant in your last post to me, but I have an idea. Still, a config file example would really help me [​IMG]
  18. Offline


    please make tutorial for it to show us how to use.
  19. Offline


    Hiya @Zenexer could u add /respond (alias: /r) to msg back the person that just messaged you last?

    /msg mhalkyer hi!
    /r hi!

    Could you also add a required/suggested CraftBook version # to the OP?
  20. Offline


    Am i to understand that updating Essentials to 128 will rewrite your Permissions/config.yml? Mine changed its formatting magically on its own, and Permissions people say its from /modgrp which no one has access to but me, and Ive yet to use it.

    Now Permissions doesnt load on startup, giving everyone free reign to do whatever they want when the server restarts till i can login and do a /plugin load Permissions
  21. Offline


    I am can't script java..
    What can I do^^
  22. Check your plugins release page and see if they support permissions

    The #175 you see are source code checkins and not builds, the build number gets updated once we release to build.

    The checkins are given a once over by another dev and tested again before they make it to the build, as such the help changes will come in the next released build.

    Can you list your plugins and we maybe able figure out the offender of the MYHOME text
  23. Offline


    Permissions seem to work for me atm. WorldEdit seems okay for now, can't verify if WorldGuard is and just added AntiBuild but have no idea if that'll conflict with WorldGuard or something (WorldGuard is in essence AntiBuild, no?)


    /i isn't working anymore :(
    /help looks all messed up
  24. Offline


    My user file and /home locations get deleted on every server crash. You should fix that please!
  25. I just updated to the most recent craftbukkit build (172), and now i get this error whenever i start the server:

    Jan 30, 2011 4:02:51 PM org.bukkit.plugin.SimplePluginManager loadPlugins
    SEVERE: Could not load plugins/Essentials.jar in plugins: null
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(
        at net.minecraft.server.MinecraftServer.e(
        at net.minecraft.server.MinecraftServer.c(
        at net.minecraft.server.MinecraftServer.d(
    Caused by: java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(
        at java.lang.reflect.Constructor.newInstance(
        ... 8 more
    Caused by: java.lang.NoClassDefFoundError: net/minecraft/server/EntityPlayerMP
        at org.bukkit.earth2me.essentials.Essentials.<init>(
        ... 13 more
    Caused by: java.lang.ClassNotFoundException: net.minecraft.server.EntityPlayerMP
        at Method)
        at java.lang.ClassLoader.loadClass(
        at java.lang.ClassLoader.loadClass(
        ... 14 more
    Any idea what might be causing this? or how to fix it?

    Basically i am only running essentials and spawncontrol (for the more precise /spawn), i tried running without spawncontrol, but no luck there.

    I tried a fresh server, but essentials doesn't even create it's config file, added to that is that if the server runs for too long with that error, Finder freezes on me (running OSX) and i have to restart it.
  26. Offline


    rollback to 166, updates broke almost all plugins and you will neeed updated plugins for 167 on.
  27. Offline


    Rolled back to 168. Works like a charm
  28. Offline


    Nevermind, I fixed it. Downgraded bukkit build
  29. V130 has been released, this should be compatible with latest crafbukkit, includes help limiting also
  30. Offline


    Good stuff, What kind of help limiting :p
  31. Just that the help should only show what peole have access too
Thread Status:
Not open for further replies.

Share This Page