Inactive [GEN] Essentials v2.1 [?]

Discussion in 'Inactive/Unsupported Plugins' started by Zenexer, Jan 19, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    Yep, confirmed that after updating to the latest Essentials version (#152), AntiBuild stopped working in a sense that no one on my server can build anymore. I suspect that for some reason, "build: true" isn't related properly to AntiBuild now? Other than that, I think even /mod works.
  3. Offline


    I'm going to disagree here I blame craftbukkit build 150+ as that’s when I had the build issue I can test this if I have to but I think its a spawn protection size issue like no one can build a thing unless there OP for over 500 blocks ore more in any direction, JUST move REALLY far away from the spawn and it should let u build.

    This could be an issue with this plug-in but I also use spawncontrol and I have this plug-in’s spawn stuff disabled.
    The key thing to remember here is I only had this issue were you have to be ridiculously far from spawn to build since upgrade to the latest build of craftbukkit.

    It might not be Antibuild at all is what im saying. Beside's I dont even use it and I still have the issue. I tried a rank below admin and built it just would not let me.

    I will test this some more. I also already made a support request on offical bug report section of bukkit about this.

    MOTD playerlist now works, thx
  4. Offline


    My bows to you, Sir, you are absolutely right. Although I'm still using CB build #141 due to problems with later builds, I did not of course realise that today I just as a test moved my spawn location with Essentials - and then tried to build literally on spawn point...

    I feel stupid now - but on the light side, Essential and AntiBuild still works :) My apologies for a false alarm.
  5. Offline


    I dont have the problem ledhead describes, it is utter bogus you cant build around spawn. Something else you use must cause this, but certainly not craftbukkit 150+.
  6. Offline


    When you /kill a player is their inventory supposed to disappear?

  7. Offline



    Awesome work with the help file. Is there a way to control what commands are displayed from other plugins(worldedit, worldguard)?
  8. Offline


    Very stable version. Haven't had any problems yet :p
  9. Offline


    And ran into another problem right away, this time more severe.

    Today, I changed the spawn point of my world with Essentials's /setspawn. Now if I do myself /spawn, I go to my newest spawn point. But all others who try to log into the server as "Default" users, still spawn to the previous location and complain getting a hangup right away. I see them on the server for 20 seconds or so, after which they log out and I get to my console "timeout".

    One user whom I have promoted to "VIP" however can get in and everything works for him. But: he logged in first time earlier today when I had not yet moved my spawn point.

    Could /setspawn screw something up?
  10. Offline


    How do I configure this? I want kits :D
  11. Offline


    I would stick with MyWarp. That's an awesome plugin. I bet you used it's features to convert your old warps.txt? I use it and I haven't had any problems with it ^_^

    More than one plugin hasn't kill anyone. Upset- Maybe~ Killed? I Doubt it.
  12. Offline


    If all you want is kits there's a plugin called "KitPlugin" that works wonders.
  13. Offline


    You do understand the more plugins you have running the more lag they produce, and those with 20+ plugins running need to simplify as much as possible. Not to mention all the changing and modifying with each update, less is better.
  14. Offline


    I like it to, but it has alot more features then I really need and that's 1 less plug-in I gotta maintain. If nothing else I'll just convert my old warps.txt by hand, just gotta cut and paste :).....

  15. Offline


    OK i guess i need to read back . is there something wrong with /kits or you just need help configuring?
    --- merged: Jan 27, 2011 7:09 PM ---
    Yeah, i just switched from MyHome and MyWArp to this and I wish there was a simple converter lol
  16. Offline


    I do and I run 15+
    BB is a killer on lag. Every time I do a rollback, everyone has huge lag for a few seconds.

    Essentials does most of my player side stuff. For this, I'm thankful!
  17. Offline


    I currently have a small player base of friends I play other games with. I only run about 5-6 plugins so far cause I'm new to this and really havent figured out what they all do.

    I really would like to get rid of noon though lol

    I do know after all the changing back and forth, this plugin is awesome!! Keep up the good work!

    Thanks for the help file, this is awesome! Did I say this is awesome? lol
  18. Offline


    Is there a correct procedure for loading in a new version of Essentials? if my server remains running, and I want to upgrade to the newest build, what would I have to do to get it working properly? I always end up having errors.

    I do /reloadall and I've tried /essentials without any luck. I've actually went as far as /plugin reload Essentials. I always end up getting an error in game that makes it show multiple command information each time i reload the pluggin.

    Like someone types /help they will see the help menu twice. then three times, and so on the more i reload the plugin.

    So am I installing the new version wrong or would i have to shut down the server to install it?
  19. Offline


    Yessir! Confirming b121 fixed up the MOTD colour issue. Thanks as always!
  20. Offline


    Every time I update my plugins I stop my server, update, then restart it. I don't know if this is necessary but it is good practice.

    I also have my server sitting next to my computer so its a little easier being able to just log onto my linux box. I don't know how it works if you use a hosting company.
  21. Offline


    @SilverbladeNL Thanks, I've fixed the wiki. You are more than welcome to copy any content, provided The tree function that you are seeing is part of WorldEdit or a similar plugin--Essentials only provides commands to make trees as you type.

    @GmK You can disable individual commands altogether via the config.yml file. Simply add the commands to the disabled-commands list.

    @Beatkidz One of my clients just requested that, so it's definitely on today's todo list. :)

    @misterzizka /modgrp [player] [group] <-- Will not work if you don't have Permissions

    @EvilMaL you need to indent the lines starting with dashes a bit more. They have to be indented further than the "items" line. The spamming blocks problem is not related to Essentials.

    @misterzizka WorldEdit does provide individualized permissions. I am working on a custom alias system that should solve your issue. though. :)

    @fffizzz @Beatkidz /plugin is temporarily volatile due to a concurrency flaw in Bukkit's design. Unfortunately, there is very little that I can do to fix this on my own, but I will do my best to push for a fix.

    @mickael9 Using Permissions will enable this sort of behavior.

    @Etsijä That it does need more documention! I am still looking for volunteers to help keep the documentation up-to-date and, even more importantly, write tutorials. I'm doing my best to distribute my time being documentation and programming, but yesterday was definitely geared more toward the development side of things. The reparsing issue definitely needs to be noted somewhere. However, that is perfectly valid notation, and it is parsed with the exact same tool that Permisisons uses. The only downside is that it removes any comments. There is no reliable way around this: reparsing the document is by far the most "ethical" means of editing it. Now, AntiBuid I have not tested. If that is the culprit here, which it likely is, this is completely unrelated to Essentials, and the situation is either a coincidence, or AntiBuild is the one improperly parsing the config file. "Permissions: null" is actually more accurate than just "Permissions:", which is technically invalid. You could also do "Permissions: ~", as tildes are shorthand for null values in YAML. (Edit: Looks like I was wrong, and it was CraftBukkit! :p)

    @grinch843 If you send me the DB file, I can automate the conversion for you, but like @Nate204 said, stick with MyWarp if you have it: I've heard fantastic things about it, and the developer is very nice. Yes, inventories are supposed to disappear. If they don't, let me know, and I'll get it fixed right away. :)

    @stevo Essentials automatically examines newer plugins to determine their commands. Currently there is no way to limit this, but if demand to do so is high, I will certain implement such a feature. :)

    @Etsijä /setspawn uses Bukkit's API. It's certainly possible that you are experiencing some strainge bug, though I haven't noticed a problem yet.

    @AskCharlie You cannot reload a JAR without bringing the server offline--at least, not without very expensive software, I'm afraid. :(

    Did I miss anyone? Please, don't hesitate to remind me if I did!
  22. Offline


    Actually, atm I think the problems with spawn location and some players not able to log in is a problem in either the client (pending also on the Java version the players are using) or CraftBukkit build - not your plugin.

    Keep up the excellent work!
    --- merged: Jan 27, 2011 9:10 PM ---
    And, if you're looking for volunteers to help you in documentation/tutorial field, feel free to PM me.
  23. Offline


  24. Offline


    With the /help system should my users be seeing all help even to commands that dont have permissions to? When I jumped from 89 to b121 is looks like they see all help for every command now...
  25. Offline


    I've tried that, but when I try the command it says the invalid message. Here's my kits.txt file located in plugins/KitPlugin.

    Just diamond tools, bow, arrow, diamond armour, watch and compass... basically essentials. I also tried editing the items file with THIS plugin, but you can't do multiple items :p
  26. Offline


    @benthemeek That will be fixed in the next release.
        - 278 1
        - 277 1
        - 276 1
        - 261 1
        - 262 64
        - 310 1
        - 311 1
        - 312 1
        - 313 1
        - 279 1
        - 345 1
        - 347 1
  27. Offline


    IS there a way to TP to coords?
  28. Offline


  29. Offline


    Thanks very much! But where do I change this?
  30. it is in the config.yml under plugins\Essentials
  31. Offline


    @Zenexer Hey, great commands, though I do have one suggestion... If a player has no permissions to accept or deny a teleport, then any player who teleports to them should automatically be granted an accept. My default class has very few permissions and since they are on a probation period, they should always be able to be teleported to by the higher ranking players (some of them have just the /tpa and /tpahere commands). Thanks.
Thread Status:
Not open for further replies.

Share This Page