Inactive [GEN] DefaultCommands v4.0.0 - The "default" plugin [1.4.5-R0.2]

Discussion in 'Inactive/Unsupported Plugins' started by vildaberper, Mar 2, 2011.

  1. Offline


    You need to enable whitelist in DefaultCommands.yml; whitelist: true.
  2. Offline


    Looks like Bukkit 1240 "broke" defaultcommands.
    java.lang.IllegalAccessError: tried to access field net.minecraft.server.ItemStack.damage from class com.vildaberper.DefaultCommands.Util
            at com.vildaberper.DefaultCommands.Util.convertItemStack(
            at com.vildaberper.DefaultCommands.SaveLoad.saveInventory(
            at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(
            at net.minecraft.server.MinecraftServer.h(
    Also does your plugin say unknown command when the command truly is unknown?

    Unless something happened
    /version is bukkit's command to print out its version.
    /gamemode is a built-in vanilla command.

    both return defaultcommands red "unknown command" message.
  3. Offline


    Ill fix that soon. :)

    It sais unknown when the command isnt registered by any of the plugins the server is running.
    Forgot /version, thanks. :)
  4. Offline


    Sweet thanks. Also your plugin stops player chat from appearing in the console. I can't find a way to turn that off so that player chat WILL appear in the console. Currently I have to look at the DefaultCommands.log file to see what is being said to me when I chat from the console and have to guess some because console chat doesn't appear in the DefaultCommands.log file. :)
  5. Offline


    Downoalding...... :D:D looks awesome
  6. Offline


    I readded it in the dev build, but its for CB 1240. :)

  7. Offline


    I'll play lab rat. Will let you know what blows up if anything. You figured out the accesserror in the dev build, too?
  8. Offline


    Yup, really simple. :)
  9. Offline


    Is there no bpermissions support?
  10. Offline


    Nope, will add support for it though. :)
  11. Offline


    Thanks so much :)

    Thanks for adding the support when you get around to it, but it seems the most latest version doesn't work with PEX either xD (I have 2 servers don't ask) I don't like it when my Regular's cane give themselves stuff and really don't prefer to use Commandbook or essentials when I can use amazing Default commands!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  12. Offline


    Seeing as DefaultCommands has so many features, I think it should have a web interface where everything can be controlled.
  13. Offline


    Is there a way to disable certain commands? Like /dcgive, for instance? I find the normal /give player item easier.
  14. Offline


    Suggestion: It would be awesome, with a "/create flat [name] <seed>", which create flat-grass worlds :)
  15. Offline


    It would seem that inventories aren't being saved properly. Through out the day inventories update correctly but restarting the server sends you back to what you started the day with. Nothing special in the logs from what I can see for a possible cause.

    I have noticed that your plugin saves inventories inside it's own folder which it has been doing without problem.
    While looking in to this issue I see there are also inventories listed in the "/world/players/" folder. Not sure if they were there before the dev build I grabbed Tuesday or not. I'm going to remove my inventory from the world folder and see what happens. I'll update you on how it goes in a few minutes.

    Good news is the player chat appears in the console now. :)

    It would seem that after a server reboot the first time a player connects to the server their inventory is loaded from your plugins directory as expected. Any time their inventory gets saved it is saved in the "/world/players/" not into your plugin's folder which is not expected. All connections after the first result in the player's inventory getting loaded from "/world/players/" which isn't expected either. Thus whenever the server reboots it causes player inventories to revert to the previous days. Not sure what the deal is there. :/

    There is nothing in the logs indicating an issue. I figured this out by looking at the last-modified times of the files change as I logged in/out and how my inventory reacted in-game as i kept deleting my "/world/players/credomane.dat" file.

    Just got some more word in from players. Seems /setwarp aren't saving across reboots either. When I look at Warp.yml is looks like it is updating, though. Thinking this is just a standard PICNIC error so don't panic just yet.

    Ok. Apparently whatever bug that appeared in your plugin because of 1240 broke the saved inventories in your plugin folder. I had to completely down the server then delete the player inventories. After that everything seems to be saving correctly again. The missing warps is from the server not shutting down cleanly for the nightly restart. Since the warps aren't saved to the file periodically some were lost. Is there a command to force save the warps, player inventories, and whatever on demand?

    Is there a /dc save? I see the docs mention a /dc load to reread the files from disk but I seem to be glossing over a force save the information to disk if there is one.

    /dc gave me a list of all the goodies. there is a /dc save
    the dev build I grabbed the other day is working great once i took care of the players PICNIC errors...and mine. :p

    /dc update says
    There is an update available (3.6.0), currently running (3.7.0).
    yes i know goes to the latest release /dc updatedev is the correct one when running a dev build or wanting a dev build.

    In the DefaultCommands.yml change the line
    give: item amount target
    give: target item amount
    That will make it act like you want.

    ok that won't quite work apparently. seems to make the player part required at that point.
    look for the lines below in Commands.yml just add the number 2 to the end of give or remove the " - give" line entirely.
     - give
     - item
     - i
    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  16. Offline


    no matter what permission plugin i use they dont seem to work with 3.6 of default commands and the old 3.5 is posting alot of errors to my console i wont to update but noone can build unless op once i do. if u would like a list of my plugins let me know btw i love the plugin
  17. Offline


    Man, this plugin does accept commands from other pluginsbecause I have a plugin to add another player and spawn ap Bukkitpage where you exercise the command does not accept.

    A brief summary of the commands of the plugin to add a newspwan.

    /gy add spawnname

    Not only that but if you can not do these modifications in your pluginyou could suggest me a plugin where I can use the commands from other plugins.

    Thank you for you have put your plugin to download very efficient since I am creating a server with 30Slots.
  18. Offline


    when i change same Settings in DefaultCommand.yml and save it, than reload server, the Settings are no mor change. they are in the unchanged like before. what is it?
  19. Offline


    [SEVERE] Could not load 'plugins/DefaultCommands.jar' in folder 'plugins':
    java.lang.UnsupportedClassVersionError: Bad version number in .class file

    Why is it doing this? I'm pretty sure my java version is up to date.
  20. Offline


    Do /dc load instead, reloading saves the files and then loads them again.

    Try redownloading the plugin. :)

    Okay, that didnt make too much sense.

    PermissionsBukkit is required to display groups, but any permissions-plugin that use superperms will work.

    If you tell DC that you need to specify a player before the item, player is required.
    Not that hard to understand since you have to specify the item to give it to someone.
    item target amount - does not require player, itll default to the sender.
    target item amount - require player since item is specified after target.
  21. Offline


    Good evening, sorry for my English is google translator. I wanted to know a few things. The first, I wanted to understand how to put the plugin only for admins and normal users can not use it. The second, when I put the plugin says that I'm not allowed to split blocks even when they are opped. how can I do? I am a beginner.
  22. Offline


    Thank you. It worked. :)
  23. Offline


    k i know permissions3.6 is not maintained anymore does that mean its not supported? and if i cant get any of the perms plugins to work could u help me?
  24. Offline


    Whenever players talk, it says something along the lines of "Bob<suffix>: Hi". How can I get rid of the "<suffix>" part? It wouldnt let me delete that part in the YML file (it kept putting it back). Also, is there a way to incorporate ColorMe into it? Because DefaultCommands seems to override colorme colors.

    Plugins running:
  25. Offline


    Please fix all the buggs, like can't acces player data, it even makes the server randomly crash sometimes! and it is a error when a player joins! When will you fix this? =(
  26. Offline


    I currently have THIS bug and after some tests it seems DefaultCommands is causing it, since it saves Inventorys when a player logs out, but when they are not logged in their inventorys are hidden, so DC saves an empty inventory. :/
    So, is there any way I can turn off the inventory saving of DC?
    Or could you somehow make it compatible with xAuth? That would be even better, because then I could use the seperate inventories function of DC too.
    Please. ;_;
  27. Offline


    im getting this error alot now, any idea whats wrong? using latest bukkit, and indev DC.

    no, im not using latest DC:p the reason why, is if i use latest DC, my permission wont work somhow.
  28. Offline


    Change it and do /dc load.

    Not enough info.

    Ill add config to disable separate inventories and armor. :)

    Use the latest DC with 1240, it wont save inventories and armor correctly otherwise.
    I didnt make any changes to the permissions relates functions, so it should work like before.
    PinguinAman likes this.
  29. Offline


    Tried redownloading, still gives me

    [SEVERE] Could not load 'plugins/DefaultCommands.jar' in folder 'plugins':
    java.lang.UnsupportedClassVersionError: Bad version number in .class file
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(
    at Method)
    at java.lang.ClassLoader.loadClass(
    at java.lang.ClassLoader.loadClass(
    at java.lang.ClassLoader.loadClassInternal(
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at org.bukkit.craftbukkit.CraftServer.<init>(
    at net.minecraft.server.ServerConfigurationManager.<init>(
    at net.minecraft.server.MinecraftServer.init(

    Sorry for large spam, I don't know if that helps more or not, but that's the errors I get.
  30. Offline


    Okay thanks! I didn't know "/dc load" was different than just reloading the server. Great plugin by the way!

    Also, is there a way you could hook this in with ColorMe? I love the "chat:" line in the config, but I don't think theres a way I could let everyone have their own colored names and the "chat:" line enabled.


Share This Page