Inactive [GEN] DefaultCommands v4.0.0 - The "default" plugin [1.4.5-R0.2]

Discussion in 'Inactive/Unsupported Plugins' started by vildaberper, Mar 2, 2011.

  1. Offline


    Zones are coming!
    I saw this and almost wet my pants.
    this is awsome....!!!
    Thank you so much.
  2. Offline


    Hey, great plugin!
    I'm having an issue though. I'm trying to create a world with a seed but for some reason I get a randomly generated one rather than the seed I entered.
    I'm typing:
    /dccreate myworldname normal 3475exampleseed934574

    Am I doing something wrong? thanks!
  3. Offline


    This is an amazing plugin. Thank you for putting your time into it. I haven't run into any problems with it so far, but I'd appreciate it if you would make it so that when creating a new world with the command it is possible to make a Skylands world. I've seen some other plugins that can make a Skylands world, but I'd like to keep the number of plugins I'm using as low as possible so they're easier to keep track of.
    Thanks again for this wonderful plugin.
  4. Offline


    ooh I'm having another issue. I set all the block spawn things for monsters to true, and they keep showing up! how do I turn them off?
  5. Offline



    I've got two problems with DefaultCommands in combination with the Permissions-Plugin.

    1. If I install DefaultCommands, no Player is allowed to build, even if in groups or users.yml "build: true" is set. I found out, that I have to set the permission to the player/group, that the player is allowed to build. Is this ok this way? Does give the players give more rights, than simple placing and removing blocks?

    2. I have a group administrators, I want them to be able to fly around the map. So I set:

    But this does not work, still the same message "No Permission". Even if i op me, I am not allowed to do that. Why?

    Please help me. Thanks in advance!

    Edit: Forgot to say: 860 + latest DefaultPlugin!
  6. Offline


    Looks fine, it should work. "/
    Ill look into it.

    Hmm, that would require a whole new world generator.

    Did you do '/dc load'?

    Players without '' cant do anything (except run around and die), its a powerful build: false. :)

    '' means that he can toggle fly for more than one player with one command. Add '', that allowes the player to toggle fly for him/herself. :)
  7. Offline


    Hi vildaberper,

    thanks for your support. I tried what you said:

            - Player
                - ''
    But still, if I press 'T' and enter /dcfly I've got "You do not have permission to do that". I reloaded the permissions, reloaded the server and finally restarted the whole bukkit server. Does not work.
    I also have now the problem, that I am not able to build, even with As you can see, I am in the group "Player"
    This group looks like this:

            default: true
                prefix: '[G]'
                suffix: ''
                build: false
            default: false
                prefix: '&3'
                build: true
               - Default
                - ''
    But still I am not able to build. Has this something to do with DefaulCommands or is it more a Permissions problem and I should aks in the Permissions thread for help?

    Thanks again
  8. Offline


    See the extra space before - ''? Thats probably whats wrong. :)
  9. Offline


    Yes, I see but this was only here in the forum.
    I have some more permissions (for chest-protecting & creating npcs)which I edited out for this post and during this, the typos happend. In my file, there are 12 blanks in front of it :)

    Edit: Hmm now it seems to work. What I did? Its weird... I did:

    # mv Permissions.jar Permissions.jar.old

    Then reloaded the Minecraft server. Was getting then some errors in the console.


    # mv Permissions.jar.old Permissions.jar

    And reloaded again. Now it works?! How can this be?

    Edit2: Okey, I think I have a general Permissions problem on my server. Now I can build also if I dont give permission '' but set build: true. But if i try to create a npc ('citizens.create.*') this does not work - no permission! But the suffix in the chat shows, that I am in the right group :( I think Im gonna post this better in the permissions thread. Thanks for your help!!!

    Ok, new post: I have kicked out ALL plugins and then rebuild my plugin folder. First I putted in permissions, then magiccarpet. Worked perfectly. Only the group, which have the permission is able to use this plugin.
    Same with Lockette (to protect Chests, and so on).

    At last I placed the DefaultCommands.jar in my plugin folder. Since then, it started to get weird:
    The Group Player has "build: true" and permission ''
    Now the "Player"-users can destroy blocks and places blocks but... they cant pick up anything?! :(

    Am I doing it wrong or is this build (I used the recommended developement-build) corrupt?

    PS: If i remove the DefaultCommand.jar and then send a reload to the console, I instantly can pickup the items! :S So it has to do with DefaultCommand :|

    Edit: IMHO the development (recommended) build is broken. If I use the 3.1.4, pickup works!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  10. Offline


    amm. igot problem with TMI. How do i get it working on my server? When i try using it it says:
    Invalid player(s)
    /dcgive <item>[:data] [amount] [player]
    Can you help me? =(
    Btw. if i put settoomanyitems.txtto: {1}: {3}{2}{0} it works but when i stop the server it reloads every file in DefaultCommands. =(
  11. Offline


    You probably downloaded it right after I updated (I forgot some stuff xD).
    Redownload and it should be fine. :)

    Follow the instructions in the main post. :)
  12. Offline


    But where do i put the command to enable TMI? I tried putting it into DefaultCommands.YML but after i stop my server it have reloaded every file in the DefaultCommands folder. :(
  13. Offline


    wat command?
  14. Offline


    to get the toomanyitems working settoomayitems.txtto:1:3 2 0
    or am i just beign confused????
    i'm having troubles :confused:
  15. Offline


    Edit the file Kits.yml
  16. Offline


    I'm using permissions 3 with this. However, my default users cannot destroy(mine) any blocks unless i allow access to all permission nodes '*'

    Any idea which node i need to add? So users can destroy blocks?

    Thank you.
  17. Offline


    '<world>'. :)
  18. Offline

    Sean O'Connell

    Hey, I just downloaded your plugin, and it is awesome, but i need to make some changes to commands/get rid of some commands, how do i go about doing this?
  19. Offline


    Fly seems to have stopped working with the new dev build. Has it changed? I'm waving my feather and nothing's happening.
  20. Offline


    I love you lol. Thank you, great work.
  21. Offline


    How do you add kits.I know you can edit the kits file , but how?
    What do you write in order to add another kit?

    Please I want the vildaberper the plugin developer to answer as soon as possible please!
  22. Offline


    Your plugin has risen to the title "The Almighty Plugin Of Plugins"
  23. Offline


    Just remove the aliases:
    - help
    Ill look into it in a sec, I think I just have to rebuild.
    Errors when shooting arrows is fine until I update too. :)

    - 'id1:data1 amount1'
    - 'id2:data2 amount2'
    etc. :)

    Cool! :D
  24. Offline


    Is there a list of the names of items we are supposed to use when doing cuboid or sphere based things? I can figure out the easy ones like "clay" but not the ones with spaces in their names like "lapis lazuli block." Any help with this would be appreciated.
  25. my MOTD is showing wierd stuff for the players list

    does this for everyone eonline.

    any ideas?
  26. Offline


    You can use the ids from this site:
    You can also edit Items.yml and add item aliases. :)

    Update to the latest version. :)
  27. Offline


    Thanks for the update vildaberper, you have now made it into our official plugin list for our server. Unlike Essentials there is no alternative to this plugin.

    Now I can smite people like Zeus again.
  28. Offline


    I just tried the new Skylands feature and it works wonderfully! Thank you so much!
  29. Offline


    I don't seem to understand something about the building permissions... I am not quite sure what and where I shall place. I guess it is the (I am no good at this though) But do I place it at the per-world config or the CommandPermissions per-world config?
  30. Offline


    In DC's Config.yml, add it to permissions. '*' :)

Share This Page