Inactive [GEN] DefaultCommands v4.0.0 - The "default" plugin [1.4.5-R0.2]

Discussion in 'Inactive/Unsupported Plugins' started by vildaberper, Mar 2, 2011.

  1. Offline

    Don Redhorse is quite fine..
    hmm doesn't work.. plugin interaction?
    no I meant that I have the same inventory in the creative world and creative nether, but that I have a different inventory in the survial world and nether. Also I want to have the same config for creative world and creative nether, like monster spawn, health etc.
  2. Offline


    I have the same problem, also using Brohoster. Run a server on your own computer in offline mode, and it should create the files you need, then edit them and upload to the admin control panel. /whitelist allow doesn't work for me either, I have to edit the whitelist manually.
  3. Offline


    Read the main post.

    Update CB.

    Oh, ok. You cant yet.
    But copy config is possible, I think the key is "copy". :)
  4. Offline


    Hmm... it would be cool to have a command, that when activated would cause chunks around you to regenerate as you walk. This would be awesome for resetting areas quickly.

    WorldEdit does have a function to regenerate chunks, it would just be cool to have it done as you walk to make it much easier.
  5. Offline


    something that would be great is, a customizable help file. to let people know the available command and such.
    would it easy?
    Also /spawn is not working for people. :p
    using dc.spawn.self*
  6. Offline


    Pardon me for not reading the whole thread, but I'm having problems with my warp commands.
    I can set them fine, and (sort of) go to them fine... but it seems if I have a warp set in a cave/mine/etc, when I warp to that point, it puts me on the next available vertical block instead of the cave itself.

    Again, sorry if this has been looked at/answered, but I just wanted to know if this is a bug or if I can fix it somehow.
  7. Offline


    Okay, so I cannot get portals to work for the live of me. It just says Invalid Selection. I've setup the Obsidian portals in both worlds, created Warp points, and I'm typing /dcsetportal OWP world1:world2 then I tried /dcsetportal OWP CWarp:OWarp. Neither worked, though
  8. Offline


    its .* :)

    Set it again, seems like the exact warp location is unsafe. :)

    Its world:<the world you want to go to> and warp:<the warp you want to go to>.
  9. Offline


    now the error comes on the normal start :/
    and the " [INFO] Failed to load inventories." inventories is still there, i thought it could be MultiInv, but its definitly not

    i will try to reduce the plugincount ... i have now 68 xD
  10. Offline


    That might be it. xD
    Maybe theres a java process in the background that crashed?
  11. Offline


    dunno, but loading 90x all 1190 inventories is realy too much open files, default maximum files for linux/apache server is 65k
    i have many guests on my server that dont stay for long, maybe adding a function to delete all inventories from all players that are in no group

    the only error i get b4 this too many open files is from bigbrother, it couldnt create a table ... whatever
  12. Offline


    I forgot to close the inputstream when loadig inventories. xD
    Should be fixed in the latest dev build, try it out. :)
  13. Offline


    ok, thx, it works fine again, no "failed to load inventory" error :)
  14. Offline


    I've had another idea.
    When a player asks an admin for items (just asking normally, no commands or anything) multiple admins may send the same item to them, resulting in useless duplicates (when using /give).
    Could you set up a broadcast for admins (through a permission like dc.give.broadcast) so when an admin sends an item to someone other than themselves (otherwise it would broadcast too many times) it tells all admins that the item was sent?
    Also I've noticed, and it may be just me, but when I /give an item to somebody else it tells me that "[otherplayer] gave [otherplayer] [item]" instead of "[you/me] gave [otherplayer] [item]"
  15. Offline


    I updated Permmisions, still same error
  16. Offline


    I wanted to avoid posting but its really bothering me, was there a change in how the config file is set up in V3? I say this because there is no "config.yml" file in your posted zip file, except the one in the world folder, and its different from the old V2 one. The point I am getting at is, is there any info on transitioning our config files from V2 to V3 or could I be having plug-ins disputing with one another? My MOTD stopped displaying in V3 (but a message from another plug-in displays that did not before) and I cant find any motd setting in the new config files....

    ....sorry if I did not clearly write this issue, I am very tired and have a major headache.
  17. Offline


    V3 is a whole new plugin. with new config files. So there is no motd yet!

    There will be config for it, like notlogbr.yml in 2.5.5.
    Thanks, will be fixed in the next version! :D

    What error whas that again?
    I dont feel like looking through the thread while Im on the ipod. ;)
  18. Offline


    I'm having trouble with permissions and I wonder if I am doing it right. The file I'm editing is plugins/DefaultCommands/Worlds/<worldname>/Config.yml But everytime I change something the file gets wiped and returned to default when the server restarts. Is there any other file I should edit?
  19. Offline


    Read the main post. :)
  20. Offline

    Don Redhorse

    A Wiki, yeah... runs off to get an account...
    or use a feather... for flying..

    hmm so i put the nether worldname in there? so what does the environment do?
  21. Offline


    I did, still can't get it to work. I start the server, copy my config.yml, type /dc load, the console says Loaded but the permissions and group assignments doesn't work. If I restart the server the file gets wiped.
  22. Offline


    What about the option: "OP-Permissions: " in the config.yml, must be false for permissions. That was the error I made.
  23. Offline


    I tried that now, but still with same result. Could it be that there is some error in my config.yml that causes it to be wiped?
  24. Offline


    good question. Try shutting down the server, then edit everything and then start it up again.
  25. Offline


    The file didn't get wiped this time, but the permissions still doesn't take effect. Nor does group assignments.
  26. Offline


    Alright, try giving me the config files. (Permissions and Config.yml)
  27. Offline


    So, there should be two separate files?

    Attached Files:

  28. Offline


    No, just me that wants to look through your permissions config to see if it is there the problem lies

    Got some things. First: its a .yml not a .txt file, so you need to rename it to .yml.
    Second: Permissions are usually enclosed in single quotes (only know Permissions, not vilda's integrated)
    Third: Users with a space in there name is usually also enclosed in single quotes

    Also, you removed the line, "permissions:" between "block_zombie_spawn" and "groups:" perhaps that is also a factor

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  29. Offline


    I don't have a config for permissions, only the config.yml
  30. Offline


    Try checking the other things I posted

Share This Page