[GEN] BukkitInventoryTools - Find it on BukkitDev.

Discussion in 'Inactive/Unsupported Plugins' started by Gabriel333, Sep 11, 2011.

  1. Offline


    olimoli123 likes this.
  2. Offline


    i dont think servercraft will let this plugin work because ive found the console but all it tells me is when the server starts, saves and when a player joins or leaves it doesn't display anything your picture does
  3. Offline


    I agree i use my plugin with CB1060 / 1.7.3 myself, but I develop under CB1185 and Spout (a development version build 370) so I know my plugin work when then they release a SpoutCraft which works.

    As I said you must use CraftBukkit not servercraft. It is not the same server.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  4. Offline


    Strange, here's what I'm getting:

  5. Offline


    I will investigate tomorrow I need to sleep now :'(, it should work on porks too...

    I dont know how I install SpoutCraft manualy (i can only find a zip file)???

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  6. Offline


    you should seperate ability to CRATE locks and USE them in digilock.use ie only ppl with permissions can create,but everyone can enter passwrd/use items with fingerprints...
    when bukkitinventorytools.digilock.use is disabled for everyone,then no one can use that was locked,just shown text,that its locked and nothing...
    this make me stick with LWC for now.
    atm using BIT only for lever locking
  7. Offline


    I want to beat LWC :) but I know it takes some time.

    Im not sure i understand why you want both create and use permissions. If a user create a DigiLock, then other users cant change/delete his lock, Thats only admins who can do it. If users dont have create permission then they will not be able to create a DigiLock, but why then use this plugin at all, if the users are not allow to use it?
  8. Offline


    This is what seems to happen if i try to fingerprint something;

    2011-09-23 01:17:35 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'digilock' in plugin BukkitInventoryTools v2.2.4
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:41)
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:163)
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:353)
        at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:756)
        at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:721)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:714)
        at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
        at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:92)
        at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java:500)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:464)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    Caused by: java.lang.ArrayIndexOutOfBoundsException: 1
        at dk.gabriel333.BukkitInventoryTools.BITCommandDigiLock.onCommand(BITCommandDigiLock.java:55)
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:39)
        ... 13 more
  9. Offline


    here can you find the dev builds.

    install: just open the minecraft.jar en drag everything from the zip in to the jar
    make sure to delete META-INF
  10. Offline


    I had forgot to test the fingerprint feature from command mode :mad:

    I have released Version 2.2.5. Where you can lock with fingerprint by typing

    /digilock lock fingerprint

    then you are able to open the lock if you are the owner. If you dont use the owner parm when you create the lock owner will be the player by default.
  11. Offline


    You get craftspout to install correctly by the way? I want to know if the L hotkey and popup works in the latest dev.
  12. Offline


    Not yet, but I will properly try tonight :)

    I have not found any errors and it works on my server: You must check your permissions.

    I have added a new permissionnode, like you wished in version 2.2.6


    By default it is true, so if you want to deny a user to create it you must do this:

    bukkitinventorytools.digilock.create: false


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  13. Offline


    Alright if you need any help let me know i've already had to help several peeps on my server.
  14. Offline


    Hrm :\

    My permissions are currently
                 bukkitinventorytools.*: true
    Edit: Okay, I tried to disable the digilock via PermissionsBukkit but it didn't take and I was still able to hit 'L' for the lock screen. BukkitInventoryTools does say it detects PermissionsBukkit... is it possible it will still ignore it if it's detected?

    Edit 2: Not sure what's going on, tools, buckets, and signs stack. Still nothing on the food. When I do /perms dump {user}, none of the pages mention bukkitinventorytools
  15. Offline


    1) No it cant ignore PermissionsBukkit, but i see one difference. I dont use bukkitinventorytools.*: true
    this gives you admin rights, and im not sure what would happen if you try to "deny" something at the same time???
    I have written all the lines my self, so i could test "deny" on the individual lines.

    I will try * myself

    Edit: i have tested it, and now i have the same error as you do... i will find that error :)

    Edit2: I have found the bug. It will be fixed in release 2.2.8. in a moment,
  16. Offline


    simple :3
    i wanted few ppl to have possibility to create lock,but everyone could use it,but if i disable digilock.use for everyone,then CANT use locked items
  17. Offline


    Anyway - I have made it for YOU :cool: Just upgrade to the newest release! (>v2.2.6)
  18. Offline


    awesome =D just what i was looking for hmmm... is there a way to remove the code so i can ruin the chest?
  19. Offline


    just press L when looking at locked chest/lever or whatever and ull see "remove" button
    thnx :cool:
    there is another idea for your plugin...
    you could add option to lock/unlock at some time (ie until 10am door/chest is unlocked,but at 10:01 am its locked,and again unlocked at 10pm)
    i personally don't need it(at least for now),but who knows...maybe someone need it :3
  20. Offline


    Im trying to install WAMPServer (www.wampserver.com) but the services does not start ??? Which WAMP server do you suggest i try?
  21. Offline


    Thanks! Things are working now! :D
  22. Offline


    Yes ... and in next release you will get an AutoCloseDoor feature, so you can close the door automatically after xxx seconds :)
  23. Offline



    1.8.1 with spout and 1185 version release of BIT

    24.09 17:16:21 [Server] INFO MCBans: bradgillap has disconnected!
    24.09 17:16:21 [Disconnect] User bradgillap has disconnected, reason: disconnect.endOfStream
    24.09 17:16:21 [Server] INFO Connection reset
    24.09 17:16:12 [Server] INFO     at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    24.09 17:16:12 [Server] INFO     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
    24.09 17:16:12 [Server] INFO     at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:464)
    24.09 17:16:12 [Server] INFO     at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    24.09 17:16:12 [Server] INFO     at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java:500)
    24.09 17:16:12 [Server] INFO     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:92)
    24.09 17:16:12 [Server] INFO     at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    24.09 17:16:12 [Server] INFO     at org.getspout.spout.packet.CustomPacket.a(CustomPacket.java:130)
    24.09 17:16:12 [Server] INFO     at org.getspout.spoutapi.packet.PacketKeyPress.run(PacketKeyPress.java:71)
    24.09 17:16:12 [Server] INFO     at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:338)
    24.09 17:16:12 [Server] INFO     at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    24.09 17:16:12 [Server] INFO     at org.bukkit.plugin.java.JavaPluginLoader$93.execute(JavaPluginLoader.java:897)
    24.09 17:16:12 [Server] INFO     at org.getspout.spoutapi.event.input.InputListener.onCustomEvent(InputListener.java:44)
    24.09 17:16:12 [Server] INFO     at dk.gabriel333.BukkitInventoryTools.BITInputListener.onKeyPressedEvent(BITInputListener.java:128)
    24.09 17:16:12 [Server] INFO     at dk.gabriel333.BukkitInventoryTools.BITGui.setPincode(BITGui.java:238)
    24.09 17:16:11 [Server] INFO     at org.getspout.spoutapi.gui.InGameScreen.attachPopupScreen(InGameScreen.java:197)
    24.09 17:16:11 [Server] INFO     at org.getspout.spoutapi.gui.GenericWidget.setScreen(GenericWidget.java:146)
    24.09 17:16:11 [Server] INFO     at org.getspout.spoutapi.gui.GenericPopup.setScreen(GenericPopup.java:67)
    24.09 17:16:11 [Server] INFO     at org.getspout.spoutapi.gui.InGameScreen.closePopup(InGameScreen.java:151)
    24.09 17:16:11 [Server] INFO java.lang.NullPointerException
    24.09 17:16:11 [Server] SEVERE Could not pass event CUSTOM_EVENT to BukkitInventoryTools
    24.09 17:14:41 [Server] INFO     at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    24.09 17:14:41 [Server] INFO     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
    24.09 17:14:41 [Server] INFO     at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:464)
    24.09 17:14:41 [Server] INFO     at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    24.09 17:14:41 [Server] INFO     at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java:500)
    24.09 17:14:41 [Server] INFO     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:92)
    24.09 17:14:41 [Server] INFO     at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    24.09 17:14:41 [Server] INFO     at net.minecraft.server.Packet15Place.a(SourceFile:57)
    24.09 17:14:41 [Server] INFO     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:592)
    24.09 17:14:41 [Server] INFO     at net.minecraft.server.ItemInWorldManager.interact(ItemInWorldManager.java:259)
    24.09 17:14:41 [Server] INFO     at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:168)
    24.09 17:14:41 [Server] INFO     at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:338)
    24.09 17:14:41 [Server] INFO     at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    24.09 17:14:41 [Server] INFO     at org.bukkit.plugin.java.JavaPluginLoader$11.execute(JavaPluginLoader.java:314)
    24.09 17:14:41 [Server] INFO     at dk.gabriel333.BukkitInventoryTools.BITPlayerListener.onPlayerInteract(BITPlayerListener.java:57)
    24.09 17:14:41 [Server] INFO     at dk.gabriel333.BukkitInventoryTools.BITGui.getPincode(BITGui.java:77)
    24.09 17:14:41 [Server] INFO     at org.getspout.spoutapi.gui.InGameScreen.attachPopupScreen(InGameScreen.java:197)
    24.09 17:14:41 [Server] INFO     at org.getspout.spoutapi.gui.GenericWidget.setScreen(GenericWidget.java:146)
    24.09 17:14:41 [Server] INFO     at org.getspout.spoutapi.gui.GenericPopup.setScreen(GenericPopup.java:67)
    24.09 17:14:41 [Server] INFO     at org.getspout.spoutapi.gui.InGameScreen.closePopup(InGameScreen.java:151)
    24.09 17:14:41 [Server] INFO java.lang.NullPointerException
    24.09 17:14:41 [Server] SEVERE Could not pass event PLAYER_INTERACT to BukkitInventoryTools
    24.09 17:13:50 [Server] INFO CONSOLE: Forcing save..
    24.09 17:13:50 [Server] INFO CONSOLE: Forcing save..
    24.09 17:13:50 [Server] INFO CONSOLE: Enabling level saving..
    24.09 17:13:50 [Server] INFO CONSOLE: Enabling level saving..
    24.09 17:13:50 [Multicraft] Auto-saving world...
    24.09 17:12:57 [Server] INFO     at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    24.09 17:12:57 [Server] INFO     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
    24.09 17:12:57 [Server] INFO     at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:464)
    24.09 17:12:57 [Server] INFO     at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    24.09 17:12:57 [Server] INFO     at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java:500)
    24.09 17:12:57 [Server] INFO     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:92)
    24.09 17:12:57 [Server] INFO     at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    24.09 17:12:57 [Server] INFO     at net.minecraft.server.Packet15Place.a(SourceFile:57)
    24.09 17:12:57 [Server] INFO     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:592)
    24.09 17:12:57 [Server] INFO     at net.minecraft.server.ItemInWorldManager.interact(ItemInWorldManager.java:259)
    24.09 17:12:57 [Server] INFO     at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:168)
    24.09 17:12:57 [Server] INFO     at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:338)
    24.09 17:12:57 [Server] INFO     at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    24.09 17:12:57 [Server] INFO     at org.bukkit.plugin.java.JavaPluginLoader$11.execute(JavaPluginLoader.java:314)
    24.09 17:12:57 [Server] INFO     at dk.gabriel333.BukkitInventoryTools.BITPlayerListener.onPlayerInteract(BITPlayerListener.java:57)
    24.09 17:12:57 [Server] INFO     at dk.gabriel333.BukkitInventoryTools.BITGui.getPincode(BITGui.java:77)
    24.09 17:12:57 [Server] INFO     at org.getspout.spoutapi.gui.InGameScreen.attachPopupScreen(InGameScreen.java:197)
    24.09 17:12:57 [Server] INFO     at org.getspout.spoutapi.gui.GenericWidget.setScreen(GenericWidget.java:146)
    24.09 17:12:57 [Server] INFO     at org.getspout.spoutapi.gui.GenericPopup.setScreen(GenericPopup.java:67)
    24.09 17:12:57 [Server] INFO     at org.getspout.spoutapi.gui.InGameScreen.closePopup(InGameScreen.java:151)
    24.09 17:12:57 [Server] INFO java.lang.NullPointerException
    24.09 17:12:57 [Server] SEVERE Could not pass event PLAYER_INTERACT to BukkitInventoryTools
    24.09 17:12:47 [Server] INFO [Spout] Successfully authenticated bradgillap's Spoutcraft client. Running client version:
    24.09 17:12:47 [Server] INFO Reading data
  24. Offline


    is there a way to protect the chests if all players a op ? because if we are op wen can open all chest what we dont want so please help us
  25. Offline


    Hi earlier im getting some kind of glitch when i logon to spout launcher and everything i press L while looking at the chest and i type in the code and when i try to reopen it the "type in code" menu pops up but instantly dissapears and the chest animation doesnt close and at the same time the top right corner will say "Achievment get: used S key" when i didnt use the S key and sometimes itll spam me afterwards if i press S everytime that chest is still open.. (even tho the gui of the chest i cant even see cuz ill be walk away from it)
    Show Spoiler

    yet im getting no errors in my console =\
  26. Offline


    ya... crashed my server.

    the log was full of this..
    2011-09-24 17:24:17 [WARNING] [BukkitInventoryTools]Error at SQL Query: query does not return ResultSet
    2011-09-24 17:24:17 [WARNING] [BukkitInventoryTools]Error at SQL Query: query does not return ResultSet
    2011-09-24 17:24:17 [WARNING] [BukkitInventoryTools]Error at SQL Query: query does not return ResultSet
    2011-09-24 17:24:17 [WARNING] [BukkitInventoryTools]Error at SQL Query: query does not return ResultSet
    2011-09-24 17:24:17 [WARNING] [BukkitInventoryTools]Error at SQL Query: query does not return ResultSet
  27. Offline


    oh, and sadly i just noticed i can punch in any password as i please and it gets inn =( is there something im missing?
  28. Offline


    Did you take into consideration that it may be because you are admin. :)
  29. Offline


    Good job on this Gabriel! I love it!

    FYI: There are some issues in CB 1185, Chests, buttons and levers doesn't work.
    No error message.
    The button and lever does not give power to any nearby redstone when entered the right pin code.
    And for the chests, when you choose the pin code and lock it, after you right click, the unlock gui shows for 1 second and then closes. Makes it impossible to unlock chests.

    Everything else is fine, Really great job!

    Edit: I use:
    CB #1185
    Spout #389
    SpoutCraft #449

    And it seems i get errors when i go in a chest and then press Esc. Even if it's not locked.
    Show Spoiler

    10:40:13 [WARNING] java.lang.NoSuchMethodException: net.minecraft.server.Entit
    10:40:13 [WARNING] at java.lang.Class.getDeclaredMethod(Unknown Source)
    10:40:13 [WARNING] at org.getspout.spout.player.SpoutCraftPlayer.closeActiv
    10:40:13 [WARNING] at dk.gabriel333.BukkitInventoryTools.BITInputListener.o
    10:40:13 [WARNING] at org.getspout.spoutapi.event.input.InputListener.onCus
    10:40:13 [WARNING] at org.bukkit.plugin.java.JavaPluginLoader$93.execute(Ja
    10:40:13 [WARNING] at org.bukkit.plugin.RegisteredListener.callEvent(Regist
    10:40:13 [WARNING] at org.bukkit.plugin.SimplePluginManager.callEvent(Simpl
    10:40:13 [WARNING] at org.getspout.spoutapi.packet.PacketKeyPress.run(Packe
    10:40:13 [WARNING] at org.getspout.spout.packet.CustomPacket.a(CustomPacket
    10:40:13 [WARNING] at net.minecraft.server.NetworkManager.b(NetworkManager.
    10:40:13 [WARNING] at net.minecraft.server.NetServerHandler.a(NetServerHand
    10:40:13 [WARNING] at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetSe
    10:40:13 [WARNING] at net.minecraft.server.NetworkListenThread.a(SourceFile
    10:40:13 [WARNING] at net.minecraft.server.MinecraftServer.h(MinecraftServe
    10:40:13 [WARNING] at net.minecraft.server.MinecraftServer.run(MinecraftSer
    10:40:13 [WARNING] at net.minecraft.server.ThreadServerApplication.run(Sour

    That might be the problem :D
  30. Offline


    haha, thanks.. now thats what u call fail =P
  31. Offline


    I spent about 20 minutes earlier yesterday going through the same issue in my head until I realized how silly. :mad:

Share This Page