[FUN] UltimateFist v1.0.4 - destroy anything in one hit [1.5.1-R0.1]

Discussion in 'Inactive/Unsupported Plugins' started by Philius, Jun 5, 2011.

  1. Offline


    UltimateFist Plugin:
    Version: v1.0.4

    The UltimateFist will destroy anything in one hit (very fast), blocks and creatures. All players who will play on the server have to install this mod: download (German forum)
    The UltimateFist can be craft like this:


    • craft a UltimateFist
    • permissions support
    • 4 different versions
      • version 1: fast, undestroyable
      • version 2: fast, durability of 45000 blocks
      • version 3: slow, undestroyable
      • version 4: slow, durability of 45000 blocks
    download (v1.0.4 version 1)
    download (v1.0.4 version 2)
    download (v1.0.4 version 3)
    download (v1.0.4 version 4)

    Previous Versions: v0.1, v0.2, v.0.3, v.0.4, v.1.0, v.1.0.1, v.1.0.2, v.1.0.3


    ultimatefist.use - Allow you to use the UltimateFist


    Version 1.0.4
    • 1.5.1 compatible
    • now available in 4 different versions!
    Version 1.0.3
    • 1.3.2 compatible
    Version 1.0.1
    • Bug fixes
    Version 1.0
    • 1.1-R4 compatible
    • PermissionsBukkit compatible
    Version 0.4
    • Fixed permission problems
    Version 0.3
    • RB 953 compatible
    Version 0.2
    • Added permissions support
    Version 0.1
    • Released the plugin


    Uploaded with ImageShack.us
    RH2009, OMGtehEPICNESSS and Nerdvana like this.
  2. Offline


    I think the Ultimate Fist Client plugin, link is broken :) I tried, even with login :p
  3. Offline


    I know, they banned me and deleted my thread :(
  4. Offline


    Ok thank you so much for the quick reply. Please update soon!
  5. Offline


    I am still getting an error on my log even with v1000

     17:48:06 [SEVERE] Could not load 'plugins\UltimateFist.jar' in folder 'plugins':
        at net.minecraft.server.RecipesTools.<init>(SourceFile:27)
        at net.minecraft.server.CraftingManager.<init>(CraftingManager.java:18)
        at net.minecraft.server.CraftingManager.<clinit>(CraftingManager.java:10)
        at de.philippwundrack.ultimatefist.UltimateFist.<clinit>(UltimateFist.java:19)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Unknown Source)
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:168)
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:207)
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:130)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:128)
        at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:97)
        at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigurationManager.java:51)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:132)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.NullPointerException
        at net.minecraft.server.StatisticList.d(SourceFile:103)
        at net.minecraft.server.StatisticList.b(SourceFile:82)
        at net.minecraft.server.Block.<clinit>(Block.java:533)
        ... 15 more
     17:48:07 [INFO] [Permissions] (Yeti) was initialized.
     17:48:07 [INFO] [Permissions] version [3.1.6] (Yeti)  loaded
     17:48:07 [INFO] Preparing level "world"
     17:48:07 [SEVERE] java.lang.NoClassDefFoundError: Could not initialize class net.minecraft.server.Block
     17:48:07 [SEVERE]     at net.minecraft.server.BiomeBase.<init>(SourceFile:43)
     17:48:07 [SEVERE]     at net.minecraft.server.BiomeRainforest.<init>(SourceFile:10)
     17:48:07 [SEVERE]     at net.minecraft.server.BiomeBase.<clinit>(SourceFile:26)
     17:48:07 [SEVERE]     at net.minecraft.server.WorldProviderHell.a(SourceFile:13)
     17:48:07 [SEVERE]     at net.minecraft.server.WorldProvider.a(SourceFile:26)
     17:48:07 [SEVERE]     at net.minecraft.server.World.<init>(World.java:139)
     17:48:07 [SEVERE]     at net.minecraft.server.WorldServer.<init>(WorldServer.java:27)
     17:48:07 [SEVERE]     at net.minecraft.server.SecondaryWorldServer.<init>(SecondaryWorldServer.java:8)
     17:48:07 [SEVERE]     at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:210)
     17:48:07 [SEVERE]     at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:148)
     17:48:07 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
     17:48:07 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
     17:48:07 [SEVERE] Unexpected exception
    java.lang.NoClassDefFoundError: Could not initialize class net.minecraft.server.Block
        at net.minecraft.server.BiomeBase.<init>(SourceFile:43)
        at net.minecraft.server.BiomeRainforest.<init>(SourceFile:10)
        at net.minecraft.server.BiomeBase.<clinit>(SourceFile:26)
        at net.minecraft.server.WorldProviderHell.a(SourceFile:13)
        at net.minecraft.server.WorldProvider.a(SourceFile:26)
        at net.minecraft.server.World.<init>(World.java:139)
        at net.minecraft.server.WorldServer.<init>(WorldServer.java:27)
        at net.minecraft.server.SecondaryWorldServer.<init>(SecondaryWorldServer.java:8)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:210)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:148)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
  6. Offline


    I get no error with v1000

    2011-07-25 12:08:56 [INFO] Starting minecraft server version Beta 1.7.3
    2011-07-25 12:08:56 [INFO] Loading properties
    2011-07-25 12:08:56 [INFO] Starting Minecraft server on *:25565
    2011-07-25 12:08:56 [WARNING] The server will make no attempt to authenticate usernames. Beware.
    2011-07-25 12:08:56 [WARNING] While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
    2011-07-25 12:08:56 [WARNING] To change this, set "online-mode" to "true" in the server.settings file.
    2011-07-25 12:08:56 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-945-g73697a4-b1000jnks (MC: 1.7.3)
    2011-07-25 12:08:57 [INFO] [Permissions] (Yeti) was initialized.
    2011-07-25 12:08:57 [INFO] [Permissions] version [3.1.6] (Yeti)  loaded
    2011-07-25 12:08:57 [INFO] Preparing level "world"
    2011-07-25 12:08:57 [INFO] Preparing start region for level 0 (Seed: -5087340806352200662)
    2011-07-25 12:08:58 [INFO] Preparing start region for level 1 (Seed: 4008627126520175819)
    2011-07-25 12:08:58 [INFO] Preparing spawn area: 8%
    2011-07-25 12:08:58 [INFO] [Permissions] SQL Interface enabled!
    2011-07-25 12:08:58 [INFO] UltimateFist version 0.4 is enabled!
    2011-07-25 12:08:58 [INFO] Server permissions file permissions.yml is empty, ignoring it
    2011-07-25 12:08:58 [INFO] Done (0,168s)! For help, type "help" or "?"
    2011-07-25 12:09:38 [INFO] Starting minecraft server version Beta 1.7.3
    2011-07-25 12:09:38 [INFO] Loading properties
    2011-07-25 12:09:38 [INFO] Starting Minecraft server on *:25565
    2011-07-25 12:09:38 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-945-g73697a4-b1000jnks (MC: 1.7.3)
    2011-07-25 12:09:38 [INFO] [Permissions] (Yeti) was initialized.
    2011-07-25 12:09:38 [INFO] [Permissions] version [3.1.6] (Yeti)  loaded
    2011-07-25 12:09:38 [INFO] Preparing level "world"
    2011-07-25 12:09:38 [INFO] Preparing start region for level 0 (Seed: -5087340806352200662)
    2011-07-25 12:09:39 [INFO] Preparing start region for level 1 (Seed: 4008627126520175819)
    2011-07-25 12:09:39 [INFO] Preparing spawn area: 16%
    2011-07-25 12:09:40 [INFO] [Permissions] SQL Interface enabled!
    2011-07-25 12:09:40 [INFO] UltimateFist version 0.4 is enabled!
    2011-07-25 12:09:40 [INFO] Server permissions file permissions.yml is empty, ignoring it
    2011-07-25 12:09:40 [INFO] Done (0,166s)! For help, type "help" or "?"

    Which other plugins do you use?
  7. Offline


    blift, chestshop, citizens, dynmap, essentials (Geo, Protect, Spawn), givemewool, heroicdeath, ichat, iconomy, lockette, mothernature, movecraft, multiverse, myhome, mywarp, permissions, tetris, turnstile, and worldedit. Those are all of my plugins
  8. Offline


    It works fine(I love you for getting this working with bukkit) but I keep getting this Message:

    2011-07-27 09:29:26 [SEVERE] Could not pass event BLOCK_BREAK to UltimateFist java.lang.NoClassDefFoundError: com/nijiko/permissions/PermissionHandler at de.philippwundrack.ultimatefist.UltimateFistBlockListener.onBlockBreak(UltimateFistBlockListener.java:17) at org.bukkit.plugin.java.JavaPluginLoader$36.execute(JavaPluginLoader.java:490) at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58) at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:332) at net.minecraft.server.ItemInWorldManager.c(ItemInWorldManager.java:157) at net.minecraft.server.ItemInWorldManager.a(ItemInWorldManager.java:121) at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:461) at net.minecraft.server.Packet14BlockDig.a(SourceFile:42) at net.minecraft.server.NetworkManager.b(NetworkManager.java:226) at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85) at net.minecraft.server.NetworkListenThread.a(SourceFile:105) at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451) at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361) at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)

    Edit: The only other Plugins that i use are BukkitPermissions and mChat.
  9. Offline


    Hi, a question.

    i realy like the fist plugin but how did u add it for the server as a plugin? And is it possible to transform other mods into a plugin/mod form?
    Would be a big help.

    Thx for the awesome plugin so far :)
  10. Works and all, but this is so irritating:
    [SEVERE] Could not pass event BLOCK_BREAK to UltimateFist java.lang.NoClassDefFoundError: com/nijiko/permissions

    Seems it tries to call premmisions, but I don't have it!
    bukkit :1000
  11. Offline


    Will the Fist break after some blocks?
    Is it unbreakable or is there a limit ?
  12. Offline


    Sorry, but I don't know what the problem is. I've tried it on my server and it works with and without the permissions plugin.

    @Redpixi1 it is unbreakable.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  13. Offline


    can you make Ultimate Fist as fast as it is in singleplayer?. Sorry for bad english
  14. Offline


    i have it installed on my server now do i have to install it on my game end too?
  15. Offline


  16. Offline


    OK ty thought I did, it was crashing when I tried to craft the fist.
    oh do I need to put mod loader in too?
  17. Offline


  18. Offline


    Sorry, when come the Ultimate Fist for Bukkit Server Minecraft 1.0.0?
    I`m from Germany and my Englisch is bad.

  19. Offline


    Not before Bukkit 1.0.0 is recommended.
  20. Offline


    Bukkit 1597 (1.0.1) is recommented ;)
    RH2009 likes this.
  21. Offline


    Pls update your Plugin. Pls i <3 this plugin :'(
  22. Offline


    sorry for my bad englisch im from germandy :D
    but my awnser is, whan i destroy blocks with the UltimateFirst the blocks respawn thats bad :(

    pleas help me :(

    the minecraft version is 1.1 and the compatible bukkit 1.1 server
  23. Offline


    Please Update the Plugin :'(
  24. Offline


    Please update for bukkit 1.1
  25. Offline


    Thanks for the update Bukkit. Get it tonight to test the same time.

    thank you
  26. Offline


    Thank you Philius it`s work great
  27. Offline


    uhm does this need spout?
  28. Offline


  29. Offline


    Oh ..! I need this plugin! Thanks!
  30. Offline


    Thank you for your trouble.
  31. Offline


    Hi Philius,

    I have install a bukkit server version 1.1, your plugin for the ultimate fist version 1.0.1 an my mc-client version 1.1

    I can craft the ultimate fist and destroy sand, earth etc. but stone respawn. what is the reason? i havenĀ“t the permissions plugin, is it necessary?

    Thank you for answering!
    Mexx666 likes this.

Share This Page