Inactive [FUN/TP/MECH] Runecraft v2.12 - Magic effects using runes [1.2.5-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by Zeerix, Apr 27, 2011.

  1. Offline


    Runecraft - The magic mod for Bukkit!
    Version: 2.12

    This is the Runecraft mod ported to the CraftBukkit server.

    Runecraft adds magic spells to the game which are triggered by block patterns called runes.
    It let's you create teleporter and waypoint runes for instant travelling, build hidden doors into mountain walls or enchant your tools. And more.

    • Build runes (block patterns) for spell casting
    • Teleportation runes
    • Faster digging with Power Pick and Power Drill
    • Hidden doors and traps using Phase Block and Lock Block runes
    • Build an easy spleef arena with Spleef Blocks
    • Shoot torches with Bow of Light rune
    • Works with multiple worlds
    • Support for Bukkit's permission system
    • Much more!


    The config file is named "disabled-runes.txt" and lies in the root bukkit folder (alongside etc.).
    The file is generated if you load the plugin. Each line contains an option which is either the name of a blacklisted rune, the name of a player not allowed to use runes, or a specific command. Some commands are:
    • whitelist - turns the rune blacklist into a whitelist
    • enable multiworld travel - allows teleportation using runes between different worlds
    • initiation - players cannot use runes until they activate a special rune containing bedrock
    More options are listed in the Official forum thread in the section Runecraft Administration.

    Bukkit's Permissions:
    Runecraft supports Bukkit's permission system since version 2.8.2. Use a permissions plugin such as PermissionsBukkit, bPermissions or PermissionsEx.
    Runecraft currently has the following permission nodes:
    runecraft.*                        - gives .teleport and .runes
    runecraft.teleport                 - must be true to allow any teleportation runes
    runecraft.runes                    - gives permission for all runes
    runecraft.runes.powerpick          - gives both .activate and .use
    runecraft.runes.powerpick.activate - gives permission to bind Power Pick rune
    runecraft.runes.powerpick.use      - gives permission to use a rune-enchanted tool
    (Replace 'powerpick' with the name of any other rune)
    'runecraft.teleport' must be given to allow any form of Runecraft teleportation (Teleporter, Personal Teleporter and Recall runes).

    All users have 'runecraft.*' by default. If your permissions plugin doesn't have negative permissions, you have to overwrite the default to disable all runes, and then enable the runes you want with your permissions plugin. To disable all Runecraft permissions by default, open the file plugins/Runecraft/config.yml and change permissions.teleport and permissions.runes to false:
      teleport: false
      runes: false
    Old permissions system (removed in recent versions):
    Show Spoiler

    You can use AttributeProviders to connect the Permissions plugin with Runecraft. You can also connect any other Permissions-like plugin with Runecraft, if there is an AttributeProvider for it.
    Runecraft currently has the following permission nodes:
    • 'runecraft.teleport' - allows or blocks any teleportation (Teleporter, Personal Teleporter and Recall runes)
    • 'runecraft.rune.<name of rune>' - allows use of that rune. 'runecraft.rune.*' allows all runes.
      For example: 'runecraft.rune.phantomtorch', 'runecraft.rune.personalteleporter'.

    More information and list of runes:

    • SuperLlama - Main developer
    • Zeerix - Co-developer, added Bukkit support

    The complete changelog and much more information can be found in the Official forum thread.

    Version 2.12
    • Updated to CraftBukkit 1.2.5.
    • New runes
    • Topsy Turvey now works vertically
    Version 2.11.1 (Bukkit-only release)
    • Updated to CraftBukkit 1.2.4.
    • Fixed teleporter for new world height (256 blocks)
    Version 2.11
    • New rune: Ovicaptor
    • Added option to change tiers in disabled-runes.txt. For example, "tier 55 6" makes redstone tier 6.
    Version 2.10.4 (Bukkit-only release)
    • Updated to CraftBukkit 1.1 dev build
    • Compass: Added an option to change "north" for the rune
    • Recall: Added an option if recalling should apply the Weakness effect for 30 seconds (for PvP servers)
    • Changed tier of piston extension back to 2
    • Fixed conversion of Pressure Sensors to the new signature system
    • Fixed Wallteleporter not beeing usable without beeing initiated
    Version 2.10.3
    • skipped
    Version 2.10.2 (Bukkit-only release, announcement post)
    • First official version for Minecraft 1.0.0.
    • Bukkit: Removed support for AttributeProvider; we only support Bukkit's permissions now
    • Bukkit: Added configuration file: config.yml
    • Bukkit: Added ability to change the default of runecraft.teleport and runecraft.runes permissions via config.yml
    • New runes: Identifier, Engraver, Bottomless Cauldron, Power Drill
    • Added subtype of Bow of Light without a torch
    • Added metadata (wool color etc.) to signatures of automation runes
    • Redstone sensor can be destroyed by picking the iron block
    • Multiple Automation Designations on a single block don't stack
    • Reduced 'power' for Power Pick (128 per tier)
    • Added some blocks to Uncrafter and Fire Pick
    • Changed tier of Tall Gras and Nether Portals to 0 (blanks)
    • Fixed issue with Recall draining too much 'uses'
    • Disabled log message for disabled runes
    • ...more...
    Version 2.10 - 2.10.1
    • test version, not fully released
    Version 2.9.4 (Bukkit-only release)
    • Fixed another dupe bug with Power Pick
    • Added option "enable mastery bypass protection" which allows Bridge Master/Wall Master to build into protected areas (enables 'old behaviour')
    Version 2.9.3 (Bukkit-only release)
    • New rune: Spleef Blocks (like Phase Blocks; replace iron ore with snow blocks)
    • Increased 'Power' for Power Picks & co
    • Fixed dupe bug with Bridge/Wall Master
    • Bridge/Wall Master obey region protections now
    • Fixed missing message "you can no longer channel through this tool"
    • Optimization for a large group of Phase Blocks
    • More bugfixes
    Version 2.9.2 (Bukkit-only release)
    • Uncrafter: Added code to check for block enchantments
    • Bugfixes

    Show Spoiler

    Version 2.9.1
    • Bow Of Light: Added redstone version; also ignores snow now
    • Twinshot: Renamed to Multishot
    • Fix for Power Pick
    Version 2.9 (demo video about new runes)
    • Added runes: Flotilla, Bow of Light, Twinshot
    • Change PowerPick/Shovel to work like PowerAxe
    • Bugfixes
    Version 2.8.3 (Bukkit-only release)
    • Changed Automation Designator rune: Use gold ore instead of iron blocks
    • Added tiers for new blocks in Minecraft 1.8.x; also added blocks from 1.9 prerelease 1+2
    • Bugfixes and a serious crashfix
    Version 2.8.2 (Bukkit-only release)
    • Added support for Bukkit's internal permissions system
    • Added permissions for usage of enchanted tools
    • Bugfixes
    Version 2.8.1 (announcement post)
    • Added another rune
    • Changed Solar Flare and Flash Freeze to affect mobs
    • Bugfixes
    Version 2.8 (announcement post)
    • Added runes: Power Axe (same template as Power Pick/Shovel), Automation Designator
    • Added runes: Redstone Sensor, Pressure Sensor, Damage Sensor, Block Sensor
    • Changed Accelerator and Force Field to affect mobs in addition to players
    • Bugfixes
    Version 2.7 (announcement post)
    • Added runes: Lock Blocks, Fairy Boots
    • Re-implemented rune: Zeerix' Chest
    • Added 2 minutes cooldown for Chrono Trigger
    • Added multiworld-support for many runes
    • Added/improved metadata-support (wool colors, etc.) for many runes
    • Added support for AttributeProviders (a bridge plugin for Permissions)
    • Added a "" file to every world folder; you can change the id of a world by editing this file with a text editor
    • Spring String resets fall distance; Shield is changed a bit and has more uses
    • Some bugfixes
    Version 2.6.1
    • Fixed Accelerator/Spring and Phantom Torch
    Version 2.6 (announcement post)
    • Added rune: Endurance
    • Re-implemented rune: Phantom Torch (with a new rune pattern)
    • Added Multiworld support (add "enable multiworld travel" to config file)
    • Meta-data support for Teleporter signatures (cloth color/step types make different signatures)
    Version 2.5.2
    • Added runes: Enchantment swap, Altar of Judgement
    • Allowed vertical teleporters
    • More fine-grained options for config file (forbid specific runes for players; allow runes with specific ink)
    • Power Pick obeys WorldGuard/Towny protection
    Version 2.5 - 2.5.1
    • Added runes: Admin Pick, Initiation, Accelerator, Force Field, Spring
    • Added new options: travel ink, teleporter toll, player ban (forbid runes for single players)
    • Added initiation mode (players must "activate" ability to use runes)
    Version 2.4.6
    • Added rune: Surface Tension
    Version 2.4.5
    • Fixed problems with teleporters
    • Fixed linked hidden passages
    Version 2.4.4
    • First release for Bukkit
    • This broke the runes Phantom Torch and Zeerix' Chest
    TienSon, DoomLord, Clucky and 2 others like this.
  2. Offline


    You don't need a Permissions/GroupManager plugin to work with Runecraft. If they are not installed or not connected to Runecraft, you can use all the runes that are not disabled in disabled-runes.txt
    If you have them connected with the AttributeProviders plugin, and you can't use the runes, you likely don't use the right permissions nodes.
    Does your player have the right to use "runecraft.rune.compass"?

    Do you have AttributeProviders installed?
    Also, you have a typo in "zeerixschest".


    Yes, there's a cooldown for chrono trigger now to reduce server load.

    Yes, minecraftforum and wiki are offline. I don't know why they do that.

    That one is really old.
    Just build the passages face-to-face instead of side-by-side, so they don't overlap.
    Or use Phase Blocks (with or w/o Lock Blocks) instead.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  3. Offline


    A question on the Chrono Trigger Rune.
    When used, does it fast forward to day or rewind to day? The players of the server I'm on have been experiencing their wheat not growing as fast. This has been happening around the day we have added Runecraft to the server.
    Please reply, Gamebito.
  4. I'm not sure if you accept suggestions for runes and I liked your "Spiderman" rune a lot.
    I think though, it would be cool with a Grappling Hook rune.
    Way to use it would be to make the rune, and then use the Fishing Rod to transport around. Of course the higher tier, the more charges.

    Thanks :p
  5. Offline


    Awesome plugin.. although, since minecraftforums is down.. Could someone make a list of the runes and how to make them, or link me to something like that if there's already one?
  6. Offline


    Wiki is back up.
    I saved the page to have a mirror, if anything happens again with the wiki.
  7. Offline


    Does it work for 1.7 ?
  8. Offline


  9. Offline


    Hey i'm having issues with the mineshaft rune it removes rune but doesnt modify the ground other than one block down even with diamond
  10. Offline


    I was just wondering... but do you or Superllama still work on the mod besides updating when needed? I haven't seen an update in forever :confused: . Not that it's needed, it's already an amazing mod!
  11. Offline


    When i try to use a Faith rune, it says "The aether has rejected your greedy request" what does this mean?
  12. Offline

    Funk Man

    Triple chest FTW

    Show Spoiler
    2011-07-05_23.13.11.png 2011-07-05_23.13.20.png 2011-07-05_23.19.27.png
  13. Offline


    plz update 953 not work on 953 =(
  14. Offline


    Might wanna update this asap. If someone uses pistons as Tier block, the rune will have unlimited charges.
  15. Offline


    Hi! Got a feature request for you. Would it be possible to restrict the use of specific tool enchants via Permissions? I ask because I'm trying to isolate one of my server's worlds (the 'old' server world, before I updated and rerolled it as a survival server) from teleports and such, but even if I disable the rune, someone could for example enchant a book with recall, then craft a new book in the other world, using it to bypass the single secure teleport I have set up (using WorldGuard to protect the teleport itself, and ItemDetector gates to clear people's inventories when they enter the teleport's specific room, which of course has a posted warning). My ideal implementation of this would be something like '-runecraft.rune.recall.tool' will let them build and activate the rune all they like, but not use the tool effect itself.

    Is that something that might be possible to implement?
  16. Offline


    plz update 953 plz :(
  17. Offline


    thx for update i love your plugin amazing

    teleporter and waypoint runes work but the other runes not owrk?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  18. Offline


    You don't want to be more specific, do you?

    Fixed Phantom Torch for newer Bukkit versions.

    runecraft.tool.<RUNE> in addition to runecraft.rune.<RUNE>?
    Or maybe runecraft.enchant.<RUNE>? hm...

    The Bukkit team currently works on a new permissions API for plugins. It will most likely be in the next RB or the one after that. I plan to change permissions support to the new API when it is released, and add tool enchantment permissions at the same time.

    I'll be busy with real-life stuff for the next few days, so I can't do it earlier.
    Also I'm waiting for Superllama to release version 2.8 which adds the new blocks and has some bugfixes.

    Mineshaft is supposted to work in untouched ground only. It stops when it hits on blocks like cobblestone, wood logs, torch, chest etc.

    Faith won't move Chests, Signs, Furnaces and the like.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  19. Offline


    That would work. Or maybe something like:
    -activate (Activate the rune on the ground)
    -tool/use (or maybe 'cast' if you want to be a bit clearer?) (Use the enchanted effect from this rune. My thinking is that this shouldn't prevent you from enchanting a tool, only from using the enchanted tool itself. So if I'm in a world where I have -runecraft.waterpick.use for example, then I could enchant a tool with it, but the effect wouldn't ever happen... "The aether punches you in the groin" message for runes like recall that get denied, etc, etc. For water pick, it could just fail silently each time, same as if the criteria (lava adjacent to a mined block) for use aren't present, and no charge gets expended.)
    -create/build (Perform the initial activation of a rune maybe? Would only have meaning for multi-use ones like Teleport? This would allow me to pick a world and let only admins build runes like topsy-turvy, but then allow anyone to activate that pre-built rune. Could work the same for Chrono Trigger, Teleporters, Depending on how your code is structured right now, that may be non-trivial to add.)

    All this actually gave me another idea. If you ever do a major redesign of the plugin, maybe get your player messages from an editable text file? Then people could even change the messages their players receive. It'd be useful for people running maybe a roleplay server if they want to make the messages fit their world lore, or stuff like that.

    Thanks, Zeerix... you're my hero. =-]
    Let me know if you need any help bug-squashing or anything. I'm not very familiar with Java, but I have thrown down a few lines of code before, so I'm really just missing syntax.
  20. Offline


  21. Offline


    idk if this is a bug but when one player has the powerpick enabled one one pickaxe then makes another powerpick on another pickaxe both powerpicks share the same amount of uses.
  22. Offline


    This is normal. Runecraft enchants tools by type, because there currently is no other way with Minecraft.
  23. Offline


    I think that's by design (hence the status message saying you get the effect with "this type of pickaxe" for example). I think it's just a consequence of how items are tracked in MC... easier probably to set a handler that says "when player X right-clicks with item #Y, do this" than to try and track a specific instance of that item, which probably doesn't have any unique identifier beyond perhaps its wear-and-tear level.

    That's what I get for not refreshing the page. =-P

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  24. Offline


    It's good that you explained it in a bit more detail.
    Items are stored in the ItemStack data structure with the information: typeId, amount and damage.
    There's currently no way to add additional information to it.

    Runecraft 2.8 is released!
    Would you like to know more?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  25. Offline


    It might be a bit early to tell, but after I updated Runecraft to 2.8 the server locks up after awhile, no error or anything, just everyone get disconnected and can't reconnect. On CB 953

    Edit: Yeah it's def runecraft. Problem stops when I either remove Runecraft or downgrade to 2.7
  26. I found an interesting bug. If you set it so that a waypoint/teleporter has to be built out of Redstone Ore (non-glowing), the following happens:

    1 ~ The teleporter: Can only be activated if all the glowstone in it's construction is 'not glowing'. This is fine, Glowing Redstone and Redstone are not the same block. Puts an unintentional timer on it's use, but I'm completely down with this. (Especially because using a 'fuel block', in our case mossy cobblestone (made via Growbie) activates one of the teleporter blocks, and you have to wait until it 'calms down' to use the Teleporter.)

    This is where things get buggy.

    The Waypoint ~ If you construct a waypoint out of Redstone Ore, as per the teleporter, you must wait until it 'calms down' before you can set the waypoint. This is not a problem. The problem comes in if any of those redstone blocks get interacted with. It will behave, as normal, as one would expect, as if the waypoint has been broken. Again, not really a problem. The problem lay in what happens next. When the redstone block returns to a non-glowing state, it will persist in saying the waypoint has been broken rather than recognizing that it's now completely composed of the required blocks.

    The "Fix" I'd hope for in this case is: Leave the teleporter as is, it seems to work just fine once all the Glowing Red-Stone has returned to being just 'Redstone'. The Waypoint, however, needs to recognize that it is 'complete' again after the redstone ceases to glow.

    I really like the 'teleporter/waypoint charging' effect this gives. You can't just dash through a teleporter, there is an enforced pause between people going through (both because of the waypoint and the teleporter), and it has a nice visual effect to represent it. I just want to make sure that I don't have to rebuild the waypoint every time someone steps on it.


    1. Can we get the ability to dictate what the teleporter/waypoint need to be constructed of as separate entities? As well as the ability to limit what can be used as signature bits for the waypoint?

    2. Perhaps we can get configuration settings for a number of the other runes? I'd really like to be able to personalize what materials are required per rune (Perhaps using something like the 'CustomCrafting' interface to describe 'recipes'), as well as affect things like the tier multiplier on Power Picks/Shovels.
  27. Offline


    Till that is fixed, you can build halfsteps on the redstone so it wont glow :p
  28. Offline


    Runecraft 2.8.1 generates the following message on server start with craftbukkit v1000

    02:47:36 [SEVERE] Error occurred while enabling Runecraft v0.4 (Is it up to date
    ?): tried to access field rmm.self from class Runecraft
    java.lang.IllegalAccessError: tried to access field rmm.self from class Runecraf
            at Runecraft.onEnable(Unknown Source)
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(
            at org.bukkit.craftbukkit.CraftServer.enablePlugins(
            at net.minecraft.server.MinecraftServer.e(
            at net.minecraft.server.MinecraftServer.a(
            at net.minecraft.server.MinecraftServer.init(
    02:47:36 [SEVERE] Error occurred while enabling Runecraft v0.4 (Is it up to date
    ?): tried to access field rmm.self from class Runecraft
    java.lang.IllegalAccessError: tried to access field rmm.self from class Runecraf
            at Runecraft.onEnable(Unknown Source)
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(
            at org.bukkit.craftbukkit.CraftServer.enablePlugins(
            at net.minecraft.server.MinecraftServer.e(
            at net.minecraft.server.MinecraftServer.a(
            at net.minecraft.server.MinecraftServer.init(
    Edit - I know it says v0.4, but I know for sure i downloaded the 2.8.1 jar for runecraft.
  29. Offline


    Check if you have two runecraft.jars in the plugin folder.
  30. Offline


    Thank you, that did it. It didn't cross my mind that you tossed the version number into the file name because hardly anybody does that sort of thing.
  31. Offline


    So then this works with Bukkit 1000 even though it's only up to 953? My server host is looking to use it but is uncomfortable with using mods that aren't up to date (a tiny difference in number, but he's cautious). I know the most recent version only just came out a couple weeks ago, but how soon will you be working to get it up to 1000? I probably missed that somewhere in my haste x.x

    Oh. Well, that answers my question! xDDD Ironic that the day I ask, it gets updated to 1000.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016

Share This Page