Inactive [FUN] SpoutEssentials v3.9.2 [SPLASH SCREENS, GUI commands, Music, Capes, Sky, and more!] [1.2.3-R0]

Discussion in 'Inactive/Unsupported Plugins' started by skawke, Aug 7, 2011.

  1. Offline


    @rediem's Banner :)
    Version: v3.9.2
    Go here for download, commands, permission nodes, and more!

    (If you would like to get a small taste, join my server @, and press ~)

    Splash Screens:

    Uses Spout's various features for a whole ton of fun!
    • Notifies when people join
    • Notifies when people leave
    • Displays a notification when people join the server
    • Allows the playing of music, both to themselves AND serverwide
    • A simple 'poke' feature
    • and TONS more! (Full list @ bukkitdev page)
    SpoutEssentials includes optimizations for these plugins:
    Want to test out the features before using it? Join my server @

    I work quite hard to make the plugin, and I try to put everyone's requested feature into SpoutEssentials. Donate to help me buy food a better server :(:(!


    · @rediem for the banner :D:D:D:D:D:D
    · @tips48 for helping me with the poking feature (basic messaging)
    · @SwearWord from #bukkitdev for helping me with config stuff
    · #spout for helping me with SpoutCraftEnabledEvent
    · @Ninja Grinch for pointing out bugs in 2.7.2
    GameFAQsRolo, Kiste, Hopium and 8 others like this.
  2. Offline


    Your bukkit dev is only up to 1.2.3. Please give us a link to something that works with MC 1.2.5@Denkfaehigkeit
  3. Offline


    For those who haven't explored. Click the link in the First Post linking to the BukkitDev. Denkae last posted there on April 4th.
  4. Offline


    I haven't downloaded it yet-what do capes have to do with this?
  5. Offline


    I'm having some trouble with setting music for regions. I'll set a region, and I'll check the worldguard config to make sure it's saved, then I'll go to the spout essentials config and I'll put the region name, a message, and the url to the music I want to play and nothing happens. No message, no music.
  6. Offline


  7. Offline


    (Due to being at work i cant confirm that's the same thing i have wrong. (image sharing centers are blocked))

    Capes worked until Spout updated. Now they look zoomed in, to the top left quarter of the cape image.
  8. Offline


    So what can I do ?
    I hate cape 4x8p...
  9. Offline

    Zach Hinchy

    Entering any WorldGuard region in my server produces a popup message no matter what. Unless the message is specifically defined in the SpoutEssentials config.yml, I'll show up with an arrow icon, the heading "Welcome", and the subheading "Welcome to the server!". This is annoying my users and it wasn't a problem before we updated to 1.2.
  10. Offline


    When we ran spout essentials on our server it would periodically crash due to "too many files open" error, which seemed to happen more frequently when coupled with us playing lots of music tracks.
    We really, really want to utilize spout essentials, especially region based music would be boners all around but obviously we can't run something that's causing errors/crashes.
    In short we patiently await an updated 1.2.5 version of spout essentials, please oblidge.

    Thank you for your time.
  11. Offline


    I know a lot of people like this plugin and it's features, but it hasn't been updated to the newest CB and Spout builds.
    Even the title makes it a warning to all users: [1.2.3-R0] We are all using MC 1.2.5.
  12. Offline


    why i cant use spoutessentials?
    i type
    /help spoutessentials
    it say
    when i type
    nothings happen
  13. Offline


    if we install this on our server do all Clients need Spout?
  14. Offline


    All I get when trying to run that plugin is : "[SEVERE] Could not load 'plugins\spoutEssentials.jar' in folder 'plugins'" ...

    Nothing else.. Could someone give me a hand on this ?
  15. Offline


    Hello guys!
    I have a problem, and i dont known what whis error mean, and how to fix it.

    I have SpoutEssentials plugin and Spout plugin, when i start my server i gate this error in console:

    08:14:46 [INFO] [SpoutEssentials] Enabling SpoutEssentials v3.9.3
    08:14:46 [SEVERE] java.lang.IllegalArgumentException: Cannot set to an empty path
    08:14:46 [SEVERE]      at org.apache.commons.lang.Validate.notEmpty(
    08:14:46 [SEVERE]      at org.bukkit.configuration.MemorySection.set(
    08:14:46 [SEVERE]      at org.bukkit.configuration.MemorySection.set(
    08:14:46 [SEVERE]      at me.skawke.spoutessentials.config.SpoutEssentialsGUI.LoadConfig(
    08:14:46 [SEVERE]      at me.skawke.spoutessentials.config.SpoutEssentialsGUI.Initialize(
    08:14:46 [SEVERE]      at me.skawke.spoutessentials.SpoutEssentials.onEnable(
    08:14:46 [SEVERE]      at
    08:14:46 [SEVERE]      at
    08:14:46 [SEVERE]      at org.bukkit.plugin.SimplePluginManager.enablePlugin(
    08:14:46 [SEVERE]      at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    08:14:46 [SEVERE]      at org.bukkit.craftbukkit.CraftServer.enablePlugins(
    08:14:46 [SEVERE]      at net.minecraft.server.MinecraftServer.t(
    08:14:46 [SEVERE]      at net.minecraft.server.MinecraftServer.a(
    08:14:46 [SEVERE]      at net.minecraft.server.MinecraftServer.init(
    08:14:46 [SEVERE]      at
    08:14:46 [SEVERE]      at

    Thanks all who is help me :)
    Sorry for bad Eanglish!...
  16. Offline


    I was using spout essentials (and loving it) until it started to crash the server randomly a couple times a day.
    Patiently waiting for an update!!

    please update asap, I know mc updates been a pain lately but spout essentials are so....essential!

    Thanks in advance
  17. Offline


    why cant I join the server :mad: [tnt]+[cake]+server=:D

    [spider] Super mob

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
  18. Offline


    Greetings, a problem has arisen between two plugins we have on our server, SpoutEssentials and RPG Essentials. When setting up capes we've came across a problem that may be caused by an incompatability issue between the two. So we were wondering if there was actually any known compatabiltiy issues between the two plugins.

  19. Offline


    lol, both plugins having many identically features... i would recommended to throw spout essentials aboard because the inactivity.
  20. Hello!
    I get this error when I run craftbukkit.

    09:58:54 [SEVERE] java.lang.IllegalArgumentException: Cannot set to an empty pat
    09:58:54 [SEVERE] at org.apache.commons.lang.Validate.notEmpty(Validate.ja
    09:58:54 [SEVERE] at org.bukkit.configuration.MemorySection.set(MemorySect
    09:58:54 [SEVERE] at org.bukkit.configuration.MemorySection.set(MemorySect
    09:58:54 [SEVERE] at me.skawke.spoutessentials.config.SpoutEssentialsGUI.L
    09:58:54 [SEVERE] at me.skawke.spoutessentials.config.SpoutEssentialsGUI.I
    09:58:54 [SEVERE] at me.skawke.spoutessentials.SpoutEssentials.onEnable(Sp
    09:58:54 [SEVERE] at
    09:58:54 [SEVERE] at
    09:58:54 [SEVERE] at org.bukkit.plugin.SimplePluginManager.enablePlugin(Si
    09:58:54 [SEVERE] at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftSe
    09:58:54 [SEVERE] at org.bukkit.craftbukkit.CraftServer.enablePlugins(Craf
    09:58:54 [SEVERE] at net.minecraft.server.MinecraftServer.t(MinecraftServe
    09:58:54 [SEVERE] at net.minecraft.server.MinecraftServer.a(MinecraftServe
    09:58:54 [SEVERE] at net.minecraft.server.MinecraftServer.init(MinecraftSe
    09:58:54 [SEVERE] at
    09:58:54 [SEVERE] at
    09:58:54 [WARNING] An error has occurred in loading the config, please go to the
    Bukkit page and tell what you see below, thank you!

    I don't know if this is important, I didn't try anything for the moment. If something is wrong, I'll tell you. Thanks. :)
  21. Offline


    How soon could be 1.3.1 version released? Or how long more to wait.. :)

Share This Page