Inactive [FUN] SpoutEssentials v3.9.2 [SPLASH SCREENS, GUI commands, Music, Capes, Sky, and more!] [1.2.3-R0]

Discussion in 'Inactive/Unsupported Plugins' started by skawke, Aug 7, 2011.

  1. Offline


    @rediem's Banner :)
    Version: v3.9.2
    Go here for download, commands, permission nodes, and more!

    (If you would like to get a small taste, join my server @, and press ~)

    Splash Screens:

    Uses Spout's various features for a whole ton of fun!
    • Notifies when people join
    • Notifies when people leave
    • Displays a notification when people join the server
    • Allows the playing of music, both to themselves AND serverwide
    • A simple 'poke' feature
    • and TONS more! (Full list @ bukkitdev page)
    SpoutEssentials includes optimizations for these plugins:
    Want to test out the features before using it? Join my server @

    I work quite hard to make the plugin, and I try to put everyone's requested feature into SpoutEssentials. Donate to help me buy food a better server :(:(!


    · @rediem for the banner :D:D:D:D:D:D
    · @tips48 for helping me with the poking feature (basic messaging)
    · @SwearWord from #bukkitdev for helping me with config stuff
    · #spout for helping me with SpoutCraftEnabledEvent
    · @Ninja Grinch for pointing out bugs in 2.7.2
    GameFAQsRolo, Kiste, Hopium and 8 others like this.
  2. Offline


    I believe the WorldEdit client thing will be released when the next version of Spout comes out. For fly mod, there's already various plugins for spout that allow zombe-like flying.
  3. Offline


    hey how do i add custom music what format does it need to be can it be mp3?
  4. Offline


    .ogg, .mid, .wav
  5. Offline


    Downloaded new version of your plugin - works now xP
  6. Offline


    Uploaded a video of what's to be expected.
    Request features if you have any! xD
  7. When I install SpoutEssentials, Spout itself disappears from the /plugins list, yet it is still in the plugins folder and none of the spout based plugins work :( Any ideas?

    Edit: Never mind, just installed Spout and Essentials at the same time and it worked :)
  8. Offline


    Haha awesome!
  9. Offline


    I did'nt get it :(
    @skawke d'you?
  10. Offline


    Wait what?
  11. Offline


  12. I installed spout, it was fine. then I installed SpoutEssentials, and the server acted as if spout wasn't on, up to it not even appearing on the list of plugins when /plugins is used. Then I installed them both at the same time, and it was all happy face forever more... :)
  13. Offline


    Version 3.4
    • Added an option to change textures if ForceTexturePack=false
    • Added iConomy support to TAB menu
    • Added VanishNoPacket support
    • Added ability to add a splash screen upon user joining.
    RGadelha likes this.
  14. Offline

    Lunar Delta

    Gives me an instant nullpointer exception upon loading. Tried redoing the config and updating Spout; still the same issue.
  15. Offline


    LOL :p

    The same to me:
    21:21:13 [INFO] Spout has been initialized
    21:21:13 [SEVERE] Error occurred while enabling SpoutEssentials v3.4 (Is it up to date?): null
            at me.skawke.spoutessentials.SpoutEssentials.onEnable(
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(
            at org.bukkit.craftbukkit.CraftServer.enablePlugins(
            at net.minecraft.server.MinecraftServer.e(
            at net.minecraft.server.MinecraftServer.a(
            at net.minecraft.server.MinecraftServer.init(
    As you can see, using Spout 1.0.5 dev build #259 :(

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 18, 2016
  16. Offline

    Lunar Delta

    I am also getting PLAYER_MOVE event errors when WorldGuard is enabled.
  17. Offline


    Same for me...
  18. Offline


    Restart your server :)
    Work for me :/ Open a ticket at BukkitDev so i can see your configs.
  19. Offline


    Same after restart, error persists.
  20. Offline


    Restarted 5 times but the error persists :'(
    How do I disable auto update of spoutEssentials?
  21. Offline

    Lunar Delta

  22. Offline


  23. Offline


    Open a ticket so I can look at your configs.
    Set autoUpdate=false in modules.yml

    Open a ticket with your configs.
  24. Offline

    Lunar Delta

    I opened a ticket like half an hour ago. ;)
  25. Offline


    It's not a configs fault, I've deleted all my spoutEssentials configs and the error's the same :(
    Anyway, I could not find "autoUpdate" inside modules.yml to set it to false so I created a line in there, "autoUpdate: false" but it's still auto updating :'(

    I already tried:
    - autoUpdate: false
    - disableAutoUpdate: true
    - enableAutoUpdate: false
    - allowAutoUpdate: false

    What else? Gonna try FlushAutoUpdateInAToiletBowl: true :p

    Edit again:
    Anyone willing to tell me what do I have to put inside modules.yml to stop that annoying auto-update thing, PLEASE?
  26. Offline


    found a way to block the autoupdate.. (if you happen to be directly beside your server!!)
    wait for the server to check with then pull the ethernet plug wait for server
    to boot up completely. Reconnect ethernet plug back to router... Worked for me. ;)
  27. Offline

    skawke could wait for about 10 minutes while i push out an update that fixes the option for auto-update :)

    Version 3.4.1 fixes autoupdate function.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 18, 2016
    Spyre likes this.
  28. Offline


    This looks awesome, i'll try this out when i get some spare time!
  29. Offline


    just having a bit of a problem the help in the top right hand corner, I cant get it to not show up I have set disableOnScreenHelpGlobally?: true but it still shows up cany idea how to fix
  30. Offline


    What do you mean?

    Version 3.4.2
    * Fixed autoupdate option in Modules.yml
    * Fixed odd problem with plugin not starting.
    * Hopefully fixed problem with WG
  31. Offline


    Awesome plugin man. Been messing around with it for the past couple hours and loving the features. Really seeing some great possibilities with the "On Screen Commands" option. Looking forward to it's continued development.

    Couple ideas for the "On Screen Commands":
    -Modifiable config file "yml" (as suggested by others)
    -Permission based (different sets of "On Screen Commands" that can be assigned by group or individually)
    -Nested Pages (ie hit tab, view list. click admin commands, new page of admin commands)
    -Editable Command Execution (ie click on command button, it pops up the command with all argument layout into an editable text field. User can click into text field and arrow to each argument and delete the prompt and type in a value, then execute.
    -Layout Presets (Column, Row, Left/Right/Center/Top/Bottom Alignments
    -TAB exit or exit button from "On Screen Commands" (Currently TAB opens, ESC exits)

Share This Page