[FUN/MECH] Lava Furnace - Furnaces that run on lava [BUKITDEV]

Discussion in 'Archived: Plugin Releases' started by Arcwolf, May 30, 2011.

  1. Offline


    Lava Furnace - Furnaces that run on lava:

    The basic idea of this plugin is to allow players to create a furnace that will run on lava but not consume buckets. It allows for customization by admins for fuel burn time, cook time, per player cook times and amount of furnaces per player. It is by default pretty balanced, but is customizable by admins for personal preference in balancing or even cheating if you so choose.

    • User created Furnaces that consume only the lava not the bucket
    • Also can be used with regular fuel sources through the Minecraft furnace interface.
    • Potential to create infinitely fueled furnaces via config file
    • Can set furnace burn times up to 2147483647 via config
    • Can set furnace cook times from 1 to 4 x normal speed via config
    • Can define the blocks a furnace is created from via config
    • Works with multi-worlds
    • Permissions via PermissionsEX, GroupManager, nijikokun based permissions, bukkit permissions or OPs
    • Lava level is easily viewable through glass door and changes with burn time of furnace
    • Optional small or large Production Chests (*based on Zarius's idea)
    • Optional Custom Smelt-ables via config
    • Production chest smelt priority from TOP LEFT to BOTTOM RIGHT
    • Per user cook times, per item cook times from 1 to 4 x normal speed via commands
    • Per player group build limits
    Tutorial Video & Review (by ValBGaming)

    Production Chest Photo:
    Alternate Chest Setup (open)


    Alternate Furnace Layouts (open)


    And you could just keep going with it.

    [​IMG] if you like this plugin and want to support me. Its much appreciated. :)
  2. Offline


    Sorry to hear that. But the problem you are having is not with my plugin but with permissions in general. I do not provide support for the permissions plugin, I dont even use it my self. You need to take it up with the permissions plugin author.

    Figure out your permissions problem and come back. If you are still having problems with my plugin "THEN" we'll talk. My hook into permissions is not the problem though. If it were then you would not be the only user having this problem.... and there has been a lot of users downloading this ~80 in the last 15 hours alone.
  3. Offline


    I had this issue, but then I realized I forgot to delete the config and had just dropped in the new jar. After I reinstalled, and restarted the server, works wonderfully. Have you tried double checking to make sure it put in the new config and wasn't using the old one?
  4. Offline


    Dosn´t work..
  5. Offline


    Does work.
  6. Offline


    If I build it exaclty like you in your video, nothing happens. If I build it wrong, it say´s something is wrong....

    So it dosn´t works.....

    Sry, because my english it´s bad.....
  7. Offline


    Your post tells me two things, 1 something you are doing is not correct. And 2 that it does in fact work or it would not tell you something is wrong.

    Maybe I can help better if you tell me what it is saying is wrong, what your config looks like, if there are any error messages in the server console and if your permissions are configured correctly. Otherwise there is not much else I can do for you.
  8. Offline


    I don´t work with permissions. There are no ERRORS in my Server Log File. If I build the LavaFurnace exactly like you in your video I got this in Game message ---> The magical runes fizzle then fade away... The magic does not yield to your command... <---
    If I build the LavaFurnace intentionally wrong, I got this inGame message ---> The magical runes fizzle then fade away... Maybe something is wrong with the Furnace construction ??? <--- at my Server Log files I can´t the any Errors.

    Maybe there are any conflicts betweene PlugIns ??? I use this all BlastControl, BorderGuard, ContainerProtect, CustumDifficulty, EasyRPG, Essantials, -Chat, - GeoIP, -GroupBridge, -GroupManager, -Protect, -Spawn, GiantTrees, Hungry, iConomy, iConomyChestShop, LavaFurnace, Minestairs 1.0 and mcMMO.

    Thats my LavaFurnace Config File

    # Lava time from 1 to 32767
    # Debug levels 1 to 5

    And this the furnace.dat
    #Do Not Edit This File
  9. Offline


    This is a permissions issue then...

    -GroupManager is in your list of plugins... Then you dont have it set up correctly I assume. Because I have tested this with groupmanager and it works if groupmanager is set up.

    If you "dont work with permissions" then why even have groupmanager installed?? It has to be set up correctly or most things wont work right.
  10. Offline


    Thanks... is working.... Now I have to try it out on my Testserver with Permissions ;-)

    Thank you so much.
  11. Offline


    I really like the idea, but could you possible make it easier to set up.
    I do not like how much space the furnace takes this way, would rather just have the furnace in front of the lava block.
    however i do like the input output bin idea.
  12. Offline


    no, it is like that by design to offset its cheat factor. Sorry but I wont be changing that.

    It was Zarius's idea. I simply implemented it.

    Glad you got it working.
  13. Offline


    I know what the problem probably is, I have gotten that exact error once. It happens when you add the lava before you finish making the furnace. The lava is the very LAST thing that should be added. Also, just adding a 2 word post, kinda unhelpful in every way.
  14. Offline


    That is correct, you can not add lava to the furnace before it has been constructed. The crucible MUST be empty when you first create the furnace.

    However, I believe we solved the problem and found that it was in fact an issue with his permissions. No harm no foul.

    If anyone else has problems with permissions I believe Debug Level 5 is a permissions debug level. Havent looked at that part of the code in a few days... so, I maybe wrong, anyway, if it is it will tell you what your permissions are when you build a furnace or do anything really. Just an FYI :)
  15. Offline


    that's fair, its just hard to fit in some pre-made structures. I do really like this plugin thought, adds functionality and efficiency to something that is usually over looked
  16. Offline


    I usually just create a new building just for the furnace. I like to look at it as a way to express more creativity in design. IE, I have a town that is pretty well built out... but how can I fit in a lavafurnace... after about 5 hours of work it usually turns out pretty damn nice. Without the furnace I wouldnt have even been bothered to mess around and build that cool looking smithy... and that one shop never looked right anyway. So I'm glad its gone.

    Ya know what I mean?

    I'm happy you like it though! Thanks for posting.
  17. Offline


    Well after installing this newest update everything seems shipshape with the lavafurnaces! Whatever changed seemed to make everything go fine now on my server, Thanks! Part of my problem may have been that I was adding lava to the construction before I activated it as well...so that might be my bad...
  18. Offline


    Thats very good news indeed. Getting everything working flawlessly is a personal goal :)
  19. Offline

    Matthew S

    Question... If I dont use permissions... and I want everyone on my server able to create one furnace... How should I set that up? Because I dont use any kind of permissions plugin.
  20. Offline


    Use the server's OPS.txt and put the users names into it.

    In the config, Max furnaces to 1

    Unfortunately, any other plugin you happen to use that ALSO, uses ops will now work for people in ops.txt...

    Sort of the downside to using ops...
  21. Offline

    Matthew S

    So there's no way to put in a configurable option without permissions and not making everyone an OP? I'm kinda herb derp with the whole permissions thing. Groups and all...
  22. Offline


    not at this time. Although with all the headaches stupid permissions keep causing me. I'm seriously considering adding something in the config to allow a sort of "Freeforall" mode...
  23. Offline

    Matthew S

    Ah okay. Thank you in advance! :D Yeah I downloaded Permissions 3.o and I couldn't get into my own chests, furnace's... or take down my own signs.
  24. Offline


    <sigh> ... permissions... :rolleyes:

    Anyway, you've prompted me to take action. I've just coded into the plugin a switch to disable permissions if you want. Give it a test. I've only just tested it a few times just now so... yea see if it works. it should nothing major changed just added a few lines in and a new config option.

    You will need to delete your config though... sorry. Price ya pay for new features I guess :)

    I'll upload it official like tomorrow... tired tonight... sleep...
  25. Offline

    Matthew S

    Awesome... You've made my fiance shout out with glee! :D
    [Update 6/20/20111 way later in the morning]
    Hey again, yeah that fix last night worked like a charm. Everyone can access the chests... BUT... If you use the plugin 'Lockette' you can put privacy on who can use those chests... But not the furnace, it'll shut down. It's nothign to fix though, because who's going to steal out your furnace? lol.
    Thanks again for the hotfix last night!
  26. Offline


    Probably has to do with the way I have to check and update the furnace. If something interferes with that check then your furnace might break. Glad everything is working good though :)


    Ok, uploaded 1.2b.

    The ONLY change is an option in the config to disable LavaFurnace Permissions checks entirely. If you choose to update to this version you MUST delete your config again. Let LavaFurnace regenerate the config.
  27. Offline


    Because i'm not smart enough to figure out DF do lava furnaces in DF use up lava? Well anyway can you make a lava furnace be fueled if it's touching a block of lava? Something along the lines of placing a bucket of lava in a furnace if the furnace is touching lava and just having the bucket be consumed and just adding a new one in? I just run a server for me and a few friends and I don't think any of them would find it too imba and if they do they don't have to use it. Or however you decide to go about it if you do something like this.
  28. Offline


    No to both questions. Although, I do believe that Toady1 has discussed lava furnaces consuming lava. They do not at this time do so.

    No to the second question, 1 because it would be simply gutting this plugin. 2 its not just about giving the bucket back. Its about adding to the implementation of a lava furnace. IMHO just how fun is it to simply add a bucket of lava to the furnace and out pops a empty bucket. It seems boring to me. Now if I want I can still do that, but if I want the challenge I can go and find the materials to create a really neat furnace. See what I'm getting at here.|

    Let me put it another way, I could simply say /give log -1
    or I could go and punch some trees. <shrugs> Thats how I look at it.

    In any case I believe I recently ran across a plugin that just gives back the bucket from a furnace. So if thats all you want then...
  29. Offline


    Now I have a new little problem. If I start my Server since yesterday I got this message every second ---> [INFO] dfp method -> powered & facing=5 layer1=true layer2=true layer3=true
    2011-06-21 <--- but my Lavafurnaces are working.... and my server crashed after 1 hour, because the LOG File is to big. What could that be ???
  30. Offline


    turn off debugging by setting the debug= in the config to 0
  31. Offline


    Woo! Lavafurnace with chests - love it, installing now :D

    btw: I'm with you - I like the concept of having to build the furnace more than the saving of buckets.

Share This Page