Inactive [FUN/MECH] ChopTree 1.24 - Chop Trees by Removing Lowest Block - Like Cacti [1000] (by Arcwolf)

Discussion in 'Inactive/Unsupported Plugins' started by askmeaboutlo0m, May 1, 2011.

  1. Offline


    ChopTree - Chop trees like cacti or make logs move down while chopping
    Version: 1.24

    There seems to be a plugin conflict where the client crashes with a blue-white screen and keeps crashing for minutes after that.
    If you encounter the error please give me a list of the plugins you are using, with enough lists I will be able to outrule what causes it. Please also tell me if you are using any client-side mods.

    Thanks very much to Arcwolf for developing version 1.24!

    Tested with Craftbukkit build [740], [766], [798], [818], [1000].
    Supports: Permissions v. 2.7.2 (Phoenix) and mcMMO v. 1.0.07.
    Please give me feedback, ask any questions you like and/or provide suggestions!
    Thank you!

    • Lets trees act like cacti - remove a block and all blocks above are yieled too.
    • Or you can make that log blocks move down one by one instead - no more climbing trees.
    • Works with all three tree types (they all yeild their own wood).
    • Also works with "big" trees that have multiple branches - makes felling them a lot easier.
    • Restrict using this plugin to certain tools only.
    • Supports mcMMO and Permissions.
    • Only works on trees, houses made of logs are safe!
    • Chunk protection to make your tree houses safe.
    Download (JAR file) | Source (ZIP file)

    This plugin was requested by Britich and is inspired by the Canary plugin RealTree by billyoyo.
    However, it is not just a simple port of that plugin, it was made from scratch after Britich's description.

    Show Spoiler

    Approach tree...

    ...and punch it.

    All logs will be yielded.

    The leaves will decay like normal.


    Even though I added a lot of things for version 1.2 it will act like the original one if you don't change any settings - with the exception of players are able to toggle the plugin.​
    To run this plugin just copy it into your plugins folder. On first startup it will create a ChopTree folder and a file, which you can edit.​
    There will be a ChopTree.players file which saves player toggles and a ChopTree.chunks file which saves protected chunks.​

    Properties File:
    Show Spoiler

    The file will look like this when first created:
    # -ChopTree Properties-
    # You can add or change the command and toggle command aliases here.
    # Because of technical limitations the console commands will always be "ChopTree" and "ct", but the in-game comments will be taken from here.
    Command = ChopTree, ct
    Toggle = ToggleChop, tc
    # Here you can change the options (can also be done in-game).
    ActiveByDefault = true
    UseAnything = true
    MoreDamageToTools = false
    InterruptIfToolBreaks = false
    SupportMcmmoIfAvailable = true
    TreeFellerNeeded = false
    LogsMoveDown = false
    OnlyTrees = true
    # -Material List-
    # If the "UseAnything" option is false, the plugin will take the items you can use to chop trees with from here.
    # You can either put in the material's name or its ID.
    mat = WOOD_AXE
    mat = STONE_AXE
    mat = IRON_AXE
    mat = GOLD_AXE
    mat = DIAMOND_AXE
    Command and Toggle can be changed manually by just adding more aliases for them, seperated by commas. Note that if you run the command from the console it will always have the aliases "ChopTree" and "ct", no matter what it says in your file.
    You can also remove either of the lines to disable the command for players completely.

    The options can be changed manually in the file too. To find out which option has which effect look at the "Commands" section below.

    The material list will only be used if the option UseAnything is false. In that case you can specify which items players can use to chop trees with this plugin, other items will not trigger plugin effects (except chunk protection). You can either use the item ID or it's name.
    If you want to make tree chopping more costly you can only allow gold axes for example.
    List of item IDs on Minecraft Wiki, list of all item names in the Bukkit documentation.

    Show Spoiler

    ChopTree - show status of all options.
    ChopTree (option) - show status of specified option.
    ChopTree (option) (true/false) - switch option on or off.
    ChopTree chunk - shows if your current chunk is protected.
    ChopTree protect - deactivates the plugin in your chunk.
    ChopTree fullprotect - disables destroying logs in general (not only with plugin) in your chunk.
    ChopTree reload - reloades changes from your properties file (the normal reload won't do that)
    ToggleChop - toggles the plugin on and off for a player.

    (option) can be:
    ActiveByDefault - choose if plugin will be toggled on or off for players (on).​
    UseAnything - if activated players can use any item to chop trees, else materials list will be used (off).​
    MoreDamageToTools - toggles damage to tools for every chooped log (off).​
    InterruptIfToolBreaks - if activated tree chopping will interrupt if the tool breaks (off).​
    SupportMcmmoIfAvailable - if activated plugin will support mcMMO if it can find it (on).​
    TreeFellerNeeded - choose if players need to have mcMMO's tree feller enabled (off).​
    LogsMoveDown - if activated logs will move down when chopped instead of popping like cacti (off).​
    OnlyTrees - if enabled only trees can be chopped, else all logs can be (on).​
    EnableOverride - if enabled choptree.override nodes can be used (off)​

    Show Spoiler

    ct or "command" in properties file for ChopTree.
    tc or "toggle" in properties file for ToggleChop.
    c for chunk.
    p for protect.
    f or full for fullprotect.
    r for reload
    a or default for ActiveByDefault.
    u or anything for UseAnything.
    m or damage for MoreDamageToTools.
    i or interrupt for InterruptIfToolBreaks.
    l or down for LogsMoveDown.
    o or trees for OnlyTrees.
    e or override for EnableOverride.

    Show Spoiler

    Permissions node - description (default if you are not using Permissions)

    choptree.chop - chop trees using this plugin (all)

    choptree.command.check - check what status the options have (all)
    choptree.command.change - change status of options (ops)
    choptree.command.toggle - toggle plugin per player (all)
    choptree.command.protect - protect/unprotect chunks (ops)
    choptree.command.chunk - see if the chunk is protected (all)
    choptree.command.reload - reload properties file (ops)

    Override nodes will be ignored if EnableOverride is false.

    choptree.override.moredamagetotools - will not have tools damaged for every log (off)
    choptree.override.useanything - can use any item (off)
    choptree.override.interruptiftoolbreaks - chopping won't interrupt when the tool breaks (off)
    choptree.override.treefellerneeded - tree feller is never needed (off)
    choptree.override.onlytrees - can chop all logs, not only trees (off)
    choptree.override.chunkprotection - chunk protection will be ignored (ops)

    To Do:
    • (Medium) Test with WorldGuard, remove conflict
    • (Medium) Enhance isTree algorithm a bit more
    • (Medium) Add [tools], [non-tools] and [hands] to material list
    • (Low) Add configurable drops
    • (Low) Add automatic sapling replant
    • Version 1.24 by Arcwolf - Download (JAR file) | Source (ZIP file) - July 28. '11
      • Removed deprecated methods
      • Fixed mcMMO compatibility
      • Updated for Craftbukkit build [1000]
    • Version 1.23 - Download (JAR file) | Source (ZIP file) - June 02. '11
      • Fixed an error with iron axe receiving double damage as if it wasn't an axe
      • Added /ct reload command to reload changes from properties file
    • Version 1.22_2 - Download (JAR file) | Source (ZIP file) - June 01. '11
      • Recompiled for Minecraft 1.6.6/Craftbukkit [818]
    • Version 1.22_1 - Download (JAR file) | Source (ZIP file) - May 22. '11
      • Fixed chunk protection Permissions
    • Version 1.22 - Download (JAR file) | Source (ZIP file) - May 22. '11
      • Fixed chunk protection
    • Version 1.21 - Download (JAR file) | Source (ZIP file) - May 16. '11
      • Added EnableOverride option (off by default) to fix wildcard problem
    • Version 1.2 - Download (JAR file) | Source (ZIP file) - May 14. '11
      • Rewrote tree finding algorithm
      • Fixed some bugs leading clients to crash
      • Fixed and extended Permissions support
      • Added toggle commands
      • Added mcMMO support
      • Added option that player has to have mcMMO's TreeFeller enabled
      • Added optional damage to tools
      • Added optional tools list to restrict using this plugin only with certian tools
      • Added option to let trees go down one by one instead of popping like cacti
      • Added chunk-wise protection
      • Included plugin.yml into source download
      • Probably more
    • Version 1.1 - Download (JAR file) | Source (ZIP file) - May 5. '11
      • Added Permissions support
      • Fixed bug with some pine trees not being chopped
    • Version 1.0 - Download (JAR file) | Source (ZIP file) - May 1. '11
      • Initial Release
  2. Offline


    Fixed that now, 1.22_1 (a lot of revisions) is ready, it should finally work now.
    Thanks for your time^^
  3. Offline


    Your welcome and thank you!

    I wish I could donate.... but I don't have the ability at the moment :(
  4. Offline


  5. Offline


    I seem to have a problem. Im running Craftbukkit 766, and the latest ChopTree.jar, but for some reason if I chop a few trees down my client will crash. When I log back in, it will face me away from the fallen trees and if I turn to look at them it will crash the client again. If I decide to walk away that is fine, but If I turn to go back, as soon as i get near the fallen trees it crashes my client. I seem to be the only person having this problem on my Server. Any idea what's causing that?

    EDIT: Anybody that goes near the location of fallen logs and saplings has their Client Crash.
  6. Offline


    That sounds very much like a bug occurring in versions 1.1 and earlier.
    The solution should be to deactivate the plugin and then go to the location and then reactivate the plugin.
  7. Offline


    Like I said in my post, I have the latest ChopTree Version. How would I go about deactivating/reactivating the plugin, /togglechop? I've done that already, but I'm assuming you're talking about something else.
  8. Offline


    No, just take the plugin out of your plugins folder, fix stuff and then put it back :p
    You have to restart both times though.
  9. Offline



    could you please add it so it plants a a sapling when you cut down a tree and the saplings protected from destruction for a specified time?
  10. Offline

    Cory Maloy

    When users chop trees they crash a split second after the logs drop. They cannot log back in if the logs (or maybe leaf decay) are within sight. If they don't look at it they can get away. I am also using worldguard. Would really like to implement this plugin.
  11. Offline


    Same exact thing happens to me, I stated my problem 2 posts above yours. Reactivating the plugin didn't work. Trying a different version now.
  12. Offline

    Cory Maloy

    I tried a few different versions without sucess :(
  13. Offline


    Yea I just tried 1.21 and same thing. I even removed the plugin entirely, restarted server, turned to look at the spot where I chopped the tree down and the client crashed. Running Bukkit build 766 in case any one is wondering.
  14. Offline


    That sounds pretty ebil.
    Are you using WorldGuard too? You could try removing all plugins and try if that works, then the cause would be another plugin conflicting with this one.
  15. Offline

    Mighty Mackinac

    this happens to me too, though it only happens when the trees are set on fire. I cant look at the tree again until all of the leaves and logs are gone. Im using World Guard, but it happens on every tree.
  16. Offline


    There is another plugin out there which does exactly that
  17. Offline


  18. Offline


    That is already in the to-do list, but it's not of high priority since it has not much to do with this plugin.

    That probably won't work since this plugin cancels the block breaking event.
    Or did you try and it works?
  19. Offline


    This combo worked for me not too long ago when I tested it on my server. I will have to go back and test again to see if it still works.
  20. Offline

    Mighty Mackinac

    It works only if you take out the second to bottom log then take out the bottom.
  21. Offline


    That's what I thought.
    Other plugins really don't like the way I handle the block removal, gotta work on that while still supporting mcMMO.
  22. Offline


    Wow I never realized that you actually added the stuff that we asked for until I updated my config! Nice man!
  23. Offline


    request to support permissions 3.x.x
    request to destroy leave blocks when chopped(i think leaves are marked to belong to a tree since i think leaf decay works like this i am not sure)
    request to add dates to changelog/download link

    :D thank you for the nice plugin :D
  24. Offline


    heeelp my screen goes gray and it appears this message in console:
    [SEVERE] Could not pass event BLOCK_BREAK to ChopTree
    java.lang.IllegalArgumentException: Listener already listening
        at net.minecraft.server.Container.a(SourceFile:28)
        at net.minecraft.server.EntityPlayer.syncInventory(
        at org.bukkit.craftbukkit.entity.CraftPlayer.updateInventory(
        at me.askmeaboutlo0m.ChopTree.ChopTreeBlockListener.Chop(
        at me.askmeaboutlo0m.ChopTree.ChopTreeBlockListener.onBlockBreak(
        at org.bukkit.plugin.RegisteredListener.callEvent(
        at org.bukkit.plugin.SimplePluginManager.callEvent(
        at net.minecraft.server.ItemInWorldManager.c(
        at net.minecraft.server.ItemInWorldManager.a(
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.Packet14BlockDig.a(SourceFile:42)
        at net.minecraft.server.NetworkManager.b(
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
        at net.minecraft.server.MinecraftServer.h(
    only happens when i chop a tree
    i have 1.6.4
  25. Offline


    As far as I know Permissions 3.x is not the main version right now, so I don't think I should support it just yet. Did you test if it already works maybe?
    Leave decay does kind of work that way, but it's not the main focus right now. First I want to resolve complications with WorldGuard.
    And look to the right of every download link, there's a date right there :p

    Read this:
    Then see that this plugin does not support your version of Crafbukkit.
    1.6.4 is unsupported and not recommended. This is why your screen goes gray.
  26. Offline


    Hey Guys,
    i got the newest Version but sometimes after i chop a Tree the Area gets crashed ... The game crash and all user in this area too. If i restart the server or my Game the game still crash .. after 10 min its fine again ... but 3-5 trees and the game crash again.

    Is there a Support for Tree Assist too?
  27. Offline


    ok, now i am in a recomended build for 1.6.6 but it stills goes gray when i chop a lot of trees, i dont thing it glitches cuz its my server, and my pc can hold anything.
    but its the same, maybe i should wait for an update of this plugins :([creeper]
  28. Offline


    What version of Craftbukkit are you using?
    I need to recompile this for Minecraft 1.6 first.

    It's still not supported, read the title of the plugin, it says [798].
    Let me recompile this first, but I don't have time for that right now, then you can use it.
  29. Offline


    i was on 803 now its updated automaticly ....
    I dont know why this crash -.-"
  30. Offline


    Now I recompiled it for Craftbukkit [818].
    Try again and if it still doesn't work give me your error message (Server and/or Client) and a list of plugins you are using so I can help.
  31. Offline


    Hey guy,
    its Crashing again =D

    this is my Game log, the server just say userx: "end of stream"

Share This Page