[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


    Whoops. Redownload, should work now.
  3. Offline


    Fullwall what kind of error post u need cuz i posted somekind of thingy here earlier? and richard robertson has helped me somehow and says the problem is in essentials. Well i removed essentials eco,chat (dont need) still the same message and i cant update those!
  4. Offline


    New version works like a charm! thanks again!! you rock!
  5. Offline


    Can you make it compatible with RealShop's RealEconomy?
  6. Offline


    What happens when you try to use a command? If it says internal server error or something, there should be an error that pops up in the console log. Paste that. If there is nothing like that, what comes up instead?
    --- merged: Mar 7, 2011 4:32 PM ---
    NPC trading support is still being worked on.
  7. Offline


    Well it says internal error, but i don't know if it is internal server error but this is what it gave me to my console:

    2011-03-07 18:46:51 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'npc' in plugin Citizens v1.05
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:33)
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:80)
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:183)
    at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:619)
    at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:582)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:576)
    at net.minecraft.server.Packet3Chat.a(SourceFile:24)
    at net.minecraft.server.NetworkManager.a(SourceFile:230)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:357)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: while parsing a block collection
    in "<reader>", line 158, column 13:
    - '*'
    expected <block end>, but found Scalar
    in "<reader>", line 196, column 16:
    - 'lwc.blockinventory'

    at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockSequenceEntry.produce(ParserImpl.java:520)
    at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:163)
    at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:148)
    at org.yaml.snakeyaml.composer.Composer.composeSequenceNode(Composer.java:203)
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:158)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:122)
    at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105)
    at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:124)
    at org.yaml.snakeyaml.Yaml.load(Yaml.java:264)
    at org.bukkit.util.config.Configuration.load(Configuration.java:73)
    at com.nijiko.permissions.Control.load(Control.java:144)
    at com.nijiko.permissions.Control.loadWorld(Control.java:108)
    at com.nijiko.permissions.Control.permission(Control.java:292)
    at com.fullwall.Citizens.Permission.permission(Permission.java:37)
    at com.fullwall.Citizens.Permission.generic(Permission.java:49)
    at com.fullwall.Citizens.Citizens.onCommand(Citizens.java:98)
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:31)
    ... 12 more
  8. Offline


    It's an error with your permissions config.yml, not the plugin itself. You have a misaligned permission or something. Redownload, added the Help plugin support. I'm off to bed.
  9. Offline


    Thanks for all your help seriously, great job! you have a good night.
  10. Offline


    good night and thanks for all the great work!
  11. Offline


    But this comes even if i don't have citizens plugin!
  12. Offline


    As I say - it's not to do with citizens, it's to do with the config.yml inside the Permissions folder. It's 1am here, so :p.
  13. Offline

    tha d0ctor

    well done you solved all the problems Ive had in the last few minutes, no complaints here :)
  14. Offline


    THANK YOU!! FULLWALL U DID IT!!! I REMOVED FEW SPACES FROM THE CONFIG!!!and it WORKS!! wee so happy right now [​IMG][​IMG][​IMG][​IMG] thx
  15. Offline


    open your yml file (should be called data.yml in the groupmanager folder or if your using the older permissions plugin it will be config.yml in the permissions folder) be sure to open it with notepad++ freely available on the net
    copy all of it inot http://yaml-online-parser.appspot.com/
    this will tell you where the error is

    be sure to never use the tab button (thats the most common mistake)

    good luck
    --- merged: Mar 7, 2011 5:00 PM ---
    ah i was a bit late with my help lol

    congrats chap
  16. Offline


    Epic! Gonna have to try this out... was just getting into the npclib stuff this weekend [​IMG].
  17. Offline


    well, thanks anyway i did also what you said :), but i still gives me that message dunno why, but don't care cuz i got citizens working
  18. Offline


    Would love to see it integrated with iChat 2.x to where it uses those prefixes and such or at least the ability to customize how the NPC name displays in the chat (I want to remove the [] from around it's name.)
  19. Offline

    Evan Melvin

    /npc remove seems to be bugged.

    Also, is there a way to remove armor?
  20. Offline


    I had to do some work, so I found time to add chat format support in Citizens.settings.
    --- merged: Mar 7, 2011 5:28 PM ---
    Set armor to 0.
  21. Offline


    same here, doesn't remove all npc using /npc remove all
    npc's cant be deleted using /npc remove name
  22. Offline


    How is /npc remove bugged?
    --- merged: Mar 7, 2011 5:29 PM ---
    I need the error (if any) please.
  23. Offline

    wolf hatake

  24. Offline


    Hmmm... I'm not sure :S. Did it say permissions was enabled in the server log?
  25. Offline


    i created a npc named Borris
    now when i try to delete him i type /npc remove Borris it says
    Couldn't find the NPC specified.

    this error message is the same for capital and non capital
  26. Offline


    Same for me but im leaving now. You should add something about Npc's giving quests and tradin/sellin/buying. Bye
  27. Offline


    If you redownload, what error do you get?
    --- merged: Mar 7, 2011 5:41 PM ---
    OK, redownload, fixed issue of /npc remove name.
  28. Offline


    Go to bed already Fullwall!
  29. seriously dude, go to sleep. btw your mod is awesome
  30. Offline

    tha d0ctor

    btw armor doesn't seem to be saving with NPCs with reloadall or server restart
  31. Offline

    wolf hatake

    No message in log, only in my tchat :p

Share This Page